Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-04-2010 12:21:23

Geai dechaine
Membre
Lieu : Provence
Distrib. : Squeeze 6.0
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 25-06-2009

Atlas virtuel de la Lune et OpenGL

Salut à tous ;-)

Voilà, dans le "Linux pratique" de mai-juin 2010, un article est consacré à un logiciel libre passionnant : l'Atlas virtuel de la Lune. La Lune étant une vieille copine à moi, je décide d'installer le programme. Oui, mais, voilà, car il y a un "oui", un "mais" et un "voilà" sinon y'aurait pas ce fil tongue !

Dans l'article y disent qu'il faut pour installer la bête

- gtk2
- OpenGL
- sqlite3

Une petite recherche me dit qu'il me faut installer gtk-engines. Pas de pb, il est déjà installé.

Pour sqlite3, je l'installe.

Mais ?

OpenGL me pose problème, cf. cette recherche.

Paquet cl-sdl-opengl

    * lenny (stable) (devel): Support for OpenGL in Common Lisp, via CL-SDL
      1:0.2.2-8: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet gambas2-gb-opengl

    * lenny (stable) (libdevel): The OpenGL component for Gambas
      2.7-1: amd64 armel i386 mips mipsel powerpc sparc

Paquet gambas2-gb-qt-opengl

    * lenny (stable) (libdevel): OpenGL with QT toolkit Gambas component
      2.7-1: amd64 armel i386 mips mipsel powerpc sparc

Paquet gnash-common-opengl

    * lenny (stable) (libs): free SWF movie player - common files/libraries
      0.8.4-3~lenny1: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet gnash-opengl

    * lenny (stable) (utils): free SWF movie player
      0.8.4-3~lenny1: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet klash-opengl

    * lenny (stable) (utils): free SWF movie player - standalone player for KDE
      0.8.4-3~lenny1: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libghc6-opengl-dev

    * lenny (stable) (devel): Haskell OpenGL binding for GHC
      2.2.1.1-2: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libghc6-opengl-doc

    * lenny (stable) (doc): Haskell OpenGL binding for GHC; documentation
      2.2.1.1-2: all

Paquet libghc6-opengl-prof

    * lenny (stable) (devel): Haskell OpenGL binding for GHC; profiling libraries
      2.2.1.1-2: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libguichan-opengl-0.8.1-1

    * lenny (stable) (libs): small, efficient C++ GUI library (OpenGL integration)
      0.8.1-4: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libhugs-opengl-bundled

    * lenny (stable) (devel): A binding for the OpenGL graphics system
      98.200609.21-5+b1: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libopengl-perl

    * lenny (stable) (perl): Perl module to display 3D data using OpenGL, GLU, GLUT, and GLX
      0.56.dfsg.1-2+b1: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libopengl-ruby

    * lenny (stable) (interpreters): OpenGL binding for Ruby
      0.32f-2+b1: armel
      0.32f-2: alpha amd64 arm hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libqt4-opengl

    * lenny (stable) (libs): Qt 4 OpenGL module
      4.4.3-1+lenny1 [security]: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libqt4-opengl-dev

    * lenny (stable) (libdevel): Qt 4 OpenGL library development files
      4.4.3-1+lenny1 [security]: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet libtiff-opengl

    * lenny (stable) (graphics): TIFF manipulation and conversion tools
      3.8.2-11.2: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc

Paquet python-opengl

    * lenny (stable) (python): Interface de programmation OpenGL pour Python
      3.0.0~b6-3: all

Paquet python-opengl-doc

    * lenny (stable) (doc): Documentation for PyOpenGL
      3.0.0~b6-3: all

Paquet spl-opengl

    * lenny (stable) (devel): SPL Programming Language -- OpenGL adapter
      1.0~pre4-3: alpha amd64 arm armel hppa i386 ia64 mips mipsel powerpc s390 sparc


Faut-il installer un de ces paquets ? Lequel ?


pc Medion MT6, cg ATI X300SE. J'utilise aptitude.

Hors ligne

#2 29-04-2010 14:40:31

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Atlas virtuel de la Lune et OpenGL

Salut,

Je pense que ce sont les bibliothèques qu'il te faut. À voir du côté de libgl1-mesa-glx et de libglu1-mesa, ou si ça ne fonctionne pas faire une recherche sur les paquets qui commencent par libgl1-, libglu1- et libglw1-, ou sur le mot clé mesa.

« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 30-04-2010 09:46:14

Geai dechaine
Membre
Lieu : Provence
Distrib. : Squeeze 6.0
Noyau : 2.6.32-5-686
(G)UI : Gnome 2.30.2
Inscription : 25-06-2009

Re : Atlas virtuel de la Lune et OpenGL

Salut, et merci de ta réponse.

J'ai déjà libgl1-mesa-glx et libglu1-mesa installées, et une recherche avec "libglw1-" m'a fait installer "libglw1-mesa" en pure perte. L'Atlas se lance bien, sur une fenêtre de visualisation toute grise où aucune Lune n'apparait.

Je laisse tomber, pas envie de galérer des jours pour un programme. Je regrette simplement que le site de l'Atlas virtuel n'explique pas ce qu'il faut pour installer son soft sous Linux. Où alors c'est la carte graphique ? Comment savoir ? Si quelqu'un y est arrivé, merci de le signaler ici.

pc Medion MT6, cg ATI X300SE. J'utilise aptitude.

Hors ligne

Pied de page des forums