Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-10-2019 09:03:16

lagrenouille
CA Debian-Facile
Lieu : Toulouse, con !
Distrib. : stretch et buster amd64
Noyau : d'olive
(G)UI : env i3-clavier bépo
Inscription : 28-03-2012
Site Web

résolu :.install intrompu, paquets cassés

salut

je mets en place un serveur sous buster
ce matin j'ai fait une connerie
j'ai mis unstable dans les sources pour installer  phpmyadmin (je l'ai fait par ailleurs sur une autre bécane et ça marche bien).
sauf que là , à la dernière question sur la mise à jour de glib6 (je crois) j'ai dis non.
connerie car maintenant, non seulement c'est pas installé,(ce qui n'est pas important)
mais j'ai des paquets cassés

 dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                   Version                             Architecture Description
+++-=====================================-===================================-============-===============================================================================
it  libc-bin                              2.28-10                             amd64        GNU C Library: Binaries
iU  libc-dev-bin                          2.29-2                              amd64        GNU C Library: Development binaries
iU  libc-l10n                             2.29-2                              all          GNU C Library: localization files
iU  libc6-dev:amd64                       2.29-2                              amd64        GNU C Library: Development Libraries and Header Files
iU  locales                               2.29-2                              all          GNU C Library: National Language (locale) data [support]
it  man-db                                2.8.5-2                             amd64        on-line manual pager



donc si je réinstall

root@lebug:~# apt install  --reinstall libc-bin
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
libc-dev-bin : Dépend: libc6 (> 2.29) mais 2.28-10 devra être installé
libc6-dev : Dépend: libc6 (= 2.29-2) mais 2.28-10 devra être installé
locales : Dépend: libc-bin (> 2.29) mais 2.28-10 devra être installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
je voudrai pas tout casser, j'ai installé des choses sur ce serveur en vue de le mettre en ligne, et je trouve pas mieux que de faire une connerie:
donc je demande conseil avant de faire quoi que ce soit

surtout que :

# aptitude install libc6
libc6 est déjà installé avec la version demandée (2.28-10)
libc6 est déjà installé avec la version demandée (2.28-10)
Les paquets partiellement installés suivants seront configurés :
  libc-bin libc-dev-bin{b} libc-l10n libc6-dev{b} locales{b} man-db
Aucun paquet ne va être installé, mis à jour ou enlevé.
0 paquets mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0 o d'archives. Après dépaquetage, 0 o seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
 libc6-dev : Dépend: libc6 (= 2.29-2) but 2.28-10 is installed
 locales : Dépend: libc-bin (> 2.29) but 2.28-10 is installed
 libc-dev-bin : Dépend: libc6 (> 2.29) but 2.28-10 is installed
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                  
1)      apache2-dev [2.4.38-3+deb10u1 (now, stable)]    
2)      apache2-ssl-dev [2.4.38-3+deb10u1 (now, stable)]
3)      build-essential [12.6 (now, stable)]            
4)      debhelper [12.1.1 (now, stable)]                
5)      dh-autoreconf [19 (now, stable)]                
6)      dh-strip-nondeterminism [1.1.2-1 (now, stable)]
7)      equivs [2.2.0 (now, stable)]                    
8)      g++ [4:8.3.0-1 (now, stable)]                  
9)      g++-8 [8.3.0-6 (now, stable)]                  
10)     libapr1-dev [1.6.5-1+b1 (now, stable)]          
11)     libaprutil1-dev [1.6.1-4 (now, stable)]        
12)     libc-dev-bin [2.29-2 (now)]                    
13)     libc6-dev [2.29-2 (now)]                        
14)     libexpat1-dev [2.2.6-2+deb10u1 (now, stable)]  
15)     libsctp-dev [1.0.18+dfsg-1 (now, stable)]      
16)     libstdc++-8-dev [8.3.0-6 (now, stable)]        
17)     libtool [2.4.6-9 (now, stable)]                
18)     locales [2.29-2 (now)]                          
19)     uuid-dev [2.33.1-0.1 (now, stable)]            

      Installer les paquets suivants :                  
20)     locales-all [2.28-10 (stable)]                  

      Leave the following dependencies unresolved:      
21)     devscripts recommande equivs                    
22)     dpkg-dev recommande build-essential            
23)     gcc-8 recommande libc6-dev (>= 2.13-5)          
24)     libgcc-8-dev recommande libc6-dev (>= 2.13-5)  
25)     gcc recommande libc6-dev | libc-dev            
26)     libltdl-dev recommande libtool              




et je veux pas virer apache, j'en ai besoin

bon, réparé avec un

 apt -f install



ce qui m'a viré pas mal de paquets, que je réinstalle

Dernière modification par lagrenouille (10-10-2019 09:42:52)


In girum imus nocte et consumimur igni 

En ligne

Pied de page des forums