Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 10-05-2010 23:47:52

Aikinux
Membre
Lieu : Beaune
Distrib. : Lenny 5.0.4
Noyau : 2.6.26.2
(G)UI : Gnome
Inscription : 07-05-2010

[RESOLU] configuration xorg - ?ECRAN NOIR? et pas de son

Bon je suis faible en connaissances à ce jour.
J'ai besoin d'un peu d'aide.
J'ai intallé dans un premier tps lenny 5.0 en 32 bits sur un HP 6830 intel core 2 duo P8400.
Un petit pb de son vite résolu.
Ensuite puisque tout fonctionnait bien j'ai essayé le live cd en 64 bit qui fonctionne très bien aussi, mis à part le son mais ça ne m'inquiettait pas.
Donc je suis parti pour la réinstal de tout mon systeme en amd64 bit et là ECRAN NOIR.

J'ai suivi tous les liens du forum pour essayer de comprendre. Ainsi que le site de amd/ati.

Mais là je suis bloqué. Impossible de démarrer X avec startx

Pourtant les fichier xorg.conf sont les memes en 32 ou 64 bits.
Et les fichiers générés avec un Xorg -configure me donne la même chose pour les deux architectures.

Par contre le système fonctionne avec les consoles tty1, 2...

Qq'un à une idée ?

D'avance merci.

Dernière modification par Aikinux (24-05-2010 11:32:48)

Hors ligne

#2 11-05-2010 07:20:36

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] configuration xorg - ?ECRAN NOIR? et pas de son

Bonjour Aikinux !

Débutant à savoir : http://debian-facile.org/debutant_a_sav … -_a_savoir

Peux-tu nous copier ton xorg.conf avec la commande cat dans un terminal user (voir : http://debian-facile.org/commande:cat) :

$ cat /etc/X11/xorg.conf


La liste de ton matériel VGA avec la commande lspci (voir : http://debian-facile.org/commande:lspci) ainsi :

$ lspci | grep VGA


ou bien tout le materiel ainsi :

$ lspci


Et la liste des modules (pilotes) installés tant qu'à faire (voir : http://debian-facile.org/commande:lsmod)  :

$ lsmod


Hop-là ! big_smile
N'hésitez pas à consulter toutes les commandes Linux sur la page d'accueil du wiki DF ! C'est le B. A. BA. pour dialoguer avec son pc, et pour l'entraide qui vous est proposé tout autant ! wink

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 11-05-2010 13:10:17

Aikinux
Membre
Lieu : Beaune
Distrib. : Lenny 5.0.4
Noyau : 2.6.26.2
(G)UI : Gnome
Inscription : 07-05-2010

Re : [RESOLU] configuration xorg - ?ECRAN NOIR? et pas de son

Merci Joël pour cette réponse rapide.

Mon xorg.conf avec cat :

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
  Identifier  "Generic Keyboard"
  Driver    "kbd"
  Option    "XkbRules"  "xorg"
  Option    "XkbModel"  "pc105"
  Option    "XkbLayout" "fr"
  Option    "XkbVariant"  "latin9"
EndSection

Section "InputDevice"
  Identifier  "Configured Mouse"
  Driver    "mouse"
EndSection

Section "Device"
  Identifier  "Configured Video Device"
EndSection

Section "Monitor"
  Identifier  "Configured Monitor"
EndSection

Section "Screen"
  Identifier  "Default Screen"
  Monitor   "Configured Monitor"
EndSection


Ensuite, le matériel :

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 95c2
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
86:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 436c


Et enfin les modules :

pc-pacboss:/home/famillepacb# lsmod
Module                  Size  Used by
nls_utf8                1760  1
nls_cp437               5568  1
vfat                    9152  1
fat                    40864  1 vfat
nls_base                6820  4 nls_utf8,nls_cp437,vfat,fat
rfcomm                 28272  0
l2cap                  17248  5 rfcomm
ppdev                   6468  0
parport_pc             22500  0
lp                      8164  0
parport                30988  3 ppdev,parport_pc,lp
ipv6                  235396  20
acpi_cpufreq            6796  1
cpufreq_userspace       3172  0
cpufreq_stats           3776  0
cpufreq_conservative     5960  0
cpufreq_ondemand        6476  1
freq_table              4224  3 acpi_cpufreq,cpufreq_stats,cpufreq_ondemand
cpufreq_powersave       1856  0
loop                   12748  0
joydev                  8480  0
uvcvideo               45800  0
pcspkr                  2432  0
compat_ioctl32          1312  1 uvcvideo
serio_raw               4740  0
snd_hda_intel         325720  1
videodev               27520  1 uvcvideo
psmouse                32336  0
snd_pcm                62660  1 snd_hda_intel
v4l1_compat            12260  2 uvcvideo,videodev
snd_seq                41456  0
snd_timer              17800  2 snd_pcm,snd_seq
snd_seq_device          6380  1 snd_seq
snd                    45636  7 snd_hda_intel,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore               6368  1 snd
snd_page_alloc          7816  2 snd_hda_intel,snd_pcm
container               3456  0
video                  16464  0
output                  2912  1 video
hci_usb                12252  2
bluetooth              44996  7 rfcomm,l2cap,hci_usb
wmi                     6440  0
battery                10180  0
ac                      4196  0
button                  6096  0
intel_agp              22524  0
agpgart                28808  1 intel_agp
evdev                   8000  7
ext3                  105576  2
jbd                    39476  1 ext3
mbcache                 7108  1 ext3
sg                     26964  0
sr_mod                 13316  0
cdrom                  30176  1 sr_mod
sd_mod                 22200  6
usb_storage            77120  1
ahci                   23596  3
libata                140448  1 ahci
scsi_mod              129548  5 sg,sr_mod,sd_mod,usb_storage,libata
dock                    8304  1 libata
ehci_hcd               28428  0
sky2                   37412  0
uhci_hcd               18672  0
usbcore               118192  6 uvcvideo,hci_usb,usb_storage,ehci_hcd,uhci_hcd
thermal                15228  0
processor              32576  4 acpi_cpufreq,thermal
fan                     4196  0
thermal_sys            10856  4 video,thermal,processor,fan


Je ne sais pas si ça peut aider.

Par contre avec un Xorg -configure , j'obtiens :

Section "ServerLayout"
  Identifier     "X.org Configured"
  Screen      0  "Screen0" 0 0
  InputDevice    "Mouse0" "CorePointer"
  InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
  RgbPath      "/etc/X11/rgb"
  ModulePath   "/usr/lib/xorg/modules"
  FontPath     "/usr/share/fonts/X11/misc"
  FontPath     "/usr/share/fonts/X11/cyrillic"
  FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath     "/usr/share/fonts/X11/Type1"
  FontPath     "/usr/share/fonts/X11/100dpi"
  FontPath     "/usr/share/fonts/X11/75dpi"
  FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load  "GLcore"
  Load  "dbe"
  Load  "record"
  Load  "dri"
  Load  "extmod"
  Load  "glx"
  Load  "xtrap"
EndSection

Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "kbd"
EndSection

Section "InputDevice"
  Identifier  "Mouse0"
  Driver      "mouse"
  Option      "Protocol" "auto"
  Option      "Device" "/dev/input/mice"
  Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
  Identifier   "Monitor0"
  VendorName   "Monitor Vendor"
  ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "NoAccel"             # [<bool>]
        #Option     "AccelMethod"         # [<str>]
        #Option     "offscreensize"       # [<str>]
        #Option     "SWcursor"            # [<bool>]
        #Option     "ignoreconnector"     # [<str>]
        #Option     "forcereduced"        # [<bool>]
        #Option     "forcedpi"            # <i>
        #Option     "useconfiguredmonitor"  # [<bool>]
        #Option     "HPD"                 # <str>
        #Option     "NoRandr"             # [<bool>]
        #Option     "RRUseXF86Edid"       # [<bool>]
        #Option     "RROutputOrder"       # [<str>]
        #Option     "TVMode"              # [<str>]
  Identifier  "Card0"
  Driver      "radeonhd"
  VendorName  "ATI Technologies Inc"
  BoardName   "Unknown Board"
  BusID       "PCI:1:0:0"
EndSection

Section "Screen"
  Identifier "Screen0"
  Device     "Card0"
  Monitor    "Monitor0"
  SubSection "Display"
    Viewport   0 0
    Depth     1
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     4
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     8
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     15
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     16
  EndSubSection
  SubSection "Display"
    Viewport   0 0
    Depth     24
  EndSubSection
EndSection


Le fichier xorg.conf.new ne me permet pas de faire fonctionner startx, alors que le fichier généré à l'installation lui permet le démarrage de l'environnement graphique sans problème.
J'ai parfois en passant en console un scintillage de l'écran en console ou en graphique mais c'est rare et ça disparait en déchargeant puis rechargeant gdm. Donc il y a bien un problème.

Voilà donc les infos que je peux donner.
En fait tout ça est sous debian 32 bits. Je vais essayer de réinstaller Debian lenny amd64 en même temps avec une sélection à faire au démarrage avec Grub et je ferais les mêmes envois plus tard.

J'ai ajouté des balises [codes] pour diminuer un peu la longueur de ce message qui faisait un km de long lol

Dernière modification par martinux_qc (25-05-2010 03:59:35)

Hors ligne

#4 11-05-2010 17:37:52

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU] configuration xorg - ?ECRAN NOIR? et pas de son

Donc, une carte graphique ATI :

01:00.0 VGA compatible controller: ATI Technologies Inc Device 95c2


Je sais pas trop, je te renvoie à ce topic que damien m'a rappelé sur le salon DF à propos des cartes ATI :
http://debian-facile.org/forum/viewtopi … 567#p17567

Si tu n'es pas du niveau, n'hésite pas à questionner pour son application pas à pas. big_smile

Amitié et remerciement à Damien, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 24-05-2010 11:29:42

Aikinux
Membre
Lieu : Beaune
Distrib. : Lenny 5.0.4
Noyau : 2.6.26.2
(G)UI : Gnome
Inscription : 07-05-2010

Re : [RESOLU] configuration xorg - ?ECRAN NOIR? et pas de son

Voilà,

J'ai enfin résolu mon problème de configuration de gestion de l'écran sur mon portable.

Je tourne avec la testing de DEBIAN (sid)
Noyau linux 2.6.32-trunk-amd64

HP 6830s
2 Processeurs Intel Core 2 Duo CPU P8400 @ 2.26 GHz

famillepacb@pc-pacb:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Device 95c2
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection
86:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8072 PCI-E Gigabit Ethernet Controller


Mes problèmes de son et de gestion graphique en 64 bits sont résolus ainsi que l'accès ftp au disque dur de la freebox HD v2 avec Nautilus directement comme un autre disque dur.

J'apprécie surtout Gnome 2.30.0 avec la gestion de fenétres en onglet dans icedove, nautilus et iceweasel.

Il reste cependant qq problèmes :
Le wifi qui ne fonctionne ([small]manque un micro firmware que je ne souhaite pas installer pour le moment[/small]) pas mais je m'en fiche pour le moment car j'ai une gestion filaire ethernet avec une freebox HD.
Il y a aussi un problème d'affiche lors des défilement écran rapide avec flèche ht ou bas et avec la sourie.
La gestion de la mise en veille et de l'hibernation ne sont pas au point. Impossible de sortie de ces modes sans rebooter.

Il y a certainement des tas d'autres problèmes mineurs, mais pour mon utilisation bureautique jusque là pas dramatiques.

J'espère que vous aurez trouvé des infos utiles à ce post.

Dernière modification par Aikinux (28-05-2010 21:47:01)

Hors ligne

Pied de page des forums