Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-05-2010 14:25:21

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

(résolu) pas de montage du dossier partagé

Bonjour,

Ayant installé un nouveau PC sur mon réseau NFS,

les pings des deux autres PC's n'aboutissent plus sur ce PC

Par contre, les pings du PC serveur (sur ubuntu 10.04) passent sans problème vers les deux autres : l'un sous debian lenny, l'autre sur ubuntu 9.04

cela empêche le partage d'un dossier NFS du PC sous ubuntu 10.04

Avez-vous une idée ?

Merci big_smile

Dernière modification par jrev (15-05-2010 13:58:48)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#2 14-05-2010 14:41:51

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : (résolu) pas de montage du dossier partagé

le firewall ? peut être configuré pour refuser les pings non ?

MaTTuX_

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#3 14-05-2010 14:42:58

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : (résolu) pas de montage du dossier partagé

salut, tu as été voir du coté d'iptables si tu n'a pas une règle qui bloque ce fameux ping.

un petit :
# iptables -L  ( # donc en root et tu sera si sa bloque ici).

Après faut voir si tu fais un ping sur ip ou un ping dns. En gros si tu utilise l'adresse ip ou le nom dns de ta machine dans ton ping.

Sinon perso je suis pas très bon en nfs (j'utilise que ssh moi perso entre mes machines linux),

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#4 14-05-2010 14:54:34

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

MaTTuX_ a écrit :

le firewall ? peut être configuré pour refuser les pings non ?

MaTTuX_


le pare-feu est désactivé cool


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#5 14-05-2010 14:57:39

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

à chiwawa :

jean@jean:~$ sudo su
root@jean:/home/jean# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
root@jean:/home/jean#

Je fais un ping 192.168.0.1 ou un ping jean du nom de la machine, ayant configuré mes fichiers /etc/hosts sur le serveur et les clients

As-tu un bon tuto pour ssh ? je ne m'en suis jamais servi ...

Dernière modification par jrev (14-05-2010 15:13:32)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#6 14-05-2010 15:10:30

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : (résolu) pas de montage du dossier partagé

tu veux un tuto pour ssh ces simple va voir dans le wiki.

Est tu en aura un, en plus ces pas bien compliquer à mettre en place. (enfin je trouve, faut dire j'en est tellement l'habitude que voilà)..

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#7 14-05-2010 15:15:20

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

chiwawa a écrit :

tu veux un tuto pour ssh ces simple va voir dans le wiki.

Est tu en aura un, en plus ces pas bien compliquer à mettre en place. (enfin je trouve, faut dire j'en est tellement l'habitude que voilà)..


Je peux plus entrer dans le wiki car je ne vois pas où m'enregistrer l'ID et le mot de passe ne sont pas les mêmes que pour le forum !


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#8 14-05-2010 15:24:47

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : (résolu) pas de montage du dossier partagé

Si ce sont les même une fois loger sur le forum tu peut basculer sur le wiki.

Sens avoir à rien renter de plus.

Sinon un petit coup de google avec les mots clès ssh et configuration ou tuto ssh et voilà ces régler.

Par exemple ici : http://www.linux-france.org/prj/edu/arc … 13s03.html
ou ici

http://www.siteduzero.com/tutoriel-3-67 … -etch.html

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#9 14-05-2010 15:29:06

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : (résolu) pas de montage du dossier partagé

Est quelques astuce pour sécurisée tout cela.

http://www.alsacreations.com/tuto/lire/ … ables.html

Après moi perso je change le port par défaut de ssh car le 22 est trop connu et tester par éventuel pirate.
Par exemple je prend le port 10022 ou 11022 et je modifie la règle iptable et de fail2ban.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#10 14-05-2010 16:26:42

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

La solution est simple, comme toujours.
Chercher la panne où elle se trouve et pas ailleurs :
Si tu changes un PC par un nouveau PC il faut changer son adresse machine (la HWaddr de la commande ifconfig 1ère ligne) dans le modem routeur.
Dans mon cas la freebox

Merci à tous de vos réponses

Dernière modification par jrev (14-05-2010 20:28:39)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#11 14-05-2010 20:15:36

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

Mais je ne peux toujours pas monter le dossier partagé sur les clients NFS
La commande

mount  /media/nfs


se bloque et se libère par time out

Ma ligne de montage dans le fichier /etc/fstab du client (debian lenny LXDE) est la suivante :
[c]192.168.0.1:/home/jean/Documents  /media/nfs nfs user,noauto  0     0[/c]

Le système de fichiers client est ext3 et celui du dossier sur le serveur est en  ext4 (linux ubuntu 10.04)

Dernière modification par jrev (14-05-2010 20:30:03)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#12 15-05-2010 13:54:31

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

[large]Je viens de réinstaller mon ubuntu 10.04 en système de fichier ext3
Mon partage NFS refonctionne spontanément.
Avis aux amateurs
tongue[/large]

Dernière modification par jrev (15-05-2010 13:55:41)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#13 15-05-2010 22:16:44

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : (résolu) pas de montage du dossier partagé

chiwawa a écrit :

salut, tu as été voir du coté d'iptables si tu n'a pas une règle qui bloque ce fameux ping.

un petit :
# iptables -L  ( # donc en root et tu sera si sa bloque ici).

Après faut voir si tu fais un ping sur ip ou un ping dns. En gros si tu utilise l'adresse ip ou le nom dns de ta machine dans ton ping.

Sinon perso je suis pas très bon en nfs (j'utilise que ssh moi perso entre mes machines linux),


parefeu, firewal ou iptables c'est la même chose ^^

C'etait quoi la commande que tu faisais avant de tout reinstaller, car la reinstall n est pas une solution, enfin dommage

MaTTuX_


\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#14 16-05-2010 09:02:56

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : (résolu) pas de montage du dossier partagé

Il m'a semblé que la réinstallation était la seule solution pour changer le type de système de fichiers ...

la commande que je faisais était la suivante :
[c]mount  /media/nfs[/c]
nfs étant le dossier dans lequel se monte le dossier partagé du serveur.

[large]Y a-t-il moyen de changer le type de système de fichiers du disque dur d'un PC en service sans perturber son fonctionnement ?[/large]

Il y avait deux réponses à mon problème : changer l'adresse machine pour le ping et changer le type de système de fichiers.
Il semblerait que le montage du dossier ne peut se faire que si le serveur et les clients sont sur le même type de système de fichiers.
Qu'en penses-tu ?
smile

Dernière modification par jrev (16-05-2010 09:11:24)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#15 16-05-2010 10:34:43

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : (résolu) pas de montage du dossier partagé

Salut jrev,

Regarde sur le forum là :
http://debian-facile.org/forum/viewtopi … 090#p11090

J'ai préservé les données depuis ext3 vers ext4. Cependant, lapartition doit être démontée.
Sinon, pour l'inverse, ce doit être pareil.

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#16 16-05-2010 18:32:33

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : (résolu) pas de montage du dossier partagé

je pense que le mount a des options pour les differents type de ext, et a mon avis la reinstall n etait pas necessaire  mais pour confirmer ca il faudrai faire des test

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

Pied de page des forums