Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-05-2010 15:50:13

fraiddo
Membre
Inscription : 02-03-2008
Site Web

xib-bot sous lenny

Bonjour,

je n'arrive pas à utiliser http://changaco.net/code/xib/ sous debian lenny:

Traceback (most recent call last):
  File "./start_bots_from_xml_config.py", line 26, in <module>
    from bot import Bot
  File "/home/toto/xib/bot.py", line 25, in <module>
    import irclib
  File "/home/toto/xib/irclib.py", line 295
    except ServerNotConnectedError as e:
                                    ^
SyntaxError: invalid syntax


Faut-il vraiment python 2.6 absolument ? Là je suis sous lenny avec python 2.5

j'ai installé manuellement xmppony et python-argparse

++


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#2 23-05-2010 20:14:15

Asmodée
Membre
Lieu : /dev/null
Distrib. : Squeeze
Inscription : 16-05-2010

Re : xib-bot sous lenny

Le "as" qui t'embête est un mot réservé par python 2.6 : python 2.5 le traite comme une variable.

Hors ligne

#3 23-05-2010 21:46:21

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Erf, y'a un moyen d'avoir python 2.6 sous lenny (avec des paquets déjà faits ?)

http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#4 24-05-2010 00:32:31

Asmodée
Membre
Lieu : /dev/null
Distrib. : Squeeze
Inscription : 16-05-2010

Re : xib-bot sous lenny

Je crois que oui, mais je ne sais pas si ça ne va pas foutre le bordel... A tes risques et périls ! smile
Tu ajoutes par exemple les dépôts de la sid ou de testing dans ton source.list. Mais avant de faire quoique ce soit, il faut absolument éditer/créer le fichier /etc/apt/preferences...

Une fois dedans, tu dois ajouter les lignes suivantes :

Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 90


Cela a simplement pour effet de réduire la priorité (pin-priority) à 90 pour sid (par rapport à 500 pour testing), sur tous les paquets (package:*).

N'hésite pas, une fois que tu auras fais un aptitude update pour mettre à jour la liste, de taper apt-cache policy pour vérifier que la priorité est bien prise en compte. Ensuite, tu peux tenter un upgrade. Avant d'accepter, vérifie bien qu'il n'y a pas de mise à jour du noyau ou de la libc dans la liste des mises à jour. Ensuite, tu auras accès à python 2.6 dans les dépôts.

Hors ligne

#5 24-05-2010 23:05:00

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Ok, merci pour toutes ces indications.

Dans ce cas, je souhaiterais garder python 2.5 "par défaut" pour l'exécution de tout programme, et avoir python 2.6 en parallèle, en précisant pour les programmes qui le demande: est-ce possible ?

http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#6 24-05-2010 23:25:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#7 25-05-2010 08:53:25

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Je viens d'essayer d'installer python2.6 et j'ai ce message:

Les paquets suivants contiennent des dépendances non satisfaites :
  python2.6: Dépend: python2.6-minimal (= 2.6.5-2) mais ne sera pas installé
             Dépend: libncursesw5 (>= 5.7+20100313) mais 5.7+20081213-1 devra être installé
             Dépend: libreadline6 (>= 6.0) mais ne sera pas installé
             Dépend: libsqlite3-0 (>= 3.6.23.1) mais 3.5.9-6 devra être installé
E: Paquets défectueux


++


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#8 25-05-2010 09:00:12

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny

Bonjour fraiddo !

Si tu as créé un fichier preferences (tu peux nous mettre une copie qu'on le voit...), cela te permet d'installer les dépendances manquantes sans passer à la branche supérieure qui les contient.
ATTENTION ! Dans la limite de ne pas modifier le fichier [large]libc6[/large] !
Car la modification de ce fichier implique le passage général de ton système à la branche supérieure pour plus d'homogénéïté.

Sinon, tu as dans les outils apt la commande pour forcer l'installation des dépendances manquantes l'option [large]-t[/large]  :

aptitude install -t <branche supérieure> <nom_du_paquet>


forcer_l_installation_d_un_paquet

Tu peux aussi simuler l'installation avec l'option -s ajoutée également :

aptitude install -s ..


Hop ! smile

Dernière modification par smolski (25-05-2010 09:06:13)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 25-05-2010 09:47:13

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

J'ai installé python2.6 et python2.6-minimal mais:

Paramétrage de python2.6-minimal (2.6.5-2) ...
Linking and byte-compiling packages for runtime python2.6...
pycentral: pycentral rtinstall: installed runtime python2.6 not found
pycentral rtinstall: installed runtime python2.6 not found
dpkg : erreur de traitement de python2.6-minimal (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de python2.6 :
 python2.6 dépend de python2.6-minimal (= 2.6.5-2) ; cependant :
 Le paquet python2.6-minimal n'est pas encore configuré.
dpkg : erreur de traitement de python2.6 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python2.6-minimal
 python2.6
E: Sub-process /usr/bin/dpkg returned an error code (1)


Les programmes sont pourtant bien executés, que se passe t'il ?

++


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#10 25-05-2010 11:42:06

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny

Vu ce message :

...des problèmes de dépendances empêchent la configuration...


Il faut que tu installes les dépendances me semble-t'il, celles signalées précédemment :

python2.6: Dépend: python2.6-minimal (= 2.6.5-2) mais ne sera pas installé
             Dépend: libncursesw5 (>= 5.7+20100313) mais 5.7+20081213-1 devra être installé
             Dépend: libreadline6 (>= 6.0) mais ne sera pas installé
             Dépend: libsqlite3-0 (>= 3.6.23.1) mais 3.5.9-6 devra être installé


Peux-tu nous dire si tu as créé le fichier [large]preferences[/large] et nous en donner la teneur ?

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#11 25-05-2010 11:52:35

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

J'y ai mis

Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 90


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#12 25-05-2010 11:59:10

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny

OK
As-tu pris connaissance du tuto des preferences dans le wiki df ici :
http://debian-facile.org/manuel:configu … perimental

As-tu forcé les installations des dépendances avec l'option -t unstable <nom des dépendances> ? smile

Amitié, Jojo

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#13 25-05-2010 12:21:32

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

smolski a écrit :

OK
As-tu pris connaissance du tuto des preferences dans le wiki df ici :
http://debian-facile.org/manuel:configu … perimental


oui

smolski a écrit :

As-tu forcé les installations des dépendances avec l'option -t unstable <nom des dépendances> ? smile


oui smile


après,une suppression de python2.6 j'ai réessayé :

aptitude install -t unstable python2.6 python2.6-minimal libncursesw5 libreadline6 libsqlite3-0
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait      
Les NOUVEAUX paquets suivants vont être installés :
  libdb4.8{a} libreadline6 python2.6 python2.6-minimal
0 paquets mis à jour, 4 nouvellement installés, 0 à enlever et 327 non mis à jour.
Il est nécessaire de télécharger 0o/4470ko d'archives. Après dépaquetage, 16,2Mo seront utilisés.
Voulez-vous continuer ? [Y/n/?] y
Écriture de l'information d'état étendu... Fait
Sélection du paquet libreadline6 précédemment désélectionné.
(Lecture de la base de données... 41168 fichiers et répertoires déjà installés.)
Dépaquetage de libreadline6 (à partir de .../libreadline6_6.1-2_i386.deb) ...
Sélection du paquet libdb4.8 précédemment désélectionné.
Dépaquetage de libdb4.8 (à partir de .../libdb4.8_4.8.30-1_i386.deb) ...
Sélection du paquet python2.6-minimal précédemment désélectionné.
Dépaquetage de python2.6-minimal (à partir de .../python2.6-minimal_2.6.5-2_i386.deb) ...
Sélection du paquet python2.6 précédemment désélectionné.
Dépaquetage de python2.6 (à partir de .../python2.6_2.6.5-2_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libreadline6 (6.1-2) ...
Paramétrage de libdb4.8 (4.8.30-1) ...
Paramétrage de python2.6-minimal (2.6.5-2) ...
Linking and byte-compiling packages for runtime python2.6...
pycentral: pycentral rtinstall: installed runtime python2.6 not found
pycentral rtinstall: installed runtime python2.6 not found
dpkg : erreur de traitement de python2.6-minimal (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de python2.6 :
 python2.6 dépend de python2.6-minimal (= 2.6.5-2) ; cependant :
 Le paquet python2.6-minimal n'est pas encore configuré.
dpkg : erreur de traitement de python2.6 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python2.6-minimal
 python2.6
E: Sub-process /usr/bin/dpkg returned an error code (1)
Échec de l'installation d'un paquet. Tentative de réparation :
Paramétrage de python2.6-minimal (2.6.5-2) ...
Linking and byte-compiling packages for runtime python2.6...
pycentral: pycentral rtinstall: installed runtime python2.6 not found
pycentral rtinstall: installed runtime python2.6 not found
dpkg : erreur de traitement de python2.6-minimal (--configure) :
 le sous-processus post-installation script a retourné une erreur de sortie d'état 1
dpkg : des problèmes de dépendances empêchent la configuration de python2.6 :
 python2.6 dépend de python2.6-minimal (= 2.6.5-2) ; cependant :
 Le paquet python2.6-minimal n'est pas encore configuré.
dpkg : erreur de traitement de python2.6 (--configure) :
 problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
 python2.6-minimal
 python2.6
Lecture des listes de paquets... Fait            
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Écriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#14 25-05-2010 12:26:40

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny

As-tu supprimé les paquets d'une façon experte ?
http://debian-facile.org/doc:systeme:ap … ion_expert

Des fois qu'il serait resté des reliquats de configuration faisant conflit ?

Plus, je ne sais pas ?

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#15 25-05-2010 12:35:06

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Oui j'avais bien purgé etc, j'ai même essayé les paquets de squeeze, idem...

http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#16 25-05-2010 13:56:35

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Ne faudrait-il pas le paquet -dev également ?

aptitude install -t testing python2.6-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu      
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait  
Les paquets suivants sont CASSÉS :
  libc6-i686 locales
Les NOUVEAUX paquets suivants vont être installés :
  cpp{a} cpp-4.4{a} gcc{a} gcc-4.4{a} gcc-4.4-base{a} libc-bin{a} libc-dev-bin{a} libc6-dev{a} libgmp3c2{a} libgomp1{a}
  libmpfr1ldbl{a} libpython2.6{a} linux-libc-dev{a} manpages-dev{a} python2.6-dev
Les paquets suivants seront mis à jour :
  binutils libc6 libgcc1 libstdc++6
Les paquets partiellement installés suivants seront configurés :
  python2.6 python2.6-minimal
4 paquets mis à jour, 15 nouvellement installés, 0 à enlever et 323 non mis à jour.
Il est nécessaire de télécharger 28,9Mo d'archives. Après dépaquetage, 59,8Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libc6-i686: Pré-Dépend: libc6 (= 2.7-18lenny2) mais 2.10.2-9 doit être installé.
  locales: Dépend: glibc-2.7-1 qui est un paquet virtuel
Les actions suivantes permettront de résoudre ces dépendances :

Mettre à jour les paquets suivants :
libc6-i686 [2.7-18lenny2 (stable, now) -> 2.10.2-9 (testing)]
locales [2.7-18lenny2 (stable, now) -> 2.10.2-9 (testing)]

Le score est de 190


car

Les paquets partiellement installés suivants seront configurés :
  python2.6 python2.6-minimal


seulement libc6 et locales mis à jour, est-ce vraiment nécessaire et sans risque ?


http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

#17 25-05-2010 14:29:24

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : xib-bot sous lenny

Aie !

L'évolution de libc6 devrait correspondre à l'évolution de tout ton système vers testing !
Si tu veux poursuivre, il paraît plus évident de passer dans la branche squeeze/testing carrément.

C'est indiqué dans un tuto du wiki df... wink
Je recherche et te pose un Edit...

Edit :
http://debian-facile.org/manuel:paquet_ … ibc6#libc6


Amitié, Joel

Dernière modification par smolski (25-05-2010 14:31:45)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#18 25-05-2010 14:54:44

fraiddo
Membre
Inscription : 02-03-2008
Site Web

Re : xib-bot sous lenny

Ben j'aimerais rester en stable pour l'instant: c'est un serveur en production avec plusieurs sites, du xmpp et tout un tas de trucs^^ En plus je n'y ai pas accès physiquement pour plusieurs semaines, donc si un truc plante...

pas moyen d'avoir python 2.6 sous lenny alors ? sad

++

http://www.strapontins.org c'est bon pour ton poil et bien plus encore tongue

Hors ligne

Pied de page des forums