Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-05-2010 12:17:43

loncle
Membre
Inscription : 20-05-2010

[RESOLU] probleme de fonctionnement DNS avec Bind9

J'ai un serveur DHCP et j'essaye d'installer DNS dessus avec Bind9.

Sur le serveur (srvlinux)

ping IP de rl1 : ok
host rl1.cpi.edu : ok
host rl1 :"connection times out; no servers could be reached"
host srvlinux.cpi.edu : ok
host srvlinux :"connection times out; no servers could be reached"


Sur le client (rl1)

ping IP de srvlinux : ok
host srvlinux.cpi.edu : "connection times out; no servers could be reached"
host srvlinux : "connection times out; no servers could be reached"
host rl1.cpi.edu : ok
host rl1 : "connection times out; no servers could be reached"

J'ai configuré les fichiers de zones et les fichiers named.conf et named.conf.options.
J'ai ajouté "-4" dans /etc/default/bind9
Je trouve pas de solution.

Dernière modification par loncle (15-06-2010 16:59:48)

Hors ligne

#2 29-05-2010 00:14:46

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [RESOLU] probleme de fonctionnement DNS avec Bind9

Bonjour loncle,

Afin de pouvoir interpréter les infos que tu donnes, peux-tu nous copier le contenu des fichiers /etc/resolv.conf et /etc/hosts de ton serveur stp?

Edit: Et nous dire aussi si le paquet avahi-daemon est installé, ainsi que network-manager.

@+

Dernière modification par tux12 (29-05-2010 00:31:34)

Hors ligne

#3 31-05-2010 11:51:02

loncle
Membre
Inscription : 20-05-2010

Re : [RESOLU] probleme de fonctionnement DNS avec Bind9

Bonjour et merci pour ton aide!

Avahi et network-manager sont installés.

fichier /etc/resolv.conf

domain ac-lyon.fr
search ac-lyon.fr
nameserver 172.16.0.1


fichier /etc/hosts

127.0.0.1 localhost
192.168.1.1 serveur.cpi.edu serveur

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts


L'adresse IP dans le fichier resolv est celle du DHCP du lycée. Je suis sous VMware.
Donc pour passer du LAN au WAN je bridge (Dhcp dynamique).
Mon probleme est que le fichier resolv.conf n'est pas mis à jour lorsque je suis en LAN. Et c'est pas le cas lorsque je passe en WAN (le dns du lycée, lui fonctionne!)

Hors ligne

#4 31-05-2010 21:15:10

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [RESOLU] probleme de fonctionnement DNS avec Bind9

Bonjour,

Bon, si j'ai bien compris, tu as un hôte (rl1 ?) sur lequel tourne une VM (srvlinux ?). L'hôte est connecté à un réseau 192.168.1.0/24, lequel est connecté au réseau 172.16.0.0/16 sur lequel tourne le DNS actuel du domaine (serveur "réel" pour la suite). La VM est bridgée et est donc elle aussi sur 192.168.1.0/24.
C'est bien cela? Sinon, merci de préciser.

Les résolutions faites avec la commande host sur srvlinux seraient faites par le serveur réel, si j'en crois le résolv.conf de srvlinux. (Ce qui implique que le DNS réel ait connaissance de srvlinux.cpi.edu, chose qui n'est pas confirmée par la réponse obtenue depuis rl1 hmm).

J'ai une peu de mal à comprendre. Peux tu nous donner le contenu du fichier resolv.conf de rl1 et tenter depuis chaque machine la commande "host srvlinux.cpi.edu IP_srvlinux" avec IP_srvlinux l'IP du serveur? Ceci permettra d'être certain que l'on interroge bien srvlinux et non le serveur réel.

Toute autre info qui te paraît pertinente (IPs des machines concernées...) est la bienvenue. wink

loncle a écrit :

Mon probleme est que le fichier resolv.conf n'est pas mis à jour lorsque je suis en LAN. Et c'est pas le cas lorsque je passe en WAN (le dns du lycée, lui fonctionne!)


Je ne comprends pas ce que tu veux dire par "être en LAN" ou "passer en WAN". Le resolv.conf est généralement modifié lors des up/down d'interfaces réseau. Pourrais-tu reformuler en termes de commandes passées sur des machines stp? Merci smile

Edit: Les resolutions de type "rl1" ou "srvlinux" devraient pouvoir fonctionner en ajoutant "cpi.edu.ac-lyon.fr" à la ligne "search ac-lyon.fr" du resolv.conf. A tester.

@+

Dernière modification par tux12 (31-05-2010 21:45:40)

Hors ligne

#5 15-06-2010 16:58:04

loncle
Membre
Inscription : 20-05-2010

Re : [RESOLU] probleme de fonctionnement DNS avec Bind9

Finalement j'ai trouvé la solution. Le fichier resolv.conf était mal configuré.
Merci du coup de main.

Hors ligne

Pied de page des forums