Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-03-2020 16:28:26

Genji
Membre
Distrib. : Debian GNU/Linux 10.3 (buster)
Noyau : 4.9.0-12-amd64
Inscription : 12-03-2018

Problème installation veracrypt GUI (résolu)

Bonjour à tous,

L'un de mes amis part bientôt à l'étranger et il m'a demandé de lui installer veracrypt. Il utilise un vieux notebook où je lui ai installé Debian 10 Buster l'été dernier. Il est encore plus novice que moi sur l'utilisation de notre OS favori.
J'ai donc téléchargé le fichier .deb sur le site de veracrypt (https://www.veracrypt.fr/en/Downloads.html => veracrypt-1.24-Update4-Debian-10-amd64.deb).
Après avoir galéré pour comprendre comment fonctionne la gestion des paquets sans passer par les dépôts j'ai essayé de l'installer avec dpkg -i

dpkg -i /home/panda/Téléchargements/veracrypt-1.24-Update4-Debian-10-amd64.deb


Sélection du paquet veracrypt précédemment désélectionné.
(Lecture de la base de données... 203613 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../veracrypt-1.24-Update4-Debian-10-amd64.deb ...
Dépaquetage de veracrypt (1.24.12-1) ...
dpkg: des problèmes de dépendances empêchent la configuration de veracrypt :
 veracrypt dépend de libwxgtk3.0-gtk3-0v5 ; cependant :
  Le paquet libwxgtk3.0-gtk3-0v5 n'est pas installé.

dpkg: erreur de traitement du paquet veracrypt (--install) :
 problèmes de dépendances - laissé non configuré
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
Des erreurs ont été rencontrées pendant l'exécution :
 veracrypt
 



Si j'ai bien compris l'erreur, il faut installer le paquet manquant dont dépend veracrypt

apt-get update && apt-get install libwxgtk3.0-gtk3-0v5


Atteint :1 http://deb.debian.org/debian buster InRelease
Réception de :2 http://deb.debian.org/debian buster-updates InRelease [49,3 kB]
Atteint :3 http://security.debian.org/debian-security buster/updates InRelease
Atteint :4 http://httpredir.debian.org/debian buster InRelease                
49,3 ko réceptionnés en 3s (16,6 ko/s)                                        
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libwxgtk3.0-gtk3-0v5 : Dépend: libwxbase3.0-0v5 (>= 3.0.4+dfsg) mais ne sera pas installé
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
 



Là je ne comprends pas trop, le paquet manquant dépend d'un autre paquet ?
Faut-il suivre la dernière ligne indiquée (E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).)

Plutôt que de jouer à l'apprenti sorcier comme j'ai l'habitude de la faire sur mon ordinateur, je préfère prendre le temps de vos réponses, d'autant que si je casse le système ça va me prendre du temps à tout réinstaller (souvenirs de cet été ^⁾.

EDIT :

apt --fix-broken install


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
  libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5
Les NOUVEAUX paquets suivants seront installés :
  libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5
0 mis à jour, 2 nouvellement installés, 0 à enlever et 82 non mis à jour.
1 partiellement installés ou enlevés.
Il est nécessaire de prendre 5407 ko dans les archives.
Après cette opération, 20,6 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://deb.debian.org/debian buster/main amd64 libwxbase3.0-0v5 amd64 3.0.4+dfsg-8 [1057 kB]
Réception de :2 http://deb.debian.org/debian buster/main amd64 libwxgtk3.0-gtk3-0v5 amd64 3.0.4+dfsg-8 [4350 kB]
5407 ko réceptionnés en 1s (3634 ko/s)              
Sélection du paquet libwxbase3.0-0v5:amd64 précédemment désélectionné.
(Lecture de la base de données... 203802 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libwxbase3.0-0v5_3.0.4+dfsg-8_amd64.deb ...
Dépaquetage de libwxbase3.0-0v5:amd64 (3.0.4+dfsg-8) ...
Sélection du paquet libwxgtk3.0-gtk3-0v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libwxgtk3.0-gtk3-0v5_3.0.4+dfsg-8_amd64.deb ...
Dépaquetage de libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-8) ...
Paramétrage de libwxbase3.0-0v5:amd64 (3.0.4+dfsg-8) ...
Paramétrage de libwxgtk3.0-gtk3-0v5:amd64 (3.0.4+dfsg-8) ...
Paramétrage de veracrypt (1.24.12-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.28-10) ...
 



apt-get update && apt-get install libwxgtk3.0-gtk3-0v5


Atteint :1 http://deb.debian.org/debian buster InRelease
Atteint :2 http://security.debian.org/debian-security buster/updates InRelease
Atteint :3 http://deb.debian.org/debian buster-updates InRelease
Atteint :4 http://httpredir.debian.org/debian buster InRelease
Lecture des listes de paquets... Fait
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
libwxgtk3.0-gtk3-0v5 est déjà la version la plus récente (3.0.4+dfsg-8).
libwxgtk3.0-gtk3-0v5 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 82 non mis à jour.
root@panda-pc:~# dpkg -i /home/panda/Téléchargements/veracrypt-1.24-Update4-Debian-10-amd64.deb
(Lecture de la base de données... 203841 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../veracrypt-1.24-Update4-Debian-10-amd64.deb ...
Dépaquetage de veracrypt (1.24.12-1) sur (1.24.12-1) ...
Paramétrage de veracrypt (1.24.12-1) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-4) ...
Traitement des actions différées (« triggers ») pour mime-support (3.62) ...
 



veracrypt


Usage: veracrypt [--auto-mount <str>] [--backup-headers] [--background-task] [-C] [-c] [--create-keyfile] [--delete-token-keyfiles] [-d] [--display-password] [--encryption <str>] [--explore] [--export-token-keyfile] [--filesystem <str>] [-f] [--fs-options <str>] [--hash <str>] [-h] [--import-token-keyfiles] [-k <str>] [-l] [--list-token-keyfiles] [--load-preferences] [--mount] [-m <str>] [--new-hash <str>] [--new-keyfiles <str>] [--new-password <str>] [--new-pim <str>] [--non-interactive] [--stdin] [-p <str>] [--pim <str>] [--protect-hidden <str>] [--protection-hash <str>] [--protection-keyfiles <str>] [--protection-password <str>] [--protection-pim <str>] [--random-source <str>] [--restore-headers] [--save-preferences] [--quick] [--size <str>] [--slot <str>] [-tc] [--test] [-t] [--token-lib <str>] [--token-pin <str>] [-v] [--version] [--volume-properties] [--volume-type <str>] [--no-size-check] [--legacy-password-maxlength] [--use-dummy-sudo-password] [Volume path] [Mount point]
  --auto-mount=<str>          Auto mount device-hosted/favorite volumes
  --backup-headers            Backup volume headers
  --background-task           Start Background Task
  -C, --change                Change password or keyfiles
  -c, --create                Create new volume
  --create-keyfile            Create new keyfile
  --delete-token-keyfiles     Delete security token keyfiles
  -d, --dismount              Dismount volume
  --display-password          Display password while typing
  --encryption=<str>          Encryption algorithm
  --explore                   Open explorer window for mounted volume
  --export-token-keyfile      Export keyfile from security token
  --filesystem=<str>          Filesystem type
  -f, --force                 Force mount/dismount/overwrite
  --fs-options=<str>          Filesystem mount options
  --hash=<str>                Hash algorithm
  -h, --help                  Display detailed command line help
  --import-token-keyfiles     Import keyfiles to security token
  -k, --keyfiles=<str>        Keyfiles
  -l, --list                  List mounted volumes
  --list-token-keyfiles       List security token keyfiles
  --load-preferences          Load user preferences
  --mount                     Mount volume interactively
  -m, --mount-options=<str>   VeraCrypt volume mount options
  --new-hash=<str>            New hash algorithm
  --new-keyfiles=<str>        New keyfiles
  --new-password=<str>        New password
  --new-pim=<str>             New PIM
  --non-interactive           Do not interact with user
  --stdin                     Read password from standard input
  -p, --password=<str>        Password
  --pim=<str>                 PIM
  --protect-hidden=<str>      Protect hidden volume
  --protection-hash=<str>     Hash algorithm for protected hidden volume
  --protection-keyfiles=<str> Keyfiles for protected hidden volume
  --protection-password=<str> Password for protected hidden volume
  --protection-pim=<str>      PIM for protected hidden volume
  --random-source=<str>       Use file as source of random data
  --restore-headers           Restore volume headers
  --save-preferences          Save user preferences
  --quick                     Enable quick format
  --size=<str>                Size in bytes
  --slot=<str>                Volume slot number
  -tc, --truecrypt            Enable TrueCrypt mode. Should be put first to avoid issues.
  --test                      Test internal algorithms
  -t, --text                  Use text user interface
  --token-lib=<str>           Security token library
  --token-pin=<str>           Security token PIN
  -v, --verbose               Enable verbose output
  --version                   Display version information
  --volume-properties         Display volume properties
  --volume-type=<str>         Volume type
  --no-size-check             Disable check of container size against disk free space.
  --legacy-password-maxlength Use legacy maximum password length (64 UTF-8 bytes)
  --use-dummy-sudo-password   Use dummy password in sudo to detect if it is already authenticated

(process:1794): GLib-GObject-WARNING **: 21:19:03.501: invalid (NULL) pointer instance

(process:1794): GLib-GObject-CRITICAL **: 21:19:03.501: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(process:1794): GLib-GObject-WARNING **: 21:19:03.501: invalid (NULL) pointer instance

(process:1794): GLib-GObject-CRITICAL **: 21:19:03.501: g_signal_handlers_disconnect_matched: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed
 



Là je n'ai rien compris. Je crois que la commande "apt --fix-broken install" a fonctionné par qu'après l'installation de la dépendance s'est bien passée (enfin c'est ce que je pense vu qu'il n'y a plus de message d'erreur). Cependant, lorsque je lance "veracrypt" je ne comprends pas ce qu'il se passe. Je m'attendais à ce qu'une fenêtre s'ouvre.

Quelqu'un a-t-il une idée ?

EDIT : C'est bon j'ai trouvé, il fallait juste entrer la commande en simple utilisateur et non pas en root.

Dernière modification par Genji (10-03-2020 21:29:21)


"Le cours de la rivière qui va jamais ne tarit, et pourtant ce n'est jamais la même eau. L'écume qui flotte sur les eaux dormantes tantôt se dissipe tantôt se reforme, et il n'est d'exemple que longtemps elle ait duré. Pareillement advient-il des hommes et des demeures qui sont en ce monde." - Kamo no Chômei, Notes de l'ermitage

Hors ligne

Pied de page des forums