Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 11-06-2010 15:23:05

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Parce que je l'ai cherché un bon moment dans les tutos du wiki df, j'en ai fait une page pour lui tout seul !
Là :
http://debian-facile.org/doc:systeme:apt:apt-listbugs

Yep ! big_smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#2 28-02-2016 10:27:11

Coconuts
Membre
Lieu : Ici dans un Rucher d'abeilles
Distrib. : Jessie/ Stretch/Sid
Noyau : Linux Version 3.16.0-4-amd64/ Linux version 4.2.0-
(G)UI : GNOME/ Version 3.14.1/LXDM-MATE
Inscription : 29-06-2014

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

@smolski Bonjour,

[Pour information sur Debian Stretch, la commande aptitude install apt-listbugs n'est pas reconnue, sur mon système, car le paquet n'est pas installé.
J'ai donc lancé la commande apt install apt-listbugs
Ci-joint le test pour l'install.
pat@testing:~$ su -
Mot de passe :
root@testing:~# aptitude install apt-listbugs
-su: aptitude : commande introuvable

apt install apt-listbugs


 Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libquvi-scripts libquvi7
  libservlet2.5-java
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  ruby-debian ruby-domain-name ruby-gettext ruby-http-cookie ruby-httpclient
  ruby-locale ruby-soap4r ruby-sqlite3 ruby-text ruby-unf ruby-unf-ext
  ruby-unicode ruby-xmlparser sqlite3
Paquets suggérés :
  sqlite3-doc
Les NOUVEAUX paquets suivants seront installés :
  apt-listbugs ruby-debian ruby-domain-name ruby-gettext ruby-http-cookie
  ruby-httpclient ruby-locale ruby-soap4r ruby-sqlite3 ruby-text ruby-unf
  ruby-unf-ext ruby-unicode ruby-xmlparser sqlite3
0 mis à jour, 15 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 1 542 ko dans les archives.
Après cette opération, 10,2 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-debian amd64 0.3.9+b5 [22,0 kB]
Réception de:2 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-locale all 2.1.2-1 [89,6 kB]
Réception de:3 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-text all 1.3.0-1 [13,0 kB]
Réception de:4 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-gettext all 3.1.7-1 [133 kB]
Réception de:5 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-xmlparser amd64 0.7.3-1+b3 [82,6 kB]
Réception de:6 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-soap4r all 2.0.5-3 [96,3 kB]
Réception de:7 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-unicode amd64 0.4.4-2+b6 [83,2 kB]
Réception de:8 http://ftp.fr.debian.org/debian stretch/main amd64 apt-listbugs all 0.1.17 [83,4 kB]
Réception de:9 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-unf-ext amd64 0.0.7.2-1+b1 [91,1 kB]
Réception de:10 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-unf all 0.1.4-1 [4 876 B]
Réception de:11 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-domain-name all 0.5.21-1 [66,8 kB]
Réception de:12 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-http-cookie all 1.0.2-1 [22,3 kB]
Réception de:13 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-httpclient all 2.6.0.1-1 [200 kB]
Réception de:14 http://ftp.fr.debian.org/debian stretch/main amd64 ruby-sqlite3 amd64 1.3.11-1 [38,8 kB]
Réception de:15 http://ftp.fr.debian.org/debian stretch/main amd64 sqlite3 amd64 3.10.2-1 [515 kB]
1 542 ko réceptionnés en 0s (1 554 ko/s)
Sélection du paquet ruby-debian précédemment désélectionné.
(Lecture de la base de données... 210902 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../ruby-debian_0.3.9+b5_amd64.deb ...
Dépaquetage de ruby-debian (0.3.9+b5) ...
Sélection du paquet ruby-locale précédemment désélectionné.
Préparation du dépaquetage de .../ruby-locale_2.1.2-1_all.deb ...
Dépaquetage de ruby-locale (2.1.2-1) ...
Sélection du paquet ruby-text précédemment désélectionné.
Préparation du dépaquetage de .../ruby-text_1.3.0-1_all.deb ...
Dépaquetage de ruby-text (1.3.0-1) ...
Sélection du paquet ruby-gettext précédemment désélectionné.
Préparation du dépaquetage de .../ruby-gettext_3.1.7-1_all.deb ...
Dépaquetage de ruby-gettext (3.1.7-1) ...
Sélection du paquet ruby-xmlparser précédemment désélectionné.
Préparation du dépaquetage de .../ruby-xmlparser_0.7.3-1+b3_amd64.deb ...
Dépaquetage de ruby-xmlparser (0.7.3-1+b3) ...
Sélection du paquet ruby-soap4r précédemment désélectionné.
Préparation du dépaquetage de .../ruby-soap4r_2.0.5-3_all.deb ...
Dépaquetage de ruby-soap4r (2.0.5-3) ...
Sélection du paquet ruby-unicode précédemment désélectionné.
Préparation du dépaquetage de .../ruby-unicode_0.4.4-2+b6_amd64.deb ...
Dépaquetage de ruby-unicode (0.4.4-2+b6) ...
Sélection du paquet apt-listbugs précédemment désélectionné.
Préparation du dépaquetage de .../apt-listbugs_0.1.17_all.deb ...
Dépaquetage de apt-listbugs (0.1.17) ...
Sélection du paquet ruby-unf-ext précédemment désélectionné.
Préparation du dépaquetage de .../ruby-unf-ext_0.0.7.2-1+b1_amd64.deb ...
Dépaquetage de ruby-unf-ext (0.0.7.2-1+b1) ...
Sélection du paquet ruby-unf précédemment désélectionné.
Préparation du dépaquetage de .../ruby-unf_0.1.4-1_all.deb ...
Dépaquetage de ruby-unf (0.1.4-1) ...
Sélection du paquet ruby-domain-name précédemment désélectionné.
Préparation du dépaquetage de .../ruby-domain-name_0.5.21-1_all.deb ...
Dépaquetage de ruby-domain-name (0.5.21-1) ...
Sélection du paquet ruby-http-cookie précédemment désélectionné.
Préparation du dépaquetage de .../ruby-http-cookie_1.0.2-1_all.deb ...
Dépaquetage de ruby-http-cookie (1.0.2-1) ...
Sélection du paquet ruby-httpclient précédemment désélectionné.
Préparation du dépaquetage de .../ruby-httpclient_2.6.0.1-1_all.deb ...
Dépaquetage de ruby-httpclient (2.6.0.1-1) ...
Sélection du paquet ruby-sqlite3 précédemment désélectionné.
Préparation du dépaquetage de .../ruby-sqlite3_1.3.11-1_amd64.deb ...
Dépaquetage de ruby-sqlite3 (1.3.11-1) ...
Sélection du paquet sqlite3 précédemment désélectionné.
Préparation du dépaquetage de .../sqlite3_3.10.2-1_amd64.deb ...
Dépaquetage de sqlite3 (3.10.2-1) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Paramétrage de ruby-debian (0.3.9+b5) ...
Paramétrage de ruby-locale (2.1.2-1) ...
Paramétrage de ruby-text (1.3.0-1) ...
Paramétrage de ruby-gettext (3.1.7-1) ...
Paramétrage de ruby-xmlparser (0.7.3-1+b3) ...
Paramétrage de ruby-soap4r (2.0.5-3) ...
Paramétrage de ruby-unicode (0.4.4-2+b6) ...
Paramétrage de apt-listbugs (0.1.17) ...
Paramétrage de ruby-unf-ext (0.0.7.2-1+b1) ...
Paramétrage de ruby-unf (0.1.4-1) ...
Paramétrage de ruby-domain-name (0.5.21-1) ...
Paramétrage de ruby-http-cookie (1.0.2-1) ...
Paramétrage de ruby-httpclient (2.6.0.1-1) ...
Paramétrage de ruby-sqlite3 (1.3.11-1) ...
Paramétrage de sqlite3 (3.10.2-1) ...
root@testing:~#



Ensuite pour tester aptitude, je l'ai installé :

apt install aptitude


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libquvi-scripts libquvi7
  libservlet2.5-java
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  aptitude-common aptitude-doc-en libboost-filesystem1.58.0 libcwidget3v5
Paquets suggérés :
  apt-xapian-index debtags libcwidget-dev
Les NOUVEAUX paquets suivants seront installés :
  aptitude aptitude-common aptitude-doc-en libboost-filesystem1.58.0
  libcwidget3v5
0 mis à jour, 5 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 3 640 ko dans les archives.
Après cette opération, 16,1 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de:1 http://ftp.fr.debian.org/debian stretch/main amd64 aptitude-common all 0.7.5-3 [1 483 kB]
Réception de:2 http://ftp.fr.debian.org/debian stretch/main amd64 libboost-filesystem1.58.0 amd64 1.58.0+dfsg-4.1 [60,6 kB]
Réception de:3 http://ftp.fr.debian.org/debian stretch/main amd64 libcwidget3v5 amd64 0.5.17-4+b1 [313 kB]
Réception de:4 http://ftp.fr.debian.org/debian stretch/main amd64 aptitude amd64 0.7.5-3 [1 357 kB]
Réception de:5 http://ftp.fr.debian.org/debian stretch/main amd64 aptitude-doc-en all 0.7.5-3 [427 kB]
3 640 ko réceptionnés en 1s (2 923 ko/s)
Récupération des rapports de bogue… Fait
Analyse des informations Trouvé/Corrigé… Fait
Sélection du paquet aptitude-common précédemment désélectionné.
(Lecture de la base de données... 212839 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../aptitude-common_0.7.5-3_all.deb ...
Dépaquetage de aptitude-common (0.7.5-3) ...
Sélection du paquet libboost-filesystem1.58.0:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libboost-filesystem1.58.0_1.58.0+dfsg-4.1_amd64.deb ...
Dépaquetage de libboost-filesystem1.58.0:amd64 (1.58.0+dfsg-4.1) ...
Sélection du paquet libcwidget3v5:amd64 précédemment désélectionné.
Préparation du dépaquetage de .../libcwidget3v5_0.5.17-4+b1_amd64.deb ...
Dépaquetage de libcwidget3v5:amd64 (0.5.17-4+b1) ...
Sélection du paquet aptitude précédemment désélectionné.
Préparation du dépaquetage de .../aptitude_0.7.5-3_amd64.deb ...
Dépaquetage de aptitude (0.7.5-3) ...
Sélection du paquet aptitude-doc-en précédemment désélectionné.
Préparation du dépaquetage de .../aptitude-doc-en_0.7.5-3_all.deb ...
Dépaquetage de aptitude-doc-en (0.7.5-3) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.21-9) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
Paramétrage de aptitude-common (0.7.5-3) ...
Paramétrage de libboost-filesystem1.58.0:amd64 (1.58.0+dfsg-4.1) ...
Paramétrage de libcwidget3v5:amd64 (0.5.17-4+b1) ...
Paramétrage de aptitude (0.7.5-3) ...
update-alternatives: utilisation de « /usr/bin/aptitude-curses » pour fournir « /usr/bin/aptitude » (aptitude) en mode automatique
Paramétrage de aptitude-doc-en (0.7.5-3) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.21-9) ...
Traitement des actions différées (« triggers ») pour menu (2.1.47) ...
root@testing:~#  



puis lancé la commande apt autoremove comme demandé plus haut :
E: L'opération autoremove  n'est pas valable, donc j'ai lancé

apt-get autoremove


Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Les paquets suivants seront ENLEVÉS :
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libquvi-scripts libquvi7
  libservlet2.5-java
0 mis à jour, 0 nouvellement installés, 5 à enlever et 0 non mis à jour.
Après cette opération, 7 177 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 213193 fichiers et répertoires déjà installés.)
Suppression de libgstreamer-plugins-base0.10-0:amd64 (0.10.36-2) ...
Suppression de libgstreamer0.10-0:amd64 (0.10.36-1.5) ...
Suppression de libquvi7:amd64 (0.4.1-3) ...
Suppression de libquvi-scripts (0.4.21-2) ...
Suppression de libservlet2.5-java (6.0.41-4) ...
Traitement des actions différées (« triggers ») pour libc-bin (2.21-9) ...
Traitement des actions différées (« triggers ») pour man-db (2.7.5-1) ...
root@testing:~#  



Et voili voilou smile ça baigne  wink

Dernière modification par Coconuts (28-02-2016 10:34:09)


Le chocolat a un effet anti-fatigue et anti-déprime, n’hésitez pas à craquer pour un carré de chocolat, c’est bon pour le moral et pour l'esprit en général.
Des points-choco faciles pour piller la cassette à Smolski – Merci qui ? Merci bendia

Hors ligne

#3 28-02-2016 10:31:23

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Merci Coconuts, je l'avais raté celui-là, je le mettrai en conformité ....

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#4 28-02-2016 10:37:26

Coconuts
Membre
Lieu : Ici dans un Rucher d'abeilles
Distrib. : Jessie/ Stretch/Sid
Noyau : Linux Version 3.16.0-4-amd64/ Linux version 4.2.0-
(G)UI : GNOME/ Version 3.14.1/LXDM-MATE
Inscription : 29-06-2014

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

@milou Merci et bon dimanche smile
Bisous wink

Le chocolat a un effet anti-fatigue et anti-déprime, n’hésitez pas à craquer pour un carré de chocolat, c’est bon pour le moral et pour l'esprit en général.
Des points-choco faciles pour piller la cassette à Smolski – Merci qui ? Merci bendia

Hors ligne

#5 28-02-2016 10:38:44

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Bon dimanche à toi aussi  smile
Bisous  wink

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#6 28-02-2016 18:37:35

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

J'ai mis en conformité la page.
J'ai utilisé apt-get à la place d'apt, comme conseillé jusqu'à maintenant ...
(j'ai fait une simul sur ma stretch pour voir si ça passait avec apt-get avant ... tongue )

Par contre pour Option list, j'ai laissé aptitude.... bon ou pas bon ?

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#7 28-02-2016 18:39:39

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Impec, laisse-le.
aptitude est un outil très évolué et pratique pour être signalé comme tel dans quelques cas précis, comme celui-ci. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 28-02-2016 18:41:08

milou
Modo ... e
Lieu : Sur une autre planète....
Distrib. : Jessie - Stretch/Sid
Noyau : 3.16.0-4-amd64
(G)UI : Lxde
Inscription : 12-02-2015
Site Web

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Ok smile

J’adorerais changer le monde, mais ils ne veulent pas me fournir le code source
Un vrai geek, c'est un mec qui croit que dans 1km, il y a 1024 mètres
Dans le doute, rebootes. Si tu te tâtes, formates.
1453651422.jpg

Hors ligne

#9 02-03-2016 21:22:41

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Salut,

Juste pour signaler que apt-listbugs épingle les paquets bogués ( pinning ) dans le fichier : /etc/apt/preferences.d/apt-listbugs
( sur ma sid, c'est ce chemin )

Il est quelque fois nécessaire d'y accéder pour la gestion des paquets ! smile
( ça arrive qu'il épingle un paquet bogué avec un * plutôt que la version défectueuse et je ne sais pas pourquoi ?
et faut bien donner sa chance à la prochaine version deboguée ! hmm )

et aussi que apt-listbugs peut être utile sous stable ! big_smile

Dernière modification par nono47 (02-03-2016 21:33:55)

Hors ligne

#10 02-03-2016 21:30:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Sous stable nono47 ? smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 02-03-2016 21:45:04

nono47
Membre
Lieu : dans l'engrenage ...
Distrib. : sid
Noyau : Linux 4.8.0-1-amd64
(G)UI : gnome-shell
Inscription : 09-05-2012

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

pour réparer sid qui évolue dans la suprême dimension...

Tiens, le système aux petits oignons tel que tu veux est dans le carton :
1456947557.png

heu, c'est quoi normal stable ? tongue

édition : ça pourrait faire un avatar .

édition2 : y'a soirée gainsbarre sur FIP !

Dernière modification par nono47 (02-03-2016 21:55:37)

Hors ligne

#12 02-03-2016 22:48:46

Papadakis
Adhérent(e)
Lieu : Far ouest environ
Distrib. : Stretch
Noyau : Linux 4.5.0-2-amd64
(G)UI : xfce 4.12
Inscription : 23-04-2014
Site Web

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Sid, apt-listbugs, mais quels sont les problèmes de vos vies ?

Comme dit nono47, dans la suprême dimension, tout est ok, on the board and roll again.

Et viva FIP !

Le désordre, c'est l'ordre moins le pouvoir.

Hors ligne

#13 02-03-2016 22:51:36

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

Ah oui, malin ça d'utiliser une stable pour utiliser tranquillement apt-listbugs.
Mais ça marche comment ?
Quel est la procédure dans ce cas-là ?

Pour les curieux :
Le tuto apt-listbugs est ici ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#14 11-09-2016 14:10:54

Mercredi
Membre
Distrib. : Testing
Noyau : 4.8
(G)UI : Gnome
Inscription : 25-09-2015

Re : Wiki - apt-listbugs Logiciel de surveillance des paquets bogués

nono47 a écrit :

Juste pour signaler que apt-listbugs épingle les paquets bogués ( pinning ) dans le fichier : /etc/apt/preferences.d/apt-listbugs
( sur ma sid, c'est ce chemin )

Il est quelque fois nécessaire d'y accéder pour la gestion des paquets ! smile
( ça arrive qu'il épingle un paquet bogué avec un * plutôt que la version défectueuse et je ne sais pas pourquoi ?
et faut bien donner sa chance à la prochaine version deboguée ! hmm )


Salut Nono,

Comme ça ?

Explanation: bla bla bla etc ...
Package: mysql-server-5.6
Pin: version *
Pin-priority: -30000


Tu corriges comment ?
En remplaçant simplement le * par le n° de version ?


De toutes les forces de l'univers, la plus dure à surmonter, c'est la force de l'habitude. T.Pratchett - Trois Soeurcières.

Hors ligne

Pied de page des forums