Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 23-06-2010 19:37:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Bug de sécurité avec flash

captnfab nous dit :

Certains l'ont peut-être remarqué, le paquet flashplayer-nonfree sous Debian sid amd64 n'est plus fonctionnel depuis quelques temps.

Les plus avides de logs d'entre vous auront peut-être remarqué le message suivant :

ERROR: 64 bit player temporarily not supported
More information might be available at:
  http://wiki.debian.org/FlashPlayer


En vérité :

Une faille majeure a été détectée dans la version beta du plugin 64bits d'adobe flash player 10.1, permettant l'exécution de code arbitraire sur la machine client.
Après quoi, ils ont arrêté le développement de cette beta. smile
Donc il n'y a pas, actuellement, de plugin flash officiel sous Debian/sid amd64.


Les solutions proposées sont :

1) Installer un firefox 32bits et un flashplayer 32 bits dans un chroot 32bits
2) Se passer de flash. smile
3) Récupérer la dernière version de la beta 64bits et mettre le libflashplayer.so dans ~/.mozilla/plugins/ (<- la mauvaise solution !  <= À ne pas faire à moins d'avoir une confiance totale pour les applets flash visionnés.)


Adobe dit qu'ils sont en train de faire une refonte profonde du player et qu'un plugin linux 64bits sera disponible une fois cela effectué.

Have fun.


Qu'on se le dise !

Merci captnfab pour cette info circonstanciée et documentée ! smile

PS :
Je me suis permis de corriger une fôte d'accord au début, tu avais écrit :

Certains l'ont peut-être remarqués


J'ai donc retirer le "s", cela t'évitera d'avoir deux traits dans la marge pour "Faute de Grammaire".

Ne me remercie pas, c'est purement philantropique de ma part, et si ça peut servir aux générations futures, hein !

Tchibâââ ! lol

Amitié, Joel, dit l'Enf...


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#2 23-06-2010 19:52:11

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug de sécurité avec flash

Mamannnnnnn ! Jojo il est vilain avec moi !
Il me moque :'(

Dernière modification par Capitaine Fab (23-06-2010 19:52:23)


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#3 24-06-2010 00:58:46

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Bug de sécurité avec flash

Bonsoir
Il y a effectivement un soucis avec le flash-64bits neutral

http://labs.adobe.com/technologies/flas … 64bit.html
( une de mes sid en a fait les frais )
Soit gnash soit patience ... soit version 32bits sad
Merci adobe

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#4 24-06-2010 13:29:02

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : Bug de sécurité avec flash

Clem a écrit :

Soit gnash soit patience ... soit version 32bits sad


Soit rien du tout... tongue


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#5 24-06-2010 13:48:17

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Bug de sécurité avec flash

mani +1  lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#6 24-06-2010 19:28:13

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Bug de sécurité avec flash

Salut,

sinon une version antérieur en attendant à télécharger ici
et copier le fichier .so ds /usr/lib/mozilla/plugins/
ou créer un répertoire plugins ds /home/user/.mozilla/

Dernière modification par n3os (24-06-2010 19:28:55)

Hors ligne

#7 26-06-2010 14:07:43

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : Bug de sécurité avec flash

Une alternative pour lire les vidéos sur youtube avec iceweasel/firefox sans utiliser flash :

aptitude install xul-ext-greasemonkey gecko-mediaplayer

Relancer le navigateur.

Installation du script http://userscripts.org/scripts/show/50771 (en cliquant sur install puis en confirmant dans la boîte de dialogue)

Et voilà.

Merci à Engil pour le tuyau.

Dernière modification par Capitaine Fab (26-06-2010 14:08:43)


captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#8 27-06-2010 18:45:58

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : Bug de sécurité avec flash

Malheureusement, gnash ou d'autres solutions libres se casseront les dents sur certains sites qui ne fonctionnent qu'avec le greffon propriétaire d'Adobe (je pense notamment à www.noirdez.com , ce qui est paradoxal de la part d'un groupe affichant par ailleurs des opinions alter et libertaires... bref).

La solution la plus simple pour utiliser le flashplugin-nonfree dans un environnement 64 bits est donc pour l'heure celle proposée par n3os.

Pour ceux qui veulent la version "up to date", il y a l'ancienne méthode consistant à utiliser le greffon 32 bits dans un Iceweasel/Firefox 64 bits grâce à nspluginwrapper.
Je la rappelle ici pour les nouveaux utilisateurs de Debian venant d'installer leur système 64 bits :

Installer nspluginwrapper :
# aptitude install nspluginwrapper

Aller sur http://get.adobe.com/fr/flashplayer/ et télécharger le .tar.gz pour Linux
Le décompresser dans son /home/user (on obtient le fichier libflashplayer.so)

Créer un répertoire plugins32 dans /usr/lib/mozilla :
# mkdir /usr/lib/mozilla/plugins32

Y copier le fichier libflashplayer.so :
# cp /home/user/libflashplayer.so /usr/lib/mozilla/plugins32
(remplacer 'user' par son nom d'utilisateur, j'le dis des fois que... )

La commande magique :
# nspluginwrapper -i /usr/lib/mozilla/plugins32/libflashplayer.so

Sous Lenny, cette dernière commande provoque l'erreur suivante :
*** NSPlugin Viewer *** ERROR: libnss3.so: cannot open shared object file: No such file or directory
libnss3.so est pourtant bien présente dans /usr/lib

Pour résoudre les problèmes de librairies, on installe getlibs.
À l'heure où j'écris ces lignes, le paquet est disponible à l'adresse ci-dessous.
On le télécharge :
$ wget http://frozenfox.freehostia.com/cappy/getlibs-all.deb
On l'installe avec dpkg :
# dpkg -i getlibs-all.deb
Puis :
# getlibs -p libcurl3
# getlibs -p libnss3-1d
# getlibs -p libnspr4-0d
# getlibs -p libidn11
# getlibs -p libssh2-1


On retape la commande :
# nspluginwrapper -i /usr/lib/mozilla/plugins32/libflashplayer.so
Cette fois, elle s'exécute sans erreur.

On redémarre Iceweasel, ça marche smile
On peut supprimer le .tar.gz et le libflashplayer.so restés dans le /home/user
__

Dernière modification par pirlouit (29-06-2010 15:48:35)

Hors ligne

#9 28-06-2010 22:28:23

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : Bug de sécurité avec flash

ha moi perso j'utilise la solution 3.

Je sait que ces pas le top, mais bon je veut pas me faire chier avec un navigateur 32 bis (en règle général je vire les programmes 32 bis car je veux que du 64 bis).

Quant au flash vivement qu'ont bascule vers les balises en html 5, pour les vidéos du moins.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#10 29-06-2010 15:43:59

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : Bug de sécurité avec flash

... bon, la solution nspluginwrapper est pas top, niveau stabilité : le plugin a planté sur une page MySpace bien chargée... obligé de redémarrer le navigateur (chez moi, Firefox 3.6.6 compilé maison sur ma Lenny 64-bit).

J'ai donc tout viré et réinstallé la version 10.0.45 x86_64 dont le lien est fourni un peu plus haut par n3os, ça roule impec.
Simple, efficace, et une seule faille connue (exploitable lors de la consultation en ligne d'un fichier PDF contenant du flash... ça s'est jamais présenté pour moi en 10 ans de navigation).

__

Hors ligne

#11 30-06-2010 17:37:55

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : Bug de sécurité avec flash

Capitaine Fab a écrit :

Une alternative pour lire les vidéos sur youtube avec iceweasel/firefox sans utiliser flash :

aptitude install xul-ext-greasemonkey gecko-mediaplayer

Relancer le navigateur.

Installation du script http://userscripts.org/scripts/show/50771 (en cliquant sur install puis en confirmant dans la boîte de dialogue)

Et voilà.

Merci à Engil pour le tuyau.


effectivement marche pas mal, ça fera plaisir à ceux qui veulent que du libre wink
le tuto ici, si quelqu'un veut se dévouer pour mettre cette alternative ds le wiki wink

Hors ligne

#12 30-06-2010 23:09:00

Tophe
Membre
Lieu : Ardeche
Distrib. : Stable
(G)UI : Kde
Inscription : 11-10-2008

Re : Bug de sécurité avec flash

chiwawa a écrit :

Quant au flash vivement qu'ont bascule vers les balises en html 5, pour les vidéos du moins.


ce n'est apparemment pour tout de suite
http://www.zdnet.fr/actualites/google-c … 752829.htm


* AMD Athlon 64 3500+ / ASUS A8N-SLI / nVidia GeForce 6200 / RAM 1Go / Debian Stable / KDE
* Eee PC X101CH / RAM 1Go / Debian Stable / KDE
Xtophe - Ardèche

Hors ligne

#13 01-08-2010 18:44:36

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Bug de sécurité avec flash

+1 pour la méthode de n3os.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#14 16-09-2010 17:11:43

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Bug de sécurité avec flash

Depuis peu, le plugin d'adobe flash player linux 64bits est de nouveau disponible sur le site d'adobe:
http://labs.adobe.com/downloads/flashplayer10.html

Il s'agit d'une version preview1 de la future version 10.2 du plugin.

Pour l'installation, télécharger le .tar.gz puis le décompresser et copier le fichier libflashplayer.so, et je reprends l'explication parfaite de n3os:
"dans /usr/lib/mozilla/plugins/
ou créer un répertoire plugins ds /home/user/.mozilla/"

Dernière modification par pili36 (16-09-2010 17:23:59)


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

Pied de page des forums