Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-07-2010 13:33:33

Geckotokai
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 30-06-2010

Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Eh voui, encore moi en mes questions smile

Aujourd'hui je vous propose l'installation de ma carte son qui, je ne sais pas pourquoi, ne veut pas fonctionner tongue

Ma carte son est une Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03), elle est bien détectée dans les périphériques avec lspci.

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)


Voici ce que j'ai déja fait :

1) J'ai poussé le son `master` à fond
2) J'ai poussé tous les volumes d'alsamixer à fond
3) Le son de vlc était à fond

La je me dis que c'est sûrement le pilote qui ne vas pas. Le gros soucis c'est que je ne vois pas comment faire. Je me demande si il n'y à pas une meilleure interface graphique pour gérer le son et le pilote utilisé.

Merci d'avance pour votre aide big_smile

Hors ligne

#2 03-07-2010 16:09:09

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Peut être essayer ça?

 alsactl init


en tant que root.
Ignorer le message d'erreur comme 'matériel inconnu', 'Unknown hardware' (this issue said to be fixed in alsa-utils .20), puis redémarrer et essayer de tester votre son.
La source de l'info est ici: http://wiki.debian.org/fr/SoundCard
et dans alsa ici: http://wiki.debian.org/fr/ALSA

Hors ligne

#3 04-07-2010 14:00:53

Geckotokai
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 30-06-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Bonjour, merci pour ta réponse smile

Malheureusement la commande init n'est pas connue du système, j'ai installé tous les paquets en rapport avec alsa et rien n'y a fait, j'ai tout le temps cette erreur :

# alsactl init
alsactl: Unknown command 'init'...


Alsactl prend les commandes suivantes en compte :

# alsactl -h
Usage: alsactl <options> command

Available options:
  -h,--help        this help
  -f,--file #      configuration file (default /var/lib/alsa/asound.state or /etc/asound.names)
  -F,--force       try to restore the matching controls as much as possible
                   (default mode)
  -P,--pedantic    don't restore mismatching controls (old default)
  -d,--debug       debug mode
  -v,--version     print version of this program

Available commands:
  store   <card #> save current driver setup for one or each soundcards
                   to configuration file
  restore <card #> load current driver setup for one or each soundcards
                   from configuration file
  names   <card #> dump information about all the known present (sub-)devices
                   into configuration file (DEPRECATED)


J'ai quasiment tout essayé rien n'a changé, toujours pas de son avec les applications, j'ai toujours un petit bruit de fond qui viens des HP, un genre de clapotis grave...

Hors ligne

#4 05-07-2010 10:02:22

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

J'ai vu ça sur le site d'ALSA, mais c'est en anglais.
Ca parle des cartes Intel.
http://alsa.opensrc.org/index.php/Intel8x0

Sinon: alsactl sans option a tu essayé?

Dernière modification par deuchdeb (05-07-2010 10:03:52)

Hors ligne

#5 05-07-2010 11:22:54

Geckotokai
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 30-06-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

alsactl sans rien donne ça :

# alsactl
alsactl: Specify command...


J'ai été voir ton lien, j'ai testé ce qui est indiqué pour les cartes intel mais ça n'a rien donné. Je continue à chercher hmm

Hors ligne

#6 05-07-2010 14:00:32

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

il y a aussi le paquet alsa-firmware-loaders.

http://packages.debian.org/fr/lenny/als … re-loaders

Hors ligne

#7 05-07-2010 15:40:41

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Salut,

Si c'est un portable, le truc tout bête, as-tu mis le bouton du son en position marche ?

Amitié, Jojo

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#8 05-07-2010 19:58:14

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Bonjour,

Tu pourrais nous donner le retour d'un lspci -nn ?

Hors ligne

#9 06-07-2010 10:49:06

Geckotokai
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 30-06-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

@deuchdeb > Le paquet est installé mais ça n'a rien changé tongue

@smolski > Oui, le bouton est bien activé, quand je fait des tests de son le clapotis grave s'intensifie et me défonce les tympans, je suis obligé de couper le son avec ce fameux bouton avant de reboot.

@tux12 > ta commande me retourne ceci :

# lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port [8086:2a41] (rev 07)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.3 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 [8086:2946] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
00:1c.5 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 [8086:294a] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 9200M GS [10de:06e8] (rev a1)
02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g [14e4:4315] (rev 01)
05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
06:00.0 FireWire (IEEE 1394) [0c00]: JMicron Technologies, Inc. Device [197b:2380]
06:00.1 System peripheral [0880]: JMicron Technologies, Inc. Device [197b:2382]
06:00.2 SD Host controller [0805]: JMicron Technologies, Inc. Device [197b:2381]
06:00.3 System peripheral [0880]: JMicron Technologies, Inc. Device [197b:2383]
06:00.4 System peripheral [0880]: JMicron Technologies, Inc. Device [197b:2384]


Merci pour votre aide, les recherches continuent big_smile

Hors ligne

#10 06-07-2010 23:16:04

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Bonjour,

D'après les infos sur ton circuit son (le 8086:293e qui apparaît dans le lspci -nn) et si j'en crois cette page du wiki debian ce chip est supporté par les modules snd-hda-intel et snd-hda-codec-conexant.

On peut vérifier si ces modules sont bien actifs avec un lsmod | grep snd-hda qui devrait si c'est le cas nous renvoyer leur nom.

A noter d'après la page en question qu'il semble que la mise en veille provoque l'absence de son. Les tests sont donc à effectuer de préférence sur un système qui n'a pas subit de mise en veille.

@+

Dernière modification par tux12 (06-07-2010 23:17:31)

Hors ligne

#11 11-07-2010 10:09:25

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Est ce résolu?

Hors ligne

#12 12-07-2010 13:01:18

Geckotokai
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : Gnome
Inscription : 30-06-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Bah pour le moment ça ne fonctionne toujours pas.

@tux12 > Le ls mod ne retourne rien du tout, les modules ne sont pas actifs et je pense pas que leur installation ai réussie vu que quand je tente de les activer ça me retourne une erreur qui dis que le mod n'existe pas :'(

Hors ligne

#13 12-07-2010 15:23:53

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Peut être ici: http://wiki.debian.org/fr/Modules

Il semble que l'on peut créer un alias pour que le module soit reconnu.
Tu pourrais créer un fichier /etc/modutils/audio en suivant la procedure décrite sur cette page.

Dernière modification par deuchdeb (12-07-2010 15:33:28)

Hors ligne

#14 12-07-2010 16:07:40

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Bonjour,

Geckotokai, peux-tu nous copier précisément la(es) commande(s) que tu passes et le message qu'elle(s) renvoie(nt)?

Donnes nous aussi le résultat d'un find /lib/modules/`uname -r` -name snd-hda*

@+

Hors ligne

#15 12-07-2010 19:18:24

Berillions
Membre
Distrib. : Squeeze
Noyau : 2.6.39-bpo2
(G)UI : Xfce 4.6
Inscription : 02-05-2009

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Si je comprends bien ton problème, tu n'as pas de son en utilisant cette carte?
Petite question tout bête, as-tu lancé alsamixer

Pour chaque canaux, vérifies que ce n'est pas "muted". On remarque cela au carré sous chaque barre verticale. Si c'est "muted", il y a un M dans ce fameux carré.
Appuie sur la touche "M" du clavier pour démutté et augmente ton volume par la suite.

J'ai eu ce problème avec la carte son intégrée de ma CM (une nForce). J'avais beau mettre le son à fond dans le gestionnaire graphique que c'était toujours mutté dans alsamixer.

Apres tes réglages, fais un alsactl store en root pour sauvegarder tes paramètres.

Hors ligne

#16 15-07-2010 20:35:13

debcool
Membre
Lieu : APTown, Debland, Freeworld
Distrib. : SQUEEZE freeze!
Noyau : 2.6.35-9-686-core2-debcool-00
(G)UI : GNOME 2.30.2 + cairo-dock
Inscription : 13-07-2010

Re : Intel Corporation 82801I (ICH9 Family) HD Audio Controller

Salut,

Essayes un :

cat /proc/asound/cards


Nous saurons l'ordre des cartes, le cas échéant.

~# cat /proc/asound/cards
 0 [CMI8738        ]: CMI8738-MC6 - C-Media CMI8738
                      C-Media CMI8738 (model 55) at 0xb800, irq 21
 1 [CX8811         ]: CX88x - Conexant CX8811
                      Conexant CX8811 at 0xf6000000
 2 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfebfc000 irq 17


Tu peux aussi ajouter "snd-hda-intel" dans /etc/modules; puis reboot.

Sinon, dans GNOME, tu vas dans Système-->Préférences-->son et tu sélectionnes la bonne carte.

Si t'as une webcam usb branchée au boot, à tous les coups, elle est détectée comme carte son 0 et donc prise par défaut.

A+
Debcool


"Debian ou lorsque l'utopie dépasse de loin l'unique réalité..."
http://counter.li.org/cgi-bin/certificate.cgi/491825

Hors ligne

Pied de page des forums