Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-07-2010 19:57:27

Abou Ilyès
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Gnome
Inscription : 19-09-2009

[Résolu] GSynaptics couldn't initialize

Bonjour à tous.



J'aimerais lancer GSynaptics afin de paramétrer au mieux mon Touchpad (notamment le double clique que je déteste, question de goût big_smile). Ceci sur une Debian Lenny

J'ai essayé de suivre ce tuto http://wiki.debian.org/SynapticsTouchpad mais j'ai toujours ce message au lancement de GSynaptics

GSynaptics couldn't initialize.
You have to set 'SHMConfig' 'true' in xorg.conf or XF86Config to use GSynaptics


Voici l'extrait de mon /etc/X11/xorg.conf

Section "Module"
    Load           "synaptics"
EndSection


(...)
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"        "/dev/psaux"
        Option          "Protocol"      "auto-dev"
        Option          "HorizScrollDelta"      "0"
        Option          "MaxTapTime"    "0"
[b]        Option          "SHMConfig"     "true"[/b]
EndSection


J'ai testé ceci également (http://doc.ubuntu-fr.org/touchpad), avec la création d'un fichier /etc/hal/fdi/policy/shmconfig.fd



Voici l'extrait du log Xorg.0.log

(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
        compiled for 4.3.99.902, module version = 1.0.0
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0

(...)


(II) Synaptics touchpad driver version 0.14.6 (1406)
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event7
(**) Option "Device" "/dev/input/event7"
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: M$
(--) SynPS/2 Synaptics TouchPad auto-dev sets device to /dev/input/event7
(**) Option "Device" "/dev/input/event7"
(--) SynPS/2 Synaptics TouchPad touchpad found


Mais sans succès.



Pourriez vous m'aider ?

Dernière modification par martinux_qc (01-12-2010 02:59:40)

Hors ligne

#2 22-07-2010 02:37:39

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] GSynaptics couldn't initialize

Salut

J'ai fait quelques recherches mais je ne sais pas si cela peut vraiment t'aider.

D'une part, il y a cette page. Vers le bas on peut lire une "solution" de laguespa.

D'autre part, sur la page de Gsynaptics, on peut que le paquet est obsolète est qu'il faut plutôt utiliser le paquet gpointing-device-settings disponible seulement dans testing et sid. Par contre, toujours sur la page de Gsynaptics on peut lire :

Debian GNOME users,
    you have to add gsynaptics-init on [System] - [Preferences] - [Sessions] - [Startup Programs] in GNOME Menu


C'est peut-être la solution.

Bonne chance
Martin


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#3 30-07-2010 10:28:10

Abou Ilyès
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Gnome
Inscription : 19-09-2009

Re : [Résolu] GSynaptics couldn't initialize

Bonjour,


Merci Martin pour t'être attardé sur mon sujet. Depuis 1 semaine, j'ai essayé de bricoler tout ça.


J'ai fais le tour des posts, notemment celui de laguespa.


Mon but étant de desactiver le tap, j'ai donc essayé de modifier le fichier /usr/share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi avec les parametres trouvé dans le man de synaptics.

Mais toujours ko : les modifications apportés ne donnent rien.

J'ai essayé en supprimant toutes réferences au touchpad dans le Xorg.conf où même en les activant (car je ne sais pas trop s'il faut ou pas "déclarer" le touchpad dans le Xorg si on utilise le fichier fdi)


Par contre, chose que je trouve bizarre (a tord ?)

Quand je me rend dans Système -> Préférences -> Souris les modifications apportés modifie le touchpad, est -ce normal ?

Quand je lance Gconf-editor j'ai "mouse" mais pas "touchpad"


Merci de votre aide, je suis à votre disposition si vous avez besoin d'info smile



Merci smile

Hors ligne

#4 30-07-2010 23:08:03

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] GSynaptics couldn't initialize

Bonjour,

Je n'ai pas d'idée bien précise, mais as-tu regardé du côté du gsynaptics-init que mentionnais Martin? En collant ce terme dans un moteur de recherche, ça à l'air d'être assez bavard (dans les premiers résultats je vois un bug "won't load" et un man chez ubuntu si besoin).

Désolé pour ce post qui ressemble à un RTFM hmm
big_smile

@+

Hors ligne

#5 01-08-2010 11:38:53

Abou Ilyès
Membre
Distrib. : Debian Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Gnome
Inscription : 19-09-2009

Re : [Résolu] GSynaptics couldn't initialize

Bonjour,


c'est résolu smile voici mon /etc/X11/xorg.conf.

Je pense qu'il manquait la partie "ServerLayout" (je n'ai pas compris encore à quoi cela servait)

Section "ServerLayout"
  Identifier     "Default Layout"
  Screen      0  "Default Screen" 0 0
  InputDevice    "Synaptics Touchpad"
EndSection

Section "Module"
    Load           "synaptics"
EndSection

Section "InputDevice"
  Identifier  "Synaptics Touchpad"
  Driver      "synaptics"
  Option      "SendCoreEvents" "true"
  Option      "Device" "/dev/psaux"
  Option      "Protocol" "auto-dev"
  Option      "SHMConfig" "true"
EndSection


J'ai également, comme indiquait Martin, mis ceci au démarrage de gnome

Debian GNOME users,
    you have to add gsynaptics-init on [System] - [Preferences] - [Sessions] - [Startup Programs] in GNOME Menu


Merci à vous smile

Dernière modification par Abou Ilyès (01-08-2010 11:43:49)

Hors ligne

#6 02-08-2010 05:52:57

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] GSynaptics couldn't initialize

Bonjour,

Le ServerLayout lie ensemble des éléments d'entrée (clavier, souris...) et de sortie (Screen, c.a.d. moniteur + CG) définis dans le xorg.conf pour définir une configuration complète du serveur:

man xorg.conf a écrit :

The ServerLayout  sections  are  at  the highest level.  They bind together the input and output devices that will be used in a session.  The input devices are described in the InputDevice  sections.  Output devices usually consist of multiple independent components (e.g., a graphics board and a monitor).  These multiple components are bound together in the Screen sections, and  it  is these  that  are  referenced  by  the ServerLayout section.  Each Screen section binds together a graphics board and a monitor.  The graphics boards are described in the Device sections, and  the monitors are described in the Monitor sections


Hopzathelps et merci pour le retour smile

Hors ligne

#7 30-11-2010 13:24:37

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] GSynaptics couldn't initialize

Salut.

J'ai aussi réglé le problème en ajoutant ça à mon xorg.conf

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
Option "SHMConfig" "on"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
# InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection


Par contre je ne crois pas que le sujet soit passé en résolu.

A+


"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

#8 30-11-2010 20:16:57

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GSynaptics couldn't initialize

9a, c'est que du bon laguespa.

Il revient à l'auteur de le déclarer [Résolu] lui-même dans le titre, après essai sur sa bécane.
En l'état, ton ajout reste une bonne piste par tout visiteur intéressé sur ce fil. smile

Amitié, Joel

Dernière modification par martinux_qc (01-12-2010 02:56:06)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#9 01-12-2010 02:55:36

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] GSynaptics couldn't initialize

Salut Joel

Bien sûr, il revient à l'auteur d'un fil de discussion de passer celui-ci en résolu s'il a trouvé réponse à sa question. Par contre, il peut arriver pour toute sorte de raisons qu'il omet de le faire. On est heureux de résoudre son problème et on passe rapidement à autre chose. Dans le message #5, on peut lire :

Bonjour,


c'est résolu smile voici mon /etc/X11/xorg.conf.

Je pense qu'il manquait la partie "ServerLayout" (je n'ai pas compris encore à quoi cela servait)


Dans ce cas-ci, le problème est bien résolu. Si l'auteur n'a pas éditer son premier message, il est bon qu'un modo passe derrière pour le faire à sa place. Dans un recherche rapide sur le forum, c'est toujours utile de voir les titres des fils avec la mention résolu lorsqu'on cherche une solution à un problème. Ici, je passe donc le fil en résolu (à moins que tu aies une objection mon honneur !).

P.S. Le titre étant trop long, j'ai dû le modifier pour placer le [Résolu]

Dernière modification par martinux_qc (01-12-2010 03:00:38)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#10 01-12-2010 05:37:45

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] GSynaptics couldn't initialize

smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#11 01-12-2010 09:05:19

laguespa
Membre
Distrib. : Jessie
Noyau : 4.2.0-0.bpo.1-amd64
(G)UI : Mate
Inscription : 25-09-2009

Re : [Résolu] GSynaptics couldn't initialize

Oui, martin_mtl, c'est vrai. Lorsque je fais une recherche laisse les messages non résolus de côté et je ne m'intéresse qu'à ceux qui le sont. Merci pour ton intervention donc.
Plus d'infos sur ce bug ici http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=586025

A+

"Ce serait peut-être l’une des plus grandes opportunités manquées de notre époque si le logiciel libre ne libérait rien d’autre que du code."

Hors ligne

Pied de page des forums