Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 06-08-2010 12:59:47

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

[Résolu] installation LXDE debian lenny

Bonjour,
Je viens d'installer la Lenny sur un eeepc Asus 900 en poste de travail.
L'installation s'est déroulée sans problèmes avec les mises à jour pour terminer.
Mais au reboot je tombe sur un écran noir avec le message :

error: file not found
grub rescue>


Que dois-je faire maintenant ?

Comment vérifier le fichier /boot/grub/grub.conf ?
Merci de me donner une piste  smile

Dernière modification par jrev (08-08-2010 13:17:37)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#2 06-08-2010 14:15:07

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : [Résolu] installation LXDE debian lenny

J'ai lancé le live-CD de la Debian lenny LXDE et j'arrive sur le bureau
En ouvrant le file manager je vois ma partition système et le dossier /boot que j'ouvre :
dans le dossier grub j'ai le menu.lst
est-ce bien normal ? pas de grub 2 et fichier grub.config ?

J'ai donc le boot sur (hd1,0) root=/dev/sdb1) alors que je devrais booter sur le 2emme disque

dois-je changer pour (hd1,1)  ?

Merci

Dernière modification par jrev (07-08-2010 17:35:56)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#3 07-08-2010 04:55:22

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] installation LXDE debian lenny

Si tu as installé via usb, c'est possible qu'il y ait des problèmes de reconnaissance des disques. Donc oui, essaie de changer les numérotations de disques. Sinon, essaie de réinstaller grub via le live-cd, par exemple par un chroot (je ne sais pas si ça marche :
# mount /ta/partition/racine /mnt
# chroot /mnt /bin/bash
# grub-setup (hd1,1)
# update-grub
Ou avec un live cd qui a grub2 : # mount /ta/partiton/racine /mnt
# grub-install --root-directory=/mnt /ta/partition

YA3HGA-H

Hors ligne

#4 07-08-2010 17:33:01

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : [Résolu] installation LXDE debian lenny

à quel moment faut-il que le fichier FSTAB monte le dossier / dans la racine duquel lequel se trouve le fichier vmlinuz 2.6.26-2-686 ?

Le boot me donne maintenant :

root (hd1.1)
file system type unknown, partition type 0x5
kernel /boot/vmlinuz 2.6.26-2-686 root= /dev/sdb1 ro single
error 17 cannot mount  selected partition


Avez-vous une piste pour la suivre ...

Dernière modification par jrev (07-08-2010 17:34:25)


Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

#5 08-08-2010 08:01:26

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] installation LXDE debian lenny

Ah ce grub...
Bon, je ne sais pas si ça a à voir, mais (hd1, 1), et root=/dev/sdb1 ce ne sont pas les mêmes partitions.
De plus; il n'arrive pas à monter la première. Est-tu sûr que ce sont les bon noms? Je crois qu'ils sont différents avec le nouveau grub.

Sinon, pouquoi ne pas réinstaller grub? essaie avec http://www.framasoft.net/article4617.html , ou alors à partir de ta debian, avec un vrai tutoriel sur le net qui t'expliquera ça mieux que moi hmm

YA3HGA-H

Hors ligne

#6 08-08-2010 10:46:49

zodar
Membre
Lieu : A coté d'Avignon
Distrib. : Sidux
Noyau : 2.6.34
(G)UI : XFCE4
Inscription : 24-02-2010
Site Web

Re : [Résolu] installation LXDE debian lenny

Salut,

Depuis une clé USB, si tu n'as rien touché au moment de l'install de grub, il y a fort à parier qu'il se soit 'installé' sur le mbr de la clé...

Hors ligne

#7 08-08-2010 13:17:10

jrev
Membre
Distrib. : Lenny
Noyau : 2.6.26-2-686
(G)UI : LXDE
Inscription : 28-04-2009

Re : [Résolu] installation LXDE debian lenny

Merci, j'ai trouvé la panne : mauvaise indication de la partition à booter

Ubuntu 10.04,  Debian lxde 6.0.0

Hors ligne

Pied de page des forums