Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-08-2010 14:07:40

rsa31
Membre
Inscription : 09-08-2010

[RESOLU][SAMBA] Migration serveur

Bonjour,
J'ai un problème après la migration de Samba d'un server Debian Woddy / Samba 3.0.4 vers un nouveau server Debian

Lenny / Samba 3.5.3
(paquetage Sernet-Debian récupéré sur le site Samba : pour les prochains ordinateurs Windows 7 à connecter).

J'ai suivi la méthode indiqué dans le manuel Samba (récupéré sur le site samba.org) SAMBA3-ByExample.pdf, Chapitre 8.3.2

Le nouveau serveur a le même nom, le même SID pour le serveur, le même SID pour le domaine que l'ancien serveur.
le SID des utilisateurs (users ou machines) est le même que sur l'ancien serveur
le SID des groupes est également le même.

Pourtant, l'authentification est refusée pour 70% des ordinateurs avec le message d'erreur :
_netr_ServerAuthenticate3 : netlogon_creds_server_check failed. Rejecting auth request from client xxx machine account xxx$.

Tous les ordinateurs sont sous Windows XP pro.
J'ai supprimé le compte machine et je l'ai récréé : le problème persiste.
j'ai fait varier le log level de 2 jusqu'à 10, mais rien dans le fichier de log de la machine ne m'indique la cause de l'erreur.

je ne comprend pas pourquoi l'authentification fonctionne pour certains postes et pas pour d'autres.
je n'ai rien trouvé dans les divers manuels (papiers et électroniques) et forums existants sur Internet.

Pouvez-vous m'indiquer des pistes ou solutions ?
Merci pour votre aide
Cordialement,

[RESOLU] par l'installation de samba 3.4.8 depuis le backport Debian Lenny

Dernière modification par rsa31 (18-08-2010 09:05:12)

Hors ligne

#2 09-08-2010 20:36:06

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : [RESOLU][SAMBA] Migration serveur

Ton smb.conf steuplé, je plussoie que tu est en securité "DOMAINE" mais n'en suis point sur en plus on sais même pas si tu utilise un annuaire ou autre chose pour l'authentification. tu a recup Samba sur les dépôts ou tu l'a compilé (sacré sys-admin !!!)

Hors ligne

#3 10-08-2010 14:29:37

rsa31
Membre
Inscription : 09-08-2010

Re : [RESOLU][SAMBA] Migration serveur

Bonjour,

Désolé, j'ai effectivement oublié certaines informations :
- je n'utilise pas LDAP, et j'utilise tdbsam (pas smbpasswd)
- je n'ai que des serveurs Linux (7 Debian 3 Redhat), le Woody est mon PDC actuel et le Lenny sera son remplaçant.
- je n'ai pas compilé Samba, j'ai récupéré le paquetage sur le site http://enterprisesamba.com/ en mettant deb http://ftp.sernet.de/pub/samba/3.4/debian lenny main dans mon fichier sources.list

Voici un extrait de mon smb.conf :
# Global parameters
[global]
    unix charset = ISO8859-1
    display charset = ISO8859-1
    workgroup = MAIRIE
    server string = Serveur %h (Samba %v)
    security = user
    log level = 0 auth:10 passdb:10 tdb:10
    log file = /var/log/samba/log.%m
    time server = Yes
    printing = cups
    printcap name = cups
    show add printer wizard = No
    logon script = %U.bat
    logon path =
    logon home =
    logon drive =
    domain logons = Yes
    os level = 255
    preferred master = Yes
    domain master = Yes
    wins support = Yes
    dns proxy = No
    name resolve order = wins host bcast lmhosts
    passdb backend = tdbsam
    ldap ssl = no
    socket address = 192.168.9.104
    admin users = @DomAdmins
    nt acl support = No
    hide special files = Yes
    guest account = nobody

[homes]
    comment = Repertoires personnels des utilisateurs
    path = /home/samba/utilisateurs/%U
    username = %S
    valid users = %S
    read only = No
    create mask = 0700
    security mask = 0700
    directory mask = 0700
    directory security mask = 0700
    browseable = No

[netlogon]
    comment = Chemin de demarrage des scripts de connexion
    path = /home/scripts
    browseable = No
    guest ok = Yes
    read only = Yes

Merci pour ton aide
Cordialement,

Hors ligne

#4 10-08-2010 22:38:13

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : [RESOLU][SAMBA] Migration serveur

pourquoi ne pas avoir télécharger directement depuis les port debian... bref... quoi qu'il en soit je ne vois rien dans ton smb.conf qui pourrais me chagriner, en plus je ne connais pas tdbsam... désolé

edit : que fait ton script .bat , juste un "net use" ?

Dernière modification par Pollux (10-08-2010 22:39:34)

Hors ligne

#5 11-08-2010 08:12:07

rsa31
Membre
Inscription : 09-08-2010

Re : [RESOLU][SAMBA] Migration serveur

Bonjour,

j'avais un autre problème avec la version samba de Lenny.
dans le netlogon j'utilisais un script lancé par root preexec pour générer mon script utilisateur.
Celà fonctionnait sur Woody, mais il ne se générait pas sur Lenny ....
Pour récupérer la dernière version de Samba, je suis allé directement sur le site Samba.org où j'ai trouvé le lien vers ce site. (version qui n'a pas réglé mon problème de root preexec).
c'est vrai que je n'ai pas pensé aux backport Lenny .... les retours de vacance sont durs.
je vais donc essayer les backports Lenny de samba (version 3.4.8).

Pour le tdbsam, c'est ce qu'ils conseillent dans la doc samba pour cette version.

Oui, mon script %U.bat utilise juste des "net use", mais qui dépendent de l'utilisateur, du groupe principal de l'utilisateur et, des "net use" particulier pour certains utilisateurs où le groupe principal ne rentre pas en compte.
Tout ceci est intégré dans des "if" imbriqués dans le script qui génére le logon script.

Merci
Bonne journée

Hors ligne

Pied de page des forums