Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-08-2010 06:02:35

damien
Modo / Rédacteur Wiki
Lieu : St Etienne
Distrib. : Debian Jessie 8
Noyau : Linux 3.16.0-4-amd64
(G)UI : Gnome3
Inscription : 22-09-2008
Site Web

lm-sensors, sensors-applet, wmsensors & xsensors (erreur)

Bonjour,

J'essaie depuis des mois de contrôler la température, vitesse de ventilo,... de mes composants de pc.
J'ai installé lm-sensors que je lance avec la commande sensors et voici le résultat

atk0110-acpi-0
Adapter: ACPI interface
ERROR: Can't get value of subfeature in0_input: I/O error
Vcore Voltage:      +0.00 V  (min =  +0.80 V, max =  +1.60 V)
ERROR: Can't get value of subfeature in1_input: I/O error
+3.3V Voltage:      +0.00 V  (min =  +2.97 V, max =  +3.63 V)
ERROR: Can't get value of subfeature in2_input: I/O error
+5V Voltage:        +0.00 V  (min =  +4.50 V, max =  +5.50 V)
ERROR: Can't get value of subfeature in3_input: I/O error
+12V Voltage:       +0.00 V  (min = +10.20 V, max = +13.80 V)
ERROR: Can't get value of subfeature fan1_input: I/O error
CPU Fan Speed:        0 RPM  (min =  600 RPM)
ERROR: Can't get value of subfeature fan2_input: I/O error
Chassis1 Fan Speed:   0 RPM  (min =  600 RPM)
ERROR: Can't get value of subfeature fan3_input: I/O error
Chassis2 Fan Speed:   0 RPM  (min =  600 RPM)
ERROR: Can't get value of subfeature fan4_input: I/O error
Power Fan Speed:      0 RPM  (min =    0 RPM)
ERROR: Can't get value of subfeature temp1_input: I/O error
CPU Temperature:     +0.0°C  (high = +45.0°C, crit = +45.5°C) 
ERROR: Can't get value of subfeature temp2_input: I/O error
MB Temperature:      +0.0°C  (high = +45.0°C, crit = +46.0°C)


De même avec wmsensors

ERROR: Can't get value of subfeature in0_input: I/O error
ERROR: Can't get value of subfeature in1_input: I/O error
ERROR: Can't get value of subfeature in2_input: I/O error
ERROR: Can't get value of subfeature in3_input: I/O error
ERROR: Can't get value of subfeature fan1_input: I/O error
ERROR: Can't get value of subfeature fan2_input: I/O error
ERROR: Can't get value of subfeature fan3_input: I/O error
ERROR: Can't get value of subfeature fan4_input: I/O error
ERROR: Can't get value of subfeature temp1_input: I/O error
ERROR: Can't get value of subfeature temp2_input: I/O error
atk0110-acpi-0
Adapter: ACPI interface
Vcore Voltage:      +0.00 V  (min =  +0.80 V, max =  +1.60 V)
+3.3V Voltage:      +0.00 V  (min =  +2.97 V, max =  +3.63 V)
+5V Voltage:        +0.00 V  (min =  +4.50 V, max =  +5.50 V)
+12V Voltage:       +0.00 V  (min = +10.20 V, max = +13.80 V)
CPU Fan Speed:        0 RPM  (min =  600 RPM)
Chassis1 Fan Speed:   0 RPM  (min =  600 RPM)
Chassis2 Fan Speed:   0 RPM  (min =  600 RPM)
Power Fan Speed:      0 RPM  (min =    0 RPM)
CPU Temperature:     +0.0°C  (high = +45.0°C, crit = +45.5°C) 
MB Temperature:      +0.0°C  (high = +45.0°C, crit = +46.0°C)


Pour l'applet sensors il me dit "Aucun capteur trouvé!" Bizarre non ?

Et pour xsensors il clignote pour m'afficher des valeures bidon 1 fois toutes les deux secondes.

Je ne vous parlent même pas de conky, il ne comprends rien du tout :(
exemple

${color 7f8ed3}Température : ${color}${hwmon 1 temp 2}°C


ne marche pas
voici le message d'erreur conky

Conky: /home/damien/.conkyrc: 18: no such configuration: 'border_margin'
Conky: can't open '/sys/class/hwmon/hwmon1/temp2_input': No such file or directory
please check your device or remove this var from Conky
Conky: Error destroying thread
***** Imlib2 Developer Warning ***** :
    This program is calling the Imlib call:

    imlib_context_free();

    With the parameter:

    context

    being NULL. Please fix your program.


1- Que veux dire ces erreurs ?

ERROR: Can't get value of subfeature in0_input: I/O error
ERROR: Can't get value of subfeature in1_input: I/O error
ERROR: Can't get value of subfeature in2_input: I/O error
ERROR: Can't get value of subfeature in3_input: I/O error
ERROR: Can't get value of subfeature fan1_input: I/O error
ERROR: Can't get value of subfeature fan2_input: I/O error
ERROR: Can't get value of subfeature fan3_input: I/O error
ERROR: Can't get value of subfeature fan4_input: I/O error
ERROR: Can't get value of subfeature temp1_input: I/O error
ERROR: Can't get value of subfeature temp2_input: I/O error


2- Est-ce que je peux trouver dans /sys/class/machin des capteurs fiable pour conky ?

Merci de votre aide
damien


logo_3dminfographie_signature.png

Hors ligne

#2 18-08-2010 09:01:19

Fatimon
Membre
Inscription : 05-08-2010
Site Web

Re : lm-sensors, sensors-applet, wmsensors & xsensors (erreur)

Salut
Je ne sait pas du tout si tu es dans ce cas mais d'après ce que je sait, selon le kernel, la façon dont l'OS peut interagir avec les fonctions ACPI du BIOS a été changée de manière à éviter qu'un bug logiciel provoque un changement de voltage non-désiré, intempestif et destructeur... roll
Ce qui gêne lm-sensors et les drivers qu'il utilise pour communiquer avec le hardware.

ATTENTION: la méthode ci-dessous est non recommandée car dangereuse pour le hardware

Chez moi, pour que lm-sensors fonctionne, j'ai dû modifier le fichier "/etc/default/grub" pour ajouter l'option "acpi_enforce_resources=lax" à la ligne "GRUB_CMDLINE_LINUX" qui est donc maintenant:
[c]GRUB_CMDLINE_LINUX="acpi_enforce_resources=lax"[/c]
Puis évidement:
[c]# update-grub2
# reboot[/c]

Si tu recherches "acpi_enforce_resources=lax" dans ton moteur de recherche préféré tu trouveras plus d'infos smile

A+

Hors ligne

Pied de page des forums