Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 30-08-2010 10:43:18

papousy
Membre
Inscription : 17-03-2010

Exim filter

Bonjour tout le monde,

Voilà je suis vraiment en détresse,
j'ai crée un filtre exim me servant à forwarder un message avec un .forward dans mon répertoire personnelle mais il y a toujours ce problème lorsque je fais un test:

2010-08-30 11:14:35 1OpzVj-0002dI-El <= brunoenee@gmail.com H=mail-ew0-f41.google.com [209.85.215.41] P=esmtp S=1992 id=4C7B75D0.2030900@gmail.com
2010-08-30 11:14:35 1OpzVj-0002dI-El == e.bruno@iis-madagascar.com R=userforward defer (-1): bad mode (0100666) for /home/mail/enee/.forward: 022 bit(s) unexpected


je vous pris vraiment de m'aider c'est très urgent, s'il  vous plait répondez moi.


Cordialement,
BRUNO

Hors ligne

#2 30-08-2010 10:45:18

papousy
Membre
Inscription : 17-03-2010

Re : Exim filter

Je vous envoi le contenu de mon fichier .forward:

e.bruno@ramses:~$ vim .forward
# Exim filter

if error_message then finish endif

if $h_Subject: contains "demande"
then
        deliver brunoenee@yahoo.fr
endif

Hors ligne

#3 31-08-2010 22:40:17

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Exim filter

Quelles sont les autorisations appliquées au fichier ???

J'aurais tendance à faire un :

chmod 755 /home/mail/enee/.forward


Sinon Q0420 de la FAQ Exim :

url : http://www.hcm.com.pl/~piotr/doc/eximFAQ.html

Q0420: Why am I seeing the error "bad mode (100664) for /home/test/.forward (userforward director)"? I've looked through the documentation but can't see anything to suggest that exim has to do anything other than read the .forward file.

A0420: For security, Exim checks for mode bits that shouldn't be set, by default 022. You can change this by setting the "modemask" option of the forwardfile director.

@+

Dernière modification par zoroastre74 (31-08-2010 23:01:50)

Hors ligne

#4 07-09-2010 10:40:47

papousy
Membre
Inscription : 17-03-2010

Re : Exim filter

Merci, j'ai résolu le problème!

Merci beaucoup

Hors ligne

#5 07-09-2010 10:51:03

papousy
Membre
Inscription : 17-03-2010

Re : Exim filter

Par contre, le nouveaux problème c'est que j'arrive pas à exécuter le script dans le fichier .forward je reçois toujours une message d'erreur:

This is an automatically generated message. An error has
been found in your .forward file. Details of the error are
reported below. While this error persists, you will receive
a copy of this message for every message that is addressed
to you. If your .forward file is a filter file, or if it is
a non-filter file containing no valid forwarding addresses,
a copy of each incoming message will be put in your normal
mailbox. If a non-filter file contains at least one valid
forwarding address, forwarding to the valid addresses will
happen, and those will be the only deliveries that occur.

The userforward router encountered the following error(s):

  unknown filtering command ""|/usr/bin/php" near line 7 of filter file

No valid addresses were generated.


voici ce que j'ai dans mon .forward:

# Exim filter

if error_message then finish endif

if $h_Subject: contains "demande"
then
        "|/usr/bin/php /home/mail/enee/script.php"
endif


J'ai déjà essayé ceci mais ça ne marche pas non plus: executer script lors de la reception d'un mail.

Je suis sur sendmail

Merci de m'aider!
Cordialement,
Bruno

Hors ligne

#6 14-09-2010 00:30:26

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Exim filter

Salut,

As-tu essayé de renvoyer ton filtre directement à un adresse mail ??? **

Peux-tu mettre ton "script.php" ? *

@+

Hors ligne

Pied de page des forums