Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 16-09-2010 07:55:58

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Résolu] Configuration du postfix en local

Voilà, j'ai la même question que http://debian-facile.org/forum/viewtopic.php?id=2713
j'ai tout installé selon  http://debian-facile.org/doc:reseau:postfix
sauf la partie sur "vacation", dernière
aurais-je dû ?


Pourquoi voudrais-je une telle installation ?

C'est assez simple: j'ai des tests de courriel à faire un assez gros projet PHP et ça ne me tente pas de lasser tout mes amis avec des messages "test" envoyés automatiquement par ma programmation.  Je veux donc un vrai serveur de courriel, mais en local.  Je pourrai alors envoyer tous les messages que je voudrai et vérifier aussi leur acheminement, leur arrivée.

Bon cela dit, j'ai installé postfix comme dans le tuto.
Je me suis créé un admin directement dans la base de données, c'était moins compliqué que par le setup.php
J'ai maintenant accès à l'interface adminstrative de postfix à l'adresse suivante:  http://localhost/postfixadmin/
Tout va bien, jusque là.

Là où ça achoppe:  envoi d'un courriel  (ah, tiens, justement ce qu'il me faut)
J'obtiens comme réponse: Invalid domain patriboom.net, and/or not discoverable in DNS

Voici ma configuration /etc/postfix/main.cf  (la partie que je crois pertinente)

mydomain=patriboom.net
myhostname = mail.patriboom.net
myorigin = /etc/mailname
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = patriboom.net, localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 10240000


Je crains que ce ne soit ces "patriboom.net" qui soient à la source du problème.  Mais que devrais-je mettre à la place ?   Quel est mon nom de domaine lorsque je suis en local ?

Bon, j'essaie avec "localhost", mais je laisse tout ceci affiché afin que ça serve à d'autres si ça marche.

Bon, j'ai donc essayé ceci (et oui, j'ai fait un apache2 restart après)

mydomain=localhost
myhostname = localhost
myorigin = /etc/mailname
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydestination = localhost
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 10240000


Même message d'erreur.


Je vais ajouter que dans mon PHP.ini j'ai ceci:

sendmail_from patrick@cartefoi.net  patrick@cartefoi.net
sendmail_path /usr/sbin/sendmail -t -i  /usr/sbin/sendmail -t -i


Encore ceci dans mon php.ini:

apache2handlerApache Version  Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny9 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_perl/2.0.4 Perl/v5.10.0
Apache API Version  20051115
Server Administrator  webmaster@localhost
Hostname:Port   Pat.qiniq.com:80
User/Group  www-data(33)/33
Max Requests  Per Child: 0 - Keep Alive: on - Max Per Connection: 100
Timeouts  Connection: 300 - Keep-Alive: 15
Virtual Server  Yes
Server Root   /etc/apache2


hostname:  qiniq.com est mon FAI   .... est-ce là une piste ?

Dernière modification par Patriboom (26-09-2010 17:10:29)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 16-09-2010 21:07:12

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration du postfix en local

Bonjour Patriboom,

Pour le reste je ne sais pas, mais je vois qu'il n'existe aucune IP associée a patriboom.net:

host:~# dig patriboom.net

; <<>> DiG 9.6-ESV-R1 <<>> patriboom.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 40745
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;patriboom.net.                 IN      A

;; Query time: 1 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu Sep 16 21:02:00 2010
;; MSG SIZE  rcvd: 31


Dans le cas contraire la réponse contiendrait quelque chose du genre:

;; ANSWER SECTION:
patriboom.net.       10800   IN      A       une.i.p.publique


Donc il y a sans doute quelque chose à faire au niveau de la gestion du DNS.

@+

Hors ligne

#3 17-09-2010 05:22:01

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

T'as bien raison.

J'ai aussi essayé avec 127.0.0.1 et localhost sans meilleur résultat.
Est-ce à dire qu'il faudrait que j'installe un serveur de DNS ?
Si oui, lequel me proposez-vous ?

En fouillant dans Synaptic, je crois que "dnsmasq" peut répondre.
J'en fais l'essai.

Et voilà un premier résultat qui semble intéressant:

dig patriboom.net

; <<>> DiG 9.6-ESV-R1 <<>> patriboom.net
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63152
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;patriboom.net.     IN  A

;; ANSWER SECTION:
patriboom.net.    0 IN  A 127.0.1.1

;; Query time: 7 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Sep 16 21:35:46 2010
;; MSG SIZE  rcvd: 47

Dernière modification par Patriboom (17-09-2010 05:37:11)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 17-09-2010 06:44:44

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bon voilà.

   je fais des tests, des tests.
   Lorsque j'envoie du courriel d'une adresse @patriboom.net à une autre (à l'intérieur de mon domaine local), à l'aide des outils postfix : le serveur postfix reste en travail jusqu'à ce que je l'arrête.

    Ce que j'observe, c'est que la création d'un compte courriel à l'aide des outils postfix crée des données dans la base de données, mais ne crée pas de sous-répertoire où mettre le courriel.  J'ai changé les droits du répertoire que je désigne comme la cible des répertoire courriel des usagers  ( chmod -R 777 mailbox  ) et la propriété  ( chown -R vmail mailbox )

   Je soupçonne, cependant que postfix reste incapable de créer les sous-répertoires nécessaires, incapable donc d'y "envoyer" le courriel et incapable aussi d'y récupérer quoi que ce soit.

   Voilà l'état de la situation pour le moment.

   Merci

Portez la paix
Patrick Allaire, ptre

Hors ligne

#5 17-09-2010 23:59:48

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration du postfix en local

Bonjour Patriboom,

le serveur postfix reste en travail jusqu'à ce que je l'arrête


As-tu regardé dans les/ses logs?

Je soupçonne, cependant que postfix reste incapable de créer les sous-répertoires nécessaires,


Peut-être voir ce qui se passe si tu crée au moins le rép pour un utilisateur, si ça résoud le problème ou pas. Ça permettra peut-être d'orienter les recherches.

Bon courage, smile
@+

Hors ligne

#6 18-09-2010 03:30:19

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bnjour,

    ça progresse, ça progresse.
    La création des nouveaux comptes fonctionnent, j'ai adapté les scripts bash pour qu'ils créent les sous-répertoires adéquatement et conformément aux variables transmises par les fichiers de configuration et les scripts d'exécution.  Pour arriver à corriger mes scripts bash, j'ai les tout simplement exécutés manuellement (en console).  J'apportai les corrections en fonction des messages d'erreur obtenus.

    J'ai cru un moment que je pourrais envoyer des courriels, car j'obtiens "Mail envoyé" comme réponse mais ... euh ... euh .... euh ... c'était un envoi fictif ou virtuel, car il n'y a aucun trace d'un tel message où que ce soit.  Quant l'internet est "on line", l'envoi dure, dure, dure .... j'ai attendu jusqu'à 5 minutes (pour du local, c'est tout de même raisonable, je crois; si je compare la réponse en 1 ms que j'obtiens au test dig )

   Depuis, j'ai complètement révisé l'installation et la configuration de dovecot qui présentait aussi des lacunes et des problèmes.

   Nouveau test:  toujours un envoi qui n'en finit plus.  Note encourageante, cependant, /etc/init.d/dovecot restart me retourne un message, maintenant. Avant: rien. Le message ne dit rien, donc je soupçonne que ce soit bon. "Restarting IMAP/POP3 mail server: dovecot."

   Quant aux logs ... ouin.  Mais où sont les logs!  Toujours la même question que j'ai, où sont mes logs.
Bon, je trouve des information dans /var/log/syslog  je tenterai d'investiguer.
Tandis que j'y étais, j'ai aussi défini de nouveaux répertoires où mettre les logs de dovecot.

Merci


.... au fait ... voici les logs après
#/etc/init.d/postfix restart
#/etc/init.d/dovecot restart


Sep 17 23:09:13 Pat dhclient: DHCPREQUEST on eth0 to 192.168.0.205 port 67
Sep 17 23:09:13 Pat dhclient: DHCPACK from 192.168.0.205
Sep 17 23:09:13 Pat NetworkManager: <info>  DHCP daemon state is now 3 (renew) for interface eth0
Sep 17 23:09:13 Pat dhclient: bound to 192.168.0.100 -- renewal in 4648 seconds.
Sep 17 23:17:01 Pat /USR/SBIN/CRON[26178]: (root) CMD (   cd / && run-parts --report /etc/cron.hourly)
Sep 17 23:25:34 Pat postfix/master[24737]: terminating on signal 15
Sep 17 23:25:35 Pat postfix/master[26348]: daemon started -- version 2.5.5, configuration /etc/postfix
dovecot: Sep 17 23:25:47 Error: auth(default): mysql: Unknown connect string: dname
dovecot: Sep 17 23:25:47 Error: Auth process died too early - shutting down
dovecot: Sep 17 23:25:47 Error: auth(default): mysql: Unknown connect string: dname
dovecot: Sep 17 23:25:47 Error: child 26373 (auth) returned error 89
dovecot: Sep 17 23:25:47 Error: child 26374 (auth) returned error 89
dovecot: Sep 17 23:25:47 Info: Dovecot v1.0.15 starting up

Dernière modification par Patriboom (18-09-2010 07:30:52)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#7 20-09-2010 02:30:45

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Encore des progrès ...
J'ai trouvé une faute de frappe dans ma configuration, ayant tapé dname au lieu de dbname.
Voici maintenant la ligne reçue de dovecot dans le log:

dovecot: Sep 19 17:51:06 Info: Dovecot v1.0.15 starting up
dovecot: Sep 19 17:51:07 Info: auth-worker(default): mysql: Connected to 127.0.0.1 (postfix)


Je crois que c'est assez positif.

De côté de postfix, ce n'est pas encore réglé.
Voici l'état de la situation, selon les dernières inscriptions au /var/log/syslog

Sep 19 18:22:32 patriboom postfix/master[11375]: daemon started -- version 2.5.5, configuration /etc/postfix
Sep 19 18:22:32 patriboom postfix/pickup[11376]: 710CDBD8133: uid=0 from=<root>
Sep 19 18:22:32 patriboom postfix/cleanup[11379]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Sep 19 18:22:32 patriboom postfix/cleanup[11379]: warning: 710CDBD8133: virtual_alias_maps map lookup problem for root@patriboom.net


Et j'obtiens une réponse semblable après modification de mon fichier /etc/postfix/mailname, y mettant localhost à la place de patriboom.net, voyez:

Sep 19 18:28:11 patriboom postfix/master[11732]: daemon started -- version 2.5.5, configuration /etc/postfix
Sep 19 18:28:11 patriboom postfix/pickup[11733]: E0505BD8133: uid=0 from=<root>
Sep 19 18:28:11 patriboom postfix/cleanup[11736]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Sep 19 18:28:11 patriboom postfix/cleanup[11736]: warning: E0505BD8133: virtual_alias_maps map lookup problem for root@localhost


Si vous avec des idées .... 
merci à l'avance.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#8 20-09-2010 03:31:39

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration du postfix en local

Re,

Les logs sont généralement dans /var/log/ ou un sous-répertoire d'icelui souvent au nom du programme considéré ( /var/log/apache2/ , /var/log/mysql/ ...).

Si vous avec des idées


As-tu cherché sur le net avec la chaîne "virtual_alias_maps map lookup problem for root@localhost"?
Désolé, je ne sais pas ca que sont les virtual_alias_maps de Postfix, mais la piste me semble bonne.

@+

Dernière modification par tux12 (20-09-2010 03:33:05)

Hors ligne

#9 20-09-2010 05:19:52

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Merci tux12.

je suis tombé sur cette page http://www.syscp-forum.org/index.php?topic=2740.0  qui me semble donner une piste, mais que je comprends pas.

but this line is no trouble, its quite alright: virtual_alias_maps map lookup problem for root@localhost
you will have to set it as an alias in /etc/aliases and then execute new-aliases.
maybe youd also have to insert the line transport_local with the respecting value.


Le problème n'est pas l'anglais, mais la référence à qu'elle inclut.
Que dois-je installer dans les alias? 
        alias root@localhost = banane
OU    alias banane = root@localhost   ????
et que doit valoir "banane" ?

Et dans transport_local ... quelle est la valeur dite "respective" ?   Encore "banane"?  ou "root@localhost" ?

Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 20-09-2010 06:25:17

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bonsoir,

Encore du progrès - j'ose croire.

J'obtiens enfin dans un très bref délai "Message envoyé" à partir de postfixadmin, mais voilà que je ne trouve pas mon message dans le sous-répertoire où il devrait se trouver !  Une petite idée ?

Enfin, c'est un début:  le serveur postfix n'a pas gelé ni ne s'est arrêté après avoir - semble-t-il - avoir trouvé le chemin d'envoi.
Ce que j'ai fait ?    j'ai défini un nouvel utilisateur dans la base de données (via phpmyadmin ) et lui ai donné les droits nécessaires sur la base postfix.
L'usager en question est l'administrateur de postfix, dans mon cas patadmin@patriboom.net    pour être sûr, j'ai créé cet usager aussi bien dans le domaine patriboom.net que dans le domaine "localhost"

Voici donc à ressemblent les trois premières lignes des fichiers
/etc/postfix mysql-virtual-mailbox-maps.cf
/etc/postfix mysql-virtual-mailbox-domains.cf
/etc/postfix mysql-virtual-alias-maps.cf

user = patadmin
password =le password de patadmin
hosts = 127.0.0.1
dbname = postfix


sans avoir oublié de refaire le postmap de ces trois fichiers

À force de chercher, je me suis trouvé à jouer dans le fichier /etc/aliases
Et voici le message que j'obtiens:

Sep 19 22:07:08 patriboom postfix/local[13408]: warning: database /etc/aliases.db is older than source file /etc/aliases


En console, j'ai fait "newaliases" et tout cela est parti. smile  smile smile

Voici donc un beau syslog tout propre après /etc/init.d/postfix restart

Sep 19 22:28:19 patriboom postfix/master[13398]: terminating on signal 15
Sep 19 22:28:19 patriboom postfix/master[13616]: daemon started -- version 2.5.5


Merci

Dernière modification par Patriboom (20-09-2010 06:32:41)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#11 22-09-2010 19:09:13

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bonjour,

je pense que j'approche du but ultime, mais je n'y touche pas encore.
Voici que les serveurs fonctionnent, mais ne donnent pas les résultats escomptés.

J'ai ces messages d'erreur dans syslog  (ça veut dire que ça vient de postfix, puisque dovecot a son propre log)


La configuration suivante:
main.cf

mydomain = patriboom.net
# mydomain = localhost
myhostname = patriboom.net
# myhostname = localhost
myorigin = /etc/postfix/mailname
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
relayhost =
mynetworks = patriboom.net
# mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
message_size_limit = 10240000


Avec mysql-virtual-mailbox-domains.cf ainsi configuré:

user = admin
password = MotPasse
#hosts = patriboom.net
dbname = postfix
query = SELECT domain FROM domain WHERE domain='%s'


J'obtiens ceci:

Sep 22 10:55:54 patriboom postfix/master[6647]: warning: process /usr/lib/postfix/trivial-rewrite pid 6676 exit status 1
Sep 22 10:55:54 patriboom postfix/master[6647]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling
Sep 22 10:56:42 patriboom postfix/master[6647]: terminating on signal 15
Sep 22 10:56:42 patriboom postfix/master[6765]: daemon started -- version 2.5.5, configuration /etc/postfix
Sep 22 10:56:42 patriboom postfix/qmgr[6767]: E673DBD813E: from=<patrick@patriboom.net>, size=346, nrcpt=1 (queue active)
Sep 22 10:56:42 patriboom postfix/trivial-rewrite[6770]: warning: connect to mysql server localhost: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Sep 22 10:56:42 patriboom postfix/trivial-rewrite[6770]: fatal: mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf(0,lock|fold_fix): table lookup problem
Sep 22 10:56:43 patriboom postfix/master[6765]: warning: process /usr/lib/postfix/trivial-rewrite pid 6770 exit status 1
Sep 22 10:56:43 patriboom postfix/master[6765]: warning: /usr/lib/postfix/trivial-rewrite: bad command startup -- throttling
Sep 22 10:57:00 patriboom postfix/pickup[6766]: E4967BD813F: uid=1000 from=<patrick>


Mais quand, j'ai cette configuration (sans remarque) dans mysql-virtual-mailbox-domains.cf ainsi configuré:

user = admin
password = MotPasse
hosts = patriboom.net
dbname = postfix
query = SELECT domain FROM domain WHERE domain='%s'


J'obtiens

Sep 22 10:49:02 patriboom postfix/master[6545]: daemon started -- version 2.5.5, configuration /etc/postfix
Sep 22 10:49:15 patriboom postfix/pickup[6546]: 76918BD813E: uid=1000 from=<patrick>
Sep 22 10:49:15 patriboom postfix/cleanup[6556]: 76918BD813E: message-id=<20100922164915.76918BD813E@patriboom.net>
Sep 22 10:49:15 patriboom postfix/qmgr[6547]: 76918BD813E: from=<patrick@patriboom.net>, size=327, nrcpt=1 (queue active)
Sep 22 10:49:15 patriboom postfix/trivial-rewrite[6557]: warning: do not list domain patriboom.net in BOTH mydestination and virtual_mailbox_domains
Sep 22 10:49:15 patriboom postfix/local[6559]: 76918BD813E: to=<patrick@patriboom.net>, relay=local, delay=0.11, delays=0.07/0.03/0/0, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Sep 22 10:49:15 patriboom postfix/qmgr[6547]: 76918BD813E: removed


Mais je ne vois pas pourquoi on me parle de "BOTH" tandis qu l'instruction n'apparaît qu'une fois.

Merci encore.


Portez la paix
Patrick Allaire, ptre

Hors ligne

#12 23-09-2010 02:06:40

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Encore du progrès!!!!

J'ai testé mes courriel directement en console

$ mail patrick@patriboom.net


Pour patrick, ça marche, mais pour les autres comptes inscrits dans la base de données de postfix, ça ne marche pas.
Si pour patrick@patriboom.net ça marche, ce n'est en fait qu'un hasard ... je ne suis pas très original dans le choix des mes destinataires  hihihi!

En fait, tout ce qui est envoyé en mail ... est transmis à la boite patrick  (et non pas patrick@patriboom.net)

J'ai donc trouvé mes courriels dans /var/mail
Ce n'est pas du tout là que je les veux, mais dans /home/vmail/mailbox

L'envoi fonctionne donc, mais la réception laisse à désirer.
Il est donc temps de se pencher sur dovecot

Voici donc un extrait de syslog pour n'importe quelle autre adresse que patrick@patriboom.net

Sep 22 17:21:31 patriboom postfix/pickup[5132]: ACA1BBD813E: uid=1000 from=<patrick>
Sep 22 17:21:31 patriboom postfix/cleanup[20806]: ACA1BBD813E: message-id=<20100922232131.ACA1BBD813E@patriboom.net>
Sep 22 17:21:31 patriboom postfix/qmgr[5133]: ACA1BBD813E: from=<patrick@patriboom.net>, size=363, nrcpt=1 (queue active)
Sep 22 17:21:31 patriboom postfix/trivial-rewrite[20815]: warning: do not list domain patriboom.net in BOTH mydestination and virtual_mailbox_domains
Sep 22 17:21:31 patriboom postfix/local[20808]: ACA1BBD813E: to=<baboom@patriboom.net>, relay=local, delay=0.04, delays=0.02/0.01/0/0.01, dsn=5.1.1, status=bounced (unknown user: "baboom")
Sep 22 17:21:31 patriboom postfix/cleanup[20806]: B6E01BD813F: message-id=<20100922232131.B6E01BD813F@patriboom.net>
Sep 22 17:21:31 patriboom postfix/qmgr[5133]: B6E01BD813F: from=<>, size=2035, nrcpt=1 (queue active)
Sep 22 17:21:31 patriboom postfix/trivial-rewrite[20815]: warning: do not list domain patriboom.net in BOTH mydestination and virtual_mailbox_domains
Sep 22 17:21:31 patriboom postfix/bounce[20816]: ACA1BBD813E: sender non-delivery notification: B6E01BD813F
Sep 22 17:21:31 patriboom postfix/qmgr[5133]: ACA1BBD813E: removed
Sep 22 17:21:31 patriboom postfix/local[20808]: B6E01BD813F: to=<patrick@patriboom.net>, relay=local, delay=0.01, delays=0/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
Sep 22 17:21:31 patriboom postfix/qmgr[5133]: B6E01BD813F: removed


On y voit bien qu'au premier passage, le serveur a tenté de livrer à baboom..., mais qu'il ne l'a pas trouvé.
Au deuxième passage, il a remplacé baboom par patrick

Voici mes configuration de dovecot:

## Dovecot configuration file

protocols = imap pop3 imaps pop3s
listen = [::]

disable_plaintext_auth = no
log_path = /var/log/dovecot/logpath
info_log_path = /var/log/dovecot/info_logpath
log_timestamp = "%b %d %H:%M:%S "
ssl_listen = [::]
mail_location = maildir:/home/vmail/mailbox/%u:INBOX=/home/vmail/mailbox/%u/INBOX
mail_privileged_group = mail
# mail_privileged_group = INBOX
mailbox_idle_check_interval = 30

protocol imap {
  #mail_executable = /usr/libexec/dovecot/imap
  mail_plugins = quota imap_quota
}
 
##
## POP3 specific settings
##

protocol pop3 {
  #mail_executable = /usr/libexec/dovecot/pop3
  pop3_uidl_format = %08Xu%08Xv
  mail_plugins = quota
}

auth default {
  mechanisms = plain
  passdb pam {
  }
  passdb sql {
    # Path for SQL configuration file, see doc/dovecot-sql-example.conf
    args = /etc/dovecot/dovecot-sql.conf
  }
  userdb passwd {
    # [blocking=yes] - By default the lookups are done in the main dovecot-auth
    # process. This setting causes the lookups to be done in auth worker
    # proceses. Useful with remote NSS lookups that may block.
    # NOTE: Be sure to use this setting with nss_ldap or users might get
    # logged in as each others!
    #args =
  }

  # SQL database <doc/wiki/AuthDatabase.SQL.txt>
  userdb sql {
    # Path for SQL configuration file, see doc/dovecot-sql-example.conf
    args = /etc/dovecot/dovecot-sql.conf
  }

}

plugin {
  quota = maildir:storage=52428800:messages=10000000000
}


Et le fichier traitant le mysql, (dovecot-sql.conf) est le suivant:

# Database driver: mysql, pgsql, sqlite
driver = mysql

connect = host=patriboom.net dbname=postfix user=usager password=Mot_de_passe
# connect = host=127.0.0.1 dbname=postfix user=usager password=Mot_de_passe
default_pass_scheme = PLAIN-MD5
user_query = SELECT maildir, 5000 AS uid, 5000 AS gid FROM mailbox WHERE username LIKE 'u%'
password_query = SELECT username as user, password FROM mailbox WHERE username LIKE 'u%'


#password_query = SELECT userid as user, password FROM users WHERE userid = '%u'
#user_query = SELECT home, uid, gid FROM users WHERE userid = '%u'

# If you wish to avoid two SQL lookups (passdb + userdb), you can use
# userdb prefetch instead of userdb sql in dovecot.conf. In that case you'll
# also have to return userdb fields in password_query prefixed with "userdb_"
# string. For example:
#password_query = SELECT userid as user, password, home as userdb_home, uid as userdb_uid, gid as userdb_gid FROM users WHERE userid = '%u'


Merci


Portez la paix
Patrick Allaire, ptre

Hors ligne

#13 25-09-2010 17:06:20

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bonjour,

  la saga est longue, mais progresse
  je suis maintenant capable d'envoyer du courriel à mon serveur postfix (et par lui) local en ayant suivi à la lettre cette étape:
           http://www.postfix.org/VIRTUAL_README.h … al_mailbox

   reste maintenant à faire le saut vers la gestion par base de données mysql, un autre pas.
   ensuite, ce sera la récupération des message avec mon logiciel de courriel.

Voici, pour ceux qui voudraient suivre le même chemin sans les mêmes embûches que moi, mon fichier /etc/postfix/main.cf actuel:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

mydomain = patriboom.net
myhostname = mail.$mydomain
myorigin = $mydomain
mydestination = localhost.$mydomain, $mydomain www.$mydomain
mynetworks = 192.168.0.0/16,127.0.0.0/8,172.16.0.0/16
local_transport = virtual
virtual_mailbox_domains = essai.net essai.com essai.ca essai.qc.ca
virtual_mailbox_base = /home/mailbox
virtual_mailbox_maps = hash:/etc/postfix/vmailbox
virtual_minimum_uid = 100
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_alias_maps = hash:/etc/postfix/virtual

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no


À cela, il faut ajouter les fichiers bidons que j'ai créés pour mes tests, lesquels fichiers vous voyez appelés dans le main.cf ci-haut
D'abord /etc/postfix/vmailbox

patrick@essai.com essai.com/patrick
info@essai.com essai.com/info
baboom@essai.ca essai.ca/baboom/
@essai.qc.ca Quebec/


et puis aussi  /etc/postfix/virtual

postmaster@essai.com essai.com/info


Notez que l'information de la partie droite de ces deux derniers fichiers est constituées du sous-répertoire destination des messages reçus à l'adresse écrite à gauche.
Ces fichiers doivent être encodés par postmap, c'est donc dire:

postmap /etc/postfix/vmailbox
postmap /etc/postfix/virtual


Notez aussi que vous devez avoir créé ces répertoires et leur avoir donné les droits adéquats pour que ça fonctionne.
Les droits adéquats sont (dans mon cas où j'ai mis les boîtes aux lettres dans /home/vmail )  :

chown -R vmail /home/mailbox
chgrp -R vmail /home/mailbox
chmod -R 755 /home/mailbox


Une bonne partie de mon casse-tête résidait dans les permissions.  Je ne savais pas à qui donner les droits d'écriture ni à quels dossiers.

Encore des épisodes à venir.

Dernière modification par Patriboom (25-09-2010 17:52:32)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#14 26-09-2010 06:37:07

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Et bien!

C'est une véritable saga, hein!
À force de tout changer, je finirai pas être en mesure de faire le wiki de cette chose!!!

Bon, postfix fonctionne très bien maintenant.

Ne me reste plus qu'à trouver comment récupérer mon courriel à partir des logiciels standards.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#15 26-09-2010 17:10:01

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Résolu] Configuration du postfix en local

Bonjour,

    tout fonctionne à merveille en IMAP: envoi / réception de courriel; en console, en PHP ou avec un logiciel comme Opera.

    Leçon de cette saga:  étape par étape, la technique du petit pas.
            1) faire fonctionner le courriel en console (mail NomUsagerLlinux)
            2) faire fonctionner le Postfix à partir des comptes usagers de Linux
            3) faire fonctionner le Postfix à partir d'un fichier de pseudo-usagers
            4) faire fonctionner le Postfix en lien avec une base de données.
            5) configurer dovecot sans base de données, mais ne produisant aucune erreur
            6) ajouter à dovecot le lien vers la base de données
            7) configurer les compte IMAP sur votre logiciel de courriel préféré

Voilà.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#16 26-09-2010 19:33:44

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Configuration du postfix en local

Salut

Pour un saga, ça était toute une ! Heureusement tout c'est bien terminé. Le mot clé ici est persévérance. Enfin, merci de nous avoir tenu au courant de tes avancées et de nous avoir communiquer le résultat final. Ce genre de retour est jamais inutile. Merci encore.

Martin

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

En ligne

#17 26-09-2010 21:48:13

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration du postfix en local

Bonjour,

Bon, le plus facile est fait. tongue
Maintenant le passage en prod avec des utilisateurs, toussa... lol

Bon courage! smile

Hors ligne

Pied de page des forums