Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-10-2007 09:39:40

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

[réglé] Site non compatible mozilla

Salut,

J'utilise Iceweasel.
certain sites on un affichage horrible et ne s'affiche bien qu'avec Internet explorer

Y'a t'il un moyen d'y remedier ?

Ou existe t-il un webbrowser basé sur IE ?

Merci

Dernière modification par TinninE (04-10-2007 06:28:27)


Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#2 03-10-2007 12:17:27

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [réglé] Site non compatible mozilla

'lut,

essaies d'installer le paquet msttcorefonts

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#3 03-10-2007 12:17:56

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [réglé] Site non compatible mozilla

Salut

As tu testé avec d'autres naviguateurs libres? konqueror, epiphany....
Peux tu nous donner un de tes sites qui s'affichent mal?

Si c'est vraiment d'une grande importance tu peux faire tourner IE sous linux avec ies4linux...mais bon...

@+ wink

Hors ligne

#4 03-10-2007 13:33:24

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

Re : [réglé] Site non compatible mozilla

Je teste ce soir msttcorefonts,
mais ce n'est pas un probleme de fontes,
c'est un probleme de champs qui sont placés n'importe où.

Pour le site, je n'ai ai pas sous la main de tête.
Celui que j'ai testé ce matin, c'est un site de mon boulot, donc je peux pas le donner.
Il utilise Java.
Avec IE la mise en page est ok
mais avec Firefox, Iceweasel, Epiphany c'est organisé bizarement.

Si je retrouve un lien je le mettrai en exemple.

Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#5 03-10-2007 15:52:25

misaine
Membre
Lieu : sables d'olonne
Distrib. : Antergos (Archlinux)
Noyau : 4.3.3
(G)UI : gnome-shell 3.18.2
Inscription : 29-07-2007

Re : [réglé] Site non compatible mozilla

certains site , malheureusement , ne respectent pas les normes http://misaine.chez-alice.fr/defaut_img/exemple.jpg

amd phenom 7650 , 4 Go DDR2 ,GeForce N210

Hors ligne

#6 03-10-2007 21:35:23

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

Re : [réglé] Site non compatible mozilla

Voilà c'est exactement ce probleme cool

Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#7 04-10-2007 00:25:38

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

As-tu fait un essai avec Opera ?
Pas que je sois une fan, plus de l'un ou de l'autre, mais... les navigateurs, et les codages sur le web... c'est la fête au n'importe quoi.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#8 04-10-2007 06:28:07

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

Re : [réglé] Site non compatible mozilla

Avec Opéra, le problème est résolu.

merci smile

Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#9 11-10-2007 02:04:13

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

TinninE a écrit :

Avec Opéra, le problème est résolu.

merci smile


Cool ! Avec plaisir. smile


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#10 11-10-2007 09:23:08

bloodi
Membre
Lieu : Tours
Inscription : 16-08-2007
Site Web

Re : [réglé] Site non compatible mozilla

J'ai aussi un p'tit probleme avec Iceweasel, j'ai des sites qui font carrément planter le naviguateur...

Exemple : google Analytics

Hors ligne

#11 11-10-2007 21:06:39

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

bloodi a écrit :

J'ai aussi un p'tit probleme avec Iceweasel, j'ai des sites qui font carrément planter le naviguateur...

Exemple : google Analytics


Mauvais navigateur : changer de navigateur !!!

Mauvais site ? Changer de site.  wink

Veux-tu essayer Firefox Safe mode ou bien Swiftweasel ?


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#12 12-10-2007 05:48:03

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

Re : [réglé] Site non compatible mozilla

Salut

Question tres tres novice.

Je viens de télécharger firefox
comment l'installer?

j'ai essayé

sh run-mozilla.sh


mais ça ne marche pas, il me dit cannot execute (alors que les permissions son ok)

Dernière modification par TinninE (12-10-2007 12:44:41)


Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#13 12-10-2007 09:34:32

bloodi
Membre
Lieu : Tours
Inscription : 16-08-2007
Site Web

Re : [réglé] Site non compatible mozilla

Melodie a écrit :

bloodi a écrit :

J'ai aussi un p'tit probleme avec Iceweasel, j'ai des sites qui font carrément planter le naviguateur...

Exemple : google Analytics


Mauvais navigateur : changer de navigateur !!!

Mauvais site ? Changer de site.  wink

Veux-tu essayer Firefox Safe mode ou bien Swiftweasel ?


Bah en fait, avec epiphany j'ai le même soucis...

Hors ligne

#14 13-10-2007 02:05:13

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

Pour installer firefox faut se rendre dans le dossier telecharger, mais il est pas dans les sources ?

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#15 13-10-2007 19:27:09

chouchou
Membre
Inscription : 17-08-2007

Re : [réglé] Site non compatible mozilla

salut,

j'ai trouvé une méthode sur le net (je ne me rappelle plus du site) pour installer Thunderbird.
Je viens de la tester pour Firefox et ça fonctionne.

desinstaller iceweasel

désarchiver firefox

copier le dossier dans /opt/

créer un lien symbolique dans /usr/bin avec cette commande
ln -s /opt/firefox/firefox /usr/bin/firefox

supprimer /.mozilla/ avec cette commande
mv /home/[user]/.mozilla/

pour lancer firefox, il suffit de taper la commande "firefox".

bonne soirée.

Dernière modification par chouchou (13-10-2007 20:18:32)

Hors ligne

#16 15-10-2007 00:23:05

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

chouchou, on n'installe pas à la main quand il y a un gestionnaire de paquetages dans la distribution.

grr!

Tu supprimes tout ce que tu viens de faire, et tu lances Synaptic.

Tu fais un tour du côté de Ubuntu avec le livre libre, et tu reviens quand tu veux, Debian ou Ubuntu pour un débutant ça ne change pas trop, sauf que je peux pointer vers un livre libre et gratuit que tu as tout intérêt à parcourir. (Tu peux même rester sous Debian et lire le livre relatif à Ubuntu, les réponses aux questions de base sont les mêmes). Qu'est-ce que les dépôts ? Lesquels configurer et pourquoi ? Comment gérer les installations désinstallations et les mises à jour ? Comment maintenir un système propre etc...

;-)

/Quand tu supprimes le répertoire caché .mozilla de ton home, tu perds toutes tes configurations, tu perds ton bookmark... je n'ai pas encore lu quelque chose d'aussi contraire au bon sens !!! Au contraire, on sauvegarde le profil qui est dedans, coûte que coûte !!!  mad

/

supprimer /.mozilla/ avec cette commande
mv /home/[user]/.mozilla/


la commande mv ne supprimes rien, mais déplaces un répertoire. Là, en l'occurence, tu as déplacé

/home/[user]/.mozilla/


vers... rien du tout.

Je te recommande de tenter de comprendre ce que tu fais, et de comprendre le contenu des commandes que tu emploies, avant de les utiliser, et surtout, avant de les transmettre à d'autres personnes...


PS: à MaTTuX_ : tu veux dire quoi avec ton dossier "télécharger", s'il te plaît ???


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#17 15-10-2007 00:31:16

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

bloodi a écrit :

Melodie a écrit :

bloodi a écrit :

J'ai aussi un p'tit probleme avec Iceweasel, j'ai des sites qui font carrément planter le naviguateur...

Exemple : google Analytics


Mauvais navigateur : changer de navigateur !!!

Mauvais site ? Changer de site.  wink

Veux-tu essayer Firefox Safe mode ou bien Swiftweasel ?


Bah en fait, avec epiphany j'ai le même soucis...


Alors essaie opera, et flock.


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#18 15-10-2007 00:38:43

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

TinninE a écrit :

Salut

Question tres tres novice.

Je viens de télécharger firefox
comment l'installer?

j'ai essayé

sh run-mozilla.sh


mais ça ne marche pas, il me dit cannot execute (alors que les permissions son ok)


Pareil, télécharges le livre libre sur Ubuntu dont j'ai passé le lien plus haut, et plonges allègrement dedans. Puis, arrêtes d'installer à la main, tu n'est pas sous Windows là... wink

On a des gestionnaires de paquetages sous Gnu/Linux, qui nous permettent de garder des systèmes assez stables et si on se débrouille bien on ne réinstalle jamais, tout en gardant un stystème réactif qui fonctionne aux petits oignons. On a des librairies dynamiques, (voyez dans /usr/lib) des mises à jour qu'on fait facilement, (si on n'installe pas inutilement des tas d'applis à la main... )


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#19 15-10-2007 07:31:14

TinninE
Membre
Lieu : 13640 La Roque D'Anthéron
Inscription : 22-09-2007
Site Web

Re : [réglé] Site non compatible mozilla

Merci Melodie, pour ce livre

Debian 4.0 Etch Gnome
kernel 2.6.18
Acer 9422 WMSi
GoForce 7300

Hors ligne

#20 19-10-2007 20:16:46

chouchou
Membre
Inscription : 17-08-2007

Re : [réglé] Site non compatible mozilla

Mélodie,

désolé pour toutes ces erreurs en un seul post !

j'ai sentis que tu n'etais pas zen en me repondant, faut pas te mettre dans cet état !

Je n'utilise pas le gestionnaire de paquets debians pour quelques logiciels comme Firefox et Thunderbird pour la simple raison que ces logiciels n'existent sur aucun depot debian (a cause du code de Talkback qui n'est pas libre il me semble).
Sinon je suis entierement d'accord avec toi que apt-get, synaptic (et surtout adept pour moi) sont bien mieux pour gerer les paquets.

Pour l'erreur de commande, je l'ai trouvé comme ca sur le site internet sur lequel j'ai récupéré la manip. Je sais que ce n'est pas une excuse mais je fais confience aux gens.

Et la derniere erreur concerne la non sauvegarde des config.
En fait j'avais un soucis car firefox ne fonctionnait pas tant que je n'avais pas enlevé les fichiers de config de Iceweasel.

voila pour mes explications plus ou moins bonne (surtout moins que plus !).


Sinon je te remercie pour le livre, il est tres bien. Je le lirais attentivement avant de donner de mauvais conseils c'est promis ! ;-)

Hors ligne

#21 20-10-2007 01:28:17

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [réglé] Site non compatible mozilla

chouchou a écrit :

Mélodie,

désolé pour toutes ces erreurs en un seul post !

j'ai sentis que tu n'etais pas zen en me repondant, faut pas te mettre dans cet état !

Je n'utilise pas le gestionnaire de paquets debians pour quelques logiciels comme Firefox et Thunderbird pour la simple raison que ces logiciels n'existent sur aucun depot debian (a cause du code de Talkback qui n'est pas libre il me semble).
Sinon je suis entierement d'accord avec toi que apt-get, synaptic (et surtout adept pour moi) sont bien mieux pour gerer les paquets.

Pour l'erreur de commande, je l'ai trouvé comme ca sur le site internet sur lequel j'ai récupéré la manip. Je sais que ce n'est pas une excuse mais je fais confience aux gens.

Et la derniere erreur concerne la non sauvegarde des config.
En fait j'avais un soucis car firefox ne fonctionnait pas tant que je n'avais pas enlevé les fichiers de config de Iceweasel.

voila pour mes explications plus ou moins bonne (surtout moins que plus !).


Sinon je te remercie pour le livre, il est tres bien. Je le lirais attentivement avant de donner de mauvais conseils c'est promis ! ;-)


Salut

Ne prend pas au pied de la lettre ce que Mélodie te dis.....elle est là pour t'aider et malgrès un franc parlé qui peut peut être te choquer je suis sûr que Mélodie est très zen au contraire wink

Je n'utilise pas le gestionnaire de paquets debians pour quelques logiciels comme Firefox et Thunderbird pour la simple raison que ces logiciels n'existent sur aucun depot debian


Ils ne portent pas le même nom mais ils y sont --> iceweasel et icedove wink

@+

Hors ligne

#22 20-10-2007 15:10:31

chouchou
Membre
Inscription : 17-08-2007

Re : [réglé] Site non compatible mozilla

Salut,

Ne t'en fais pas Syb, Mélodie ne m'a pas choqué, juste fait un peu sourire car je sais bien qu'elle est là pour m'aider, ce qu'elle a déjà fait.

Sinon Icedove et Iceweasel je connais, j'en parle dans mon dernier post que tu as cité.

J'utilise Iceweasel car il est à jour sur les dépots de Debian Etch par rapport à Firefox.
Si j'ai mis Firefox c'était simplement pour tester pour TinninE.

En revanche Icedove en est toujours à la version 1.5 sur les dépots Debian Etch alors que Thunderbird est à la version 2.0.
Et j'apprécie les améliorations de cette version.
C'est pour cette raison que je n'utilise pas le gestionnaire de paquets pour ce logiciel.

a+

Hors ligne

#23 22-10-2007 01:07:46

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

chouchou, essaie donc Sylpheed au lieu de Thunderbird. C'est un excellent client mail, qui gagne à être connu.

--

ôôôômmmm padme ôôôômmmm !!!  wink

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#24 22-10-2007 05:44:26

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [réglé] Site non compatible mozilla

enfin je dis ca comme ca, mais le post est réglé depuis un bail donc soit on ouvre un autre post, soit un discutte sur irc ^^

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

Pied de page des forums