Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 08-10-2010 00:25:54

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Carte son non reconnue [résolu]

Bonsoir,

J'ai installé récemment Debian sur mon ordinateur et je n'ai pas de son depuis.
Ca fait maintenant deux semaines que je fouille dans les sites et les forums pour trouver une solution.
Je voulais essayer de m'en sortir toute seule mais bon... roll
J'ai peur d'avoir fait plus de mal que de bien!! lol
C'est ce qui m'amène ici!

Alors voilà des informations qu'on demande souvent dans les autres sujets et qui me semblent pertinentes.

# uname -a
Linux debian 2.6.26-2-686 #1 SMP Thu Sep 16 19:35:51 UTC 2010 i686 GNU/Linux
# lsmod | grep snd
# lsmod | grep snd-hda-intel
# lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
# aplay -l
aplay: device_list:207: no soundcards found...


C'est bizarre parce que j'ai l'impression d'être moins avancée (dans l'installation des drivers ou un truc dans le genre, excusez du manque de précision! tongue) que tous les autres personnes qui ont des problèmes de son...
Ah oui! Et j'ai une version stable, Lenny 5.06.

Voilà, voilà. Merci d'avance pour votre aide.

Dernière modification par alice... (26-10-2010 16:40:53)

Hors ligne

#2 08-10-2010 00:34:24

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Je viens de me rendre compte que je m'étais trompée de forum, enfin de sujet quoi... (je devrais être dans multimédia)
Désolée. hmm
Si pour quelqu'un peut m'expliquer comment faire pour réparer mon erreur. Merci!

Dernière modification par alice... (08-10-2010 00:46:45)

Hors ligne

#3 08-10-2010 00:41:45

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Carte son non reconnue [résolu]

Bonsoir alice... et bienvenue sur DF.

Je ne sais pas te répondre mais je suppose qu'un complément d'information pourrait éventuellement être utile.
Saurrais tu nous dire quel environnement graphique tu utilises (Gnome, KDE,....)?

As-tu essayé plusieurs applications (lecture cd, mp3, vidéo sur le net ou depuis un DVD)? Tu n'as vraiment aucun son, pas même les sons système ?

@+

Hors ligne

#4 08-10-2010 00:49:42

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Alors, je suis sous KDE et j'ai essayé plusieurs applications mais rien ne marche.
Pas même les sons système.

Hors ligne

#5 08-10-2010 01:14:43

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Carte son non reconnue [résolu]

Ok. Je ne sais ce que tu as déjà compris ou pas; la commande lsmod que tu cites montre que le module noyau qui gère ta carte n'est pas chargé (car la commande ne renvoit rien). Pour charger le module il faudrait en root passer la commande modprobe snd-hda-intel . Un nouveau lsmod devrait cette fois renvoyer au moins une ligne contenant snd-hda-intel.

Ensuite tu peux relancer la commande aplay -l et nous dire ce que ça donne.

@+

Ne t'inquiète pas pour le choix du forum. Il n'est de toute façon pas toujours simple de savoir à l'avance dans quelle catégorie ça rentre. De là à faire une news  et un sondage "pour ou contre les cartes son" ... wink

Hors ligne

#6 08-10-2010 09:48:49

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Merci pour les précisions Tux12. J'avais compris intuitivement ce que signifiait la commande lsmod mais je ne savais pas qu'elle était spécifique aux modules noyau.
Voici ce que me renvoie la commande

debian:/# modprobe snd-hda-intel
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/sound/core/snd-page-alloc.ko': No such file or directory
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/sound/core/snd.ko': No such file or directory
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/sound/core/snd-timer.ko': No such file or directory
WARNING: Could not open '/lib/modules/2.6.26-2-686/kernel/sound/core/snd-pcm.ko': No such file or directory
FATAL: Could not open '/lib/modules/2.6.26-2-686/kernel/sound/pci/hda/snd-hda-intel.ko': No such file or directory


Sachant que j'ai exploré un peu ce dossier sound et voici ce que ça donne

debian:/lib/modules/2.6.26-2-686/kernel/sound# ls
ac97_bus.ko  i2c  oss     soundcore.ko       synth
drivers      isa  pcmcia  sound_firmware.ko  usb


Je ne possède donc ni le dossier core ni le pci? En fait, j'ai vraiment rien!!
C'est normal ça? Il ne le fait pas automatiquement?

Dernière modification par alice... (08-10-2010 09:50:03)

Hors ligne

#7 08-10-2010 13:09:29

Invité-5
Banni(e)

Re : Carte son non reconnue [résolu]

Bonjour alice;

Je te propose de revoir ton problème de côté alsa ( Advanced Linux Sound Architecture ) si c'est ne pas déjà fait http://www.delafond.org/traducmanfr/man … onf.8.html J'éspere que ta carte son est reconnu, tu peux vérifier http://www.alsa-project.org/main/index. … ndor-Intel Essaye d'installer les outils ( dépôts ) comme alsaconf où alsamixer et tu verrais par la suite.

Courage.

Dernière modification par arien (08-10-2010 13:41:41)

#8 08-10-2010 18:22:59

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Normalement, ma carte son est reconnue. Je suis déjà allée voir ça sur un site.
Donc, je vais m'atteler à la page alsa project sur le module hda-intel.
En fait, j'avais déjà vu cette page mais l'ensemble m'a un peu affolé!! lol
Mais je vais prendre mon courage à deux mains et c'est parti!
Je reviens donner des nouvelles dès que j'ai réussi...
ou que j'ai rencontré un problème!
A très bientôt...

Hors ligne

#9 08-10-2010 23:48:11

Chris
Membre
Lieu : Bourgogne
Distrib. : Jessie 64
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : kde
Inscription : 15-11-2008

Re : Carte son non reconnue [résolu]

wink Bonsoir,

J'ai eu récement un soucis de "déconfiguration" de son en utilisant un programme spécifique KDE (k3b) alors que je tourne sous gnome. Peut-être peux-tu t'inspirer de ce thread ? : sur ce forum il y a quelques jours

Et bien sûr ne pas oublier de mettre "résolu" si ça marche (parce que ça fait plaisir d'une part, et parce que cela accélère les recherches fructueuses avec google. Ex : j'ai un soucis de clavier avec connection bluetouth, je tape

clavier bluetouth (résolu)


pour accéder directement aux solutions qui ont au moins une fois fonctionné.

Bonne continuation smile

Hors ligne

#10 10-10-2010 16:47:48

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Coucou,

Chris, merci mais j'ai l'impression que nos problèmes ne sont pas les mêmes. La commande alsaconf ne renvoie rien chez moi... ou plutôt si! Ca dit :
No supported PnP or PCI card found

Donc, j'ai plutôt suivi les conseils d'arien et j'ai atterri sur le site de alsa-project. Ici précisément :
http://www.alsa-project.org/main/index. … -hda-intel
Bon, autant l'avouer tout de suite, je suis super motivée mais faut pas se leurrer, j'y arriverai pas toute seule...  big_smile
Alors, voici.
Au début voici les consignes données pour créer un dossier où l'on va mettre les codes sources de alsa (traduction littérale de ma part!) :

cd /usr/src
       mkdir alsa
       cd alsa
       cp /downloads/alsa-* .


Donc j'ai bien créé ce dossier alsa mais la dernière commande me pose déjà problème... Si je ne me trompe pas, l'objectif est de copier le contenu du dossier /downloads/alsa-* dans le dossier actuel alias /usr/src/alsa. Mais je ne possède rien qui ressemble au premier dossier donc, forcément, ça marche pas!! roll
Alors bon, c'est ptêtre pas un document destiné aux débutantes comme moi parce que je ne comprends pas comment procéder... Est-ce que je possède ce dossier mais autre part??
En cherchant un peu, j'ai trouvé ça

debian:/etc/alsa/modprobe-post-install.d# ls
alsa-utils


mais je ne sais pas du tout à quoi ça correspond donc pour l'instant je n'y touche pas!!

Sinon, Chris, pour l'indication résolu, pas d'inquiétude à avoir, si j'arrive à résoudre mon problème, je m'empresserai de l'indiquer!!

Voilà, voilà, je vais m'arrrêter là pour l'instant. A très bientôt! wink

Hors ligne

#11 10-10-2010 19:31:54

Invité-5
Banni(e)

Re : Carte son non reconnue [résolu]

Salut,

Pas de panique. Tu as bien les paquets alsa-source alsa-base alsa-utils alsa-tools installé vérifier

Ensuite 1. # alsaconf et 2.$ alsamixer ( peut-être la sortie sur Front est à 0 )

wiki ; alsamixer    http://debian-facile.org/doc:media:alsamixer

Par contre si la commande $ aplay -l n'est te renvoi rien ça devient enquêtant. Je ne suis pas un grand spécialiste du son juste quand je commencé utiliser linux il y a trois ans je me suis débrouillé avec les outils alsa avec succès. Sinon bcp de lecture.

Courage

Dernière modification par arien (11-10-2010 00:23:41)

#12 10-10-2010 22:02:53

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

En fait, il semblerait que je n'ai pas le paquet alsa-source et quand je cherche à l'installer, il me dit :
E: Impossible de trouver le paquet alsa-source
(ça je le fait en console)
et quand je lui demande d'installer alsa-base par le biais de synaptic, il me répond :
alsa-base:
Le paquet alsa-base n'est pas disponible bien qu'il soit listé dans la base de données.
Les explications possibles sont que le paquet est listé dans les dépendances sans jamais avoir été publié, qu'il est devenu obsolète ou qu'il n'est pas disponible sur les dépôts vers lesquels pointe le fichier sources.list
Donc mystère!!

Pour ce qui est d'alsaconf, comme je le disais plus haut, lorsque je le lance, il me renvoie le message suivant:
No supported PnP or PCI card found. Would like to probe legacy ISA cards/chips?
Et là je réponds non parce que je ne reconnais rien dans les propositions qu'il me fait par la suite.
Enfin la commande alsamixer me renvoie ceci

debian:~# alsamixer
alsamixer: function snd_ctl_open failed for default: No such file or directory


C'est là que c'est bizarre parce qu'il y a environ deux semaines j'ai réussi à le lancer...
C'est pour ça que je dis dans mes premiers messages que j'ai peur d'avoir fait n'importe quoi. J'ai l'impression d'avoir des problèmes depuis que j'ai cherché à installer make... Je ne sais pas du tout si mes impressions sont justifiées ou pas. Ptêtre que ça n'a rien à voir!

Enfin pour la commande, ça donne

# aplay -l
aplay: device_list:207: no soundcards found...


Je continue mes recherches!

Hors ligne

#13 10-10-2010 23:15:33

Invité-5
Banni(e)

Re : Carte son non reconnue [résolu]

alice... a écrit :

J'ai l'impression d'avoir des problèmes depuis que j'ai cherché à installer make...


C'était ta première compilation où alors, j'ai mal compris. On installe au debut par sudo apt-get install ( ou aptitude a la place de apt-get - soit l'un soit l'autre sans mélanger le deux ) + le nom de paquet dans un terminal. 

Si tu trouve pas alsa-source et alsa-base ça veut dire que ta installation ce mal passé.

Vérifie ton fichier sources.list   $ sudo gedit /etc/apt/sources.list ( gedit ou nano ) => $ sudo apt-get update ( ou aptitude ) manuel sources.list

Pour les commandes $ = simple utilisateur # = root donc si tu vois # alsaconf tu utilise sudo si tu vois $ alsamixer tu tape directement alsamixer après $
 
Pour # alsaconf tu réponds Yes ou Oui pour tout. Tu n'as rien à perdre puisque de tout les façons tu n'a pas de son. Au pire tu serais obligé de réinstaller.

Evite d'utliser la commande SU j'éspere que tu as déjà paramètré /etc/sudoers

Courage.

EDIT : Tu utilise bien le terminal ? Applications => Accessoires => Terminal

Dernière modification par arien (11-10-2010 01:26:37)

#14 11-10-2010 13:12:10

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Carte son non reconnue [résolu]

Quelques pages du Debian Wiki en français qui t'aideront peut être.

http://wiki.debian.org/fr/ALSA
http://wiki.debian.org/fr/Sound
http://wiki.debian.org/fr/SoundConfiguration
http://wiki.debian.org/fr/SoundCard

Dernière modification par deuchdeb (11-10-2010 13:14:45)

Hors ligne

#15 11-10-2010 21:30:52

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Carte son non reconnue [résolu]

Bonjour,

A mon avis tant que le module qui gère la carte (snd-hda-intel?) ne sera pas chargé, ça ne fonctionnera pas. Actuellement aucune carte n'est détectée par le système d'après les messages cités. Curieux aussi qu'il manque une partie de l'arborescence des modules noyau. C'est quoi comme machine précisément?
Pour vérifier le support du matériel par le noyau, peux-tu nous donner le résultat de lspci -nn | grep [Aa]udio passé en root?

Que ce soit pour alsaconf (paquet alsa-utils) ou tout autre logiciel, Debian est sans doute la distribution la plus complète existante, et il faut prendre le réflexe de vérifier en premier si ce que l'on cherche n'existe pas dans les dépôts avant de vouloir intégrer du code extérieur. Ça évite du boulot pour rien (même si ça peut être formateur) et ça permet une meilleure intégration au système.

Je te suggères de ré-installer pour repartir sur des bases propres vu que tu dis avoir pas mal bricolé (ce n'est pas un reproche wink ) et qu'il semble manquer une partie du système. Si la machine à fonctionné sous Windows et qu'il n'y a pas eu de modif du Bios ou d'ajout/retrait de carte son ton matériel devrait être reconnu (sous réserve de confirmation par le lspci plus haut). En cas de choix, privilégier ALSA au détriment de OSS.

Tiens nous au courant, et bon courage smile

Hors ligne

#16 11-10-2010 22:25:05

Invité-5
Banni(e)

Re : Carte son non reconnue [résolu]

Salut,

+1 pour ré-installation complète.

Amitié

#17 12-10-2010 23:26:11

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Alors, voici ce que me renvoie la commande

debian:~# lspci -nn | grep [Aa]udio
00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)


Donc normalement, c'est bon, non? Ca veut dire qu'il reconnaît la carte son?
Sinon, ma machine c'est un lenovo (un 3000N200 précisément).
Pour ce qui est de la modification du BIOS... roll
Euh, je suis plus sûre mais je crois que j'ai fait ça une fois je ne sais plus pour quelle obscure raison!!

Et puis, pour être plus claire et plus exhaustive, je suis effectivement allée sur cette page :
http://wiki.debian.org/fr/ALSA, et après avoir suivi les instructions, ils disent que si le son ne marche toujours pas, c'est peut-être à cause du chipset Realtek (ce que j'ai, je suis allée voir sur internet) et qu'il faut installer un fichier spécial mais qu'avant tout ça il faut s'assurer que gcc, make, build-essential, linux-headers de votre noyau, etc étaient bine installé. Donc, j'ai suivi (un peu bêtement, c'est vrai!!) ces conseils et c'est là que j'ai commencé (il me semble) à avoir des problèmes...
J'ai l'impression que j'avais alsa-source et alsa-base dans mes paquets (dans synaptic) mais qu'après avoir installé make, il y a des choses qui ont disparu...
Enfin bref!! Je vais suivre vos conseils et réinstaller tout ça dès que j'aurais un peu de temps! Merci pour tous les liens.

Arien, c'est vrai que j'ai tendance à me mettre en su dès que j'ouvre le terminal (je ne connaissais pas la commande sudo avant que tu m'en parles et que je fasse une ptite googlisation) et c'est vrai aussi que j'ai un peu mélangé apt-get et aptitude...
La totale quoi!! tongue

Merci encore et, promis, je vous donne des nouvelles dès que j'ai avancé.
A très bientôt!

Hors ligne

#18 13-10-2010 02:54:12

Invité-5
Banni(e)

Re : Carte son non reconnue [résolu]

Salut,

Parce-que il faut aller avec son temps, quand tu vas installer Squeeze qui sortirait bientôt en stable, il sera judicieux de paramétrer ton sudoers ( merci  smolski ) et normalement ça roule.

Amitié

Dernière modification par arien (13-10-2010 03:05:03)

#19 13-10-2010 04:23:04

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Carte son non reconnue [résolu]

Bonjour,

Avec les informations du lspci, et des "saintes écritures" du noyau, il semble que ta carte son soit bien reconnue. J'avais décrit la méthode dans ce fil. Dans notre cas ça donne:

tux12@host:~$ grep 8086 /lib/modules/`uname -r`/*map | grep 284b
/lib/modules/2.6.26-2-686/modules.pcimap:snd-hda-intel        0x00008086 0x0000284b 0xffffffff 0xffffffff 0x00000000 0x00000000 0x0


La présence de cette ligne confirme que ce hardware devrait être supporté par le module snd-hda-intel du noyau de Lenny (la stable actuellement).
De plus l'utilisateur du fil susnommé a le même circuit son que toi et ne mentionne pas de problèmes de ce côté là. C'est un bon présage. wink

Après ré-installation, si ça devait néanmoins ne pas fonctionner "out of the box" tu peux reprendre ce fil du début (lsmod ...) pour nous dire ce qu'il en est.

À te lire smile

Hors ligne

#20 26-10-2010 15:38:13

alice...
Membre
Lieu : Lille
Distrib. : Squeeze
Noyau : 2.6.32-5-686
(G)UI : Xfce
Inscription : 08-10-2010

Re : Carte son non reconnue [résolu]

Bonjour tout le monde,

Alors, ça y est j'ai réinstallé Debian et c'est bon, le problème est résolu. Cette version a reconnu et utilisé ma carte son tout de suite. Je n'ai rien eu à faire. cool
Mais bon, j'ai un peu "triché" vu que je suis passée à Squeeze! (j'étais sous Lenny avant) Je mets quand même résolu dans le titre?
Parce que finalement, je sais pas vraiment ce que j'ai pu faire et qui ne marchait pas!

Voilà, merci à tous et à très bientôt pour un nouveau topic! big_smile

Hors ligne

#21 26-10-2010 15:55:53

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Carte son non reconnue [résolu]

Bonjour alice,

Oui, tu mets le Résolu dans le titre, car de passer en squeeze est LA solution à ce problème.

À bientôt, au passage, prends donc un amical point pour le carré de chocolat, ce gentil retour le mérite amplement. wink

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums