Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 20-10-2010 00:34:36

Invité-5
Banni(e)

[résolu] problème de noyau

Bonjour,

Depuis quelques jours, je des problèmes de noyau provoqué probablement par mon matériel ( processeur ? ) avec le message suivant ;

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041241] ------------[ cut here ]------------

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041250] invalid opcode: 0000 [#1] SMP

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041253] last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041362] Stack:

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041376] Call Trace:

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041430] Code: 10 48 8d 7b 18 e8 58 87 00 00 c7 43 08 00 00 00 00 4c 89 e7 e8 65 fe ff ff 48 85 c0 49 89 c4 75 f0 48 83 bd f0 00 00 00 00 74 04 <0f> 0b eb fe 48 83 c4 20 5b 5d 41 5c c3 41 56 41 be f4 ff ff ff

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041810] ------------[ cut here ]------------

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041817] invalid opcode: 0000 [#2] SMP

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041819] last sysfs file: /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041920] Stack:

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041933] Call Trace:

Message from syslogd@debian at Oct 19 21:31:47 ...
 kernel:[32492.041954] Code: 10 48 8d 7b 18 e8 58 87 00 00 c7 43 08 00 00 00 00 4c 89 e7 e8 65 fe ff ff 48 85 c0 49 89 c4 75 f0 48 83 bd f0 00 00 00 00 74 04 <0f> 0b eb fe 48 83 c4 20 5b 5d 41 5c c3 41 56 41 be f4 ff ff ff


Au début ça à commence par "erreur de segmentation" dans les 3 navigateurs ( Epiphany, Iceweasel et Kazehakase + Icedove ) que je voulus résoudre par supprimer les répertoires .mozilla et .icedove dans mon home, en réinstallant les navigateurs aprés, sans beaucoup de succes. Quand je lance le navigateur dans le terminal 1 fois sur 2 ça marche, sinon "erreur/segmentation" Et pour couronner le tout j'ai à présent un gros problème de noyau. Je crus comprendre que il s'agit de fréquence CPU mal règle ou alors mon processeur brûle-t-il ??? aprés 4 ans de service. Je regardé un tout petit peu dans cpufrequtils sans conviction ne sachant pas bien manipuler ces utils, je juste essayé de regler ondemand dans

# /etc/init.d/cpufrequtils

MAX_SPEED = "2133000"
MIN_SPEED  = "1600000"
   
Mes compétences pour ce problème s'arrêtaient la, je besoin de votre aide.

Salutations.

EDIT : J'ai trouvé le coupable, donc je pus solutionner le problème par moi-même. Mon matériel n'est pour rien, c'est du solide. Merci.

Dernière modification par arien (21-10-2010 10:21:47)

#2 22-10-2010 13:05:43

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [résolu] problème de noyau

Super!!:)

Bon, on t'a pas beaucoup aider.

Et quel était le problème?

Hors ligne

#3 01-11-2010 20:23:41

Invité-5
Banni(e)

Re : [résolu] problème de noyau

Salut,

Désole pour la réponse tardive.

Voila, la majorité des noyaux Linux fournis par nos distributions utilisent des >>governors<< pour définir une politique à appliquer sur des processeurs. Debian applique par défaut le governor "ondemand" qui abaisse le processeur à sa vitesse minimale la plupart du temps et change dynamiquement sa fréquence en l'augmentant jusqu'au son maximum selon les besoins du système. Le problème venant du processeur "scotché" sur la fréquence minimum ( 1.60 GHz dans mon cas ) sans jamais"monter" malgré des lourdes tâches imposé. Pourquoi ? mystère. Quand j'ai vu ça sur mon Conky, ma première idée été d'indiquer manuellement des fréquences mini et maxi à mon processeur. Cpufrequtils étant déjà installé sur Squeeze:

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies


La console renvoi 2133000-1867000-160000 ( chez moi )

# nano /etc/init.d/cpufrequtils


je cherche
ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="0"
MIN_SPEED="0"

et je change en
ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="2133000"
MIN_SPEED="1600000"

On peut aussi utiliser >>governor<< userspace ( régler la fréquence du processeur en intermédiaire où maximum ) mais je crois pas que c'est la meilleure solution parce-que après

$ cpufreq-info


environ 80% d'utilisation s'effectue à 1.60 GHz ( chez moi ) et c'est inutile de chauffer le processeur sans parler de la consommation électrique.

Pour le moment plus des problèmes ( j'avais vérifié aussi avant tout les barrettes de mémoire avec memtest86+ ) erreur de segmentation = barrette défectueuse.
 
Tout ça sur la Squeeze amd64 + qques paquets pioché dans Sid.

Amicalement.

Pied de page des forums