Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-10-2010 03:05:52

Rizla
Membre
Lieu : Millau
Distrib. : Squeeze
(G)UI : XFCE
Inscription : 21-10-2010

Probleme WIFI scan essid

Salut salut
je suis passer a debian il y a quelque jours et je suis en wifi (j'avais toujours était en cpl avant)
miraculeusement tout a fonctionner directement, mise a part le fait que j'ai 2 petit probleme (j'utilise une clef wifi wg111v3 netgear)
donc j'utilise nm-applet pour me connecter a mon wifi non sécurisé (juste cryptage MAC)
mon soucis étant que je suis un joueur (quake 3) et qu'aparament et en fait, c'est meme sur smile network-manager fait un scan de la liste des essid toute les X minutes (2 je crois tongue)
donc le soucis c'est que durant ce scan je me tape un enooooorme lag qui me gène moi, et mes adversaire donc c'est pas super
donc j'ai lu pas mal de tuto pour me renseigner, donc apparament depuis la version 8.1.0 de network manager il suffit de spécifier le BSSID auquel on veut se connecter pour annuler ce scan ... sauf que chez moi quand je le specifie et que j'essaye de me connecter, il creé automatiquement une nouvelle connexion ...
donc je me suis dis, essayons de se connecter manuellement (ifup)
donc j'ai suivis plusieurs tuto mais cela n'as pas fonctionné, wala a quoi j'ai droit:
#killall nm-applet
# ifup wlan0 Montbazet
Listening on LPF/wlan0/00:22:3f:ea:89:f4
Sending on   LPF/wlan0/00:22:3f:ea:89:f4
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Ignoring unknown interface Montbazet=Montbazet.


merci au gens qui voudront/pourront m'aider
smile

Dernière modification par Rizla (21-10-2010 03:06:52)

Hors ligne

#2 21-10-2010 07:07:04

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Probleme WIFI scan essid

Bonjour Rizla,

Pour l'utilisation de network-manager et wicd, tu peux voir là que c'est pas top :
http://debian-facile.org/doc:reseau:network-manager

Le mieux pourrait être que tu configures ton reseau à la main une bonne fois pour toute après avoir supprimé l'installation de ces applications litigieuses pour le moins. wink
http://debian-facile.org/manuel:config:interfaces

Pour configurer le wifi, regarde chez not' copain le captnfab là :
http://wiki.chezlefab.net/tuto_nix/conf … faces_wifi

Voilà voilà...

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 21-10-2010 07:36:16

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : Probleme WIFI scan essid

Smolski, toujours plus rapide que la lumière!
Avec wicd, ça devrait aller vite. Sinon, ben confère les liens de smolski pour gérer à la main.
Bon courage et bienvenue sur debian!

YA3HGA-H

Hors ligne

#4 21-10-2010 20:29:38

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Probleme WIFI scan essid

Bonjour,

DHCPDISCOVER on wlan0 to 255.255.255.255 ......
No DHCPOFFERS received.


Ceci signifie qu'aucun serveur DHCP n'a pu être trouvé pour attribuer une IP à l'interface. As-tu un serveur DHCP actif sur le routeur/APwifi ?

Voici ce que j'ai dans le fichier /etc/network/interfaces pour gérer une cké Wifi, c'est bien sûr à adapter à ton cas particulier pour les valeurs (nom de l'interface, canal, essid, clé de cryptage, IP, DNS) mais sur le principe tout est là:

allow-hotplug wlan1
iface wlan1 inet static
        wireless-mode managed
        wireless-channel 11
        wpa-ssid OutofHereBastards
        # plain text passphrase
        wpa-psk laclewpapskquetumetscequetuveuxalaplace
        # static ip settings
        address 192.168.1.12
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.1.1


En DHCP il faut remplacer le "inet static" de la deuxième ligne par "inet dhcp" et tu n'as pas dans ce cas à indiquer tout ce qui suit la ligne "#static ip settings", y compris la mention de DNS.
Je précise que j'ai viré network-manager et que je n'utilise pas non plus wicd.

Si ça peut aider...
@+

Dernière modification par tux12 (21-10-2010 20:30:53)

Hors ligne

#5 22-10-2010 13:59:27

Rizla
Membre
Lieu : Millau
Distrib. : Squeeze
(G)UI : XFCE
Inscription : 21-10-2010

Re : Probleme WIFI scan essid

Ok merci de vos réponse
je suis passer a "wicd" qui règle mon probleme du scan essid qui me fait lagué
mais c'est qu'une solution temporaire j'essayerai ta technique ce soir
merci a tous smile

Hors ligne

#6 22-10-2010 15:07:37

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Probleme WIFI scan essid

J'eu fais une chose comme ça :

### fichier : /etc/resolv.conf
# pour freebox
search n°_ip_externe
nameserver 212.27.40.240
nameserver 212.27.40.241

### fichier : /etc/wpa_supplicant/wpa_supplicant.conf ###

# WPA-PSK/TKIP

ctrl_interface=/var/run/wpa_supplicant

network={
        ssid="ma_boite"
        key_mgmt=WPA-PSK
        proto=WPA
        pairwise=TKIP
        group=TKIP
#       En ascii, mettre des "doubles_quotes"
        psk=ma_belle_clé_en_hexadecimal
}


##### fichier : /etc/network/interfaces #####

# The loopback network interface
auto lo
iface lo inet loopback

# ethernet
allow-hotplug eth0
iface eth0 inet dhcp

# Wifi
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#7 22-10-2010 16:51:42

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Probleme WIFI scan essid

Bonjour,

Ah oui, wpa-supplicant, je l'oublie à chaque fois celui-là. hmm

Par contre je ne toucherais pas au resolv.conf dans le cas d'une config en DHCP, le modem/routeur fournissant les dns en même temps que l'IP du client.

@+

Edit; vérification faite, pour la config que j'ai donné précédemment je n'ai pas de fichier de config pour wpa-supplicant. Il faut juste avoir installé le paquet wpasupplicant.

Dernière modification par tux12 (22-10-2010 18:21:12)

Hors ligne

Pied de page des forums