Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 29-10-2007 16:55:32

Cyber-Gedeon
Membre
Lieu : Haut-Jura
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox
Inscription : 15-07-2007

[ résolu ] Debian lenny et serveurX

Bonjour
J'ai installé lenny sur mon PC mais je ne parviens pas à faire fonctionner l'affichage ( carte nvidia ), il y de multiples messages sur le forum et ailleurs mais je ne m'en sort pas. Après avoir tenté divers tripatouillages avec apt-get install (sur lesquels je passe...) j'obtiens en bout de course le message suivant :

Fatal serveur error :
No valid FrontPath could be found.


Si je démarre en utilisateur ordinaire un message me signale que le serveur x est désactivé.

Quelle méthode puis-je employer pour faire fonctionner X ?

Merci d'avance.

Dominique

Dernière modification par Cyber-Gedeon (02-11-2007 02:06:00)

Hors ligne

#2 29-10-2007 17:19:59

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [ résolu ] Debian lenny et serveurX

Saurais-tu envoyer le contenu du fichier /etc/x11/xorg.conf sur

http://pastebin.com

s'il te plaît ?

Quelle est la version de carte nVidia que tu as ? Qu'as-tu installé comme driver ? Est-ce qu'il te faut le Direct Rendering  ? (est-ce que tu utilises des jeux ?)

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#3 29-10-2007 17:56:26

Cyber-Gedeon
Membre
Lieu : Haut-Jura
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox
Inscription : 15-07-2007

Re : [ résolu ] Debian lenny et serveurX

Bonjour
Je ne peux pas faire grand chose car vu que mon PC affiche comme un minitel, je me vois mal envoyer quoique ce soit :-(
Ce PC est assez ancien ( Atlon 1,4 giga ) je n'ai pas besoin d'avoir un super affichage, et  dans un premier temps je voudrais que ça marche de façon basique ( même en 32 couleurs  !) pour que je puisse faire quelque chose.
Ce n'est pas le PC que j'utilise actuellement, je vais essayer de copier le contenu avec les moyens du bord ...
A+
Dominique

Hors ligne

#4 30-10-2007 00:57:45

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [ résolu ] Debian lenny et serveurX

Euh... en 32 couleurs ? En 16 ça va aussi, probablement.

Qu'est-ce que tu as comme périphériques internes ? Modèle et marque de carte mère, ram...

Pastes ton xorg.conf directement ici aussi, si tu peux ?

Bon, et puis tu pourrais t'informer pour savoir s'il y a des installs parties dans ton coin, le contact direct ça aide bien des fois. (voir association sequanux.org, ils sont vers Besançon, je crois).

Si tu peux mettre le vieil ordi et celui que tu utilises actuellement en réseau (y a-t-il une carte réseau dans chacune des deux machines ?) tu pourrais copier les fichiers de l'ordinateur distant depuis une console, grâce à une connexion ssh. Il suffit pour ça d'installer openssh et les dépendances qui viennent avec) sur les deux machines.

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#5 30-10-2007 23:46:03

Cyber-Gedeon
Membre
Lieu : Haut-Jura
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox
Inscription : 15-07-2007

Re : [ résolu ] Debian lenny et serveurX

Bonsoir,
Merci pour le mal que tu te donnes pour résoudre mon problème mais après réflexion, je pense que j'ai du cafouiller après ou pendant l'installation.En efet; sur ce PC j'ai installé diverses distrib (DebianEtch, ubuntu, mandriva, slackware, FreeBSD ) à chaque fois l'affichage à fonctionné. Donc je ne pense pas que le problème vienne de de ma carte graphique, ni même de Lenny...j'ai certainement fait une boulette quelque part...
Debian a la réputation d'avoir une procédure d'installation délicate, je vais finir par penser que c'est vrai !
J'ai utilisé la procédure d'installation par internet, je ne sais pas trop comment ça fonctionne avec Lenny, mais ça a été très rapide ( beaucoup plus qu'avec Etch ) manifestement, tout n'a pas été installé.
Je vais creuser le problème.
Dominique

Hors ligne

#6 31-10-2007 00:35:40

ninux
Modérateur
Lieu : ici ou ailleur :D
Distrib. : De boisson
Noyau : olive et cerise
(G)UI : mon écran
Inscription : 01-06-2007

Re : [ résolu ] Debian lenny et serveurX

Bonsoir !
Pour une install plus facile ( enfin si ont veux) au tout premier prompt tu tape "installgui" et tu auras un semblant d'interface pour faire ton install .

Debian a la réputation d'avoir une procédure d'installation délicate, je vais finir par penser que c'est vrai !


je fais des test sous debian depuis pas mal de temp, je fais une install environ toutes les semaines pour tester les distrib et je ne trouve pas ça plus dur qu'avec une ubuntu ou autre genre de distrib (enfin sauf pour gentoo, slackware et quelques autres ) .

Donc essai avec installgui et tu verras que c'est un peu plus simple .
Tient nous au courant stp .
Merci !


Je suis capable du meilleur comme du pire, mais dans le pire, c'est moi le meilleur ! lol __ Ces temps ci " je suis dans le PIRE ha ha ha !
pour avoir du génie, faut être mort.  Pour avoir du talent faut être vieux. Moi je ne suis ni mort ni vieux, alors soyez indulgent ! big_smile

Hors ligne

#7 31-10-2007 06:18:30

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [ résolu ] Debian lenny et serveurX

Cyber-Gedeon a écrit :

En efet; sur ce PC j'ai installé diverses distrib (DebianEtch, ubuntu, mandriva, slackware, FreeBSD ) à chaque fois l'affichage à fonctionné. Donc je ne pense pas que le problème vienne de de ma carte graphique, ni même de Lenny...j'ai certainement fait une boulette quelque part...


Ok, en ce cas le plus facile serait de récupérer un fichier xorg.conf généré par une distribution rapide à installer, puis une fois le fichier de configuration mis de côté, réinstaller Debian. Si tu veux utiliser des procédures d'installation rapide sans CD, n'hésites pas à le dire : j'ai essayé celle pour Zenwalk, la petite soeur de Slackware, bien rapide à installer, offrant un très joli xorg.conf, et une jolie configuration réseau aussi, et j'ai essayé celle pour Debian, les deux méthodes sont sympa. Debian, avec hd-media, Zenwalk, avec une méthode de partition prémontée dans laquelle on envoie tous les fichiers contenus dans l'image iso du CD d'installation... Les deux méthodes nécessitent qu'un OS ou une distribution soit déjà installée, en même temps...

Éventuellement, si tu installais Zenwalk depuis Debian, tu pourrais ensuite installer Debian depuis Zenwalk. smile

ninux : je ne connais pas installgui, je l'essaierai à l'occasion. Si tu peux faire passer une capture du premier prompt, à l'occasion ? (Fais-tu des installations en machine virtuelle aussi ?)


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#8 01-11-2007 01:05:21

Cyber-Gedeon
Membre
Lieu : Haut-Jura
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Fluxbox
Inscription : 15-07-2007

Re : [ résolu ] Debian lenny et serveurX

Ça y est l'affichage fonctionne !
Je  résume mes manips au cas oû quelqu'un ait les mêmes problèmes que moi  en installant lenny, je passe sur divers tâtonnements et messages d'erreurs.
Netinstall ( avec en fait l'installation minimum )
Puis:

apt-get install xserver-xorg
apt-get install xfonts-base
apt-get install x-window-system
apt-get install gnome


( pour avoir un envirinnement graphique )
Je ne sais pas si cet ordre est le plus judicieux mais c'est ainsi que j'ai procédé.

ensuite configuration du fichier /etc/X11/xorg.conf en me servant de celui de kubuntu que j'ai sur une autre partition du même disque dur:

dkpg-reconfigure xserver-xorg


et finalement 

startx


et voilà
En route pour de nouvelles aventures ( et bonne nuit pour ceux qui sont encore debout ! )
Merci pour vos conseils

Maitenant il ne me reste plus qu'à installer les driver nvidia ....

Dominique

Hors ligne

#9 01-11-2007 13:09:20

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [ résolu ] Debian lenny et serveurX

En ce cas, veux-tu noter dans le titre du premier message, que c'est résolu ?

le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

Pied de page des forums