Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 01-12-2010 17:35:21

nerach
Membre
Lieu : 84
Distrib. : Lenny/Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : XFCE
Inscription : 03-11-2010

Connexion téléphone 3G sur USB sans NetworkManager

Bonjour,

J'utilise XFCE et j'ai un petit soucis avec NetworkManager.
Pour commencer il ne gére pas ma carte réseau, je ne sais pas pourquoi...

Si je garde NM actif c'est uniquement pour pouvoir me connecter lorsqu'il y a des coupures téléphonique dans ma régions.

Le soucis, c'est qu'à chaque fois que je branche mon téléphone portable je suis ensuite obliger de restaurer /etc/resolv.conf à la main ou refaire un route pour préciser le gw pour que je puisse à nouveau me connecter.

Je cherche donc une solution viable pour avoir accès à Internet via mon téléphone sans avoir recours à NetworkManager.

Note au passage.
mon /etc/interfaces

cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
allow-hotplug eth0

#static IP
iface eth0 inet static
address 192.168.1.109
netmask 255.255.255.0
gateway 192.168.1.1

Hors ligne

#2 01-01-2011 20:08:26

Bruno10
Membre
Lieu : Rennes
Distrib. : Wheezy/Sid
Noyau : 3.2 amd64
(G)UI : XFCE 4.10
Inscription : 25-03-2010

Re : Connexion téléphone 3G sur USB sans NetworkManager

Je ne sais pas si je réponds vraiment à la question, mais:

- J'utilise le nm de gnome sur mon eeePC qui reconnaît parfaitement mon 3G Orange. Pas sûr que le problème vienne de là...

- En ce qui concerne resolv.conf, j'ai résolu définitivement le problème avec un petit:

# chattr +i /etc/resolv.conf


Après avoir mis le nameserver qui me convient, et là cela ne bougera plus.

Hope it helps... smile

Dernière modification par Bruno10 (01-01-2011 20:08:53)


If it ain't broke, don't fix it.

Hors ligne

#3 01-01-2011 20:27:17

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Connexion téléphone 3G sur USB sans NetworkManager

Salut,

Au vu de la résolution ici :
http://debian-facile.org/forum/viewtopi … 456#p26456

Je te propose déjà de ne pas mettre :

auto eth0
allow-hotplug eth0


Mais seulement :

allow-hotplug eth0


Et de lire ici le pourquoi du comment de chacune de ces options :
http://debian-facile.org/config:interfa … _demarrage

Hop ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 01-01-2011 20:56:37

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Connexion téléphone 3G sur USB sans NetworkManager

Bonjour

nerach a écrit :

à chaque fois que je branche mon téléphone portable


Commentes la ligne "allow-hotplug eth0" du /etc/network/interfaces, redémarre les services réseau et dis nous ce que ça donne stp.

Dernière modification par tux12 (01-01-2011 21:11:29)

Hors ligne

Pied de page des forums