Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-12-2010 10:09:40

arnooooooo
Membre
Inscription : 18-12-2010

mise à jour debian bloquée dépendance package

Bonjour,

J'ai un BIG soucis :

Cela faisait longtemps que je ne m'étais pas préoccupé des mises à jour de mon serveur. Et je me suis apperçu qu'il devait y avoir beaucoup de retard sur ma config.

Mon sources.list avait l'air HS. Donc je le modifie avec des sources trouvés sur le net sans trop savoir ce qu'il fallait mettre. voila ce que j'ai actuellement dans mon sources.list :

deb http://ftp.fr.debian.org/debian stable main contrib non-free
deb-src http://ftp.fr.debian.org/debian stable main contrib non-free

- 1ere question : Est ce que mon /etc/apt/sources.list est correct ?

Lorsque je lance un

/usr/bin/apt-get update

Tout a l'air OK

Réception de : 1 http://ftp.fr.debian.org stable Release.gpg [1033B]
Atteint http://ftp.fr.debian.org stable Release
Ign http://ftp.fr.debian.org stable/main Packages/DiffIndex
Ign http://ftp.fr.debian.org stable/contrib Packages/DiffIndex
Ign http://ftp.fr.debian.org stable/non-free Packages/DiffIndex
Ign http://ftp.fr.debian.org stable/main Sources/DiffIndex
Ign http://ftp.fr.debian.org stable/contrib Sources/DiffIndex
Ign http://ftp.fr.debian.org stable/non-free Sources/DiffIndex
Atteint http://ftp.fr.debian.org stable/main Packages
Atteint http://ftp.fr.debian.org stable/contrib Packages
Atteint http://ftp.fr.debian.org stable/non-free Packages
Atteint http://ftp.fr.debian.org stable/main Sources
Atteint http://ftp.fr.debian.org stable/contrib Sources
Atteint http://ftp.fr.debian.org stable/non-free Sources
1o réceptionnés en 0s (7o/s)


puis je fais un :

/usr/bin/apt-get upgrade

cela me donne ça

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
  libc6-i386: Dépend: libc6 (= 2.7-18lenny6) mais 2.3.6.ds1-13etch10 est installé
  locales: Dépend: glibc-2.7-1
E: Dépendances manquantes. Essayez d'utiliser l'option -f.


donc je fais :

/usr/bin/apt-get -f upgrade

cela me donne une liste de packet plutot important a mettre à jour et :

Extraction des modèles depuis les paquets : 100%
Préconfiguration des paquets...
(Lecture de la base de données... 28424 fichiers et répertoires déjà installés.)
Préparation du remplacement de binutils 2.17-3+etch1 (en utilisant .../binutils_2.18.1~cvs20080103-7_amd64.deb) ...
Dépaquetage de la mise à jour de binutils ...
dpkg : erreur de traitement de /var/cache/apt/archives/binutils_2.18.1~cvs20080103-7_amd64.deb (--unpack) :
impossible de créer « ./usr/bin/addr2line »: Permission non accordée
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
dpkg : concernant .../libc6-dev_2.7-18lenny6_amd64.deb contenant libc6-dev :
libc6-dev entre en conflit avec binutils (<< 2.17cvs20070426-1)
  binutils (version 2.17-3+etch1) est installé.
dpkg : erreur de traitement de /var/cache/apt/archives/libc6-dev_2.7-18lenny6_amd64.deb (--unpack) :
paquets en conflit - libc6-dev non installé
Préparation du remplacement de libc6 2.3.6.ds1-13etch10 (en utilisant .../libc6_2.7-18lenny6_amd64.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
Dépaquetage de la mise à jour de libc6 ...
dpkg : erreur de traitement de /var/cache/apt/archives/libc6_2.7-18lenny6_amd64.deb (--unpack) :
impossible de créer « ./usr/bin/iconv »: Permission non accordée
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/binutils_2.18.1~cvs20080103-7_amd64.deb
/var/cache/apt/archives/libc6-dev_2.7-18lenny6_amd64.deb
/var/cache/apt/archives/libc6_2.7-18lenny6_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


Je ne sais pas trop ce que j'ai foutu mais entre mes essais de sources.list et essais de mis à jour, j'ai du mettre un peu le bazard la dedans.
Depuis je cherche sur le net, pour comprendre ce qu'il se passe mais ne trouve pas. Je suis autodidacte et je n'ai jamais eu le temps de me plonger dans les problemes de config alors si quelqu'un peut un peut m'aider, je suis preneur.

Petite info, j'essaye de mette mon système à jour car j'avais des comportements un peu bizarre sur mon serveur : postgresql qui tombe en rade + message warning lors de redemarrage numero de version introuvable pour un package.

Pour exim4 :

/etc/init.d/exim4 restart
Stopping MTA for restart: exim4_listener.
Restarting MTA: exim4.
* ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken

enfin voila, je crois que j'ai un gros soucis, mais je me suis dit que la premiere chose à faire etait de mettre à jour le systeme, mais je suis bloqué.

Merci d'avance pour votre aide.

Hors ligne

#2 18-12-2010 10:27:44

mksmn
Membre
Lieu : Ile de France
Distrib. : Debian Gnu-Linux Jessie 8.x & Backports
Noyau : Noyau Linux 3.16.0-4-686-pae
(G)UI : Xfce 4.10 & Mate 1.8.1
Inscription : 30-06-2008

Re : mise à jour debian bloquée dépendance package

bonjour,

est-ce voulu de ne pas avoir les dépots debian-security ?

je pense que ce n'est pas recommendé !!!

rajoute cette ligne

[c]# lenny security
deb http://security.debian.org/ lenny/updates main contrib non-free
deb-src http://security.debian.org/ lenny/updates main contrib non-free

[/c]

ensuite apt-get update puis upgrade

Dernière modification par mksmn (18-12-2010 10:28:45)


Debian, c'est bien.
Adhérent APRIL 9141
Fan de Norah Jones, depuis toujours et pour toujours.

Hors ligne

#3 18-12-2010 11:16:22

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : mise à jour debian bloquée dépendance package

Bonjour arnooooooo et bienvenue sur df !

J'ajouterai de remplacer les stables de ton sources.list par lenny, une migration de squeeze (la testing actuelle) vers stable est en approche et il n'est pas recommandé d'effectuer cette migration trop tôt.

Tu as sur le wiki df toutes les explications concernant les branches debian auxquels nous nous référons dans ce fil, là :
http://debian-facile.org/doc:systeme:ap … hes-debian

Ainsi que quelques conseils d'administration élémentaire là :
http://debian-facile.org/#administration

Et pour la migration prochaine vers squeeze :
http://debian-facile.org/doc:install:mi … is-windows

Tutos avec lesquels tu peux t'inspirer dans ta situation actuelle (idem pour un lecteur néophyte suivant ce post). wink

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 18-12-2010 11:57:35

arnooooooo
Membre
Inscription : 18-12-2010

Re : mise à jour debian bloquée dépendance package

Merci MKSMN, j'ai ajouté les deux lignes mais cela ne suffit pas j'ai toujours

dpkg : erreur de traitement de /var/cache/apt/archives/binutils_2.18.1~cvs20080103-7_amd64.deb (--unpack) :
impossible de créer « ./usr/bin/addr2line »: Permission non accordée
dpkg-deb: sous-processus paste tué par le signal (Relais brisé (pipe))
dpkg : concernant .../libc6-dev_2.7-18lenny6_amd64.deb contenant libc6-dev :
libc6-dev entre en conflit avec binutils (<< 2.17cvs20070426-1)
  binutils (version 2.17-3+etch1) est installé.


Merci Smolski, je vais lire tout ça mais pour le moment, j'essaye d'aller au plus vite pour corriger mes soucis.

Pour remplacer les stable de lenny, je met ?

deb http://security.debian.org/ lenny/stable main contrib non-free
deb-src http://security.debian.org/ lenny/stable main contrib non-free

ou

deb http://security.debian.org/lenny stable main contrib non-free
deb-src http://security.debian.org/lenny stable main contrib non-free

ou autre ?

Merci

Hors ligne

#5 18-12-2010 12:11:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : mise à jour debian bloquée dépendance package

Un sources.list complet pour lenny est là :
http://debian-facile.org/manuel:sources … pour_lenny

Je te déconseille de mettre les backports, la migration prochaine les rend moins utilisables.

Hop ! smile

PS : Je comprends parfaitement ton recul à visiter tout le wiki df, mais je préfère quand même t'en proposer les liens, ne serait-ce que pour t'éviter à y revenir et y trouver en plus quelques compléments d'explications utilisables.

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#6 18-12-2010 12:18:25

arnooooooo
Membre
Inscription : 18-12-2010

Re : mise à jour debian bloquée dépendance package

Merci pour tes liens, j'ai commencé à les lire.

J'ai remplacé mon sources.list

J'ai été obligé de retirer le multimedia car marche pas probleme de signature

Mais cela ne corrige pas le probleme.

Je vais continuer à lire les manuels quand j aurais plus de temps aujourd hui ca va pas etre possible.

Merci en tout cas. Mais je crains que tes manuels ne suffisent pas pour corriger mon probleme. Donc s'il y a des idées je suis preneurs.

Merci

Dernière modification par arnooooooo (18-12-2010 12:18:51)

Hors ligne

#7 18-12-2010 12:25:19

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : mise à jour debian bloquée dépendance package

probleme de signature


C'est le lien à la suite du précédent tuto pour le sources list lenny :
http://debian-facile.org/doc:systeme:apt:signatures

Tu as tenté l'authentification ?
Tu peux indiquer le kernel que tu utilises actuellement :

uname -r


Amitié, Mystère Wiki df ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 18-12-2010 15:48:10

arnooooooo
Membre
Inscription : 18-12-2010

Re : mise à jour debian bloquée dépendance package

uname -r me donne ça

2.6.24.5-xxxx-std-ipv4-64

pour l'authentification =>

apt-get install debian-multimedia-keyring debian-backports-keyring
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes :
Les paquets suivants contiennent des dépendances non satisfaites :
  libc6-i386: Dépend: libc6 (= 2.7-18lenny6) mais 2.3.6.ds1-13etch10 devra être installé
  locales: Dépend: glibc-2.7-1
E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet
(ou indiquez une solution).


et apt-get -f install ne change pas mon erreur

une idée ?

Hors ligne

#9 18-12-2010 16:18:32

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : mise à jour debian bloquée dépendance package

debian-backports-keyring


si tu ne mets pas les dépôts backports, il n'est pas nécessaire de les authentifier.

Je remarque ça :

2.3.6.ds1-13etch10


Tu viens donc de la branche oldstable etch.
Il semblerait qu'il te soit nécessaire de laisser les dépôts etch dans ton sources.list pour d'abord mettre à jour les paquets etch avant de migrer vers lenny.

Donc, tu remplace lenny par etch dans ton sources.list et tu mets à jour plusieurs fois, tant qu'il y a de la mise à jour.
Utilises apt-get plutôt que aptitude, c'est le conseil qui a été donné pour une migration de sarge vers etch dernièrement sur le forum, voir là :
http://debian-facile.org/forum/viewtopic.php?id=3267
Post auquel tu peux d'ailleurs t'inspirer pour ta propre migration.

Tu as aussi le tuto du wiki df de migration de lenny à squeeze que je t'ai déjà indiqué plus tôt.

C'est à peu près les mêmes principes :
Mettre à jour son système dans sa branche ancienne puis, après stabilisation, migrer vers la nouvelle branche en ajoutant les nouvelles sources SANS effacer les anciennes auxquels les dépendances sont toujours attachées.

Nous ne connaissons pas non plus ton matériel, si tu peux l'indiquer dans le Profil du bandeau d'accueil ?

Voilà, pas mieux ici, je n'ai jamais pratiqué de telle migration. Je préfère de loin refaire toute l'installation sur des partitions préparées et vierges.

Si ton serveur n'est pas en production, c'est ce que je te recommanderai de faire pour aller au plus rapide et au plus efficace.
Il est à noter que tu peux être en 32 bits et non en 64, vue l'ancienneté de ton installation, non ?
Voit à bien utiliser l'iso qui conviendra pour une netinstall lenny.
http://debian-facile.org/manuel:debian-facile_install

Amitié, joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#10 18-12-2010 17:03:02

arnooooooo
Membre
Inscription : 18-12-2010

Re : mise à jour debian bloquée dépendance package

Merci Joel.

au vu du lien que tu m'as filé, j'ai eu une goutte de sueur.
En effet, le serveur est en prod.

Pour mon matos, je ne sais meme plus trop ce que c est ca fait un an et demi que je l ai et me rappelle plus trop c est un serveur hébergé chez OVH.

tu as une commande pour connaitre le matos ?

et un tuto pour sauvegarder le systeme et restaurer le systeme si crach du serveur actuel ?

Pour mon probleme, j'ai tout remis en etc => il y a pas mal de sources qu il ne trouve pas apparemment mais bon j ai l impression que ca a fait un peu de nettoyage peut etre meme un peu trop, je n ai plus ma commande préférée "top" bizarre
Puis, j ai remis les sources lenny, et le apt-get update et le apt-get -f install ont fonctionné.
j'allais faire un apt-get upgrade et là je me suis dit qu'il fallait peut etre faire une sauvegarde du systeme. Est ce que je peux faire le upgrade sans tout cracher ou y a t il un risque ? et si oui quels outils puis je utiliser pour faire une sauvegarde du systeme proprement ?

merci

Hors ligne

#11 23-12-2010 15:10:19

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : mise à jour debian bloquée dépendance package

Sauvegarde du système, peut être voir ici?

http://debian-facile.org/doc:systeme:sauvegarde

Connaître le matos:

lspci


et

lsusb


Pour en savoir plus:  http://wiki.debian.org/fr/HowToIdentifyADevice

J'espère avoir aidé.

Hors ligne

Pied de page des forums