Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-01-2011 09:01:33

andson
Membre
Inscription : 02-01-2011

Problème de language.

Bonjour à tous,

Actuellement sous Linux Mint LMDE 64bits je rencontre des problèmes de localisation du system. Ces soucis sont apparus pour certains après quelques temps.
D'une part j'ai toute la partie language du system qui est en anglais, les menus de certaine applications sont en anglais d'autres non. Les paquets languages spécifiques s'il y en a sont installés.
J'ai fait plusieurs :

sudo dpkg-reconfigure locales


sans résultats.

un  locale -a | grep fr me donne

andson@p5kc ~ $ locale -a | grep fr
français
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8


j'ai même supprimé le paquet us sans résultat.

D'autre part ceratine application comme Open Office, VLC, 2ManDVD sont en hébreux (ou quelque chose qui y ressemble) alors qu'il n'y a aucun paquets linguistiques hébreu d'installés, d'ailleurs je n'en trouve pas.
Une recherche  avec -fr via synaptic me sort quelques paquets spécifiques à certains logiciels mais c'est tout. Pas de language-packs-fr ou quelque chose de similaire.
J'espère n'avoir pas été trop confus dans mes explications.

Ma question est la suivante. Y a-t-il un moyen de recharger les paquets languages via synaptic ou en mode console. Avez-vous une autre piste.

D'avance merci

Hors ligne

#2 02-01-2011 12:25:47

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Problème de language.

Bonjour,

Installe localepurge et ne conserve que fr_FR.utf8 ( éventuellement fr_FR.iso88591  et fr_FR.iso885915@euro )

Ca fera déjà un peu de ménage.
Puis re:

sudo dpkg-reconfigure locales


@+


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#3 02-01-2011 13:51:36

andson
Membre
Inscription : 02-01-2011

Re : Problème de language.

Bonjour,

Cela ne change rien. J'ai toujours mes menus logiciels et mes messages systèmes en anglais.

Hors ligne

#4 02-01-2011 14:17:23

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Problème de language.

Il a dit quoi localepurge?

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#5 02-01-2011 16:19:45

andson
Membre
Inscription : 02-01-2011

Re : Problème de language.

Désolé pour le retard.

andson@p5kc ~ $ sudo localepurge
[sudo] password for andson:
localepurge: Disk space freed in /usr/share/locale: 0 KiB
localepurge: Disk space freed in /usr/share/man: 0 KiB
localepurge: Disk space freed in /usr/share/gnome/help: 0 KiB
localepurge: Disk space freed in /usr/share/omf: 0 KiB

Total disk space freed by localepurge: 0 KiB


Par contre si ensuite je fais

sudo dpkg-reconfigure locales


les locales qui étaient installées sont toujours cochées.

andson@p5kc ~ $ sudo dpkg-reconfigure locales
[sudo] password for andson:
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.


Après localpurge j'ai reinstallé un seul paquet mais cela ne change rien.

andson@p5kc ~ $ sudo dpkg-reconfigure locales
[sudo] password for andson:
Generating locales (this might take a while)...
  fr_FR.UTF-8... done
Generation complete.


Un autre truc bizarre, Open Office, VLC et 2ManDVD sont entièrement en hébreu (ou quelque chose de ressemblant) alors qu'il n'y a aucun pâquets d'installés installé. (si je me fie à synaptic bien sur ..)

Hors ligne

#6 02-01-2011 17:26:36

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Problème de language.

Pour open-office il y a le paquet francophone openoffice.org-l10n-fr

Normalement localepurge aurait du virer tout les autres languages
Chez moi ( Debian Sid):

clem@Sid:~$ locale -a
C
français
french
fr_FR
fr_FR@euro
fr_FR.iso88591
fr_FR.iso885915@euro
fr_FR.utf8
POSIX

Dernière modification par Clem (02-01-2011 17:26:45)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#7 02-01-2011 17:40:54

andson
Membre
Inscription : 02-01-2011

Re : Problème de language.

Justement le paquet openoffice.org-l10n-fr est installé. Se sont d'ailleurs les seuls paquets languages que je vois avec synaptic, les paquets dédiés à des logiciels bien spécifiques, autrement je ne vois rien.

locale -a me donne :
C
fr_FR.utf8
POSIX

Les seuls paquets que je peux rajouter à l'aide de dkpg-reconfigure sont:
fr_FR.iso88591
fr_FR.iso885915@euro
pour "français - french - fr_FR - fr_FR@euro" je ne vois pas d'option à cocher.

Hors ligne

#8 03-01-2011 04:26:46

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Problème de language.

Yep!

Que donne locale tout court :

~$ locale
LANG=fr_FR@euro
LANGUAGE=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=fr_FR.UTF-8


Chez moi, je force les locales dans le fichier /etc/environment :

LANG=fr_FR.UTF-8
LANGUAGE=fr_FR.UTF-8
LC_ALL=fr_FR.UTF-8


Elles sont ainsi appliquées à tous les utilisateurs, root compris. Car j'avais des polices dégueulasses avec midnight commander (mc) en su.

J'utilise ceci depuis Lenny et n'ai pas trouvé une autre solution viable.

Il est aussi possible de forcer l'environement dans le fichier ~/.xsession, malgrés la recommandation de ne pas y toucher mais je n'ai jamais approfondie ce terrain.

Donc pour résumer :
  - En root : tu as les commandes dpkg-reconfigure locales et locale-gen
                   Le fichier /etc/environment
                   Un redemarrage peut être necessaire.
  - En user : tu as la commande set-language-env ou tu peux taper directement dans
                   une console, LANG=fr_FR.UTF-8 (le temps de la session)
                   Le fichier ~/.xsession

A tester tongue

Un autre truc bizarre, Open Office, VLC et 2ManDVD sont entièrement en hébreu (ou quelque chose de ressemblant) alors qu'il n'y a aucun pâquets d'installés installé


Peut-être un problème de police également...

@+

Zoroastre.

Dernière modification par zoroastre74 (03-01-2011 05:00:29)

Hors ligne

#9 03-01-2011 08:50:03

andson
Membre
Inscription : 02-01-2011

Re : Problème de language.

Bonjour,

MLerci de t'être penché sur mon problème. J'ai fini par faire une réinstall. Suite à l'installation de KDE que j'ai fini par enlever apt-get autoremove m'a signaler tout une liste de fichiers à supprimer, et je me demande si mon problème ne venait pas de la. Donc dans le doute...
Par contre a piste de la police je la retiens pour le cas ou ...:rolleyes:

Bonne journée

Hors ligne

Pied de page des forums