Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-01-2011 17:52:48

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

ATTENTION: Ce fil a été scindé en deux fils de discussion, pour clarifier la situation.

Bonjour,

A part le bug de VLC qui n'inhibe pas l'économiseur d'écran sous gnome, l'autre grand problème se situe avec les webcams et cheese.

Je dispose de deux webcams qui fonctionnent très mal voir pas du tout sur Debian Squeeze. J'ai déjà fais un rapport de bug mais je n'ai eu aucune réponse.
Les deux webcams sont:
- Philips (or NXP) SPC 900NC PC Camera / ORITE CCD Webcam(PC370R)
"0471:0329".
- Logitech, Inc. QuickCam Fusion "046d:08c1"

Ce fil concerne la première: Phillips SPC 900NC.

Elle fonctionne nativement sous Linux, Skype et VLC peuvent parfaitement la reconnaître. En revanche, Cheese, n'est pas capable d'en afficher l'image. Il plante les 3/4 du temps avec un "erreur de segmentation" ou affiche une image verte et entrelacée sur la 900NC. Le comportement est très aléatoire.

Cheese est un logiciel familial et très convivial pour les débutants, j'aimerais vraiment que mes webcams apprécient le fromage big_smile !
Comment corriger une telle inconstance ? Vers où dois-je orienter mes recherches ?

Les deux PCs utilisant ces webcams tournent sur Debian Squeeze et fonctionnent "out-of-the-box".

Merci,
H.

EDIT: J'ai remarqué en essayant de compiler Cheese 2.32 qu'ils suggèraient de tester si la webcam marche en tapant "gstreamer-properties", qui donne exactement les mêmes symptomes d'image qu'avec Cheese.

EDIT: Voici deux captures d'écran de cheese en action avec la 900NC, en 640x480 et 320x240:
[img align=C]http://dl.dropbox.com/u/369241/spc900-320240.png[/img]
[img align=C]http://dl.dropbox.com/u/369241/spc900-640480.png[/img]

Dernière modification par dbkblk (01-06-2011 12:04:55)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#2 04-01-2011 18:36:28

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Bonjour dbkblk,

Si tu pouvais mettre à jour les indications concernant ta distri et ton matériel, cela simplifierait tes communications :

Ouvrir sur le bandeau d'accueil : Profil  --> Infodistri


Je ne peux personnellement pas te répondre sur cheese. roll

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 04-01-2011 18:42:20

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

'Lut,

Je serais moi aussi incapable de t'aider puisque chez moi cheese marche trés bien en Sid et en Squeeze ... mais ...
J'incriminerait plutôt les pilotes de la webcam : certains sont proprios semblerait-il ...
@+

Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#4 04-01-2011 21:01:28

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Oublions Cheese, le problème semble plutôt provenir de gstreamer, qui est exploité par cheese. En tapant "gstreamer-properties", j'ai exactement les mêmes symptômes d'image verte.

En cherchant, j'ai abouti à ça:
dbkblk@h-debianmint-fixe ~/Bureau/pwc-v4l2-20090629-042701 $ dmesg | grep pwc
[   20.074062] pwc: Philips webcam module version 10.0.13 loaded.
[   20.074064] pwc: Supports Philips PCA645/646, PCVC675/680/690, PCVC720[40]/730/740/750 & PCVC830/840.
[   20.074065] pwc: Also supports the Askey VC010, various Logitech Quickcams, Samsung MPC-C10 and MPC-C30,
[   20.074067] pwc: the Creative WebCam 5 & Pro Ex, SOTEC Afina Eye and Visionite VCS-UC300 and VCS-UM100.
[   20.074090] pwc: Philips SPC 900NC USB webcam detected.
[   20.098273] pwc: Registered as /dev/video0.
[ 2842.541186] pwc: Philips SPC 900NC USB webcam detected.
[ 2842.939303] pwc: Registered as /dev/video0.

Est-ce normal que la webcam soit enregistrée deux fois ?

Dernière modification par dbkblk (04-01-2011 21:24:57)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#5 04-01-2011 22:57:07

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Bonsoir,

Vu le temps écoulé, les deux enregistrements sont séparés d'environ 45mn (2822 s). Ça laisse penser à une déconnexion, mais je ne saurais pas en déterminer la cause.

En tout cas, sur ce coup le problème ne se situe pas entre la cheese et le webcam. wink

@+

Hors ligne

#6 05-01-2011 14:14:40

Asmodée
Membre
Lieu : /dev/null
Distrib. : Squeeze
Inscription : 16-05-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Deux choses, 1) pwc n'est plus maintenu à ma connaissance 2) as-tu "paramétré" ta webcam ?

Pour le premier point, je n'ai pas de webcam Philips, donc je ne peux pas te dire si d'autres pilotes sont actuellement incorporés au noyau. Seule certitude, aptitude ne me renvoie rien sur un "philips webcam".

Pour le second, il existe setpwc qui te permet de configurer les pilotes de ta webcam. Il est possible que cela suffise.

Hors ligne

#7 05-01-2011 20:32:45

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Merci Asmodée pour ta réponse.
Il se trouve que j'ai déjà essayé de manipuler setpwc et cela n'a rien changé au problème de bandes vertes.
J'ai également remarqué que pwc n'était plus maintenu, mais ce qui est étrange, c'est ça fait 3 à 4 ans que j'utilise Ubuntu, et ma webcam marchait correctement, d'ailleurs, VLC affiche correctement l'image. C'est étrange qu'avec les nouvelles versions de gstreamer, ma webcam ne marche plus.

Pour tout vous dire, la webcam de mon portable ne marche pas bien du tout non plus, elle démarre et s'arrête sans cesse. Parfois elle n'affiche rien. Sa réference est: 174f:5a35 Syntek Sonix 1.3MPixel USB 2.0 Camera (pilote uvc je suppose ?)
Depuis que je suis sous Debian, la seule webcam que j'ai vu marcher correctement, c'est celle de ma conjointe.

Dernière modification par dbkblk (05-01-2011 20:35:46)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#8 05-01-2011 21:08:13

Asmodée
Membre
Lieu : /dev/null
Distrib. : Squeeze
Inscription : 16-05-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Ah... Bon, dans ce cas, c'est peut-être une histoire de codecs... Essaie d'installer les paquets de type gstreamer-[quelque chose] dans synaptic... Avec un peu de chance...

Ajouter les dépôts de Debian multimedia n'est peut-être pas mal non plus...

Hors ligne

#9 11-01-2011 13:06:16

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Merci Asmodée.
Je n'ai pas trouvé de greffons gstreamer qui perturbe l'affichage de cette webcam. J'ai testé avec un livecd de Ubuntu 10.10 et la webcam marche parfaitement bien. Je sais donc que ça peut être corrigé, mais comment obtenir des infos là dessus ? Quels logs je dois lire ? Je sais qu'il y a un message d'erreur avec uvcvideo au démarrage qui renvoie une valeur -100 (c'est vague.. mais je ne sais pas où le lire dans un log). De toutes façons je ne pourrais pas apporter davantage d'informations avant samedi.

Aussi, la webcam de mon PC portable marche étonnamment bien depuis deux jours, je ne sais plus quoi en penser.

Dernière modification par dbkblk (11-01-2011 13:06:50)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#10 31-05-2011 22:16:04

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : Debian Squeeze et la webcam Phillips SPC 900NC (driver pwc) !

Par hasard, j'ai avancé dans mon problème pour ma webcam Phillips SPC900NC (driver "pwc"). L'utilisation de VLC ou Skype fonctionne bien mais gstreamer est récalcitrant.

En utilisant "gstreamer-properties", dans les paramètres vidéos, le test ne fonctionne pas avec "v4l2src device="/dev/video0"" (l'argument par défaut), car l'image est toujours verte. Lorsque j'utilise ces paramètres "v4l2src device="/dev/video0" ! videoscale", l'image s'affiche correctement.

Cependant, je n'arrive pas à dire à gstreamer d'utiliser le paramètre "! videoscale" par défaut en ouvrant /dev/video0, car tout se réinitialise tout seul à chaque fois ! Vous savez faire ça ?

Dernière modification par dbkblk (01-06-2011 12:05:36)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

Pied de page des forums