Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-01-2011 18:04:36

werewolf
Membre
Inscription : 04-03-2008

[RESOLU]serveur web, je suis bloquer en local :s

Bonjour tout le monde et je profite de ce message pour vous souhaiter à toutes et tous une très bonne année 2011,

Je viens vers vous car je tombe sur un problème d'accès à mon serveur web depuis internet, je m'explique.

Tout d'abord, je suis sous debian 5 squeeze, j'ai installer apache2/php/mysql/ftp
J'ai récupérer mon ip public qui est pour l'exemple "125.32.56.138" (elle est fausse celle-ci biensur)

J'administre mon serveur via ssh (aucune interface graphique ni périphérique d'entré tel que clavier,souris...) depuis mon portable. Tout deux connecter via belgacom et ca bbox

depuis mon portable aucun souci j'accède au site "http://125.32.56.138/~test1" (normale on est sur le même réseau et la bbox reconnait mon ip public et donc reste dans un domaine locale, du moins je suppose, dite le moi si je me trompe)

par contre depuis mon téléphone portable (qui possède la navigation web), impossible d'accéder à mon site 'Temps d'attente dépasser'

J'en déduit donc que mon serveur est dans un boucle local seulement

Direction la config de la bbox, j'ajoute une redirection de port (NAT)
port 80 vers 192.168.1.8 et sont ports 80 ( ip local du serveur ), coche la case enabled pour l'activer
un petit redémarrage du rooter pour être sûr qu'il prend en charge les modifications

Résultat pareil toujours bloqué dans le local

Du coup je me dit qu'il faut peut-être modifier la directive Listen dans le fichier ports.conf de apache 2, et pour ma part il me semble correct et ne restreint par l'accès à 127.0.0.1
Voici le fichier en question

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
</IfModule>

<IfModule mod_gnutls.c>
    Listen 443
</IfModule>


pour ma part il me semble correct, dès lors je ne voi pas d'où pourrait venir le problème, et vous demande votre aimable aide

D'avance je vous remerci de m'aider à résoudre ce problème
Cordialement

Dernière modification par werewolf (04-01-2011 19:16:06)

Hors ligne

#2 04-01-2011 19:15:36

werewolf
Membre
Inscription : 04-03-2008

Re : [RESOLU]serveur web, je suis bloquer en local :s

Problème résolu, me suis dit "puisque le router est bien configurer, les virtualhost aussi, la configuration apache aussi et bien c'est le FAI le problème", direction le site du FAI espace client et cherche dans la jungle les options internet, et là surprise même si les port routeur sont bien configurer ils sont bloqué automatiquement, suivit d'un petit bouton "Débloqué" et là miracle tout fonctionne.

Évidement c'était tout bête mais bon va savoir que les ports reste bloqué même si tu les NAT...

Désolé donc du post inutile

Hors ligne

#3 04-01-2011 20:25:53

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]serveur web, je suis bloquer en local :s

Pas inutile werwolf !
wink
Merci du retour.

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums