Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 13-01-2011 02:49:02

Akumu
Membre
Inscription : 13-01-2011

[Résolu] Son sur internet

Bonjour à tous,

tout nouveau linuxien, j'ai décidé il y a quelques jours de franchir le pas et de tester une distribution un peu moins user-friendly (jusque là sous Ubuntu 10.10, sans absolument aucun problème, j'ai l'impression de ne pas mettre suffisamment les mains dans le cambouis pour apprendre correctement).

J'ai donc installé Debian Squeeze : presque tout fonctionne correctement, j'ai réussi à installer le wifi...ravi.

Seulement, je rencontre un petit soucis de son sur internet. Le son fonctionne correctement (sauf .mp3, sans encore eu le temps de régler ce problème) ainsi que la vidéo (mais pas les .flv)

J'ai iceweasel, et quand je me rend sur un site type dailymotion, la vidéo fonctionne mais je n'ai pas de son. Iceweasel freeze complètement quand j'essaie de changer de page et je n'arrive plus à le fermer. Je suis obligé d'utiliser "forcer à quitter" (je ne trouve pas iceweasel dans ce que me donne top ?? j'ai parfois un firefox-bin). Tant qu'il n'est pas tué, je n'ai plus de son nul part.

Sont installés :

- Alsa-base
- Alsa-OSS
- Alsa-utils
- Linux-sound-base
- Pulseaudio
- gstreamer0.10-pulseaudio

Également, je rencontre un problème de son sur l'écran de connexion de gnome (il y a un tam-tam sous ubuntu, je ne sais pas sous debian, je ne l'ai jamais entendu, le son bloque sur la première note tant que je n'ai pas saisi mon mdp). Peut être est-ce lié ?

Je ne sais pas du tout comment m'y prendre malgré mes recherches. Je suis embrouillé parmi tous ces paquets, et je me demande si je ne m'y suis pas tout simplement mal pris dès le départ.

Si quelqu'un pourrait m'indiquer comment régler ce problème, ou au moins une piste ?

En vous remerciant pour l'aide apportée précédemment par le wiki et le forum, et d'avance pour celui-ci !

antoine@Antoine-deb:~$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Dernière modification par Akumu (17-01-2011 17:27:42)


Laptop HP DV7
Debian squeeze - Awesome WM - Bépo

Hors ligne

#2 13-01-2011 03:31:54

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : [Résolu] Son sur internet

Alors pour le son de la connexion je ne sais pas parce que ce n'est pas le truc dont j'ai une nécessité urgente, les sons système m'enquiquinent plus qu'autre chose en général.

Par contre, Debian étant plus chatouilleux que Ubuntu sur les licences non-libres, ça se passe par là :
http://debian-multimedia.org/debian-m.php

Il faut ajouter le dépôt à moins que tu ne préfère le faire par paquet. Pour la signature, installer en premier :
http://www.debian-multimedia.org/pool/m … 16_all.deb

Ça te permettra dans la foulée d'installer le flash de Adobe avec le paquet flashplugin-nonfree

Pour choisir le flash et non le gnash, en root :
[c]update-alternatives flash-mozilla.so
[/c]

Puisque tu as mis pulse-audio installe aussi les outils qui vont avec (ça commence par pa) comme pavucontrol et padevchooser

J'ai surement oublié des choses, mais c'est un bon début je pense.

« Un optimiste, explique Raymond Aubrac, n’est pas un être satisfait, content de la situation actuelle. C’est quelqu’un qui pense qu’il peut faire quelque chose qui servira. »

Hors ligne

#3 14-01-2011 10:28:24

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] Son sur internet

Comme le dit Haricophile, je te conseille de désinstaller gnash (libre) "aptitude remove gnash-common" et d'installer flash (propriétaire) "apt-get install flashplugin-nonfree" à l'aide du dépôt Debian Multimédia.

J'utilise cette méthode pour installer Pulseaudio, as-tu fais la même chose?:

$ apt-get install pulseaudio pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-module-hal gstreamer0.10-pulseaudio

puis éditer /etc/asound.conf (ou ~/.asoundrc) :

pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}


A noter que le son fonctionne très bien avec Pulseaudio, sans avoir besoin d'installer "pavucontrol" ou "padevchooser". Par contre, j'ai un soucis très étrange probablement lié à celui que tu rencontres. En effet, quand je met le son en sourdine, il n'y a plus de son (logique)... sauf sur les vidéos flash qui le conserve !! Par contre si je descend manuellement jusqu'à 0%, les vidéos flash n'ont plus de son non plus.

Je pense que c'est lié parce Flash ne réagit pas correctement avec Pulseaudio.

PS: Tiens, en cadeau, un égaliseur graphique pour PulseAudio, au cas où tu veuilles améliorer le son si tu as un portable: https://launchpad.net/~psyke83/+archive … .7_all.deb


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#4 14-01-2011 11:37:09

Akumu
Membre
Inscription : 13-01-2011

Re : [Résolu] Son sur internet

Merci pour vos réponses à tous les deux.

En effet, j'ai bien gnash d'installé. il me posait quelques problèmes sous Ubuntu, j'ai du mettre le non libre. Donc, c'est noté, même chose ici !

J'ai remarqué que le problème de son concernait également le système (ou plutôt Gnome je pense). Comme je le disais, j'ai ce soucis de son mal joué lors de l'écran de connexion. Quand je test les thèmes sonores (dans Système > Préférences > Son), j'ai exactement le même rendu étrange.

J'utilise cette méthode pour installer Pulseaudio, as-tu fais la même chose?:


Je pense les avoir installé via synaptic (ne connaissant pas les noms des paquets). Je vais tenter avec l'édition du fichier, mais pourrais-tu m'expliquer à quoi ça sert (histoire de pas éditer des trucs sans comprendre) ?

Aussi, quels rôles respectifs jouent Alsa et Pulseaudio ? La question peut paraître idiote, mais bon...

Bon, je vais suivre vos conseilles et installer le plug-in non-free. Je vous tiens au courant !

Merci encore à tous les deux !

Dernière modification par Akumu (14-01-2011 11:37:55)


Laptop HP DV7
Debian squeeze - Awesome WM - Bépo

Hors ligne

#5 15-01-2011 12:16:50

Akumu
Membre
Inscription : 13-01-2011

Re : [Résolu] Son sur internet

Bonjour,

j'ai repris les choses à zéro, mais le problème n'est pas résolu...franchement je sèche !

gnash n'est plus installé et j'ai mis le plugin flash-nonfree. Je n'ai aucun problème pour lire les vidéo en ligne...mais ça bug quand je quitte la page, et toujours pas de son.

Tant que je ne "kill" pas iceweasel, je n'ai plus de son.

Mais j'ai également un soucis avec les sons du système (les sons de gnome pour être plus précis) : je pense orienter mes recherches dans cette direction. Tout aide sera la bienvenue

dbkblk > je n'ai pas de fichier /etc/asound.conf ni ~/.asoundrc

Est-ce que ça pourrait être un problème de pilote ? tout a été fait automatiquement par l'installateur.

Merci d'avance

Dernière modification par Akumu (15-01-2011 12:18:41)


Laptop HP DV7
Debian squeeze - Awesome WM - Bépo

Hors ligne

#6 15-01-2011 14:19:36

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Résolu] Son sur internet

Au niveau pilote, je ne sais pas encore si tu as un problème. Vu que tu arrives à avoir le son, tout doit être en ordre.

En revanche, les lignes que je te demande d'écrire dans le fichier /etc/asound.conf (qu'il faut créer !) sont les lignes pour que Pulseaudio reconnaisse ton matériel audio, exploitable grâce à Alsa (prises dans le wiki de pulseaudio: http://pulseaudio.org/wiki/PerfectSetup).
Ca permettra de vraiment finir de l'installer (car il suffit pas d'installer les paquets). Il y a juste ça à faire en plus.

En fait, ALSA c'est une couche qui gère le son sous linux. Elle va directement interagir avec ta carte son pour émettre un son. En théorie, elle peut pas émettre deux sons en même temps puisque la carte son ne peut faire qu'une seule chose à la fois.

Pulseaudio, c'est une "sur-couche" qui contrôle les périphériques qu'exploite Alsa (ton micro, tes enceintes, etc...). L'avantage, c'est que ça décuple les possibilités d'exploitation parce que tu peux jouer plusieurs sons en même temps, sur plusieurs sorties, et tout est très simple à configurer. PA s'occupe de "mixer" le son quand il y en a plusieurs en même temps, donc pour toi c'est transparent.

J'espère que ça t'avancera un peu !

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#7 17-01-2011 17:33:34

Akumu
Membre
Inscription : 13-01-2011

Re : [Résolu] Son sur internet

Merci beaucoup, j'ai suivi ton conseil dbkblk et ça fonctionne.

Il suffisait donc de créer le fichier asound.conf ! J'aurai du être plus franc en lisant ton premier message !

Leçon retenue : lire la doc !! roll

Par contre, contrairement à toi, je n'ai aucun problème avec la sourdine.

Merci également pour les explications, j'y vois plus clair !

[Résolu] À bientôt

Laptop HP DV7
Debian squeeze - Awesome WM - Bépo

Hors ligne

Pied de page des forums