Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 18-11-2007 19:12:01

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

[réglé]Pbm xorg : écran décentré

Bonjour,

Je viens de me faire une netinstall de Debian Lenny afin de découvrir Gnu/Linux sans trop de pré-maché et je bute sur un (premier) problème :

J'ai installé xorg et un gnome minimal sans problème sauf que l'écran est décentré sur la gauche : le bureau est rogné à gauche et une bande noire apparaît à droite (c'était comme ça avec tous les live-cd que j'ai testé : *buntu, Fedora, Zenwalk... seule Kaella s'affichait correctement).

Après pas mal de temps passé sur la toile, j'ai fini par trouver un moyen pour y remédier en utilisant l'outil xvidtune en root :

xvidtunesr3.png

La ligne
"1152x864"     104.00 1152 1192 1312 1552  864  867  871  905 -hsync +vsync
apparait dans le terminal en cliquant sur "show" dans xvidtune après avoir appliqué les changements.

Pour que ces paramètres soient conservés et s'appliquent au prochain démarrage, il faut copier cette ligne dans /etc/X11/xorg.conf à la section "Monitor" de la manière suivante.

Avant :

Section "Monitor"
    Identifier    "Sony HMD-220"
    Option        "DPMS"
    HorizSync    30-70
    VertRefresh    50-160
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI rage 128"
    Monitor        "Sony HMD-220"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Après :

Section "Monitor"
    Identifier    "Sony HMD-220"
    Option        "DPMS"
    HorizSync    30-70
    VertRefresh    50-160
    ModeLine "1152x864"     104.00 1152 1192 1312 1552  864  867  871  905 -hsync +vsync
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI rage 128"
    Monitor        "Sony HMD-220"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection


Mon problème, c'est que ça ne change rien, le décalage est toujours là quand xorg se lance et que j'arrive sur l'écran de login, puis sur le bureau.
Je ne sais plus quoi essayer (j'ai même tenté un L minuscule dans "ModeLine").

Quelqu'un a-t-il une solution pour le newbie enthousiaste ?

_______________________________________________________
dual boot Debian Lenny / Win98SE - Duron 850 Mhz - 640 Mo RAM

Hors ligne

#2 18-11-2007 19:47:10

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [réglé]Pbm xorg : écran décentré

J'ai la même chose chez moi, mais mon écran se recalibre tout seul en appuyant sur un bouton (c'est un LCD). As-tu regardé de ce côté là ? Sinon pour moi si c'est bien centré avec le driver libre nVidia, ce sera décalé avec le driver propriétaire (et inversement). Tu as installé le driver propriétaire d'ATI ?

Dernière modification par mani (18-11-2007 20:09:30)


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#3 18-11-2007 20:08:41

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : [réglé]Pbm xorg : écran décentré

Salut mani

Je n'ai pas ce genre de bouton sur mon écran.

J'utilise le driver libre ATI (paradoxalement, le driver proprio ATI ne marche pas avec ma vieille carte).
J'ai essayé le vesa : même problème... qui se règle de toute façon très bien avec xvidtune.
Le truc, c'est que j'arrive pas à sauvegarder les paramètre dans mon xorg.conf, donc je doit refaire le réglage après chaque démarrage.

Hors ligne

#4 18-11-2007 20:09:19

mani
Road-Runnerus digestus
Lieu : Au bout du bout
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Mate
Inscription : 20-06-2007

Re : [réglé]Pbm xorg : écran décentré

Je viens de tilter sur un truc, tu appliques le ModeLine sur une résolution de 1152x864 alors que la résolution maximale définie dans ton xorg.conf est de 1280x1024. Es-tu bien en 1152x864 ? Si oui, essaye de virer "1280x1024", autrement essaye de mettre "1280x1024" dans ton ModeLine.

Et n'oublie pas : garde toujours une sauvegarde de ton xorg.conf fonctionnel dans un coin ! :smile:

Dernière modification par mani (18-11-2007 20:09:41)


« Those who dream by day are cognizant of many things which escape those who dream only by night. »
- Edgar Allan Poe

Hors ligne

#5 18-11-2007 22:43:59

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [réglé]Pbm xorg : écran décentré

Salut,

xorg a aussi un outil pour créer un modeline, en ligne de commandes pour par exemple une résolution de
1280x1024 en 75 Hz.

tu saisis :
gtf 1280 1024 75
ce qui donne:

[neos ~]> gtf 1280 1024 75

  # 1280x1024 @ 75.00 Hz (GTF) hsync: 80.17 kHz; pclk: 138.54 MHz
  Modeline "1280x1024_75.00"  138.54  1280 1368 1504 1728  1024 1025 1028 1069  -HSync +Vsync

[neos ~]>


tu mets donc cette ligne dans ton xorg.conf puis tu modifies comme ceci pour forcer la résolution

Section "Monitor"
    Identifier    "Sony HMD-220"
    Option        "DPMS"
    HorizSync    30-70
    VertRefresh    50-160
    Modeline "1280x1024_75.00"  138.54  1280 1368 1504 1728  1024 1025 1028 1069  -HSync +Vsync
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "ATI rage 128"
    Monitor        "Sony HMD-220"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1280x1024_75.00"
    EndSubSection
EndSection

Hors ligne

#6 18-11-2007 23:43:07

pirlouit
Membre
Distrib. : sid
Noyau : 2.6.35.10-amd64-perso
(G)UI : gnome
Inscription : 18-11-2007

Re : [réglé]Pbm xorg : écran décentré

Merci pour l'info, neos.

@ mani : oui, je suis bien en 1152x864 et j'avais déjà essayé de virer "1280x1024" sans résultat.

J'ai résolu mon problème : j'ai tout bêtement utilisé le menu du moniteur Sony pour centrer l'image !!
Je pensais qu'en faisant ça, ce serait mon Windows qui serait décalé dans l'autre sens quand j'y retournerais... eh bé nan.
Et en revenant sur nunux, pas de problème, il s'est souvenu de la config.

Je me suis bien compliqué la vie et je ne sais toujours pas pourquoi mon modeline dans xorg.conf n'a pas été pris en compte.
Mais bon, ça m'a quand même permis d'apprendre des trucs au passage... c'est quand même le but.

Merci de vous être penchés sur le problème en tout cas smile

Hors ligne

Pied de page des forums