Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-02-2011 20:59:18

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

Mise à jour de xorg-server qui a échoué.

Bonsoir à tous,
J'ai procédé à une mise à jour de ma debian Sid aujourd'hui, et il y a un gros bug.
A l'invite de la commande startx, j'ai eu le message d'erreur suivant :

exec : 3 : /usr/bin/X : not found


Pour pouvoir poster sur ce forum, j'utilise un cd d'installation de Gentoo.
Il semblerait que xorg-server ne soit plus installé !
J'ai donc fait ceci :

aptitude install xserver-xorg
The following NEW packages will be installed:
  xserver-xorg xserver-xorg-core{ab} xserver-xorg-input-all{a}
  xserver-xorg-input-evdev{ab} xserver-xorg-input-synaptics{ab}
  xserver-xorg-input-wacom{a} xserver-xorg-video-all{a}
  xserver-xorg-video-apm{ab} xserver-xorg-video-ark{ab}
  xserver-xorg-video-ati{ab} xserver-xorg-video-chips{ab}
  xserver-xorg-video-cirrus{ab} xserver-xorg-video-fbdev{ab}
  xserver-xorg-video-i128{ab} xserver-xorg-video-intel{ab}
  xserver-xorg-video-mach64{ab} xserver-xorg-video-mga{ab}
  xserver-xorg-video-neomagic{ab} xserver-xorg-video-nouveau{ab}
  xserver-xorg-video-openchrome{ab} xserver-xorg-video-r128{ab}
  xserver-xorg-video-radeon{ab} xserver-xorg-video-rendition{ab}
  xserver-xorg-video-s3{ab} xserver-xorg-video-s3virge{ab}
  xserver-xorg-video-savage{ab} xserver-xorg-video-siliconmotion{ab}
  xserver-xorg-video-sis{ab} xserver-xorg-video-sisusb{ab}
  xserver-xorg-video-tdfx{ab} xserver-xorg-video-trident{ab}
  xserver-xorg-video-tseng{ab} xserver-xorg-video-vesa{ab}
  xserver-xorg-video-vmware{ab} xserver-xorg-video-voodoo{ab}
0 packages upgraded, 35 newly installed, 0 to remove and 0 not upgraded.
Need to get 5829 kB of archives. After unpacking 14.3 MB will be used.
The following packages have unmet dependencies:
  xserver-xorg-video-apm: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-ark: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-ati: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-openchrome: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-s3virge: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-mga: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-chips: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-core: Breaks: xserver-xorg-input-7 which is a virtual package.
                     Breaks: xserver-xorg-video-6 which is a virtual package.
  xserver-xorg-video-mach64: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-trident: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-sis: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-siliconmotion: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-savage: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-tdfx: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-intel: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-vmware: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-r128: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-input-evdev: Depends: xorg-input-abi-7.0 which is a virtual package.
  xserver-xorg-video-vesa: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-s3: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-voodoo: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-fbdev: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-nouveau: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-neomagic: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-sisusb: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-tseng: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-radeon: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-cirrus: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-input-synaptics: Depends: xorg-input-abi-7.0 which is a virtual package.
  xserver-xorg-video-rendition: Depends: xorg-video-abi-6.0 which is a virtual package.
  xserver-xorg-video-i128: Depends: xorg-video-abi-6.0 which is a virtual package.
The following actions will resolve these dependencies:

      Keep the following packages at their current version:
1)      xserver-xorg [Not Installed]                      
2)      xserver-xorg-core [Not Installed]                  
3)      xserver-xorg-input-all [Not Installed]            
4)      xserver-xorg-input-evdev [Not Installed]          
5)      xserver-xorg-input-synaptics [Not Installed]      
6)      xserver-xorg-input-wacom [Not Installed]          
7)      xserver-xorg-video-all [Not Installed]            
8)      xserver-xorg-video-apm [Not Installed]            
9)      xserver-xorg-video-ark [Not Installed]            
10)     xserver-xorg-video-ati [Not Installed]            
11)     xserver-xorg-video-chips [Not Installed]          
12)     xserver-xorg-video-cirrus [Not Installed]          
13)     xserver-xorg-video-fbdev [Not Installed]          
14)     xserver-xorg-video-i128 [Not Installed]            
15)     xserver-xorg-video-intel [Not Installed]          
16)     xserver-xorg-video-mach64 [Not Installed]          
17)     xserver-xorg-video-mga [Not Installed]            
18)     xserver-xorg-video-neomagic [Not Installed]        
19)     xserver-xorg-video-nouveau [Not Installed]        
20)     xserver-xorg-video-openchrome [Not Installed]      
21)     xserver-xorg-video-r128 [Not Installed]            
22)     xserver-xorg-video-radeon [Not Installed]          
23)     xserver-xorg-video-rendition [Not Installed]      
24)     xserver-xorg-video-s3 [Not Installed]              
25)     xserver-xorg-video-s3virge [Not Installed]        
26)     xserver-xorg-video-savage [Not Installed]          
27)     xserver-xorg-video-siliconmotion [Not Installed]  
28)     xserver-xorg-video-sis [Not Installed]            
29)     xserver-xorg-video-sisusb [Not Installed]          
30)     xserver-xorg-video-tdfx [Not Installed]            
31)     xserver-xorg-video-trident [Not Installed]        
32)     xserver-xorg-video-tseng [Not Installed]          
33)     xserver-xorg-video-vesa [Not Installed]            
34)     xserver-xorg-video-vmware [Not Installed]          
35)     xserver-xorg-video-voodoo [Not Installed]          



Accept this solution? [Y/n/q/?]


J'ai également essayé de rétrograder, mais rien n'y fait !
Je précise que j'ai installé les drivers fglrx.
Merci.

Hors ligne

#2 07-02-2011 22:46:41

eol
Membre
Inscription : 03-09-2009

Re : Mise à jour de xorg-server qui a échoué.

Comment as-tu fais ta mise à jour ?
Chez moi, l'apt-get update apt-get upgrade quotidien m'ont mis quelques paquets à jour mais m'ont spécifiés que xserver-xorg serait conservé à sa version actuelle, dans la famille, seul xserver-common a été mis à jour et donc pas de bug.

Tu as forcé la mise à jour ?

Hors ligne

#3 07-02-2011 22:49:33

Clem
Membre
Lieu : Au coin du bois
Distrib. : Stable && Sid
Noyau : 3.16-2 & 3.17-1 *-amd-64
(G)UI : XMonad & Mate(?)
Inscription : 09-03-2010

Re : Mise à jour de xorg-server qui a échoué.

Et avec:

aptitude install xserver-xorg-video-radeon


Ps: J'ai évité l'upgrade de X car un soucis de dépendances des différent composants de X m'ont rendus méfiants.

Les paquets suivants ont des dépendances non satisfaites :
  xserver-xorg-core: Casse: xserver-xorg-input-7 qui est un paquet virtuel
                     Casse: xserver-xorg-video-6 qui est un paquet virtuel
  xserver-xorg-input-evdev: Dépend: xorg-input-abi-7.0 qui est un paquet virtuel
  xserver-xorg-video-vesa: Dépend: xorg-video-abi-6.0 qui est un paquet virtuel
  xserver-xorg-input-synaptics: Dépend: xorg-input-abi-7.0 qui est un paquet virtuel
  nvidia-glx: Dépend: xorg-video-abi-6.0 qui est un paquet virtuel ou
                       xserver-xorg-core (< 2:1.7.7) mais 2:1.9.4-1 doit être installé.


Le paquet "fautif" est xserver-xorg-core

Quand on dit qu'il ne faut pas se précipiter sur les màj après une release neutral

PS: La correction ne manquera pas d'arriver à mon avis.

EDIT=

eol a écrit :

Tu as forcé la mise à jour ?


+1 ?

Dernière modification par Clem (07-02-2011 22:52:06)


Moi, je suis PC (x86_64) et formater windows, c'était MON idée
Le sommeil de la raison ...

Hors ligne

#4 07-02-2011 22:51:22

eol
Membre
Inscription : 03-09-2009

Re : Mise à jour de xorg-server qui a échoué.

Et si tu essayes

# apt-get -s install xorg-video-abi-6.0 xorg-input-abi-7.0


Que t'est-il proposé ?

Hors ligne

#5 07-02-2011 23:06:04

Aragorn
Membre
Distrib. : Sid
Noyau : 2.6.32-5-amd64
(G)UI : Openbox
Inscription : 12-07-2010

Re : Mise à jour de xorg-server qui a échoué.

Bonsoir,
Oui, j'ai forçé la mise à jour avec un :

aptitude full-upgrade


sans avoir vérifié les paquets qui allaient être mis à jour !

root@sysresccd /root % mkdir /mnt/debian
root@sysresccd /root % mount /dev/sda5 /mnt/debian
root@sysresccd /root % mount /dev/sda1 /mnt/debian/boot
root@sysresccd /root % mount --bind /dev /mnt/debian/dev
root@sysresccd /root % chroot /mnt/debian /bin/bash
root@sysresccd:/# aptitude install xserver-xorg-video-radeon
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
perl: warning: Setting locale failed.    
perl: warning: Please check that your locale settings:
  LANGUAGE = (unset),
  LC_ALL = (unset),
  LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
                                         
root@sysresccd:/# apt-get -s install xorg-video-abi-6.0 xorg-input-abi-7.0
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Note, selecting 'xserver-xorg-core' instead of 'xorg-video-abi-6.0'
Note, selecting 'xserver-xorg-core' instead of 'xorg-input-abi-7.0'
xserver-xorg-core is already the newest version.
xserver-xorg-core set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@sysresccd:/#

Hors ligne

#6 07-02-2011 23:39:38

eol
Membre
Inscription : 03-09-2009

Re : Mise à jour de xorg-server qui a échoué.

Étant d'un naturel feignant, je n'utilise jamais le full-upgrade. wink
Ça m'évite de faire des réparations.

Sinon, pour être un peu plus constructif, je te dirais bien que si tu ne purges pas automatiquement le cache de ton gestionnaire de paquets, le répertoire /var/cache/apt/archives/
contient encore les versions de tous les paquets dont tu as besoin ( à réinstaller manuellement avec "dpkg -i nom_paquet.deb" ) pour réparer ton système.

Il existe peut-être une solution plus simple et plus rapide mais je ne la vois pas pour l'instant.

Bon courage. wink

Hors ligne

Pied de page des forums