Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 09-02-2011 20:47:39

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

[Résolu] Configuration manuelle de la connection internet

Bonjour a tous,

Voilà comme le titre l'indique je suis en train de configurer ma connections Internet en Manuelle sans passer par le serveur DHCP , d'après le document Formation Debian ( très bien d'ailleurs).

voici ce que me renvoie ifconfig :

eth0      Link encap:Ethernet  HWaddr **:**:**:**:**:**
          inet adr:192.168.1.30  Bcast:192.168.1.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2728 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2616 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:2560642 (2.4 MiB)  TX bytes:314854 (307.4 KiB)
          Interruption:28 Adresse de base:0xc000

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:504 errors:0 dropped:0 overruns:0 frame:0
          TX packets:504 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:39840 (38.9 KiB)  TX bytes:39840 (38.9 KiB)


J'ai supprimer l'adresse Ipv6 dans la config eth0 mais dans lo elle apparait toujours , est-ce possible de la supprimer ou pas ?

voici mon /etc/network/interfaces :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
#auto lo
#iface lo inet loopback

auto lo
allow-hotplug eth0

iface lo inet loopback

iface eth0 inet static
   address 192.168.1.30
   netmask 255.255.255.0
   getway  192.168.1.1
   dns-nameservers 208.67.222.222 208.67.220.220

# The primary network interface
#allow-hotplug eth0
#iface eth0 inet dhcp


J'ai désactivé les lignes d'origines et j'ai rajouté mon propre config mais j'ai un doute sur le dns-nameservers , faut il les séparer par une virgule ou les mettre sur 2 lignes ou autre ?

Merci pour vos réponses  wink

Dernière modification par zaphir (11-02-2011 01:53:10)

Hors ligne

#2 09-02-2011 20:51:08

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : [Résolu] Configuration manuelle de la connection internet

Salut,

ce que tu as desactivé c est la mac-address et non l'ipv6, pour les dns , je te conseille de les mettres dans /etc/resolv.conf

avec la syntaxe suivante :

nameserver 208.67.222.222
nameserver 208.67.220.220


\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#3 09-02-2011 21:02:18

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Configuration manuelle de la connection internet

Et pour désactiver l'ipv6, c'est ce tuto :
http://debian-facile.org/doc:reseau:ipv6

Comme quoi que la vie est bien faite tout de même !

Tchibâââ ! lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#4 09-02-2011 21:08:31

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Résolu] Configuration manuelle de la connection internet

Bonjour Mattux,

e que tu as desactivé c est la mac-address et non l'ipv6


non en fait j'ai volontairement mis des asteris pour l'address MAC
Voici ce que j'ai fais pour desactiver l'ipv6 ,en fait je l'ai supprimé( selon la doc. )  :

ifconfig eth0 del fe80::221:85ff:fe08:232f/64


je te conseille de les mettres dans /etc/resolv.conf


Oui cela je l'ai fais dejà ,mais il est conseillé de les inscrire dans le fichiers /etc/network/interfaces pour une configuration permanente ( toujours selon la donc )
Ou alors cela suffit de le ajouter dans /etc/resolv.conf ?

Hors ligne

#5 09-02-2011 21:50:09

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration manuelle de la connection internet

Bonsoir,

Si ça n'a pas changé entretemps (et sans présumer du parasitage par un programme de config automatique du réseau genre wicd ou network-manager), soit tu mets tes DNS dans le resolv.conf, soit tu installes le paquet resolvconf et tu déclares les dns avec une ligne "dns-nameserver une.i.p.v4" dans le fichier interfaces.

Pour désactiver ipv6, sous Lenny j'ai ajouté le module ipv6 au /etc/modprobe.d/blacklist.
Je ne sais pas si c'est la pratique orthodoxe, mais c'est efficace. smile

@+ smile

Hors ligne

#6 10-02-2011 00:17:58

Invité-5
Banni(e)

Re : [Résolu] Configuration manuelle de la connection internet

Salut,

Comme vous savez probablement a partir du noyau 2.6.30 l'IPv6 n'est plus compilé en module mais en dur.
Donc le fait de blacklister ipv6 ne suffit plus sous Squeeze avec le noyau 2.6.32. Il faut suivre la procédure du wiki => Vous devez rajouter ipv6.disable=1 dans le fichier /etc/default/grub dans l'option GRUB_CMDLINE_LINUX.

Exemple, si vous avez :

GRUB_CMDLINE_LINUX=""

Vous devz modifier la ligne en :

GRUB_CMDLINE_LINUX="ipv6.disable=1"

Mettre à jour le grub par la commande root :

# update-grub2

et au reboot, IPV6 est bien désactivé.

Il ne doit plus y avoir de répertoire /fichiers dans

 $ cat /proc/sys/net/ipv6


@

Dernière modification par arien (05-04-2011 10:33:45)

#7 10-02-2011 02:33:36

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Résolu] Configuration manuelle de la connection internet

De retour après une très grosse pause  smile

@arien  @tux12  @smolski

j'ai utiliser le tuto pour désactiver l'ipv6 ( merci smolsky) . En revanche le fichier blacklist n'existait pas ou bien il était vide j'ai donc ajouter la ligne concernée .( a moins qu'il ne s'agisse du fichier blacklist.conf ?? )
Enfin lorsque je fais un ifconfig la ligne de ipv6 n’apparaît pas ,par déduction je me dis que cela fonctionne .

Une chose que je n'avais pas compris avant de commencer ma manip c'est qu'apparemment il faut executer la commande suivante a chaque demarrage du pc pour se connecter au net sinon pas de net :
route add default gw 192.168.1.1 dev eth0

N'existe-il pas une solution a cela ? Ou bien ce n'est pas grave je ferais avec .

EDIT : GROSSE BOULETTE je viens d'effacer par erreur le fichier /etc/modprobe.d/blacklist.conf en voulant l'éditer .
Bon je vais chercher s'il est possible de le recuperer quelquepart mais bon le l'ai affacé avec un rm en plus Aie !!

Dernière modification par zaphir (10-02-2011 02:47:24)

Hors ligne

#8 10-02-2011 06:23:30

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Configuration manuelle de la connection internet

Merci de cette précision arien, je l'ajoute au wiki df tout de suite.
La solution est bien indiquée dans le wiki mais je vais la mettre plus en avant !
Là :
http://debian-facile.org/doc:reseau:ipv … avec_grub2

Et là le TP proprement dit :
http://debian-facile.org/doc:systeme:no … rimer_ipv6

Hop hop hop ! big_smile

zapyr, peux-tu nous indiquer dans l'infodistri de ton Profil ta configuration ?
Voir là :
http://debian-facile.org/atelier:indications-forum

lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#9 10-02-2011 11:35:00

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Résolu] Configuration manuelle de la connection internet

@smolsky

Mise a jour du profil=> ok

EDIT:
Essaie de récupération du fichier /etc/modprobe.d/blacklist.conf avec le logiciel Photorec n'a rien donné , le fichier était détérioré donc le contenu était vide .
Existe-il un moyen de récupérer ce fichier quelque part ou suis je condamné a une réinstallation ?

Comme je suis en Hors sujet j'ai ouvert un autre topic http://debian-facile.org/forum/viewtopic.php?id=3492 en rapport avec la récupération du fichier /etc/modprobe.d/blacklist.conf , il me semble que cela est plus correct .

Dernière modification par zaphir (10-02-2011 19:06:26)

Hors ligne

#10 10-02-2011 21:39:55

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration manuelle de la connection internet

Bonsoir,

zaphir a écrit :

il faut executer la commande suivante a chaque demarrage du pc pour se connecter au net sinon pas de net :
route add default gw 192.168.1.1 dev eth0


Il doit suffire d'ajouter le gateway au fichier interfaces pour que ça marche.

@+

Hors ligne

#11 10-02-2011 22:50:01

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Résolu] Configuration manuelle de la connection internet

@tux12

Il est déjà écrit dedans, voir mon mess #1
Oui en principe cela doit fonctionner mais dans la pratique on dirait qu'il y a un problème a ce niveau , enfin chez moi .

Dernière modification par zaphir (10-02-2011 22:50:25)

Hors ligne

#12 11-02-2011 00:59:54

tux12
Membre
Lieu : ./
Distrib. : Squeeze
Noyau : Linux 2.6.32-5-686-bigmem
(G)UI : KDE
Inscription : 27-02-2008

Re : [Résolu] Configuration manuelle de la connection internet

Désolé, pas fais gaffe.

Remplace alors ton 'getway' actuel par 'gateway', ça devrait être mieux. wink

@+

Hors ligne

#13 11-02-2011 01:52:10

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Résolu] Configuration manuelle de la connection internet

Pas de souci tux12  wink

Ah oui , elle est belle cette faute ...  et je me suis relu plusieurs fois en plus !!
Merci pour ton coup d’œil avisé cool
Effectivement ça va même beaucoup mieux maintenant !!!!
Connexion active dès le démarrage, je crois que tout est OK je passe en Résolu .
Merci a tous .

Hors ligne

Pied de page des forums