Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-02-2011 21:32:01

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Mon disque dur externe ne se monte pas automatiquement

Bonjour !
Je viens d'installer Squeeze (version stable).
Visiblement, cette version n'utilise pas fstab pour monter automatiquement les clés usb et les disques externes. Lorsque je branche une clé, elle est montée automatiquement, sans avoir à modifier mon fstab.

Quant à mon disque externe, en ntfs, j'ai un problème. Il apparait dans le menu "raccourcis" mais ne peut pas être monté ; un message automatique me dit :

*************
Impossible de monter EXTERNE

Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sdc1': Permission denied
Failed to mount '/dev/sdc1': Permission denied
Please check '/dev/sdc1' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://ntfs-3g.org/support.html#unprivileged
*************

Bien sûr, j'ai ntfs-3g installé.

Si j'ajoute la ligne suivante dans mon fstab, j'arrive à le monter :

***
UUID=4A8CA57E8CA56563    /media/externe    ntfs-3g    defaults,user,uid=root,gid=win,umask=113,dmask=002    0    0
***

Mais...
Je me retrouve avec deux liens dans le menu "raccourcis" :
Un disque EXTERNE qui est apparu automatiquement (et qui ne peut pas être monté : apparait l'erreur : ntfs-3g-mount: failed to open /dev/fuse: Permission non accordée)
Un disque EXTERNE monté grâce au fstab

Ca marche me direz-vous, mais c'est pas élégant.

Comment faire pour que mon disque soit monté automatiquement, sans avoir à activer la ligne correspondante du fstab ? Ou alors comment empêcher le système de tenter de monter mon disque automatiquement ?

A ce sujet et pour finir, comment fait le système pour monter automatiquement les supports externes USB sans passer par le fstab ?

J'espère avoir été clair... et merci de votre aide.

A+
Joël

Hors ligne

#2 12-02-2011 22:30:44

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Mon disque dur externe ne se monte pas automatiquement

Bonjour joelpince et bienvenue sur df !

As-tu essayé de monter le disque ntfs avec la commande en root :

/dev/sdc1 mount -t ntfs-3g /media/externe


Hop ! smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 12-02-2011 22:38:34

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : Mon disque dur externe ne se monte pas automatiquement

Bonsoir !
J'ai la réponse suivante :

***
zsh : permission non accordée : /dev/sdc1
zsh : exit 126 /dev/sdc1 mount -t ntfs-3g /media/EXTERNE
***

Je retrouve une erreur comparable au montage automatique, à savoir un refus de permission...
Tu sais d'où ça peut venir ?

Merci de ton message de bienvenue ; voilà des années que je bidouille la debian mais là, je me suis lancé pour de bon dans la migration de Windows vers Debian.

A+
Joël

Hors ligne

#4 12-02-2011 22:51:58

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Mon disque dur externe ne se monte pas automatiquement

tu as permission non accordé car dans ton fstab tu as mis UID=root donc seulement lui peut avoir acces a ton disque dur, change par le nom de ton user et tu n'aura plus de soucis

MaTTuX_

\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#5 12-02-2011 23:19:42

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : Mon disque dur externe ne se monte pas automatiquement

Salut,

Si je mets mon user dans l'UID, je ne peux plus monter le disque :

***
ntfs-3g-mount: failed to open /dev/fuse: Permission non accordée
zsh: exit 21    mount /media/Externe
[21] joel@aboulafia> cd /dev/fuse                                             ~
cd: n'est pas un dossier: /dev/fuse
zsh: exit 1
***

Mais c'est quoi ce /dev/fuse ?...

Et si je passais mon disque en FAT32, ce serait pas plus simple ?... et pourquoi pas en ext3 ?...
Mais j'aimerais bien comprendre ce qui se passe...

A+
Joël

Dernière modification par joelpince (12-02-2011 23:21:24)

Hors ligne

#6 13-02-2011 14:03:50

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Mon disque dur externe ne se monte pas automatiquement

ntfs-3g est-il installé?

Hors ligne

#7 13-02-2011 14:10:59

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Mon disque dur externe ne se monte pas automatiquement

Eh ho, les cocos ! Commencez par le début wink*

système -> administration -> utilisateurs et groupes -> privilèges utilisateur  -> accéder automatiquement a des périphériques de stockage externe

en ligne de commande il faut être dans les groupes plugdev et fuse je pense.

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#8 13-02-2011 14:59:20

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : Mon disque dur externe ne se monte pas automatiquement

Bonjour à tous !

Alors, commençons par le conseil d'Haricophile. Mon user était déjà configuré dans accéder automatiquement à des périphériques de stockage externe ; il était déjà dans le groupe plugdev et je l'ai rajouté au groupe fuse.

Malheureusement, cela n'a pas réglé le problème dont je rappelle le message :

***
Impossible de monter EXTERNE
Error mounting: mount exited with exit code 1: helper failed with:
Error opening '/dev/sdc1': Permission denied
Failed to mount '/dev/sdc1': Permission denied
Please check '/dev/sdc1' and the ntfs-3g binary permissions,
and the mounting user ID. More explanation is provided at
http://ntfs-3g.org/support.html#unprivileged
***

Je rappelle qu'il s'agit ici du montage automatique par la Debian (Squeeze) ; si j'ajoute une ligne dans mon fstab, je peux monter la partition en faisant mount -a. Voici la ligne de mon fstab :

***
UUID=4A8CA57E8CA56563  /media/Externe  ntfs-3g defaults,user,uid=root,gid=win,umask=113,dmask=002      0       0
***

Le fait que l'uid soit root ne change rien, en tout cas en ce qui concerne le montage automatique. La ligne de mon fstab ne résoud pas le montage automatique, elle permet seulement le montage manuel. De plus, comble de l'inélégance, je me retrouve avec deux raccourcis dans la barre des tâches supérieure de Gnome nommés Externe parmi lesquels l'un est monté (il correspond au montage manuel) et l'autre ne l'est pas (il correspond au montage automatique foiré.

Je suis allé voir ici : http://www.tuxera.com/community/ntfs-3g … rmissions/. J'y ai trouvé des infos intéressantes, dont l'une qui suggère de monter la partition avec mount -t ntfs-3g -o inherit /dev/sdc1 /media/Externe en root. Avec cette commande, je n'ai plus qu'un raccourcis Externe dans Gnome... mais ça reste manuel.

Visiblement, il s'agit d'un problème de permission dans ntfs-3g mais je ne sais pas les gérer... Si quelqu'un a la solution... en attendant, je continue de chercher... c'est pour ça que j'adore ma Debian...

Bon dimanche,
Joël

Hors ligne

#9 16-02-2011 00:56:02

HITMANU
Membre
Lieu : Grand voyageur
Distrib. : squeeze
Noyau : 2.6.32.5-amd64
(G)UI : Xfce4.6 ATI HD4330
Inscription : 15-12-2010

Re : Mon disque dur externe ne se monte pas automatiquement

bonsoir a tous,

tu aura toujour le meme probleme avec les permissions en ntfs que ce sois pour le monter ou le démonter regulierement je peut le constater avec de nombreux disk dur externe des windosiens tu peut essayer de faire un chmod +R 777 a la racine du disk dur externe pour regler une partie de t on probleme hmm

HP ProBook 4515s, squeeze, Xfce4.6
IBM Thinkpad x31, ArchLinux, WMFS
ACER Travelmate 420, squeeze, mon SERVEUR smile

Hors ligne

#10 16-02-2011 01:17:28

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Mon disque dur externe ne se monte pas automatiquement

Yep!

Je me suis retrouvé il y a peu avec le même problème, il faut donc :

   1- Faire partir des groupes plugdev et fuse (quoique fuse pas sûr)
   2- Préparer son fstab
   3- Avoir accés au dossier du montage en question, faire un chmod 777 /media/Externe si besoin
   4- Et pour finir, en root :

chmod 4755 /usr/bin/ntfs-3g


afin que tout à chacun puisse executer la commande en tant que root (le 4 pour le fameux setuid ou suid)

La solution fonctionne correctement dans mon cas, un disque dur externe usb ntfs et je peux enfin monter et démonter tous mes périphériques dans mon gestionnaire de fichier (emelfm2). Par contre, mes dossiers de montage je les ai placé dans /mnt et  noauto dans mon fstab wink

$ id
uid=1000(philippe) gid=1000(philippe) groupes=1000(philippe),20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),105(fuse),110(netdev)


cat /etc/fstab

### disque 200 Go ###
UUID=AA843CEB843CBC1F /mnt/200  ntfs-3g rw,users,noauto,uid=1000,gid=1000,umask=022  0       0


$ ls -l /usr/bin/ntfs-3g
-rwsr-xr-x 1 root root 44116 16 mars   2010 /usr/bin/ntfs-3g


Il faut que je paufine mon fstab et me retire du groupe fuse pour essai...

@+

Zoroastre.

PS : http://www.tuxera.com/community/ntfs-3g … lugandplay
section : Why do I get “fusermount: option blkdev is privileged” error? et Why don’t the ‘user’ and ‘users’ options work in /etc/fstab?

Dernière modification par zoroastre74 (18-02-2011 19:17:02)

Hors ligne

#11 18-02-2011 19:11:07

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : Mon disque dur externe ne se monte pas automatiquement

Yep!

Je confirme qu'il est nul besoin de faire partie du groupe fuse

@+

Zoroastre.

PS :

Yep!

N'oubliez pas messieurs d'indiquer RESOLU (si c'est le cas) dans le titre du topic, svp !

@+

Zoroastre.

Dernière modification par zoroastre74 (23-02-2011 06:30:09)

Hors ligne

#12 09-03-2011 01:04:36

HITMANU
Membre
Lieu : Grand voyageur
Distrib. : squeeze
Noyau : 2.6.32.5-amd64
(G)UI : Xfce4.6 ATI HD4330
Inscription : 15-12-2010

Re : Mon disque dur externe ne se monte pas automatiquement

quelque chose me dit que tu a installer squeeze a partir d un disk externe en usb, j ai fais le test et me suis retrouver avec le même problème sad

HP ProBook 4515s, squeeze, Xfce4.6
IBM Thinkpad x31, ArchLinux, WMFS
ACER Travelmate 420, squeeze, mon SERVEUR smile

Hors ligne

Pied de page des forums