Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-02-2011 18:00:35

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Résolu : probléme de son Squeeze

Salut à tous j'ai des problèmes de son avec ma Debian Squeeze 32 bits j'ai essayé cette méthode alsactl init puis régler alsamixer mais à chaque redémarrage il faut que je refasse la manipulation.
Merci pour l'aide.

Dernière modification par unit (11-05-2011 20:46:15)


Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#2 14-02-2011 20:43:23

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Résolu : probléme de son Squeeze

J'ai aussi des problèmes de son.

Le paquet vlc-plugin-pulse est il installé ou d'autres paquets en rapport avec pulse?

Je suis un peu comme toi je cherche d'autant que c'est très aléatoire.

Souvent il suffit déteindre et de redémarrer et tout est ok.

Hors ligne

#3 14-02-2011 20:49:43

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Résolu : probléme de son Squeeze

Joel se dit alors que la migration peut attendre encore un peu...
wink

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 14-02-2011 20:57:49

Dohri
Membre
Lieu : /home/dohri/canapé
Distrib. : Sid
Noyau : 3.10.1 amd64
Inscription : 19-12-2010
Site Web

Re : Résolu : probléme de son Squeeze

unit a écrit :

Salut à tous j'ai des problèmes de son avec ma Debian Squeeze 32 bits j'ai essayé cette méthode alsactl init puis régler alsamixer mais à chaque redémarrage il faut que je refasse la manipulation.
Merci pour l'aide.


il faut "enregistrer" avec

# alsactl store


Asus Zenbook ux32vd > Sid   |   eeepc 1215 > Sid + gnome  |   eeepc 1015 > Squeeze + gnome   |   sony vaio > Squeeze CLI   |   serveur home made > debian squeeze CLI

Hors ligne

#5 14-02-2011 22:20:59

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Résolu : probléme de son Squeeze

Joël est un sage. cool

Hors ligne

#6 14-02-2011 23:06:25

unit
Adhérent(e)
Lieu : Marcq-en-baroeul
Distrib. : Jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : Xfce 4.10
Inscription : 11-03-2010

Re : Résolu : probléme de son Squeeze

Ok merci de vos réponses.

Exige beaucoup de toi-même et attends peu des autres. Ainsi beaucoup d'ennuis te seront épargnés.
Confucius.

Hors ligne

#7 16-02-2011 11:46:28

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Résolu : probléme de son Squeeze

Pour ma part, le son à l'air de ne plus poser de problèmes.

Aprés purge des paquets cassés, des paquets obsolètes et des paquets orphelins.

A suivre. hmm

Dernière modification par deuchdeb (16-02-2011 11:46:45)

Hors ligne

#8 23-02-2011 11:01:09

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Résolu : probléme de son Squeeze

En fait pour mes problèmes de son cela venait du fait que j'ai deux cartes son.

Une intégrée à la carte mère (HS).
Une que j'ai donc ajouté.

( A noté que ce problème ne s'était jamais posé avec Lenny).

Donc un coup c'était la carte hs qui était la carte par défaut, donc pas de son et un coup c'était l'autre carte qui était la carte par défaut, donc son OK.

Pour que la bonne carte soit toujours par défaut, j'ai modifié le fichier /etc/modprobe.d/alabase.conf.

J'ai suivi ce tuto et tout est OK: http://www.audiokeys.net/forum/showthre … %A9marrage

Dernière modification par deuchdeb (23-02-2011 11:02:15)

Hors ligne

#9 23-02-2011 14:01:15

Invité-5
Banni(e)

Re : Résolu : probléme de son Squeeze

Salut,

Quand vous ajoutez une nouvelle carte son la première chose a faire est désactiver la carte son intégrée à la carte mère dans le BIOS pour éviter le shmilblick. Si vous avez plusieurs cartes il faut effectivement définir l'ordre d'utilisation. Par exemple la commande ( carte son intégrée à la carte mère désactivé ) donne
$ cat /proc/asound/modules
0 snd_hda _intel  ( carte vidéo ATI )
1 snd-ctxfi           ( SB-XFi - Creative X-Fi )
2 snd_usb_audio ( USB-Audio - QuickCam Pro 9000 )
Sous Squeeze contrairement au tuto la commande
# nano /etc/modprobe.d/alsa-base.conf se présente comme ça

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2


Si vous voulez utiliser principalement SB-XFi - Creative X-Fi puis USB-Audio - QuickCam Pro 9000 il faut changer l'ordre dans /etc/modprobe.d/alsa-base.conf

install sound-slot-1 /sbin/modprobe snd-card-0
install sound-slot-2 /sbin/modprobe snd-card-1
install sound-slot-0 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3


Puis a la fin rajoutez votre config

options snd-ctxfi      index=0
options snd-usb-audio  index=1
options snd-hda-intel  index=2


Enregistrer et redémarrer

#10 23-02-2011 15:14:36

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Résolu : probléme de son Squeeze

SUPER GROS MERCI POUR CETTE EXPLICATION.

Mais où va t-il trouver tout ça? wink

Hors ligne

#11 20-03-2011 13:46:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Résolu : probléme de son Squeeze

Et même pas un [Résolu] dans le titre encore...

Allez allez, unit, c'est ton post, hop hop hop ! lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

Pied de page des forums