Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 19-02-2011 20:15:31

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

comment sortir de la mise en veille sous Squeeze ?

Bonjour,

Je viens de basculer sous Squeeze, mais j'ai un souci.
Lorsque mon pc est inactif pendant 10 mn, il se met en veille, et mon ecran est tout noir.

Sous Lenny je pouvais faire la combinaison CTRL + ALT +F1 , puis ALT+F7 , pour sortir du mode veille.
Mais sous squeeze la combinaison de touches  ne marche plus. Mon ecran reste noir, aucune touche fonctionne .

Lorsque je lance une vidéo sous Totem, au bout de 10mn le pc se met en veille, et le seul moyen de sortir est de faire un hard reset !
J'ai désactivé le service concernant ACPI, la gestion d'energie, rien n'y fait.
J'ai même mis dans Grub2  acpi=off , ca ne marche pas.
J'ai également modifié le Bios , ca ne marche pas.
Je suis allé dans  Systeme\Préférences\Economiseur d'ecran, et j'ai mis "jamais" dans "mettre l'ordinateur inactif..."

j'ai désactivé dans totem, VLC , la mise en veille pendant la lecture , ca ne marche pas.
J'ai été dans gconf-editor , "Apps\gnome-power manager \lock , et j'ai tout decoché

J'ai une carte nvidia  gforce4 mx 440 avec pilote nv18 , et  je n'ai pas de fichier xorg.conf

Je ne sais plus quoi faire ? Help ! sad

Dernière modification par xtriade (19-02-2011 20:37:39)


Hadopi = loi débile

Hors ligne

#2 19-02-2011 21:06:43

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

j'ai contourné le probleme avec gconf-editor.

Dans "/apps/gnome-power-manager/timeout/ , la valeur par défaut etait 600 , soit 10mn. J'ai mis une valeur de 86400 soit 24H.

Pourtant quand on utilise l'interface graphique de l'economiseur d'ecran  pour regler la valeur , ca ne marche pas ?!?

Hadopi = loi débile

Hors ligne

#3 20-02-2011 01:37:58

deb2deb
Membre
Distrib. : Version testing (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-2-amd64
(G)UI : GNOME 3.4.1
Inscription : 12-02-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Il me semble que ça se règle dans Système>Préférences>Gestionnaire d'énergie

Hors ligne

#4 20-02-2011 11:20:48

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

oui , c'est ce que j'ai fait.
Mais ca ne marche pas.

Totem se met en veille au bout de 10 mn

Hadopi = loi débile

Hors ligne

#5 20-02-2011 11:57:48

Invité-5
Banni(e)

Re : comment sortir de la mise en veille sous Squeeze ?

Salut,

xtriade a écrit :

J'ai une carte nvidia  gforce4 mx 440 avec pilote nv18 , et  je n'ai pas de fichier xorg.conf


Je soupçonne la mauvaise gestion d'énergie par ta carte graphique. Apparemment tu utilise le bon pilote 96xx legacy version. Essaye ( sans garantie )

 # nano /etc/X11/xorg.conf

Section   "Module"
      Load         "glx"
EndSection

Section   "Device"
      Identifier   "Video Card"
      Driver       "nvidia"
EndSection

Dernière modification par arien (20-02-2011 12:00:27)

#6 20-02-2011 12:33:29

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

j'ai pas de fichier xorg.conf sous squeeze, il faut en creer un ?

Dernière modification par xtriade (20-02-2011 12:34:51)


Hadopi = loi débile

Hors ligne

#7 20-02-2011 12:42:45

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Salut !

J'ai le même problème avec une Gforce GT 8600 M...
Je fais tout mon possible pour qu'il n'entre pas en veille car sinon, au redémarrage, c'est "hard reboot" assuré...

A+
Joël

Hors ligne

#8 20-02-2011 12:42:46

Invité-5
Banni(e)

Re : comment sortir de la mise en veille sous Squeeze ?

Justement, je te propose de créer un, pour voir si ça peut résoudre ton problème.

#9 20-02-2011 14:05:16

Invité-5
Banni(e)

Re : comment sortir de la mise en veille sous Squeeze ?

joelpince a écrit :

J'ai le même problème avec une Gforce GT 8600 M..


Tu utilise bien le driver Debian 195.36.31-6 ?
Peut-être il te faut aussi un xorg.conf si c'est pas déjà fait ?
# apt-get install nvidia-xconfig
puis toujours en root
# nvidia-xconfig
pour générer un xorg.conf

#10 20-02-2011 16:29:08

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : comment sortir de la mise en veille sous Squeeze ?

J'ai désactivé le service concernant ACPI, la gestion d'energie,

Si le but est de gérer la mise en veille, c'est pas le bon système...

Sous Lenny je pouvais faire la combinaison CTRL + ALT +F1 , puis ALT+F7 , pour sortir du mode veille.

Ça c'est déplacé, on a confié au "bureau" la gestion de tout ça. S'il veut bien le gérer.  Sinon pour déplanter plus en douceur, cf. les "magic sysreq keys"
http://en.wikipedia.org/wiki/Magic_SysRq_key
http://doc.ubuntu-fr.org/touches_magiques

Pour la nvidia je ne sais pas trop, mais il me semble qu'on peut forcer le rechargement du module à la reprise. J'irais faire un tour dans les logs. (~/.xsession-errors et /var/log/Xorg.0.log )

Dernière modification par Haricophile (20-02-2011 16:29:46)


« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#11 20-02-2011 17:23:10

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Mint et LMDE
Noyau : 2.6.38.8
(G)UI : Gnome ou KDE
Inscription : 03-01-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Bonjour,

J'avait moi même déjà eu le souci, et j'ai pu contourné ce problème en suivant un tuto trouvé sur le net, et que j'ai simplifié.

A voir si cela pourrai être concevable dans ce problème smile

@micalement
@+ Gerinald

Si vous avait un écran de veille qui se met en fonction, alors que vous avait tout désactivé, voici ce qu'il faut faire pour avoir la paix:)

Tout d'abord, ouvrez une console, et mettez vous en root, nous aurons besoin de cette console durant la quasi totalité de cet astuce.

En console, tapez xset q, regardez ensuite à la ligne : Standby: 300 Suspend: 600 Off: 600 , c'est généralement la valeur par défaut.

Si vous avait ces valeurs, alors suivez le guide:)

En console, mode root, sous Gnome, tapez gedit.

Ouvrez le fichier : sous Gnome : /etc/gdm/Init/Default, et à la fin de celui-ci, ajouter les lignes :

xset s off
xset -dpms

Cela vous donnera ceci :

$SETXKBMAP -symbols "$XKBSYMBOLS"
fi
fi
fi
fi
xset s off
xset -dpms
exit

Nous n'avons pas fini, restons en console:)

Tapez xset dpms 0 0 0

Rebooter et revenez en console, faite un xset q, vous devez avoir

DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Enabled
Monitor is On

La ligne qui nous intéresse, c'est surtout : Standby: 0 Suspend: 0 Off: 0

Cette fois, vous ne devriez plus avoir de souci.

@micalement
@+ Gerinald


Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#12 20-02-2011 20:54:05

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

salut

sans faire la manip de Gerinald , et en tapant   xset q :
j'obtiens :

DPMS (Energy Star):
Standby: 0 Suspend: 0 Off: 0
DPMS is Enabled
Monitor is On

Le probleme de la mise en veille persiste càd que l'ecran s'eteint et je ne peux pas le réveiller.

Dernière modification par xtriade (20-02-2011 20:59:40)


Hadopi = loi débile

Hors ligne

#13 20-02-2011 21:41:44

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Mint et LMDE
Noyau : 2.6.38.8
(G)UI : Gnome ou KDE
Inscription : 03-01-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Hum ..... et que te dit le fichier "/etc/gdm/Init/Default" ????

@micalement
@+ Gerinald

Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#14 21-02-2011 17:10:09

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

Voici le fichier Defaut

PATH="/usr/bin:$PATH"
OLD_IFS=$IFS

gdmwhich () {
  COMMAND="$1"
  OUTPUT=
  IFS=:
  for dir in $PATH
  do
    if test -x "$dir/$COMMAND" ; then
      if test "x$OUTPUT" = "x" ; then
        OUTPUT="$dir/$COMMAND"
      fi
    fi
  done
  IFS=$OLD_IFS
  echo "$OUTPUT"
}

sysresources=/etc/X11/Xresources

# merge in defaults
if [ -f "$sysresources" ]; then
    xrdb -merge "$sysresources"
fi

sysmodmap=/etc/X11/Xmodmap

XMODMAP=`gdmwhich xmodmap`
if [ "x$XMODMAP" != "x" ] ; then
  if [ "x$GDM_PARENT_DISPLAY" = "x" ]; then
    if [ -f $sysmodmap ]; then
      $XMODMAP $sysmodmap
    fi
  else
    ( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $XMODMAP -pke ) | $XMODMAP -
  fi

  #
  # Switch Sun's Alt and Meta mod mappings
  #

  UNAME=`gdmwhich uname`
  PROCESSOR=`$UNAME -p`
  if [ "x$PROCESSOR" = "xsparc" ]; then
    if $XMODMAP | /usr/bin/grep mod4 | /usr/bin/grep Alt > /dev/null 2>/dev/null
    then
      $XMODMAP -e "clear Mod1" \
               -e "clear Mod4" \
               -e "add Mod1 = Alt_L" \
               -e "add Mod1 = Alt_R" \
               -e "add Mod4 = Meta_L" \
               -e "add Mod4 = Meta_R"
    fi
  fi
fi

SETXKBMAP=`gdmwhich setxkbmap`
if [ "x$SETXKBMAP" != "x" ] ; then
  # FIXME: is this all right?  Is this completely on crack?
  # What this does is move the xkb configuration from the GDM_PARENT_DISPLAY
  # FIXME: This should be done in code.  Or there must be an easier way ...
  if [ -n "$GDM_PARENT_DISPLAY" ]; then
    # Hurray for awk
    XKBARGS=$( (DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $SETXKBMAP -v -v) | awk '/^model:/ { printf "-model %s ", $2 } /^layout:/ { printf "-layout %s ", $2 } /^variant:/ { printf "-variant %s ", $2 } /^options:/ { printf "-option %s ", $2}' )
    XKBSETUP=`( DISPLAY=$GDM_PARENT_DISPLAY XAUTHORITY=$GDM_PARENT_XAUTHORITY $SETXKBMAP -v )`
    if [ -n "$XKBARGS" ]; then
      $SETXKBMAP $XKBARGS
    fi
  fi
fi

exit 0

Dernière modification par xtriade (21-02-2011 17:11:42)


Hadopi = loi débile

Hors ligne

#15 21-02-2011 19:41:48

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Mint et LMDE
Noyau : 2.6.38.8
(G)UI : Gnome ou KDE
Inscription : 03-01-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Hello,

Je ne voit pas les lignes :
xset s off
xset -dpms

Reprend le tuto ci-dessus, et ajoute les, et fait comme dit dans le tuto smile

@micalement
@+ Gerinald

Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#16 21-02-2011 19:54:13

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

comme je disais plus haut

j'obtiens le même resultat sans faire le tuto; càd sans mettre les lignes dans le fichier Defaut
xset s off
xset -dpms


Resultat avec xset q  :

  DPMS (Energy Star):
  Standby: 0    Suspend: 0    Off: 0
  DPMS is Enabled
  Monitor is On


J'ai rebooté , et même symptôme :  l'ecran s'eteint au bout de 10mn et impossible de le reveiller en faisant la combinaison de touches citées plus haut dans mon post. Chose que je pouvais faire lorque j'etais encore sous Lenny il y a 3 jours. C'est encore Xorg qui fait des siennes !

Mon avis : c'est une fausse piste avec xset

Dernière modification par xtriade (21-02-2011 20:23:53)


Hadopi = loi débile

Hors ligne

#17 21-02-2011 21:37:37

Gerinald
Membre
Lieu : Bois d'Haine
Distrib. : Mint et LMDE
Noyau : 2.6.38.8
(G)UI : Gnome ou KDE
Inscription : 03-01-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Pas de souci, c'est toi qui voit

Je passe la main

@micalement
@+ Gerinald

Dernière modification par Gerinald (21-02-2011 21:37:50)


Rien ne sert de courir, tout vient à point à qui sait attendre
Mon habit s’appelle Kernel .... le reste .... n'est que fioriture.

Hors ligne

#18 21-02-2011 22:13:34

xtriade
Membre
Lieu : Lyon
Distrib. : Lenny
Noyau : 2.6.26-1-686
(G)UI : Gnome
Inscription : 27-02-2009

Re : comment sortir de la mise en veille sous Squeeze ?

encore merci de ton aide Gerinald

Le probleme n'est pas bloquant , juste agacant

Hadopi = loi débile

Hors ligne

#19 22-02-2011 08:10:56

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : comment sortir de la mise en veille sous Squeeze ?

arien a écrit :

joelpince a écrit :

J'ai le même problème avec une Gforce GT 8600 M..


Tu utilise bien le driver Debian 195.36.31-6
Peut-être il te faut aussi un xorg.conf si c'est pas déjà fait ?
# apt-get install nvidia-xconfig
puis toujours en root
# nvidia-xconfig
pour générer un xorg.conf


Salut !
Comment fait-on pour vérifier ce pilote Debian ?
J'avais gardé le pilote libre de l'installation d'origine.
Je viens de suivre tes conseils et j'ai installé le pilote propriétaire avec les commandes que tu m'a suggérées.
Effectivement le problème a été résolu pour moi.
Comment peut-on vérifier les réglages du xorg ?
A+
Joël

Hors ligne

#20 22-02-2011 11:39:29

Invité-5
Banni(e)

Re : comment sortir de la mise en veille sous Squeeze ?

Salut,

joelpince a écrit :

Je viens de suivre tes conseils et j'ai installé le pilote propriétaire avec les commandes que tu m'a suggérées.


Tu as utilisé quelle méthode pour installer ton pilote, le wiki où le raccourci ? Pour vérifier ce pilote Debian tu dois aussi installer # apt-get install nvidia-settings tu auras l'info sur ton pilote, ainsi que avec la commande $ glxinfo

Comment peut-on vérifier les réglages du xorg ?


Tu peux éditer ton xorg.conf avec la commande # nano /etc/X11/xorg.conf ou simplement juste pour voir en graphique avec la souris Poste de travail => Système de fichiers => etc => X11 => xorg.conf.

PS : Si tu utilise apt-get c'est apt-get tout le temps, en revanche si tu utilise aptitude c'est aptitude tout le temps il faut jamais mélanger le deux. A mon avis, quand vous migrez de Lenny vers Squeeze il est préférable de réinstaller vos pilotes graphiques.

@

#21 23-02-2011 10:08:48

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : comment sortir de la mise en veille sous Squeeze ?

Salut,

Pour installer le pilote, j'ai utilisé
# aptitutde install nvidia-xconfig
puis
nvidia-xconfig
Je viens d'installer
# aptitude install nvidia-settings
et glxinfo me renvoie ça :

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4


Ca marche absolument au poil à présent : affichage parfait, support 3D (je m'en fous mais ça fait plaisir de savoir), mise en veille et hibernation (très rapide au réveil) !...
Plus le temps passe et plus je ne peux que constater que Squeeze est super rapide (largement plus rapide que Windows 7 !!!) et d'une stabilité incroyable !
Mais pourquoi y a-t-il encore 97% des gens qui s'em**dent avec Windows ???...
A+
Joël

Hors ligne

Pied de page des forums