Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-02-2011 12:16:42

PengouinPdt
Adhérent(e)
Lieu : 47 - France
Distrib. : Jessie
Noyau : Linux 3.16
(G)UI : XFCE
Inscription : 09-02-2011
Site Web

[rsync] Problème: skipping directory .

Bonjour,

J'ai un script type, dont on peut voir le pastebin suivant ...

Ce sont des données qui sont envoyés de mon serveur Debian vers mon FreeNAS.
Tout est en local ; j'utilise le serveur rsync sur FreeNAS avec gestion utilisateur, et module serveur.

Depuis quelques temps, j'ai le message suivant 'skipping directory .' - résultat, il ne sauvegarde aucun des répertoires demandés ... seuls les fichiers du répertoire 'etc'.

Avez-vous une idée de la raison de ce mauvais fonctionnement ?!

Hors ligne

#2 22-02-2011 11:29:59

PengouinPdt
Adhérent(e)
Lieu : 47 - France
Distrib. : Jessie
Noyau : Linux 3.16
(G)UI : XFCE
Inscription : 09-02-2011
Site Web

Re : [rsync] Problème: skipping directory .

Bjr,

A ce que je vois, personne n'a pas plus d'idée que moi ... snifff, nifff.

Hors ligne

#3 22-02-2011 13:56:09

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [rsync] Problème: skipping directory .

Yep!

Je ne vois pas dans ton script l'option -r pour recursive !!!

J'ai regardé vite fait ton script, mais tu pourrais essayé de remplacer :

SYNC_OPTIONS="-avcRHKz --delete-after --exclude=*~ --ignore-errors --force --numeric-ids --partial --stats --timeout=900"


par :

SYNC_OPTIONS="-avcrRHKz --delete-after --exclude=*~ --ignore-errors --force --numeric-ids --partial --stats --timeout=900"


Aprés, il reste à contrôler les autorisations et principalement la possibilité à ton daemon rsync de créer des repertoires.

@+

Zoroastre.

Dernière modification par zoroastre74 (22-02-2011 13:58:14)

Hors ligne

#4 23-02-2011 12:55:26

PengouinPdt
Adhérent(e)
Lieu : 47 - France
Distrib. : Jessie
Noyau : Linux 3.16
(G)UI : XFCE
Inscription : 09-02-2011
Site Web

Re : [rsync] Problème: skipping directory .

@zoroastre: c'est normal que tu ne vois pas l'option 'r' ... pour la belle et simple raison que l'option 'a' remplace les différentes options que sont '-rlptgoD'...

Ensuite, le problème se situe bien au niveau de la création des répertoires, s'ils n'existent pas ... et, là, je vais à nouveau faire un man rsync, parce que je séche sérieux !

Normalement, si j'ai bien compris rsync doit créer les répertoires s'ils n'existent pas ... il le fait nativement ! (et selon les options choisies, doit détruire sur la cible ceux qui n'existent plus sur la source ...)

Or, ce n'est pas le cas ... là !

Dernière modification par PengouinPdt (23-02-2011 13:09:47)

Hors ligne

Pied de page des forums