Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 21-02-2011 17:14:59

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

[Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Bonjour,

J'écris ici parce que la version 1.1.3 de VLC sur Squeeze est emprise d'un bug qui n'inhibe pas gnome-screensaver. En gros, l'écran de veille se déclenche au bout de quelques minutes en lecture d'une vidéo plein écran. C'est vraiment très pénible même si on peut le contourner avec l'applet d'inhibition.

En fait ce bug me gonfle car il est difficile de démontrer à des gens que Linux "c'est mieux" si je dois leur dire "ah oui mais là ya un bug donc tu dois faire ça", alors que Debian est supposée être "solide comme un roc". Je veux bien utiliser le fait que Flash fait pareil car c'est une solution proprio merdique, mais là il s'agit d'un logiciel libre !

Le bug est rapporté ici http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=436339 et soit-disant "RESOLU" ! Mon cul oui ! C'est résolu dans la version 1.1.5 de VLC mais ça m'étonnerait fortement qu'elle débarque dans Squeeze. Ca fait 3 mois que le bug est marqué résolu et rien n'a changé pour Squeeze.
J'ai envoyé un message sur la mailing list et au mainteneur mais tout le monde s'en fout j'ai l'impression.

Je me demandais pourquoi est ce qu'ils réagissent comme ça ? Le bug est connu et résolu mais en théorie seulement. Est ce juste une question de temps ou il faudra manuellement mettre le paquet sur les PC Squeeze ?

EDIT: Aussi, j'ai écris au responsable VLC du rapport de bug (Benjamin Drung) mais il m'a répondu qu'il s'occupait pas de l'empaquetage. A qui dois-je donc m'adresser ?

Dernière modification par dbkblk (21-02-2011 18:29:18)


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#2 21-02-2011 19:03:46

eol
Membre
Inscription : 03-09-2009

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

dbkblk a écrit :

Bonjour


Bonjour

dbkblk a écrit :

J'écris ici parce que la version 1.1.3 de VLC sur Squeeze est emprise d'un bug qui n'inhibe pas gnome-screensaver. En gros, l'écran de veille se déclenche au bout de quelques minutes en lecture d'une vidéo plein écran. C'est vraiment très pénible même si on peut le contourner avec l'applet d'inhibition.


Tu le vois dans ce sens là toi ?
Tu penses que c'est au lecteur video de contenir du code pour gérer les économiseurs d'écran de tous les utilitaires et environnements de bureaux différents ?
Où bien que c'est à l'environnement de détecter une activité vidéo quelconque et de ne donc pas lancer l'économiseur ?

Moi je penche pour la deuxième possibilité.

Je ne connais pas gnome-screensaver, mais en attendant une solution convenable,
tu peux toujours essayer quelque chose dans ce goût là ( à adapter ) :

Si tu lances vlc depuis une icône de ton panel, tu peux avec un clic droit dessus accéder à ses caractéristiques et changer la commande vlc par quelque chose comme :

gconf blahblah screensaver false; vlc; gconf blahblah screensaver true


N'ayant pas gnome je n'ai pas l'intitulé exact mais gconf te permet à coup sûr de t'en tirer.

Eh oui, même dans les clicodrômes les commandes dépannent ... wink

Dernière modification par eol (21-02-2011 19:06:48)

Hors ligne

#3 21-02-2011 19:44:34

n3os
Modérateur
Lieu : /Debian/Home/neos
Distrib. : Sid
Noyau : 2.6.35
(G)UI : e17
Inscription : 14-07-2007

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Salut,

tu as l'option "Désactiver l'économiseur d'écran" dans les paramètres vidéo de vlc,
tu as testé ?

Hors ligne

#4 22-02-2011 00:15:39

Invité-5
Banni(e)

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Salut,

n3os a écrit :

tu as l'option "Désactiver l'économiseur d'écran" dans les paramètres vidéo de vlc,


En principe, cette option est activée par défaut dans vlc. 
Discuter pour discuter. Personnellement j'ai aucun problème avec l'écran de veille pour visionner ni les vidéos ni la télévision avec vlc ( driver proprio Debian nvidia 195.36.31 ) donc pour moi le bug est probablement résolu.  En revanche avec la carte ati et le pilote libre radeon j'avais effectivement des coupures au bout de quelques minutes une fois sur deux ( réglé également ) Comme ça a été dit précédemment il vaut mieux bien adapter son environnement.

Amicalement.

#5 22-02-2011 08:50:29

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

eol a écrit :

Tu le vois dans ce sens là toi ?
Tu penses que c'est au lecteur vidéo de contenir du code pour gérer les économiseurs d'écran de tous les utilitaires et environnements de bureaux différents ?
Où bien que c'est à l'environnement de détecter une activité vidéo quelconque et de ne donc pas lancer l'économiseur ?

Moi je penche pour la deuxième possibilité.


Non, je suis d'accord avec toi, c'est l'environnement qui devrait gérer l'économiseur d'écran mais il semble que Gnome ne le fait pas bien et n'inhibe pas flash ni vlc. Quand j'avais rapporté le bug pour flash sur Ubuntu 10.04, on m'a répondu que c'était la faute d'adobe et qu'on peut rien y faire. Ici, il s'agit bien d'un bug de VLC et Gnome, mais visiblement, pas tout le monde n'est affecté. J'ai un ordi qui possède une Nvidia 6200 (moisie !) et le bug est là aussi.
L'option de VLC est effectivement activée par défaut et ne fonctionne pas. xdg-utils est également installé par défaut.

Le problème est surtout que le bug a été marqué "résolu" parce qu'une version de VLC en amont le résolvait, mais que cette version n'arrivera sûrement pas dans Squeeze; c'est paradoxal !

Quand au driver libre "radeon", hors de question sur mon portable parce qu'il fait trop chauffer la carte graphique dans la version présente dans Debian 6.0

Amicalement (et pardonnez mon ton légèrement énervé du premier post),


M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#6 23-02-2011 02:31:11

joelpince
Membre
Lieu : Miramont-de-Comminges
Distrib. : Squeeze
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 12-02-2011

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Salut,
Ça fera pas avancer le shmilblick mais chez moi, y'a aucun problème avec VLC.
J'utilise une Nvidia GT 8600 M et le pilote propriétaire (mais ça marchait aussi avec le pilote libre).
Je pose une question bête : tu ne peux pas installer manuellement la version 1.1.5 sur squeeze ?
A+
Joël

Hors ligne

#7 25-02-2011 15:29:22

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Bon, j'ai testé sur un PC Squeeze 64bits avec Nvidia 7300, et le bug de l'écran de veille est là aussi. En installant la version 1.1.7 des dépôts, le bug est toujours là sad

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#8 25-02-2011 20:12:44

Invité-5
Banni(e)

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Donc, si j'ai bien compris, avec n'importe quelle version de VLC ta as ce "bug" de l'écran de veille ? Par curiosité, quel pilote graphique as-tu installé ou pas avec CG Nvidia 7300 ? Et l'écran de ton PC est dans quel état ? Peut-être la mauvaise gestion d'énergie est en cause. Es-que avec la CG ATI t'as pas ce problème ? cool

EDIT : Voir ce topic

Dernière modification par arien (26-02-2011 14:01:21)

#9 27-02-2011 01:15:02

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Re, oui VLC ne semble pas être la cause, car la soit-disant résolution du bug ne résoud pas mon problème.
Pour info, j'ai ce bug avec des Nvidias 7300LE / 6200 et ATI HD3850 /HD2600M. Pilotes prioprio ou non.

Je me suis inscris également à ce bug de xdg-utils: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610155 car l'écran de veille s'active également sur les vidéos flash en plein écran !
Je ne comprend pas pourquoi vous ne l'avez pas non plus !

La solution de l'autre fil "xset -display :0 s off -dpms" ne résoud pas mon problème hmm

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#10 10-03-2011 11:21:21

Invité-5
Banni(e)

Re : [Discussion] Un peu gonflé par VLC & Debian à cause d'un bug...

Salut,

Peut-être tu trouveras ton bonheur ici

Pied de page des forums