Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-02-2011 19:30:21

yod
Membre
Inscription : 20-02-2011

Problème installation Samba

Bonjour,

Je voudrais de l'aide pour installer Samba, j'ai trouvé quelques tutos sur le net mais je bloque assez rapidement.

J'ai la dernière Debian installée uniquement en lignes de commandes (ben ouais pour mieux apprendre concrètement lol)

Donc je fais: # apt-get install samba samba-common smbclient smbfs swat samba-doc, tout est bien installé.

Au moment de le lancer: /etc/rc.d/init.d/smb start ou /etc/init.d/smb start > "Aucun fichier ou dossier de ce type"

Voilà ça commence pas top c'est pourquoi un peu d'aide si possible serait la bienvenue merci beaucoup ^^'

Dernière modification par yod (26-02-2011 19:47:23)

Hors ligne

#2 25-02-2011 19:51:47

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Problème installation Samba

Bonjour yod,

Tu utilises l'autocomplémentation ?
voir les commandes linux là :
http://debian-facile.org/manuel:commande

Notamment pour les débutants. smile

Pour debian, la commande est :

# /etc/init.d/...       <= ce que tu veux relancer et utilise restart


Hop ! big_smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 25-02-2011 20:11:09

yod
Membre
Inscription : 20-02-2011

Re : Problème installation Samba

Salut, merci bien pour la liste des commandes ça me sera très utile. wink

Jusque-là je me contentais de suivre les tutos et de mémoriser les commandes que j'ai effectuées.

Par contre quand tu dis:

Pour debian, la commande est :

# /etc/init.d/...       <= ce que tu veux relancer et utilise restart


Hop ! big_smile


ok ça relance samba mais que dois-je faire ensuite?

ps: bien la citation et l'avatar wink

Hors ligne

#4 25-02-2011 20:16:37

yod
Membre
Inscription : 20-02-2011

Re : Problème installation Samba

Ah ok je viens de réaliser grâce au dir /etc/init.d qu'il fallait utiliser "samba" au lieu de "smb" contrairement au tuto de ccm, j'espère que ça fonctionnera mieux maintenant smile

Dernière modification par yod (25-02-2011 20:22:31)

Hors ligne

#5 25-02-2011 22:10:10

yod
Membre
Inscription : 20-02-2011

Re : Problème installation Samba

-

Dernière modification par yod (25-02-2011 23:40:00)

Hors ligne

#6 25-02-2011 23:28:34

MaTTuX_
La Paillasse !!!
Lieu : Zoubidou-Land
Distrib. : 75 serveurs
Noyau : 3.2.0-4-amd64
(G)UI : tty et ... pas gnome en tout cas....
Inscription : 28-05-2007
Site Web

Re : Problème installation Samba

La commande c'est

fdisk -l


il me semble pourtant que smolski t'as passé le lien avec les comandes basiques à savoir.

MaTTuX_


\o/ Le closedSource c'est tabou on a viendra tous à bout \o/

Hors ligne

#7 26-02-2011 19:32:14

yod
Membre
Inscription : 20-02-2011

Re : Problème installation Samba

Oui et je le remercie,

Le truc c'est que j'aimerais tout simplement partager toutes les données présentes sur une partition NTFS sur l'ensemble de mon réseau. Je dois éditer le smb.conf mais pour celà il faut que je monte cette partition.

Lorsque je # fisk -l j'ai déjà un message d'erreur:

Device Boot Start End Blocks Id System
/dev/sdb 1 122 975872 82 Linux swap / solaris
Partition 1 does not end on cylinder boundary.
/dev/sdb2 122 1338 9765888 83 Linux
/dev/sdb3 1338 4256 2343712 83 Linux
/dev/sdb4 4256 121601 942579936+ 7 HPFS/NTFS

Il me semble pourtant avoir installé la distrib proprement..

Lorsque je # /sbin/cfdisk /dev/sdb4 j'ai un autre message d'erreur:
FATAL ERROR: Bad primary partition 0: Partition begins after end-of-disk

J'ai installé le support ntfs selon ccm > install ntfs-3g ntfsprogs ntfstools (sauf ntfstools qui est introuvable) et j'ai édité le fstab comme indiqué > www.commentcamarche.net/faq/5544-lire-et-ecrire-les-partitions-windows-ntfs

puis j'ai tenté de monter la partition: # mount /media/windows et j'obtiens un 3ème problème:
ntfs-3g-mount: mount failed: périphérique ou ressource occupé

..

Dernière modification par yod (26-02-2011 19:36:02)

Hors ligne

#8 03-03-2011 10:49:30

Pollux
Membre
Distrib. : Squeeze
Noyau : 2.6.32
(G)UI : aucune
Inscription : 19-11-2009

Re : Problème installation Samba

pas besoin de mettre t'es partoche en NTFS pour du partage samba, il se débrouille tous seul, formate ta partoche en ext3 ou 4, et de toute façon tu a installer swat donc si tu te connecte à ton serveur avec un navigateur web tu devrais pouvoir administrer samba via une interface web, enfin c'est pas ce que je recommande m'enfin...

Hors ligne

Pied de page des forums