Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-03-2011 16:43:30

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

[Non réglé] Gestionnaire de mise a jour plus efficace

Bonjour,

  question de petits détails ...

   lorsque je lance le "Gestionnaire de Mise à Jour"  (sous Gnome), j'aimerais bien que la vérification se fasse dès le lancement.
   Actuellement, ce que j'ai:  je lance le Gestionnaire, puis je dois cliquer sur "vérifier".  Non, mais .... si je lance le Gestionnaire, n'est-il pas normal de vérifier ?   Pourquoi le Gestionnaire ne vérifie-t-il pas derechef ?

    Un petit truc de config à quelque part ?

Dernière modification par Patriboom (04-04-2011 15:24:56)


Portez la paix
Patrick Allaire, ptre

Hors ligne

#2 25-03-2011 16:57:17

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

# aptitude show update-notifier
Paquet : update-notifier                      
Nouveau: oui
État: non installé
Version : 0.99.3debian8
Priorité : optionnel
Section : gnome
Responsable : Julian Andres Klode <jak@debian.org>
Taille décompressée : 438 k
Dépend: libc6 (>= 2.7), libdbus-glib-1-2 (>= 0.78), libgconf2-4 (>= 2.27.0), libgdu0 (>= 0.2), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.14.0), libgudev-1.0-0 (>=
         146), libnotify1 (>= 0.5.0), libnotify1-gtk2.10, libx11-6, gconf2 (>= 2.28.1-2), update-notifier-common (= 0.99.3debian8), python, update-manager-gnome |
         update-manager, notification-daemon, gksu
Recommande: apport-gtk, synaptic, software-properties-gtk, anacron
Suggère: ubuntu-system-service
Casse: update-notifier-common (< 0.99.3debian)
Remplace: update-notifier-common (< 0.99.3debian)
Description : démon qui signale la disponibilité de paquets mis à jour
 Place une icône dans la zone de notification de l'utilisateur lorsque des mises à jour de paquets sont disponibles.


@+

Zoroastre.

Hors ligne

#3 25-03-2011 17:26:26

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Merci zoroastre, mais ça j'ai déjà.
Quand je clique sur l'icône - dans la zone de notification - ça ouvre le Gestionnaire de Mise à Jour.
Tout va bien jusque là.

Ce que je voudrais, en plus, c'est qu'en ouvrant le Gestionnaire, une vérification soit faite automatiquement et que je n'aie pas besoin de cliquer sur "Vérifier" comme je dois le faire actuellement.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#4 25-03-2011 18:10:22

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

Ce que tu cherches ressemble beaucoup à MintUpdate...??? Linux Mint...

@+

Zoroastre.

Dernière modification par zoroastre74 (25-03-2011 18:11:09)

Hors ligne

#5 25-03-2011 18:16:50

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Merci encore zoroastre.
Peut-être sais-tu comment s'appelle (le nom du logiciel selon le système) le "Gestionnaire de Mise à Jour"
Je pourrais tenter de trifouiller là-dedans.

Au plaisir.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#6 25-03-2011 18:31:49

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

Alors il te faut, gksu (debian), synaptic (debian), mint-translations (mint), mint-common (mint) et mintupdate (mint), à installer dans cette ordre. (Du moins ce sont les paquets que j'ai dû installer...)

Pour les 3 derniers, J'ai pris les dernières versions et c'est fonctionnel : http://packages.linuxmint.com/pool/main/m/

J'ai maintenant un joli bouclier blanc dans ma barre de notification...

Un petit retour pour voir ce que tu en penses !!!

@+

Zoroastre.

Dernière modification par zoroastre74 (25-03-2011 18:35:58)

Hors ligne

#7 25-03-2011 18:44:26

zaphir
Membre
Distrib. : Wheezy
Noyau : 3.2.0-4
(G)UI : Fluxbox
Inscription : 10-09-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Saluttt,

Intéressant la procédure d'ajout !!
mais l'interêt c'est d'avoir une notification des mises a jour + le recherche a l'ouverture du gestionnaire ,c'est bien ça ?
un petit alias_maj='sudo aptitude update && sudo aptitude safe-update' c'est aussi rapide,  mais sans la notification c'est vrai  wink
Le retour m'interesse aussi pour voir .

Hors ligne

#8 25-03-2011 20:13:09

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

Bon pour l'instant il n'y a pas de mise à jour disponible...donc on verra çà plus tard.

Par contre, petite astuce : Comme je compte tester ce logiciel quelques temps, j'ai naturellement voulu faire démarrer l'icone de notification automatiquement.
Le problème est que mintupdate lance la fenêtre logiciel, un petit coup de 'ps aux' et là je découvre un script python :

python /usr/lib/linuxmint/mintUpdate/mintUpdate.py show


C'est encore mieux que je ne le pensais wink

Il suffit simplement de modifier le show en hide et hop, plus de fenêtre logiciel au démarrage système.

Je sens que je vais trifouiller du python... tongue

@+

Zoroastre.

Hors ligne

#9 25-03-2011 21:22:31

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Pour ma part, je chercheai davantage à fouiller les paquets instalés.  Mint n'est pas installé sur mon ordi. 
Ce que je cherche: maximiser ce qui est là sans nouveau paquet si possible.    Je vise donc à toucher mon "Gestionnaire de mise à Jour" pour l'adapter à mes besoins.

Mes références aux updates, par ailleurs, font déclarer à aptitude que mint est introuvable.  Idem pour Synaptic.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#10 25-03-2011 22:14:22

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

Surprenant que tu n'aies pas Synaptic...

aptitude search synaptic


Rien ?

Mint n'est naturellement pas trouvable dans les paquets car il s'agit d'une distribution linux. Elle est basé sur Debian et sur *buntu. http://www.linuxmint.com/about.php et le  logiciel que je te proposais est un script écrit en python, donc tout à fait portable...

Pour ta recherche, je n'ai pas d'autres solutions à t'apporter...et doute fortement qu'il y ait une option de configuration pouvant répondre à ta demande.

Il te reste la possibilité de faire les mises à jour automatiquement, sans aucune intervention humaine ou tester PackageKit en testing.

@+

Zoroastre.

Dernière modification par zoroastre74 (25-03-2011 22:51:35)

Hors ligne

#11 26-03-2011 00:03:38

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

J'ai dû faire une faute frappe.  Je voulais simplement écrire que je trouvais via Synaptic pas les composantes citées.

Merci de tes efforts.  Ce n'est qu'une petite question de confort, rien d'essentiel, de toutes façons.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#12 27-03-2011 13:16:16

Invité-5
Banni(e)

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Bonjour,

Patriboom a écrit :

Actuellement, ce que j'ai:  je lance le Gestionnaire, puis je dois cliquer sur "vérifier".  Non, mais .... si je lance le Gestionnaire, n'est-il pas normal de vérifier ?   Pourquoi le Gestionnaire ne vérifie-t-il pas derechef ?


Je veux essayer expliquer la situation.

1. Je suppose qu'il n'y a pas beaucoup des mises a jours sous Lenny en ce-moment.
2.  En revanche chaque nouvelle mise à jour s'affiche directement dans le "Gestionnaire de Mise à Jour" donc la vérification se fasse dès le lancement.
3. Pas de mise à jour, pas d'affichage ( "automatiquement" on clique pour verifier )

Espérant avoir répondu clairement a ta question.

#13 02-04-2011 11:08:09

deb2deb
Membre
Distrib. : Version testing (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-2-amd64
(G)UI : GNOME 3.4.1
Inscription : 12-02-2011

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

1/ Système > Administration > Sources de mise à jour
2/ Onglet Updates
3/ Cocher Install security updates without confirmation

Et voilà !

Hors ligne

#14 02-04-2011 17:50:14

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Bonjour à tous,

décidément, je ne fus pas clair dans ma présentation.
Tout ce qui a été suggéré ci-haut est déjà fait et fonctionne.
Cependant, ce que je veux faire n'a pas été touché dans les messages ci-haut.

Si j'ai des références à des dépôts qui - par exemple - n'ont pas de clef ou sont désuets ou sont ci ou ça.
Si une lubie me prend de voir s'il y a des mises à jour.
Alors j'ouvre le Gestionnaire (je le trouve dans le menu de gnome).
La fenêtre s'ouvre et m'offre le bouton "Vérifier les mises à jour".
Il me semble un peu ridicule de devoir cliquer sur ce bouton alors qu'en ouvrant le logiciel par moi-même, c'est bien sûr que je veux vérifier les mises à jour.
Ne serait-il pas possible que la recherche des mises à jour se fasse automatiquement en ouvrant la fenêtre ( un auto-clic sur ouverture de fenêtre) ?

merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#15 02-04-2011 20:16:47

deb2deb
Membre
Distrib. : Version testing (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-2-amd64
(G)UI : GNOME 3.4.1
Inscription : 12-02-2011

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Peut-être remplir un rapport de bogue (wishlist) sur le paquet update-manager ?

Sinon, depuis gconf-editor, il existe une option auto-launch pour update-notifier. Pas essayé, mais d'après la description, ça peut correspondre à ce que tu veux.

Dernière modification par deb2deb (02-04-2011 20:21:34)

Hors ligne

#16 02-04-2011 20:49:13

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Merci deb2deb,

   c'est justement ce que je cherche dans gconf-editor, mais dans le mien je n'ai pas de "auto-launch"
   voici les trois options qui se trouvent dans gconf-editor:  check-list-upgrades, remind-reload, show-details
   C'est dans apps/update-manager

   Pourquoi le mien n'a-t-il pas les mêmes options que ton gconf-editor ?
 

   Merci.

   au fait, comment fait-on pour remplir un rapport de souhait (wishlist) ?

Portez la paix
Patrick Allaire, ptre

Hors ligne

#17 03-04-2011 00:46:57

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

Pour ma part, je continue à tester MintUpdate qui, il me semble, correspond à tes attentes. Vérifications des mises à jours périodiques et d'un simple clic, dans la barre des tâches, on accède à la liste de celles-ci avec à la suite le choix entre acceptation ou non.
Le problème est, qu'actuellement, je n'arrive pas à faire fonctionner correctement le script python sous un utilisateur courant. La configuration d'origine me réclamait le mot de passe root. Chose que je voulait éviter en passant par sudo et synaptic. Que nenni ! Il ne veut rien entendre le bougre...Alors...

Je continue mes experimentations......cherche encore...

@+

Zoroastre.

Hors ligne

#18 03-04-2011 01:00:57

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Merci Zoroastre,

     je ne comprends pas que tu veuilles faire des mises à jour par un compte utilisateur.  J'ai toujours soupçonné que les mises à jour relevaient de la compétence de root. Suis-je le seul?  Il semble que tes problèmes me donnent raison pour l'instant.  Il me semble qu'en tant qu'administrateur système, je n'aimerais pas trop que des utilisateurs fassent des mises à jour de ci de là à leur bon gré et - cochant oui, cochant non - au gré de leur bonne ou mauvaise humeur du jour.

    Dois-je installer Mint pour avoir MintUpdate ?   Si non, comment faire?
    Oui, oui, j'ai compris que Mint est sous-distribution de Debian, mais je me demande comment avoir une partie sans le tout et même si cela est possible.

    Merci.

Portez la paix
Patrick Allaire, ptre

Hors ligne

#19 03-04-2011 11:07:52

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Yep!

  Je suis tout à fait d'accord avec toi sur la methode de mise à jour. D'ailleurs, en dehors de l'essai de cet utilitaire, je réalise toutes mes mises à jour via aptitude update & aptitude safe-upgrade.

  Le script python utilise sudo pour l'utilisation de synaptic et afficher ainsi une notification sur les mises à jour comme le fait update-notifier. Le script utilise également gksu pour ouvrir le logiciel avec les bons droits afin de réaliser cette fois les mises à jour. Le logiciel ne réclame aucune vérification des dépots car elle se réalise à intervalle régulier selon le choix de l'utilisateur.
  J'ai tenté de ramener le script côté utilisateur, afin de pouvoir le rendre un peu plus souple dans l'utilisation et pouvoir travailler dessus aisement.

  Comme je l'ai dit auparavant, je ne connais pas d'autres options, ou logiciels capables de réaliser tes désiderata...Quant à l'installation, elle est relativement simple, 3 paquets à telecharger et à installer via dpkg : voir mon post du 25 mars.

@+

Zoroastre.

Hors ligne

#20 03-04-2011 17:56:57

deb2deb
Membre
Distrib. : Version testing (wheezy) 64 bits
Noyau : Noyau Linux 3.2.0-2-amd64
(G)UI : GNOME 3.4.1
Inscription : 12-02-2011

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Patriboom a écrit :

Merci deb2deb,

   c'est justement ce que je cherche dans gconf-editor, mais dans le mien je n'ai pas de "auto-launch"
   voici les trois options qui se trouvent dans gconf-editor:  check-list-upgrades, remind-reload, show-details
   C'est dans apps/update-manager

   Pourquoi le mien n'a-t-il pas les mêmes options que ton gconf-editor ?
 

   Merci.

   au fait, comment fait-on pour remplir un rapport de souhait (wishlist) ?


auto-launch est dans apps/update-notifier.

Pour les rapports de bogues, j'utilise reportbug (Applications > Outils système >) il suffit d'indiquer le niveau de gravité à wishlist. Simple.

Hors ligne

#21 03-04-2011 18:10:24

Patriboom
Membre
Lieu : Arctique canadien
Distrib. : Jessie
Noyau : Linux 3.16.0-4-686-pae
(G)UI : MATE
Inscription : 25-12-2008
Site Web

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Après une autre vérification, je n'ai pas "auto-launch" dans apps/update-manager

Merci pour le renseignement sur "wichlist", je n'avais aucune idée par où commencer.

Au plaisir.

Je vais mettre "délaissé" au sujet, pour que les prochains résultats de recherche indiquent déjà qu'aucune solution n'est pour le moment possible, à moins d'installer d'autes paquets (ceux de Mint).

Portez la paix
Patrick Allaire, ptre

Hors ligne

#22 04-04-2011 14:16:50

Invité-5
Banni(e)

Re : [Non réglé] Gestionnaire de mise a jour plus efficace

Les Tags

Patriboom a écrit :

je ne comprends pas que tu veuilles faire des mises à jour par un compte utilisateur.  J'ai toujours soupçonné que les mises à jour relevaient de la compétence de root. Suis-je le seul?  Il semble que tes problèmes me donnent raison pour l'instant.  Il me semble qu'en tant qu'administrateur système, je n'aimerais pas trop que des utilisateurs fassent des mises à jour de ci de là à leur bon gré et - cochant oui, cochant non - au gré de leur bonne ou mauvaise humeur du jour.


Normalement, le mot de passe root est demandé avant ouverture de "Gestionnaire de Mise à Jour" sauf si tu as coché la case << se souvenir de mot de passe >> dans "Gestionnaire de paquets Synaptic"

Après une autre vérification, je n'ai pas "auto-launch" dans apps/update-manager


Comme c'était signalé plus haut "auto-launch" se trouve dans apps/update-notifier.

voici les trois options qui se trouvent dans gconf-editor:  check-list-upgrades, remind-reload, show-details
   C'est dans apps/update-manager


Peut-être parce-que tu es sous Lenny et ça se voit pas dans ton infodistri. Perso, quand j'ouvre ( rarement ) le "Gestionnaire de Mise à Jour" soit je vois >> Votre système est à jour << soit les mises à jour sont affichées directement. As-tu dans Settings => Updates => Only notify about available updates (coché)

à moins d'installer d'autes paquets (ceux de Mint)


Je ne crois pas du tout. ( mint/ubuntu et quoi encore ? )

EDIT : Je viens encore vérifié aujour'hui (07/04) et après mon mdp root les nouvelles mises à jours étaient affichés.

Amicalement.

Dernière modification par arien (07-04-2011 15:28:14)

Pied de page des forums