Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 02-04-2011 23:19:46

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

[Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Bonjour,
Je viens d'installer la nouvelle Debian 6.0.1 et je n'arrive pas à faire fonctionner mon contrôleur Wifi.
Voici quelques informations :

lspci –v :

05:00.0 Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)
    Subsystem: Dell Wireless 1500 Draft 802.11n WLAN Mini-card
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
    Memory at fcf00000 (64-bit, prefetchable) [size=1M]
    Capabilities: [40] Power Management version 2
    Capabilities: [58] Vendor Specific Information: Len=78 <?>
    Capabilities: [e8] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [d0] Express Endpoint, MSI 00
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [13c] Virtual Channel
    Capabilities: [160] Device Serial Number d2-5f-69-ff-ff-8e-00-22
    Capabilities: [16c] Power Budgeting <?>
    Kernel driver in use: b43-pci-bridge


iwconfig :

lo        no wireless extensions.

eth0      no wireless extensions.


Je viens de trouver ça sur le net :

aptitude install module-assistant
module-assistant auto-install broadcom-sta
modprobe -r b44 b43 b43legacy ssb brcm80211
modprobe wl


À présent, j'écris la commande lsmod | grep wl :

wl                1937867  0
lib80211             3654  1 wl


Pourtant, iwconfig :

lo        no wireless extensions.

eth0      no wireless extensions.


Je viens d'essayer une autre solution, qui ne fonctionne pas non plus :
Compilation du pilote propriétaire : www.broadcom.com/support/802.11/linux_sta.php

make
make install
depmod
modprobe wl


Même résultat : je vois "wl" dans lsmod mais rien dans iwconfig. Et même après ça :

echo wl >> /etc/modules
reboot


Même résultat.

Après un modprobe wl, voici ce que contient /var/log/messages :

Apr  2 00:53:54 debian kernel: [ 1225.060133] lib80211: common routines for IEEE802.11 drivers


Ce que renvoie la commande dmesg :

[ 1225.060133] lib80211: common routines for IEEE802.11 drivers
[ 1225.060136] lib80211_crypt: registered algorithm 'NULL'


Ce qu'affiche la commande ifconfig -a :

eth0      Link encap:Ethernet  HWaddr 00:21:70:17:9c:8c 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interruption:29 Adresse de base:0x2000

lo        Link encap:Boucle locale 
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


Et ce qu'affiche ifconfig wlan0 up :

wlan0: ERROR while getting interface flags: Aucun périphérique de ce type


Je ne sais pas du tout quoi faire, mon interface Wifi BCM4321 n'est toujours pas reconnue. sad

Je viens de vous donner le maximum de détails, afin que vous puissiez voir ce que j'aurais "loupé". Merci d'avance pour votre aide.

Dernière modification par e-miel (16-04-2011 05:31:29)

Hors ligne

#2 03-04-2011 08:43:22

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Ton installation du pilote wl est faite correctement avec module-asisstant.
Cependant pour que ça fonctionne chez moi, il faut redémarrer l'ordi. Enfin attention, il faut l'éteindre totalement, puis le démarrer, comme s'il fallait que la carte wifi soit réellement redémarée.

YA3HGA-H

En ligne

#3 03-04-2011 09:03:25

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Cela fait plusieurs jours que je cherche. Entre temps, mon PC a déjà été éteint et rallumé plusieurs fois. Cela ne fonctionne toujours pas.

D'après ce que j'ai compris, tout repose sur le fichier wl.ko, peux-tu me le confirmer ?

Hors ligne

#4 03-04-2011 13:02:53

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Oui, ben le fichier wl.ko, c'est justement le module une fois qu'il est compilé.
Alors, tu es sous quel noyau? Avec le 2.6.32, j'ai le même souci que toi, mais pas avec le 2.6.38.
En fait, il y a eu une mise à jour des broadcom-sta-sources, et maintenant, ça ne marche que avec le nouveau noyau on dirait.
Donc tu es sous quelle branche de debian, stable ou unstable? Il te faudra sans doute récupérer l'ancien paquet broadcom-sta-source.

Sinon, tu as une alternative un peu plus "libre", mais qui ne marche pas pour les réseaux sans clé wep ou wpa chez moi : installer le paquet firmware-b43-lpphy-installer . Bon, bien sur, il faut purger tous les broadcom-sta pour que ça fonctionne, comme ces derniers blacklistent automatiquement b43 et compagnie.

YA3HGA-H

En ligne

#5 03-04-2011 13:55:10

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Thuban a écrit :

Tu es sous quel noyau? Avec le 2.6.32, j'ai le même souci que toi, mais pas avec le 2.6.38.


2.6.32-5-amd64

En fait, il y a eu une mise à jour des broadcom-sta-sources, et maintenant, ça ne marche que avec le nouveau noyau on dirait.


Ok, tout s'explique.

Donc tu es sous quelle branche de debian, stable ou unstable?


Stable (6.0.1), je l'ai écrit en haut du premier message.

Sinon, tu as une alternative un peu plus "libre", mais qui ne marche pas pour les réseaux sans clé wep ou wpa chez moi : installer le paquet firmware-b43-lpphy-installer.


Merci, je vais essayer ça.

Bon, bien sur, il faut purger tous les broadcom-sta pour que ça fonctionne, comme ces derniers blacklistent automatiquement b43 et compagnie.


J'ai l'habitude de réinstaller souvent Debian, pour être sûr que mes problèmes ne viennent pas d'une ancienne manipulation. Merci.

Hors ligne

#6 03-04-2011 15:56:00

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Je viens d'essayer d'installer firmware-b43-lpphy-installer mais j'ai un message d'erreur disant que je n'ai pas le bon contrôleur.

J'ai donc fait une recherche sur Debian.org : le paquet firmware-b43-lpphy-installer est annoncé comme compatible BCM4312-LPPHY (Low-Power-PHYsical), mais j'ai trouvé le paquet firmware-b43-installer qui est compatible BCM4306/3, BCM4311, BCM4312 et BCM4318.

Or, mon contrôleur est un BCM4321, mais j'ai quand-même essayé. L'installation a réussie smile et m'a créé un dossier /lib/firmware/b43/ contenant 32 fichiers *.fw puis j'ai éteint et rallumé mon PC, afin de vider la RAM du contrôleur (sinon il ne demandera pas son firmware) et... rien, pareil qu'avant, aucune reconnaissance d'ifconfig et d'iwconfig. sad

Une autre suggestion ?

Hors ligne

#7 04-04-2011 12:41:21

Invité-5
Banni(e)

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Salut,

Pour éviter les questions inutiles peux-tu remplir infodistri dans ton Profil

Amicalement.

#8 04-04-2011 12:54:24

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

C'est fait.

J'ai mis la Squeeze dans mon profil, bien que j'essaie aussi la Testing et la Unstable. Tant que tout ne fonctionne pas correctement, je ne suis pas engagé dans une distribution particulière.

Mon problème n'est toujours pas résolu.

Hors ligne

#9 04-04-2011 15:58:55

Invité-5
Banni(e)

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

e-miel a écrit :

Network controller: Broadcom Corporation BCM4321 802.11a/b/g/n (rev 03)


As-tu essayé d'installer Paquet firmware-brcm 80211 + wireless-tools
http://wiki.debian.org/brcm80211#Squeeze

EDIT : wiki DF

Dernière modification par arien (04-04-2011 17:57:04)

#10 05-04-2011 08:11:57

Quazaban
Membre
Lieu : Lille
Distrib. : Debian Squeeze / Intel Celeron CPU 2.8Ghz
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 19-03-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Moi il me semble que je suis passé par cette page pour mon wifi : http://www.aldeid.com/index.php/Install … enovo-G550

Je suis sur le broadcom 4312

- Samsung NP305V5A / AMD A8 / Windows 7 / Debian pas encore
- Acer T650 (tour) / Intel Celeron / Debian Squeeze et Gnome 2
- Samsung Galaxy Note / Android
- Lenovo ThinkPad T61 / LMDE et Mate

Hors ligne

#11 06-04-2011 23:54:42

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

arien a écrit :

As-tu essayé d'installer Paquet firmware-brcm 80211 + wireless-tools


D'après la page Debian, le paquet firmware-brcm80211 contient les firmware des contrôleurs BCM4314, BCM43224 et BCM43225. J'ai néanmoins essayé de l'installer, ce qui rajoute un dossier dans /lib/firmware/ puis j'ai redémarré, mais toujours rien n'est reconnu.

Quazaban a écrit :

Moi il me semble que je suis passé par cette page pour mon wifi : http://www.aldeid.com/index.php/Install … enovo-G550

Je suis sur le broadcom 4312


Et moi sur BCM4321. Je viens de regarder ta page, elle correspond à ce que j'ai essayé en début de discussion avec module-assistant, donc cela ne fonctionne pas chez moi.

Dernière modification par e-miel (06-04-2011 23:59:15)

Hors ligne

#12 10-04-2011 13:32:01

Quazaban
Membre
Lieu : Lille
Distrib. : Debian Squeeze / Intel Celeron CPU 2.8Ghz
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 19-03-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

test ça

# apt-get update
# apt-get install broadcom-sta-common broadcom-sta-source
# m-a a-i broadcom-sta
# modprobe wl

normalement ça fonctionnera

- Samsung NP305V5A / AMD A8 / Windows 7 / Debian pas encore
- Acer T650 (tour) / Intel Celeron / Debian Squeeze et Gnome 2
- Samsung Galaxy Note / Android
- Lenovo ThinkPad T61 / LMDE et Mate

Hors ligne

#13 10-04-2011 13:49:55

ProgVal
Membre
Lieu : Metz
Distrib. : GNU/Linux Sid
Noyau : Linux 3.2 (amd64)
(G)UI : KDE 4.7 / Gnome 3.4
Inscription : 18-08-2010
Site Web

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Bonjour,

Quazaban a écrit :

# apt-get update
# apt-get install broadcom-sta-common broadcom-sta-source
# m-a a-i broadcom-sta
# modprobe wl


À noter qu'il faut activer le dépôt "non-free".

ProgVal

Hors ligne

#14 10-04-2011 16:33:15

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

@Quazaban : ne serait-ce pas ce que j'ai écrit dans mon premier message ? (sachant que m-a est synonyme de module-assistant et a-i de auto-install)

@ProgVal : j'avais utilisé le dépôt "non-free" (de toute façon ça ne marche pas sans).

Merci quand-même.

Hors ligne

#15 15-04-2011 23:43:05

Invité-5
Banni(e)

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

e-miel a écrit :

je n'arrive pas à faire fonctionner mon contrôleur Wifi.


#11 Et moi sur BCM4321. Installation du Wifi avec le driver officiel Linux Broadcom

Dernière modification par arien (15-04-2011 23:52:22)

#16 16-04-2011 01:28:38

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Je viens de lire ton tutoriel, il parle du pilote officiel Broadcom que j'ai déjà essayé. Néanmoins je viens de retenter en écrivant scrupuleusement les commandes du tutoriel. Il y a quelques différences par rapport à Debian, par exemple ieee80211_crypt_tkip n'existe pas, mais lib80211_crypt_tkip existe, de même que /etc/blacklist que j'ai remplacé par /etc/blacklist.conf et au final... ça ne marche pas. sad

Je crois que je vais continuer comme depuis 3 ans : surfer sous Windows, et utiliser Debian comme plateforme de développement sans réseau.

Un informaticien qui n'arrive pas à surfer sur le net. La honte. tongue

Dernière modification par e-miel (16-04-2011 01:36:33)

Hors ligne

#17 16-04-2011 05:53:26

e-miel
Membre
Distrib. : Squeeze 6.0.3
Noyau : 2.6.32-5-amd64
(G)UI : Xfce 4.6.2
Inscription : 02-04-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

J'ai l'impression que mon installation de Debian était trop sale, à force d'y faire des essais sans toujours réinstaller. À présent ça fonctionne. Il est très important de mettre ssb en liste noire à la fois dans l'arborescence de démarrage et celle du disque-dur:

echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
update-initramfs -u


Télécharger le pilote sur www.broadcom.com/support/802.11/linux_sta.php (choisir 32 ou 64 bits en fonction du système).

tar -xzf pilote.tar.gz
aptitude install linux-headers-2.6-amd64 (dans le cas d'un système 64 bits)
make
make install
depmod


Il ne vous reste plus qu'à nettoyer le bazar (make clean peut en partie vous aider) et à redémarrer.

Hors ligne

#18 16-04-2011 09:00:00

Invité-5
Banni(e)

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Merci pour le retour d'info cool
Apparemment, c'est un bon tuto:
http://linuxmanua.blogspot.com/2009/02/ … river.html

Dernière modification par Invité-5 (30-04-2011 23:15:48)

#19 30-04-2011 11:27:42

Quazaban
Membre
Lieu : Lille
Distrib. : Debian Squeeze / Intel Celeron CPU 2.8Ghz
Noyau : 2.6.32-5-amd64
(G)UI : Gnome 2.30.2
Inscription : 19-03-2011

Re : [Résolu] Je n'arrive pas à faire fonctionner le Wifi (BCM4321)

Je prend note wink

- Samsung NP305V5A / AMD A8 / Windows 7 / Debian pas encore
- Acer T650 (tour) / Intel Celeron / Debian Squeeze et Gnome 2
- Samsung Galaxy Note / Android
- Lenovo ThinkPad T61 / LMDE et Mate

Hors ligne

Pied de page des forums