Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#26 12-07-2011 19:17:01

Invité-5
Banni(e)

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

Salut Martin,

Après vérification, la priorité par défaut de squeeze-backports est de 100. En la mettant à 900 comme tu as fait, tu risques de voir des paquets mis à jour alors que tu ne l'aurais peut-être pas voulu ; tous les dépôts ayant la même priorité. Avec une priorité de 100, on s'assure de prendre seulement ce que l'on veut et on ne touche pas aux paquets.


Merci, je suis au courant depuis le début. C'êtait pour répondre à notre ami :

wlourf a écrit :

dbkblk a écrit :

Si vous souhaitez des mises à jour automatiques de LibreOffice, ajoutez ces lignes dans /etc/apt/preferences (NON TESTE SUR LE LONG TERME.):

Package: libreoffice libreoffice-gnome libreoffice-help-fr
Pin: release n=squeeze-backports
Pin-Priority: 1001


Bonjour,
J'ai installé libre office sur Squeeze grace au tuto du premier post. En revanche, pour les mises à jour, je n'ai pas ce fichier  /etc/apt/preferences (j'ai un dossier vide /etc/apt/preferences.d ). Créer le fichier avec les instructions du tuto sera suffisant pour bénéficier des mises à jour ?


Crois tu que LibreOffice présent un ...... (je ne trouve pas le mot adéquat) et il faut plutôt l'éviter la mise à jour ? Je suis curieux de savoir.

Dernière modification par Invité-5 (13-07-2011 18:48:54)

#27 13-07-2011 02:15:59

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

Salut Darien

Je ne suis pas certain de saisir ce que tu demandes. Libre à nous t'utiliser ou non LibreOffice. Depuis le rachat de Sun par Oracle, Debian a décidé par contre t'intégrer LibreOffice. La disponibilité de celle-ci achève la migration entreprise par le projet Debian. LibreOffice est maintenant disponible dans ses 3 branches. Par conséquent, LibreOffice devient une incontournable.

En ce qui concerne l'utilisation du dépôt backports, je citerai ici Carl Chenet à propos de Squeeze-backports (il exprime très bien ma pensée sur le sujet). On retrouve le détail sur cette page dans les commentaires.

Oui, je vous conseille de les activer et de vous en servir sur les paquets que vous souhaitez voir évoluer un peu plus que ce qui est permis par la Debian Stable en cours. L’application étant plus récente que celle présente par défaut dans Squeeze, vous perdez un peu en stabilité mais vous y êtes parfois contraints par vos besoins. De plus, utiliser les backports est la solution la plus simple, efficace et élégante de faire une petite entorse aux paquets présents par défaut dans Squeeze


Il répondait à une question reliée à l'utilisation d'un serveur, la stabilité étant très importante dans ce cas. Je me dis qu'on peut aussi appliquer ce principe pour sa machine même si ce n'est pas un serveur si la stabilité est importante pour nous. C'est une question de choix perso. On peut aussi décider de prendre un peu plus de risque et de piocher au max dans squeeze-backports et même ailleurs (dans testing par ex) si on désire vraiment avoir plusieurs paquets plus récents. Tout est une question de choix.

Donc, oui j'utilise squeeze-backports mais avec parcimonie. J'installe donc, par exemple, LibreOffice mais je désire seulement que les nouveaux paquets qui y sont reliés soient mis à jour (pas le choix si des dépendances présentes dans la stable et dans squeeze-backports). dans le cas de l'utilisation d'une stable, il n'est pas vraiment pas nécessaire de mettre une priorité de 1001. Le gestionnaire de paquets ne trouvera pas LibreOffice ailleurs. D'où l'idée de mettre une seule priorité pour tout le dépôts squeeze-backports afin d'avoir une mise à jour des paquets issus de ce dépôt.

J'ai écrit tout un tas de trucs qui tu connaissais sûrement déjà sans répondre vraiment à ton interrogation. Dans ce cas, reformule ta pensée. J'y verrais peut-être mieux. Des fois, je comprends vite mais il faut m'expliquer longtemps lol.

Martin

Dernière modification par martinux_qc (13-07-2011 02:36:31)


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#28 13-07-2011 20:41:24

Invité-5
Banni(e)

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

martin_mtl a écrit :

D'où l'idée de mettre une seule priorité pour tout le dépôts squeeze-backports afin d'avoir une mise à jour des paquets issus de ce dépôt.


A vrai dire, je ne sais plus si on parle de l'installer LO facilement sous Squeeze ou des mises à jour automatiques de LibreOffice. Peu importe, tu utilise quelle priorité pour backports ?  cool

Amicalement.

#29 14-07-2011 02:35:50

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

J'ai toujours suivi les instructions sur la page du site des backports. Avec Lenny, priorité de 200 et j'avais toutes les mises à jour des paquets backports. Maintenant, j'ai encore suivi les instructions et mis une priorité de 100. Je verrais bien ce qui arrivera, c'est-à-dire si les mises à jour se feront effectivement (cela doit/devrait être le cas). Comme les mises à jour pour la stable (backports inclus) sont plutôt rares, comparativement à sid, je risque d'attendre un peu longtemps avant de voir la prochaine mise à jour. Je vais par contre suivre l'évolution de LibreOffice pour la stable pour voir quand une version supérieure des paquets backports pour LibreOffice arrivera et m'assurer que les mises à jour se font.

Je parle ici de LibreOffice parce que j'ai très peu de paquets issus du dépôt backports, j'installe seulement le stricte nécessaire. C'est pour cela que je suis les paquets LibreOffice. Mais le raisonnement est le même pour tous les paquets issus de ce dépôt.

"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#30 14-07-2011 08:25:42

Invité-5
Banni(e)

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

Voila, c'est claire, net et sans bavure. Pas besoin de fichier preferences (sans accents) pour squeeze-backports. wink

À consulter :

 $ man apt_preferences

#31 13-09-2012 06:56:42

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

de mon côté, sur un squeeze stable installé par le dvd, après avoir installé les backports, la ligne

apt-get install -t squeeze-backports libreoffice libreoffice-gnome libreoffice-help-fr

n'a pas abouti dans le terminal, avec des mentions de python manquant ou similaire. j'ai alors suivi ce post, ai mis en root :

aptitude -t squeeze-backports install libreoffice-l10n-fr libreoffice-wiki-publisher \
mozilla-libreoffice libreoffice-help-fr libreoffice-gnome libreoffice-emailmerge \
libreoffice-pdfimport libreoffice-style libreoffice



et tout a bien fonctionné. open office a été désinstallé, et libre office français 3.5.4.2 installé à sa place.


"Being is not doing"

Hors ligne

#32 13-09-2012 07:09:09

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

Ah !

Intéressant retour d'expérience jeanmarc1, merci.
Une question me taraude, tu as bien utilisé un terminal root pour la première commande qui n'a pas fonctionnée ?

On va mettre la seconde commande dans le wiki df au chapître traitant de Libre Office. smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#33 13-09-2012 08:20:07

jeanmarc1
Adhérent(e)
Lieu : Vence (06)
Distrib. : Jessie en dual-boot sur portables Dell
Noyau : Linux 3.16.0-4-686-pae
(G)UI : Mate
Inscription : 09-09-2012
Site Web

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

smolski a écrit :

Ah !
Une question me taraude, tu as bien utilisé un terminal root pour la première commande qui n'a pas fonctionnée ?



oui, de mémoire, j'étais bien en root. j'y avais accédé par su. j'ai tenté deux fois la procédure, avant de passer à la seconde.


"Being is not doing"

Hors ligne

#34 13-09-2012 08:48:29

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu/Mode d'emploi] Installer Libreoffice facilement sur Squeeze

OK, merci.

Je tente le coup sur un de mes pc pour voir les deux méthodes afin d'en être sûr.
Perso, il me semble qu'il est préférable de désinstaller OpenOffice d'abord puis installer LibreOffice...
Je te m'en vas voir le tuto df pour tout cela.

Hop hop hop ! big_smile

Edit :
Effectivement, le résultat de ta commande supprime bien openoffice pour installer libreoffice :

# aptitude -t squeeze-backports install libreoffice-l10n-fr libreoffice-wiki-publisher \
> mozilla-libreoffice libreoffice-help-fr libreoffice-gnome libreoffice-emailmerge \
> libreoffice-pdfimport libreoffice-style libreoffice
« libreoffice-style » est un paquet virtuel fourni par :
  libreoffice-style-tango libreoffice-style-oxygen libreoffice-style-hicontrast libreoffice-style-galaxy libreoffice-style-crystal
  libreoffice-style-andromeda
Vous devez en choisir un à installer.
Les NOUVEAUX paquets suivants vont être installés :
  fonts-opensymbol{a} libbase-java-openoffice.org{a} libcommons-codec-java{a} libcommons-httpclient-java{a} libcommons-lang-java{a}
  libjaxp1.3-java-gcj{a} libreoffice libreoffice-base{a} libreoffice-base-core{a} libreoffice-calc{a} libreoffice-common{ab} libreoffice-core{ab}
  libreoffice-draw{a} libreoffice-emailmerge libreoffice-filter-binfilter{a} libreoffice-filter-mobiledev{a} libreoffice-gnome libreoffice-gtk{a}
  libreoffice-help-fr libreoffice-impress{a} libreoffice-java-common{a} libreoffice-l10n-fr libreoffice-math{a} libreoffice-pdfimport
  libreoffice-report-builder-bin{a} libreoffice-style-galaxy{a} libreoffice-style-tango{a} libreoffice-wiki-publisher libreoffice-writer{a}
  libserializer-java-openoffice.org{a} libxerces2-java{a} libxerces2-java-gcj{a} mozilla-libreoffice
Les paquets suivants seront mis à jour :
  uno-libs3 ure{b}
2 paquets mis à jour, 33 nouvellement installés, 0 à enlever et 107 non mis à jour.
Il est nécessaire de télécharger 131 Mo d'archives. Après dépaquetage, 419 Mo seront utilisés.
Les paquets suivants ont des dépendances non satisfaites :
  libreoffice-common: Est en conflit avec: openoffice.org-common (< 1:3.3.0~) mais 1:3.2.1-11+squeeze7 est installé.
  ure: Casse: openoffice.org-core (< 1:3.3~) mais 1:3.2.1-11+squeeze7 est installé.
  libreoffice-core: Casse: mozilla-libreoffice (< 1:3.5.0~beta~) mais 1:3.4.6-2~bpo60+2 doit être installé.
Les actions suivantes permettront de résoudre ces dépendances :

      Supprimer les paquets suivants :                                                                        
1)      gnome-office                                                                                          
2)      openoffice.org                                                                                        
3)      openoffice.org-base                                                                                    
4)      openoffice.org-base-core                                                                              
5)      openoffice.org-calc                                                                                    
6)      openoffice.org-common                                                                                  
7)      openoffice.org-core                                                                                    
8)      openoffice.org-draw                                                                                    
9)      openoffice.org-emailmerge                                                                              
10)     openoffice.org-evolution                                                                              
11)     openoffice.org-filter-binfilter                                                                        
12)     openoffice.org-filter-mobiledev                                                                        
13)     openoffice.org-gcj                                                                                    
14)     openoffice.org-gnome                                                                                  
15)     openoffice.org-gtk                                                                                    
16)     openoffice.org-help-en-us                                                                              
17)     openoffice.org-help-fr                                                                                
18)     openoffice.org-impress                                                                                
19)     openoffice.org-java-common                                                                            
20)     openoffice.org-math                                                                                    
21)     openoffice.org-officebean                                                                              
22)     openoffice.org-report-builder-bin                                                                      
23)     openoffice.org-style-galaxy                                                                            
24)     openoffice.org-style-tango                                                                            
25)     openoffice.org-thesaurus-en-us                                                                        
26)     openoffice.org-thesaurus-fr                                                                            
27)     openoffice.org-writer                                                                                  
28)     python-uno                                                                                            

      Conserver les paquets suivants dans leur version actuelle :                                              
29)     libreoffice-emailmerge [Non installé]                                                                  
30)     mozilla-libreoffice [Non installé]                                                                    

      Laisser les dépendances suivantes non satisfaites :                                                      
31)     gnome recommande gnome-office (= 1:2.30+7)                                                            
32)     openoffice.org-help-en-us recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-en
33)     openoffice.org-help-en-us recommande openoffice.org-java-common                                        
34)     openoffice.org-help-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr  
35)     openoffice.org-help-fr recommande openoffice.org-java-common                                          
36)     openoffice.org-l10n-fr recommande openoffice.org-core (> 1:3.2.1) | language-support-translations-fr  
37)     openoffice.org-writer recommande openoffice.org-filter-binfilter                                      
38)     openoffice.org-writer recommande openoffice.org-java-common (>= 1:3.2.1~)                              
39)     openoffice.org-writer recommande openoffice.org-emailmerge                                            
40)     openoffice.org-writer recommande openoffice.org-math                                                  
41)     libreoffice-writer recommande libreoffice-emailmerge                                                  


Accepter cette solution ? [Y/n/q/?]
 


Je l'ajoute donc ainsi dans le wiki df mais je conserve la désinstallation préalable d'openoffice tout de même.

aptitude purge --purge-unused openoffice.org openoffice.org-common


Puis :

aptitude -t squeeze-backports install libreoffice-l10n-fr libreoffice-wiki-publisher \
> mozilla-libreoffice libreoffice-help-fr libreoffice-gnome libreoffice-emailmerge \
> libreoffice-pdfimport libreoffice-style libreoffice


Je pense que c'est mieux. cool

C'est là :
http://debian-facile.org/logiciel:libre … stallation

Tchibâââ ! lol

Dernière modification par smolski (13-09-2012 10:24:19)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

Pied de page des forums