Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 25-05-2011 17:35:47

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

[Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Bonjour,

Je suis actuellement sous Wheezy, j'ai le logiciel de messagerie instantanée pour MSN qui se nomme Emesene, le problème c'est que la nouvelle version sous Wheezy marche très mal, je voudrais savoir comment installer le Emesene de Squeeze ? Tout du moins est-ce possible ?

Je vous remercie par avance. wink

Dernière modification par Bleryu (25-05-2011 20:58:04)

Hors ligne

#2 25-05-2011 17:59:50

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Salut Bleryu

Oui, tu peux mettre une version d'application de squeeze en ajoutant les sources stable (squeeze) dans ton fichier sources.list.
Tu updates (mise à jour) avant et après ta manip surtout !

aptitude update


Puis tu desinstalles le Emesene qui te gongle et tu installes le Emesene stable en le forçant ainsi :

aptitude -t stable Emesene


Voir le tuto là :
http://debian-facile.org/manuel:command … _un_paquet

Puis là, sur la même page :
Si votre paquet installé est d'une version inférieure à la version de votre branche debian installée (ce qui va être ton cas), vous pouvez le maintenir en place avec la commande :

aptitude hold nom_du_paquet


L'est pas belle la vie, libre ? smile

Dernière modification par smolski (25-05-2011 18:07:13)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 25-05-2011 18:29:56

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Merci ça marche impeccablement !

En installant emesene j'ai plusieurs paquets qui s'installent avec, je dois donc hold tous les paquets venants de Squeeze ou c'est pas grave que les dépendances (venant de Squeeze) se màj ?

Dernière modification par Bleryu (25-05-2011 18:30:23)

Hors ligne

#4 25-05-2011 19:13:41

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : [Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Bonne question que je ne m'était jamais posé.

Jusqu'à présent je ne mettais hold que sur le paquet voulu, pour toi emesene.
Je n'ai jamais eu de problèmes.

Vraiment bonne question!!! smile

Dernière modification par deuchdeb (25-05-2011 19:17:56)

Hors ligne

#5 25-05-2011 19:52:46

Invité-5
Banni(e)

Re : [Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Vraiment bonne question!!! wink


Je crois savoir que cette méthode peut être utile.

La forme particulière affecte une priorité (Pin-Priority) à un paquet précis, à une version précise ou à un intervalle spécifiant plusieurs versions. Par exemple, l'entrée suivante affecte une priorité haute à toutes les versions du paquet emesene dont le numéro de version commence par 1.6. (stable)

fichier /etc/apt/preferences a écrit :

Package: emesene
Pin: version 1.6.3-1
Pin-Priority: 1001

Dernière modification par Invité-5 (25-05-2011 19:54:04)

#6 25-05-2011 20:57:50

Ichigo-Roku
Membre
Lieu : ::1
Inscription : 11-11-2009

Re : [Résolu] Remplacer Emesene Wheezy par Emesene Squeeze...

Ouais bah ça marche impeccablement dans les deux sens, je passe donc en résolu. wink

Hors ligne

Pied de page des forums