Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 28-05-2011 10:27:51

ljere
Membre
Distrib. : xubuntu/openbox 14.04
Noyau : Linux 3.13.0-24-generic
(G)UI : xfce/openbox
Inscription : 23-03-2011

[résolu] gimp ne se lance plus

bonjour je suis en debian wheezy avec le noyau 2.6.38.2-686 i686
lorsque je lance gimp depuis le terminal j'obtiens ce message d'erreur

ljere@debian:~$ gimp

(gimp:29789): GLib-WARNING **: /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0
ljere@debian:~$


j'ai réinstallé gimp libglib2.0-0 libglib2.0-dev et libglib2.0-bin mais ça ne change rien
je ne sais vraiment pas quoi faire

Dernière modification par ljere (30-05-2011 16:24:31)


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba [doc]satellite_c670d-11l[/doc] sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#2 28-05-2011 11:02:45

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [résolu] gimp ne se lance plus

Salut ljere !

La branche debian wheezy est en testing, il arrive que dans la cascade des dépendances, suite à une mise à jour, une application se trouve dépourvue de quelques-unes d'entre elles.
Non pas seulement celles qui sont réclamées, mais celles qui composent et composent et composent encore celle qui est réclamée.
Le choix d'utiliser testing impose de choisir les mises à jour proposée par soi-même et avec le plus grand soin.
C'est pourquoi, pour la gestion positive des paquets, il est vivement conseillé d'utiliser l'application en ligne de commande : aptitude
Voir le tuto :
http://debian-facile.org/manuel:commande_aptitude
Et de valider ou non l'acceptation des mises à jour concernant notamment nos applications installées.

En attendant le retour des dépendances à la norme, sur l'urgence, tu peux ajouter les sources stable à ton fichier sources.list, enlever l'application gimp, forcer l'installation de la version gimp de la stable, et maintenir cette version avec l'option hold, le temps que la version en testing se recompose...

Tout ça est dans le même tuto aptitude !
Et oui, c'est super. wink

À noter que les versions buguées sous la branche sid sont souvent recomposées plus rapidement que les versions sous testing dans le même état ! big_smile

Amitié, Joel

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 28-05-2011 11:18:35

dbkblk
Membre
Distrib. : Debian Wheezy 64bits
Noyau : 3.2
(G)UI : Gnome 3.2
Inscription : 24-10-2010

Re : [résolu] gimp ne se lance plus

(Aussi, si tu débutes sur Debian, je te conseille d'utiliser stable et de piocher seulement les logiciels que tu veux à jour dans wheezy (chose que tu ne pouvais pas faire sur Ubuntu mais qui rend Debian magique! : http://debian-facile.org/manuel:configuration:pinning)

M. Gandhi: "C'est une erreur de croire nécessairement faux ce qu'on ne comprend pas."
C'est quoi ce bordel ?

Hors ligne

#4 28-05-2011 14:06:31

ljere
Membre
Distrib. : xubuntu/openbox 14.04
Noyau : Linux 3.13.0-24-generic
(G)UI : xfce/openbox
Inscription : 23-03-2011

Re : [résolu] gimp ne se lance plus

hello smolski j'ai essayé ta méthode en squeeze et en sid ça ne fonctionne pas
je pense que ça vient de la lib mais comme elle a énormément de dépendance je vais donc attendre n'utilisant que rarement gimp ce n'est pas très grave j'ai même trouvé un alternatif gpaint
d'après mes recherches le bug semble connu donc il finira par être résolu
@dbkblk je connais cette possibilité merci mais je préfère rester sur wheezy

Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba [doc]satellite_c670d-11l[/doc] sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

#5 28-05-2011 17:41:33

Invité-5
Banni(e)

Re : [résolu] gimp ne se lance plus

Regardes, que-ce que j'ai comme message avec la version libglib2 2.28.6-1(testing)

ddd@squeeze:~$ gimp

(gimp:6515): GLib-WARNING **: /tmp/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0


Bien évidemment gimp ne fonctionne pas. Je reviens de suite à la version 2.24.2-1(stable)

#6 30-05-2011 16:23:59

ljere
Membre
Distrib. : xubuntu/openbox 14.04
Noyau : Linux 3.13.0-24-generic
(G)UI : xfce/openbox
Inscription : 23-03-2011

Re : [résolu] gimp ne se lance plus

yop voila du nouveau j'ai de nouveau gimp qui fonctionne malgres

ljere@debian:~$ gimp
(gimp:29761): GLib-WARNING **: /build/buildd-glib2.0_2.28.6-1-i386-A3fp41/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0


le souci c'est que j'ai fait tellement de manip que je ne sais pas ce qui l'a réellement résolu
mais je pense à libgegl et libbabl que j'ai réinstallé suite à ce message

ljere@debian:~$ gimp
gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory
ljere@debian:~$ gimp
gimp: error while loading shared libraries: libbabl-0.0.so.0: cannot open shared object file: No such file or directory


j'espère que ça pourra servir wink


Modérateur d'ubuntu-fr.org
athlon 2800+, nvidia FX5200 et 2 Go de ram et sempron 3000+, ati radeon et 1 Go de ram sur voyager 12.04 32 bit
Toshiba [doc]satellite_c670d-11l[/doc] sur openbox/xubuntu 14.04 64 bit
Mon Blog et Une découverte

Hors ligne

Pied de page des forums