Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 24-06-2011 16:42:05

foliolur
Membre
Inscription : 24-06-2011
Site Web

Service Pxe sous débian [Probléme de boot]

Bonjour.
Après plusieurs jours de recherche,je passe de votre coté pour trouver une solution.
Voici l’exposé du problème :

Dans le cadre d'une formation je cherche à mettre en place un serveur PXE
monté sous Debian R6. Le but est de déployer des images d'os Microsoft.

N'étant pas un utilisateur régulier de Linux, j'ai condensé plusieurs tutoriaux disponible sur le net.

Voici la config :

Maquette hébergée sous Vmware workstation

Un serveur debian R6 :
Services installés : DHCP / TFTP / PXE / APACHE / SAMBA

Description des fichiers :

Interfaces -> /etc/network/interfaces

# the loopback
auto lo
iface lo inet loopback

#eth0
iface eth0 inet static
address 192.0.0.1
netmask 255.255.0.0
network 192.0.0.1
broadcast 192.0.0.255
gateway 192.0.0.1


Dhcpd.conf -> /etc/dhcp/dhcpd.conf

option domain-name "Workgroup";
option domain-name-servers 192.0.01;
option subnet-mask 255.255.0.0;
option routers 192.0.0.1;

default-lease-time 3600;
max-lease-time 8600;

subnet 192.0.0.0 netmask 255.255.0.0
{
range 192.0.0.2 192.0.0.254;
option routers 192.0.0.1;
next-server 192.0.0.1;
filename "pxelinux.0;"
autoritative;
}


Pxe.conf -> /etc/pxe.conf

#interface to use
interface=eth0
default_address=192.0.0.1

#multicast
multicast_address=192.0.0.0

#mtftp info
mtftp_adresse=192.0.0.1
mtftp_client_port=1758
mtftp_server_port=1759

[...]

#tftpd base dir
tftpbase=/tftpboot

#domain name
domain=Workgroup


Arborescence tftpboot

/tftpboot
      pxe
      pxelinux.0
      pxelinux.cfg

pxe = Images des OS

pxelinux.cfg contient le fichier default (Ne sert qu'à titre de test)

LABEL local
      localboot 0
LABEL linux
      kernel vmlinuz
      append initrd=initrd.gz


_____________________________________________________________________________________


Le problème viens de :
Boot sur la machine cliente = Dhcp répond (Attribution d'adresse ok)
TFTP  ne répond pas Error : File not found

Je suis à la recherche de solution, si vous avez des idées.
Si il manque des infos dites le moi que je puisse vous fournir le nécessaire.

Amicalement,

Hors ligne

#2 22-07-2011 14:50:14

ostyll
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.0.0-1-amd64
(G)UI : Gnome 2.30.2
Inscription : 13-05-2010

Re : Service Pxe sous débian [Probléme de boot]

Bonjour foliolur,

En faite ta je crois que ta oublier de configurer le fichier conf de tftp qui se situe dans /etc/default/tftpd-hpa.
Dans l'option tftp_directory que devra définir ton répertoire tftpboot donc dans ton cas la valeur serait /tftpboot, puis redémarre le service /etc/init.d/tftpd-hpa restart.

Amicalement.

Hors ligne

Pied de page des forums