Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 07-07-2011 08:35:42

dok
Membre
Distrib. : jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME
Inscription : 02-02-2010

[Resolu]pb eclipse xml

Bonjour,

J'ai installé eclipse via synaptics et récupéré un projet développé sous eclipse windows.

Eclipse me remonte une erreur sur le fichier web.xml : Referenced file contains errors (http://java.sun.com/j2ee/dtds/web-app_2_3.dtd).

<?xml version="1.0" encoding="ISO-8859-1"?>

    <!DOCTYPE web-app
      PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
      "http://java.sun.com/j2ee/dtds/web-app_2_3.dtd">

Le problème semble provenir de la ligne DOCTYPE, si je la supprime, plus d'erreur
Mais j'ai besoin de cette ligne

Comment corriger ?

J'ai installé le plugin tomcat pour eclipse mais rien n'y change.

Dernière modification par dok (07-07-2011 09:48:30)

Hors ligne

#2 07-07-2011 09:47:52

dok
Membre
Distrib. : jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME
Inscription : 02-02-2010

Re : [Resolu]pb eclipse xml

Je me réponds

Il manquait des plugins

Bizarre qu'ils ne soient pas installés par défaut sous linux comme sous windows

Hors ligne

#3 07-07-2011 10:01:36

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Resolu]pb eclipse xml

Salut dok et merci du retour et du résolu.

Toutefois, peux-tu détailler ce :

Il manquait des plugins


Yop ? smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#4 07-07-2011 10:09:25

dok
Membre
Distrib. : jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME
Inscription : 02-02-2010

Re : [Resolu]pb eclipse xml

le problème est que j'ai rajouté pleins

mais dans intall new softwares

prendre JST Server UI, JST Server Adapters, JST Server, Eclipse XSL Developer Tools, Eclipse XML, Eclipse Java EE, Eclipse Java Web

Parmi cela, il a mis les plugins manquants

Hors ligne

#5 07-07-2011 12:00:16

firebird
Membre
Distrib. : wheezy/sid
Noyau : 3.2.0
(G)UI : Gnome 3.2/Awesome
Inscription : 03-06-2009
Site Web

Re : [Resolu]pb eclipse xml

Juste comme ça, les IDE style Eclipse et Netbeans, datent vraiment dans les dépôts, même en sid. Mieux vaut directement installer ces IDE depuis les installateurs disponible sur leur site respectif.

Pas d'GPL, pas d'logiciels!

Hors ligne

#6 07-07-2011 13:34:59

dok
Membre
Distrib. : jessie
Noyau : Linux 3.16.0-4-amd64
(G)UI : GNOME
Inscription : 02-02-2010

Re : [Resolu]pb eclipse xml

J'ai downloadé la dernière version Indigo sur le site d'Eclipse et j'ai eu le même problème

Peut-être était-ce dû au fait que je suis en 64 bits, mais j'y crois moyen

Hors ligne

Pied de page des forums