Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 14-07-2011 16:28:57

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

[Résolu] Soucis de proxy après passage de Lenny à Squeeze

Bonjour à tous,
Je rencontre un soucis que j'ai mis du temps à isoler, depuis mon passage de Lenny à Squeeze.
Je dirais pour commencer, que cet upgrade s'est plutôt bien déroulée.

Je ramouille depuis Lundi, à raison d'1 à 2 h par jour pour traiter les dommages collatéraux de cet upgrade.

J'ai donc réussi à régler les soucis de Shorewall, de Postfix, de Imap et d'Egroupware, mais je bloque sur Squid3.

Sous lenny, j'avais installé le proxy Squid3 et Squidguard.
Pour la petite histoire, c'est à cause de mon fils qui avait formaté son PC pour virer le contrôle parental lol que je suis passé avec un serveur sous Debian, et également pour avoir un agenda partagé avec un Webmail perso.

Avant de démarrer, je tenais à préciser que j'étais à jour de tous les paquets et mise à niveau de sécurité sous Lenny.
J'ai fait ma mise à jour de distribution.
Après avoir une distrib qui fonctionne (surtout Egroupware qui ne voulait pas redémarrer), je ne pouvais plus me connecter à itunes depuis mon PC ou mon iphone en wifi.
Via le reseau data du telephone, cela fonctionne.

De plus, impossible de me connecter à un site (sur le serveur ou en dehors, sur le net) s'il utilise le protocole https.
Je précise que le proxy n'est pas transparent.

Si dans la config windows, je décoche le proxy pour les protocoles https, cela fonctionne.
En revanche, depuis l'iphone, rien (il utilise le proxy pour tous les protocoles), ce qui explique que je cherche à passer par le proxy pour le https (en plus de la mise en cache qui accélère la restitutions des pages).

La version de Squid est la 3.1.6

Avez vous une piste ?
Merci par avance

Dernière modification par kuch (15-07-2011 15:33:25)

Hors ligne

#2 14-07-2011 16:52:17

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Salut kuch,

Je rencontre un soucis que j'ai mis du temps à isoler, depuis mon passage de Lenny à Squeeze.


Pour upgrader de lenny à squeeze, il est conseillé d'utiliser l'outil apt-get plutôt que aptitude, il n'est peut-être pas trop tard pour le faire, au cas où...

Amitié, Joel


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#3 14-07-2011 17:07:22

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Bonjour et merci de votre reponse.
C'est ce que j'ai fait, et en mode console en plus !
j'ai fait, en root:
/etc/init.d/gdm stop

puis, je me suis logué root
ensuite, apt-get update
aucune erreur signalée, donc:
apt-get upgrade

changement des sources pour passer de Lenny à squeeze

apt-get install linux-image-2.6.686
apt-get install udev

redémarrage
apt-get dist-upgrade

une fois l'ensemble redémarré correctement,
upgrade-from-grub-legacy

apt-get autoremove
et enfin
apt-get install gdm3

Bizarrement, je n'ai pas eu de soucis pour passer de mysql server 5.0 à 5.1, mais a côté, quel bordel...
C'est pas très grave, c'est formateur de fouiller les fichiers log et de faire disparaitre les error ou warning 1 à 1.

Reste ce soucis de Squid3...

Voici le fichier de config:

# Attention si vous modifiez les valeurs de la ligne suivante : lancez squid3 -f /etc/squid3/squid.conf -z pour reconstruire le cache !

cache_dir ufs /var/spool/squid3 1024 256 256

# Les journaux
cache_access_log /var/log/squid3/access.log common
cache_log /var/log/squid3/cache.log
cache_store_log /var/log/squid3/store.log
cache_swap_log /var/log/squid3/cache_swap.log
emulate_httpd_log on

# Page en francais
error_directory /usr/share/squid-langpack/fr

acl manager proto cache_object
acl localhost src 127.0.0.1/32
acl to_localhost dst 127.0.0.0/8
#acl serveur dst 192.168.10.20
acl LocalNet src 192.168.10.0/24
acl SSL_ports port 443
acl Safe_ports port 80    # http
acl Safe_ports port 82    # http
acl Safe_ports port 85    # http
acl Safe_ports port 21    # ftp
acl Safe_ports port 443   # https
acl Safe_ports port 441   # https
acl Safe_ports port 70    # gopher
acl Safe_ports port 210   # wais
#acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280   # http-mgmt
acl Safe_ports port 488   # gss-http
acl Safe_ports port 591   # filemaker
acl Safe_ports port 777   # multiling http
acl Safe_ports port 10000 # port pour webmin
acl CONNECT method CONNECT

#ports pour la radio
acl Safe_ports port 554  
acl Safe_ports port 1755 
acl Safe_ports port 5000
acl Safe_ports port 7070

#ports pour mediatomb
acl Safe_ports port 1900
acl Safe_ports port 49152

#ports pour teamspeak
acl Safe_ports port 14534 #tcp
acl Safe_ports port 51234 #tcp
acl Safe_ports port 8767  #udp

http_access allow manager localhost
http_access deny manager
http_access allow localhost
http_access allow LocalNet
#http_access allow serveur
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow all
icp_access allow all

http_port 3128

hierarchy_stoplist cgi-bin ?

acl QUERY urlpath_regex cgi-bin \?
cache deny QUERY
refresh_pattern ^ftp:   1440  20% 10080
refresh_pattern ^gopher:  1440  0%  1440
refresh_pattern .   0 20% 4320
icp_port 3130
coredump_dir /var/spool/squid3

url_rewrite_program /usr/bin/squidGuard -c /etc/squid/squidGuard.conf
url_rewrite_children 5

Dernière modification par kuch (14-07-2011 17:28:38)

Hors ligne

#4 14-07-2011 17:18:11

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Je ne peux t'aider là, mais tu peux mettre l'ensemble de la configuration que tu indiques entre les crochets code, tu as l'applet (les crochets<>) sur la fenêtre de rédaction, cela est bien plus pratique pour le lire sur le forum.

Hop ! smile

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#5 14-07-2011 17:19:25

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Juste une question, tu à été voir dans tes .log sa peut être utilise pour trouver une piste.

Après perso je suis pas très Squid, car mes cours sur Squid remonte à un baill est du coup j'ai pas vraiment pratiquer le Squid.

Mais bon une petite lecture dans tes log, sa peut aider déjà, surtout quant il parle de ssl ou https.
Je pense qu'il doit y avoir eu une modification de le conf par défaut d'une version vers l'autre peut être.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#6 14-07-2011 17:29:10

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

smolski a écrit :

Je ne peux t'aider là, mais tu peux mettre l'ensemble de la configuration que tu indiques entre les crochets code, tu as l'applet (les crochets<>) sur la fenêtre de rédaction, cela est bien plus pratique pour le lire sur le forum.

Hop ! smile


Hop, c'est fait.
Désolé, je savais pas.
Milles excuses.

Hors ligne

#7 14-07-2011 17:46:55

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

kuch peut tu nous donner le résulat de la commande

tai l-50 /var/log/squid3/access.log


et

tail -50 /var/log/squid3/cache.log


Sa peut être cool de voir ou sa bloque.

Dernière modification par chiwawa (14-07-2011 17:50:08)


Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

#8 14-07-2011 17:53:25

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Pour le:

tai l-50 /var/log/squid3/access.log


voilà le résultat:

192.168.10.31 - - [14/Jul/2011:17:38:11 +0200] "CONNECT particuliers.societegenerale.fr:443 HTTP/1.1" 500 0 TCP_MISS:NONE
192.168.10.13 - - [14/Jul/2011:17:41:37 +0200] "GET http://crt.comodoca.com/UTNAddTrustServerCA.crt HTTP/1.1" 200 1505 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:37 +0200] "GET http://crt.ovh.net/OVHLowAssuranceSecureCA.crt HTTP/1.1" 200 1643 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:37 +0200] "GET http://crt.comodoca.com/UTNAddTrustServerCA.crt HTTP/1.1" 200 1505 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:37 +0200] "GET http://crt.ovh.net/OVHLowAssuranceSecureCA.crt HTTP/1.1" 200 1643 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:51 +0200] "GET http://crt.comodoca.com/UTNAddTrustServerCA.crt HTTP/1.1" 200 1505 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:51 +0200] "GET http://crt.ovh.net/OVHLowAssuranceSecureCA.crt HTTP/1.1" 200 1643 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:51 +0200] "GET http://crt.comodoca.com/UTNAddTrustServerCA.crt HTTP/1.1" 200 1505 TCP_HIT:NONE
192.168.10.13 - - [14/Jul/2011:17:41:51 +0200] "GET http://crt.ovh.net/OVHLowAssuranceSecureCA.crt HTTP/1.1" 200 1643 TCP_HIT:NONE
192.168.10.31 - - [14/Jul/2011:17:43:58 +0200] "CONNECT particuliers.societegenerale.fr:443 HTTP/1.1" 500 0 TCP_MISS:NONE
192.168.10.31 - - [14/Jul/2011:17:44:06 +0200] "GET http://debian-facile.org/forum/index.php HTTP/1.1" 200 22091 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:06 +0200] "GET http://debian-facile.org/forum/style/spacefun.css HTTP/1.1" 304 254 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:06 +0200] "GET http://debian-facile.org/forum/style/imports/base.css HTTP/1.1" 304 254 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:06 +0200] "GET http://debian-facile.org/forum/style/imports/spacefun_cs.css HTTP/1.1" 304 254 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:06 +0200] "GET http://debian-facile.org/forum/img/df_bleu_test.png HTTP/1.1" 304 255 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:11 +0200] "GET http://debian-facile.org/forum/viewforum.php? HTTP/1.1" 200 23522 TCP_MISS:DIRECT
192.168.10.31 - - [14/Jul/2011:17:44:13 +0200] "GET http://debian-facile.org/forum/viewtopic.php? HTTP/1.1" 200 28920 TCP_MISS:DIRECT


Pour le:

tail -50 /var/log/squid3/cache.log


Voilà la réponse:

2011/07/14 17:37:44| Starting Squid Cache version 3.1.6 for i486-pc-linux-gnu...
2011/07/14 17:37:44| Process ID 14257
2011/07/14 17:37:44| With 65535 file descriptors available
2011/07/14 17:37:44| Initializing IP Cache...
2011/07/14 17:37:44| DNS Socket created at 0.0.0.0, FD 7
2011/07/14 17:37:44| Adding domain lan from /etc/resolv.conf
2011/07/14 17:37:44| Adding domain lan from /etc/resolv.conf
2011/07/14 17:37:44| Adding nameserver 192.168.1.254 from /etc/resolv.conf
2011/07/14 17:37:44| helperOpenServers: Starting 5/5 'squidGuard' processes
2011/07/14 17:37:44| Unlinkd pipe opened on FD 22
2011/07/14 17:37:44| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
2011/07/14 17:37:44| Swap maxSize 1048576 + 262144 KB, estimated 100824 objects
2011/07/14 17:37:44| Target number of buckets: 5041
2011/07/14 17:37:44| Using 8192 Store buckets
2011/07/14 17:37:44| Max Mem  size: 262144 KB
2011/07/14 17:37:44| Max Swap size: 1048576 KB
2011/07/14 17:37:44| Version 1 of swap file with LFS support detected...
2011/07/14 17:37:44| Rebuilding storage in /var/spool/squid3 (CLEAN)
2011/07/14 17:37:44| Using Least Load store dir selection
2011/07/14 17:37:44| Set Current Directory to /var/spool/squid3
2011/07/14 17:37:44| Loaded Icons.
2011/07/14 17:37:44| Accepting  HTTP connections at 0.0.0.0:3128, FD 26.
2011/07/14 17:37:44| Accepting ICP messages at 0.0.0.0:3130, FD 27.
2011/07/14 17:37:44| HTCP Disabled.
2011/07/14 17:37:44| Squid modules loaded: 0
2011/07/14 17:37:44| Adaptation support is off.
2011/07/14 17:37:44| Ready to serve requests.
2011/07/14 17:37:44| Store rebuilding is 75.43% complete
2011/07/14 17:37:44| Done reading /var/spool/squid3 swaplog (5429 entries)
2011/07/14 17:37:44| Finished rebuilding storage from disk.
2011/07/14 17:37:44|      5429 Entries scanned
2011/07/14 17:37:44|         0 Invalid entries.
2011/07/14 17:37:44|         0 With invalid flags.
2011/07/14 17:37:44|      5429 Objects loaded.
2011/07/14 17:37:44|         0 Objects expired.
2011/07/14 17:37:44|         0 Objects cancelled.
2011/07/14 17:37:44|         0 Duplicate URLs purged.
2011/07/14 17:37:44|         0 Swapfile clashes avoided.
2011/07/14 17:37:44|   Took 0.05 seconds (100968.96 objects/sec).
2011/07/14 17:37:44| Beginning Validation Procedure
2011/07/14 17:37:44|   Completed Validation Procedure
2011/07/14 17:37:44|   Validated 10883 Entries
2011/07/14 17:37:44|   store_swap_size = 107608
2011/07/14 17:37:45| storeLateRelease: released 0 objects
2011/07/14 17:38:11| comm_open: socket failure: (97) Address family not supported by protocol
2011/07/14 17:43:58| comm_open: socket failure: (97) Address family not supported by protocol

Hors ligne

#9 14-07-2011 18:12:47

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

Ca y est, j'ai trouvé grâce à vous!

Voici ce qui m'a mis la puce à l'oreille:

comm_open: socket failure: (97) Address family not supported by protocol


J'ai donc cherché sur le net et j'ai trouvé un post qui dit:

Squid opens IPv4/IPv6 hybrid sockets to receive and send both v4 and v6
traffic in one socket for simplicity and ease of transition. If that fails
like in your case it falls back to IPv4-only sockets.

I recommend re-enabling IPv6 socket capability in your OS.


J'ai donc réactivé l'IPV6, updaté grub et relancé le serveur.

Maintenant tout est OK!

Merci encore à tous de m'avoir guidé.

Kuch

Hors ligne

#10 14-07-2011 18:34:31

chiwawa
Membre
Distrib. : Débian Satable
Noyau : Celui présent dans la dernière stable
(G)UI : Gnome 3
Inscription : 18-04-2009

Re : [Résolu] Soucis de proxy après passage de Lenny à Squeeze

De rien les log sont fait pour sa, ces le premier truc à regarder avant les fichiers de conf d'ailleurs.

Tous mes PC sont sous Débian maintenant.
Poste mobile => ASUS M51S.
Poste fixe => PROC AMD double cœur + 4 go de ram + 3 disques en raid 5 + disque système (un jour ce sera un ssd promis).

Hors ligne

Pied de page des forums