Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-07-2011 14:38:16

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

[RESOLU]Accents non gérés en TTY

Plop plop plop,

Faisons simple, faisons bref :

problème: en TTY, caractère bizarre (les accents). Pas de souci en console graphique.

Ce que j'ai fait : reconfigurer les locales, aucun changement 

~$ locale
LANG=fr_FR.utf8
LC_CTYPE="fr_FR.utf8"
LC_NUMERIC="fr_FR.utf8"
LC_TIME="fr_FR.utf8"
LC_COLLATE="fr_FR.utf8"
LC_MONETARY="fr_FR.utf8"
LC_MESSAGES="fr_FR.utf8"
LC_PAPER="fr_FR.utf8"
LC_NAME="fr_FR.utf8"
LC_ADDRESS="fr_FR.utf8"
LC_TELEPHONE="fr_FR.utf8"
LC_MEASUREMENT="fr_FR.utf8"
LC_IDENTIFICATION="fr_FR.utf8"
LC_ALL=


Une p'tite aide ?

Merci beaucoup,
Debiannement,
Magiccerbere

[RESOLU] En installant les pilotes propriétaires de la carte graphique (pour une autre raison). Merci.

Dernière modification par magiccerbere (03-09-2011 15:06:34)


Plop

Hors ligne

#2 26-07-2011 15:13:19

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

Essaye ça :

~$ aptitude install console-tools


Si tu polishes ta caisse elle brille !

Hors ligne

#3 26-07-2011 22:33:10

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

GutsBlack a écrit :

Essaye ça :

~$ aptitude install console-tools


Je l'ai installé... et maintenant il n'y a rien qui s'affiche quand je tape des é ou è, mais par contre, les lettres avec accents déjà affichées sont toujours bizarres...


Plop

Hors ligne

#4 26-07-2011 23:00:16

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

ok maintenant dans /etc/console-tools/config tu met les lignes :

SCREEN_FONT=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz
SCREEN_FONT_vc2=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz
SCREEN_FONT_vc3=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz
SCREEN_FONT_vc4=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz
SCREEN_FONT_vc5=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz
SCREEN_FONT_vc6=/usr/share/consolefonts/Lat15-TerminusBold16.psf.gz


Si tu polishes ta caisse elle brille !

Hors ligne

#5 26-07-2011 23:15:13

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

J'ai bien rajouté ces lignes, mais, même après un redemarrage, cela ne change pas... (par contre, il y a à nouveau quelque chose qui s'affiche lorsque j'appuis sur les é, è en console : toujours les mêmes caractères bizarres...).

Merci de t'y interesser.

Magiccerbere

P.S: Au fait, j'a bien aimé ton post sur Gnome 3.

Plop

Hors ligne

#6 26-07-2011 23:19:19

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

Merci !
Chez moi ça a résolu mon problème. Ha si j'ai fait un dernier truc j'ai activé GRUB_GFXMODE dans /etc/default/grub

Si tu polishes ta caisse elle brille !

Hors ligne

#7 26-07-2011 23:28:20

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Je l'ai activé (enlever le diez qui était devant) (la phrase complète est : GRUB_GFXMODE=640x480) et puis j'ai fait un

update-grub


. Toujours pas d'accents...

hmm

Magiccerbere, qui vous souhaite bonne nuit.


Plop

Hors ligne

#8 27-07-2011 10:19:12

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

Tu es bien sur TTY 1 ? Sinon lance:

unicode_start


Si tu polishes ta caisse elle brille !

Hors ligne

#9 27-07-2011 17:32:56

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Oui, je suis bien sur TTY 1.

unicode_start
unicode_start: Already in UTF8 mode


hmm


Plop

Hors ligne

#10 27-07-2011 20:18:32

Invité-5
Banni(e)

Re : [RESOLU]Accents non gérés en TTY

Une question => pourquoi spécifiquement en tty1 et pas les autres (tty 2,3,4 etc..)
Perso, problème inconnue chez moi.

#11 27-07-2011 21:04:45

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Le problème est le même sur toutes les TTY...

Il n'y a qu'en mode graphique où je ne n'ai pas ce souci.

Plop

Hors ligne

#12 27-07-2011 23:02:41

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

Darien a écrit :

Une question => pourquoi spécifiquement en tty1 et pas les autres (tty 2,3,4 etc..)
Perso, problème inconnue chez moi.


Parce que unicode_start démarre avant les autres tty2,3, 4... et donc il n'applique l'utf-8 que sur tty1.


Si tu polishes ta caisse elle brille !

Hors ligne

#13 27-07-2011 23:04:47

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

magiccerbere a écrit :

Le problème est le même sur toutes les TTY...

Il n'y a qu'en mode graphique où je ne n'ai pas ce souci.


Pour la différence mode graphique et tty c'est normal ce n'est pas la même chose.  Mais je ne vois pas pourquoi ça ne marche pas chez toi :'(

Et si tu augmentes la résolution du GFXMODE ? (moi je suis en 1280x1024)


Si tu polishes ta caisse elle brille !

Hors ligne

#14 28-07-2011 07:49:49

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Bon... Toujours pas de changement. Merci tout de même pour ton aide et d'avoir pris du temps pour regarder...

J'ai qu'a avoir mon système en anglais, et toc ! (je plaisante évidemment, ce serait bête que Debian se limite à ceux parlant anglais, même si l'utilisation des TTY n'est non plus pas la priorité pour bon nombre de gens... mais pour moi, si !).

Si quelqu'un a une illumination sur ce souci...

Magiccerbere

Plop

Hors ligne

#15 28-07-2011 09:38:23

GutsBlack
Membre
Lieu : Marseille
Distrib. : Testing (Wheezy)
Noyau : 2.6.39+35.1: amd64
(G)UI : Gnome 2.30
Inscription : 22-07-2011

Re : [RESOLU]Accents non gérés en TTY

Donne moi ça :

cat /etc/locale.gen | grep fr


cat /etc/environnement


Si tu polishes ta caisse elle brille !

Hors ligne

#16 28-07-2011 10:24:15

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Accents non gérés en TTY

sous squeeze :

$ cat /etc/environment
$


et non environn [large]e[/large] ment par l'autocomplement.
Bien que présent, le fichier est vide.

Idem en root smile

Dernière modification par smolski (28-07-2011 10:26:29)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#17 28-07-2011 11:01:24

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

~$ cat /etc/locale.gen | grep fr
# fr_BE ISO-8859-1
# fr_BE.UTF-8 UTF-8
# fr_BE@euro ISO-8859-15
# fr_CA ISO-8859-1
# fr_CA.UTF-8 UTF-8
# fr_CH ISO-8859-1
# fr_CH.UTF-8 UTF-8
# fr_FR ISO-8859-1
fr_FR.UTF-8 UTF-8
# fr_FR@euro ISO-8859-15
# fr_LU ISO-8859-1
# fr_LU.UTF-8 UTF-8
# fr_LU@euro ISO-8859-15
# fr_FR.UTF-8 UTF-8


cat /etc/environment : rien n'apparaît.

Dans les locales, j'ai effectivement plein d'intrus... Mais quand je fais locale, tout est en UTF-8...

Est-ce grave, docteur ?

Magiccerbere


Plop

Hors ligne

#18 28-07-2011 11:14:17

eol
Membre
Inscription : 03-09-2009

Re : [RESOLU]Accents non gérés en TTY

Bonjour,
Est-ce que le paquet console-common est installé ?
Chez moi, c'est lui qui fournit /etc/init.d/keymap.sh qui lance unicode_start.

Dernière modification par eol (28-07-2011 11:16:39)

Hors ligne

#19 28-07-2011 12:44:56

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [RESOLU]Accents non gérés en TTY

locale pour mi :

# cat /etc/locale.gen | grep fr
# fr_BE ISO-8859-1
# fr_BE.UTF-8 UTF-8
# fr_BE@euro ISO-8859-15
# fr_CA ISO-8859-1
# fr_CA.UTF-8 UTF-8
# fr_CH ISO-8859-1
# fr_CH.UTF-8 UTF-8
# fr_FR ISO-8859-1
# fr_FR.UTF-8 UTF-8
# fr_FR@euro ISO-8859-15
# fr_LU ISO-8859-1
# fr_LU.UTF-8 UTF-8
# fr_LU@euro ISO-8859-15
fr_FR.UTF-8 UTF-8


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

En ligne

#20 28-07-2011 13:53:24

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

eol a écrit :

Bonjour,
Est-ce que le paquet console-common est installé ?
Chez moi, c'est lui qui fournit /etc/init.d/keymap.sh qui lance unicode_start.


Oui, il est installé.

Pour le locale, je l'avais affiché au tout début de ce topic...

Magiccerbere


Plop

Hors ligne

#21 08-08-2011 17:39:10

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Mmmh... Toujours pas d'idées ?

Plop

Hors ligne

#22 08-08-2011 17:47:17

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [RESOLU]Accents non gérés en TTY

Yep!

Donnes nous le resultat de :

cat /etc/default/locale
LANG=fr_FR.UTF-8


J'ai eu divers déconvenues également avec la gestion des locales, principalement sous root d'ailleurs.

Pour palier, j'ai brutalement complété :

$ cat /etc/environment
LANG=fr_FR.UTF-8
LANGUAGE=fr_FR.UTF-8
LC_ALL=fr_FR.UTF-8


@+

Zoroastre.

Hors ligne

#23 09-08-2011 20:12:08

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Salut Zoroastre74,

Merci pour ta réponse.

# cat /etc/default/locale
#  File generated by update-locale
LANG=fr_FR.UTF-8


J'ai rajouté les trois lignes que tu m'as dit dans /etc/environment
Pas de changement (mais je n'ai pas redémarré, je me suis juste déconnecté de TTY.) (je fais les modification en console graphique, mais je ne pense pas que cela change quelque chose...).


Plop

Hors ligne

#24 10-08-2011 00:02:07

zoroastre74
Membre
Distrib. : Debian Wheezy
Noyau : Linux 3.2
(G)UI : Awesome wm v3.4.13 (Octopus)
Inscription : 28-08-2010

Re : [RESOLU]Accents non gérés en TTY

Yep!

Si si un redemarrage est necessaire.

La liste des locales dans /etc/locale.gen est relativement exhaustive.

Ceci serait plus pertinent :

cat /etc/locale.gen | grep -v '#'


puis tout simplement en utilisateur et en tty :

locale


cat /etc/default/console-setup


Et pour finir :

dpkg -l | grep font


Aprés tu peux essayer de modifier certain paramètre de la console avec :

setupcon -v


setupcon --help
Usage: setupcon [OPTION] [VARIANT]
Sets up the font and the keyboard on Linux console.

  -k, --keyboard-only  setup the keyboard only, do not setup the font
  -f, --font-only      setup the font only, do not setup the keyboard
      --force          do not check whether we are on the console
  -v, --verbose        explain what is being doing, try it if s.t. goes wrong
      --save           copy the font and the console map in /etc/console-setup,
                         update /etc/console-setup/cached.kmap.gz
      --save-only      only save; don't setup keyboard/font immediately
                         (implies --force)
  -h, --help           display this help and exit

If VARIANT is not specified setupcon looks for the configuration files
(in this order) ~/.console-setup and if this doesn't exist then the
combination/etc/default/keyboard + /etc/default/console-setup.  When
a VARIANT is specified then setupcon looks for the configuration files
~/.console-setup.VARIANT and /etc/default/console-setup.VARIANT.


@+

Zoroastre.

Dernière modification par zoroastre74 (10-08-2011 00:21:55)

Hors ligne

#25 18-08-2011 17:19:41

magiccerbere
Membre
Distrib. : Wheezy
Noyau : Noyau Linux 3.2.0-4-686-pae
(G)UI : Gnome 3.4.2
Inscription : 07-08-2008

Re : [RESOLU]Accents non gérés en TTY

Plop,

Merci Zoroastre, les choses avancent !

Avec

setupcon -v


j'ai droit aux accents ! Alléluia.... Mais... après un redémarrage, c'est à nouveau la même chose...
Comment faire pour sauvegarder cela ?

Merci.

P.S: Désolé du temps que j'ai pris pour répondre.


Plop

Hors ligne

Pied de page des forums