Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 26-08-2011 23:20:08

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

[Résolu] Xorg et Fglrx : No screen found

Bonsoir voilà je vous expose mon problème, j'ai installé les pilotes proprio de ATI (wiki debian.org), l'installation s'est bien passé... et au moment d'éditer automatiquement un fichier xorg.conf par la commande : aticonfig --initial

il me retourne ca

aticonfig: No supported adapters detected


Je pige pas trop ce que ca veur dire... Bon pas grave je me dis que je vais en éditer un moi même dans etc/X11... j'en récupére un trés minimaliste, je renseigne le driver fglrx, le BusID ect...

Je reboot et lance le serveur X et la il me dit : No screen Found...

J'ai cherché sur google mais j'avoue sécher devant ce probléme...

Alors je viens vers vous en espérant trouver une solution...

voici mon xorg.conf

Section "Device"
  Identifier  "ATI Technologies Inc RC480 [Radeon Xpress 200M]"
  Driver    "fglrx"
  BusID   "PCI:1:5:0"
EndSection


Merci

Dernière modification par capolino (01-09-2011 17:14:15)

Hors ligne

#2 27-08-2011 07:51:35

Invité-5
Banni(e)

Re : [Résolu] Xorg et Fglrx : No screen found

Pour pouvoir obtenir un xorg.conf minimal vous devez:

    Passer sur un tty (pas dans un pseudo-terminal sous X) avec Alt+CTRL+F1 (Alt+F7 pour revenir en graphique…)
    Passer root (via su)
    Arrêter le serveur X si il était en fonction mais mal configuré

# invoke-rc.d gdm3 stop


Toujours en tant que root lancez cette commande

# Xorg -configure


Vous obtiendrez en sortie un fichier /root/xorg.conf.new

Il ne reste plus qu'à copier notre nouveau fichier là où il doit se trouver:

 #cp /root/xorg.conf.new /etc/X11/xorg.conf


Et à relancer notre serveur X

# invoke-rc.d gdm3 start


Et voila, si ça veut rire vous voila prêt à vous logguer. Sinon :

# reboot

Dernière modification par Invité-5 (03-10-2011 00:01:55)

#3 29-08-2011 13:37:05

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Xorg et Fglrx : No screen found

Merci pour les infos... j'ai reussi à me faire un vrai xorg.conf... De plus j'ai vraiment l'impression d'avoir gagné en fluidité avec le xorg.conf tout neuf... Avant sur internet quand je défilais les pages, ca saccadait maintenant c'est fluide... Malheureusement quand je passe en driver proprio "fglrx" ca me met toujours No Screen Found... Bon c'est pas grave... je verrai ca plus tard...

merci pour le wiki de xorg
A bientot

Hors ligne

#4 29-08-2011 17:58:36

Invité-5
Banni(e)

Re : [Résolu] Xorg et Fglrx : No screen found

#5 01-09-2011 17:13:47

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Xorg et Fglrx : No screen found

Oui je vais mettre résolu même si j'en suis au même point... Je souhaitais passer sous les drivers proprio pour ensuite installer compiz-fusion, mais en regardant le site officiel, je me suis rendu compte que compiz ne marche pas avec quelques cartes graphique : dont la mienne qui est une ATI xpress 200, famille des RS480 avec un PCI ID de 1002...

Je mets le lien pour ceux qui sont dans le même sac que moi.... où qui le seront lol !

Site officiel de compiz

Hors ligne

#6 01-09-2011 21:28:47

Invité-5
Banni(e)

Re : [Résolu] Xorg et Fglrx : No screen found

Tout "marche" sous Debian ! As tu vu la date de ton lien ?
Hardware/Blacklist (dernière édition le 2010-05-06 17:02:56 par Soreau)

#7 02-09-2011 07:29:36

Thuban
Modérateur
Distrib. : OpenBSD
Noyau : current
(G)UI : xfce ou dwm
Inscription : 09-01-2009
Site Web

Re : [Résolu] Xorg et Fglrx : No screen found

Est-tu sur que ta carte est supportée par fglrx ?
http://wiki.debian.org/ATIProprietary#Supported_Devices
Sinon, le pilote radeon et le paquet firmware-linux-nonfree est pour toi :
http://wiki.debian.org/AtiHowTo

YA3HGA-H

Hors ligne

#8 04-09-2011 19:09:17

capolino
Membre
Lieu : On Earth
Distrib. : Wheezy (64bit)
Noyau : 3.1
(G)UI : Gnome 3
Inscription : 09-08-2011

Re : [Résolu] Xorg et Fglrx : No screen found

Merci... j'ai installé firmware-linux-nonfree et suivit le howto cité plus haut... et tout à l'air en place... j'ai même testé avec glxgears et les roues tournent bien... avec glxinfo les direct rendering affiche yes... tout à l'air opérationel... j'ai plus qu'a peaufiner avec les options...
Merci à tous... cette fois c'est résolu.... big_smile

Hors ligne

Pied de page des forums