Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 12-09-2011 14:24:29

skn
Membre
Inscription : 30-11-2010

Probleme d'accès internet (LAN via serveur Linux en passerelle)

Bonjour,

Voila il se trouve que je dispose d'un réseau LAN composé de 5 postes sous XP, un serveur Linux qui fait office de filtrage avec squid et une Livebox pour la connexion Internet.

Il se trouve que depuis le déplacement de la salle informatique ainsi que de la Livebox, mes postes sous XP n'ont plus d'accès a internet dans les nouveaux locaux, pourtant la configuration est resté la même.

Configuration des postes du LAN :

- Le serveur de filtrage a en passerelle la livebox
- Les postes ont en passerelle le serveur de filtrage
- Les DNS sur chaque poste sont les DNS d'orange 194.2.0.20 et 194.2.0.50

Cette configuration fonctionnait avant le changement et permettait au poste de naviguer sur internet sans problème )

- Le serveur de filtrage à en passerelle la livebox : 192.168.1.1 (classique), en complément squid3 est installé pour assurer le filtrage et la livebox est déclaré dans le fichier resolv.conf

nameserver 192.168.1.1


Ce qui marche :

- Le serveur ping bien la livebox ainsi que google.fr
- Le serveur ping bien les poste du LAN et inversement
- Les postes ping bien le serveur ainsi que la livebox
- Lorsque la box est mise en passerelle sur les postes, cela fonctionne sans problème seulement les postes doivent être filtré via le serveur Linux

Ce qui ne marche pas sur les postes :

- Navigation sur internet
- Ping sur google.fr : message suivant l'hôte de destination n'a pas pu être trouvé
- Ping sur le DNS google ne fonctionne pas non plus
Code:

ping 8.8.8.8


Pouvez vous s'il vous plait me dire pourquoi cela ne marche pas alors que la configuration actuel fonctionnait avec l'ancienne Livebox ? Comment résoudre le problème ?? L'installation de Bind9 est elle nécessaire ??

Merci beaucoup de votre aide et de vos réponses

Hors ligne

#2 20-09-2011 13:19:39

kuch
Membre
Distrib. : Squeeze Poweredge 2600 et Mint11 LMDE Aspire 5736Z
(G)UI : Gnome dans les deux cas
Inscription : 14-07-2011

Re : Probleme d'accès internet (LAN via serveur Linux en passerelle)

Bonjour,
j'ai à peu près la même config, mais elle fonctionne.

Quelques questions:
Vous avez bien deux cartes réseau dans la passerelle ? (je sais, c'est c.n comme question, mais on peut faire avec une seule si on bidouille.
La passerelle est-elle en IP fixe (attribuée par la livebox)?
Les postes sous XP sont-ils eux aussi en IP fixe ?

Il me semble que pour moi, la configuration est:
eth0, connecté à la passerelle, adresse ip fixe attribuée par la livebox, dans le même sous réseau 192.168.1.x
C'est la passerelle qui donne les DNS.

eth2, connecté au swich sur lequel sont les divers bidules connectés au net.
Les adresses ip sont fixes, distribuées par le serveur (attribuées selon l'adresse MAC) et le DNS est l'IP de la Box (mais je vérifierais ça ce soir).
L'intérêt de  mettre la passerelle en serveur DHCP (qui écoute sur l'interface eth2), c'est que les clients ont toujours la même ip, du coup pour le filtrage, c'est facile et configurable poste à poste.
Sinon, comment faites vous la personnalisation des droits d'accès par poste?

Cordialement
Kuch

Hors ligne

#3 20-09-2011 16:34:09

paskal
autobahn
Lieu : ailleurs
Inscription : 14-06-2011
Site Web

Re : Probleme d'accès internet (LAN via serveur Linux en passerelle)

Bonjour.

skn a écrit :

Il se trouve que depuis le déplacement de la salle informatique ainsi que de la Livebox, mes postes sous XP n'ont plus d'accès a internet dans les nouveaux locaux, pourtant la configuration est resté la même.


skn a écrit :

Pouvez vous s'il vous plait me dire pourquoi cela ne marche pas alors que la configuration actuel fonctionnait avec l'ancienne Livebox ?


Pour bien préciser les choses : la Livebox a-t-elle été seulement déplacée ou en est-ce une autre ?


I'd love to change the world
But I don't know what to do
So I'll leave it up to you...

logo-sur-fond.png

Hors ligne

Pied de page des forums