Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 22-09-2011 09:18:20

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Clé USB (NTFS)

Bonjour à tous,


Je viens de passé en testing.
J'ai une clé formatée au format ntfs mais voilà je m'apperçoi qu'il m'est impossible de la monter et je crois que cela est normal.  (ntfs-3g et fuse)
Je ne sais pas si cela vaut bien la peine de me lancer la dedans. J'ai trouvé une combine en utilisant l'utilitaire Gparted qui en se lançant en root à l'option monter vers dev/usb*
Je laisse comme cela ?

La seule contrainte, si je supprime un dossier sur cette clé, la suppression ne passe pas par le .trash  mais par une suppression définitive.

Merci par avance.

Dernière modification par golgot200 (22-09-2011 09:20:32)


L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#2 22-09-2011 09:41:14

Haricophile
Adhérent(e)
Lieu : Pignans (Var)
Distrib. : SID
Noyau : 4.0.0-1-amd64
(G)UI : Mate / i3 selon...
Inscription : 14-09-2009

Re : Clé USB (NTFS)

D'abord vérifier à quel groupe appartiens l'utilisateur (droit de monter les disques). Dans gnome système -> administration -> utilisateurs et groupes.

Ensuite un système ntfs a besoin d'être propre pour être monté automatiquement ( pour corriger ntfsfix ou chkdsk dans windows qui est plus complet ).

Pour la corbeille, c'est probablement un problème de droits http://wiki.cyclotronp.net/doku.php/lin … /corbeille

Si tu utilise toujours la même clé, tu as peut-être intérêt à ajouter une ligne dans fstab en utilisant l'uuid, ce qui permet de fixer les droits et caractéristiques du montage (point de montage, umask etc.) Si tu veux le modifier pour toutes les clés, voir plutôt les règles udev.

« La religion et l'art sont les luxes des lâches, qui permettent de fuir la réalité quand elle devient trop difficile à affronter. La différence c'est que la religion transforme tout mensonge en vérité alors que l'art transforme toute vérité en mensonge. »

Hors ligne

#3 22-09-2011 10:02:32

golgot200
Membre
Lieu : AIN
Distrib. : Debian Jessie
Noyau : Linux debian 3.16.0-4-amd64
(G)UI : MATE
Inscription : 05-08-2007

Re : Clé USB (NTFS)

Bonjour,
Merci de ton aide.
Ma clé passe sur ma debian squeeze, mon portable avec ubuntu et autres.
Juste un pc avec une Wheezy.
Ce n'est pas un problême de droits, tout est OK
Le FAT32 se monte bien. Je la repasse en NTFS est voilà et je suis pas le seul apparement :

Impossible de monter Système de fichiers 16 GB
Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged

...

L'ultime question ... l'intelligence a besoin de la bêtise pour s'affirmer, la beauté a besoin de la laideur pour resplendir, le courage nait dans la peur, les forts impressionnent au millieu des faibles, mais au final,... qui a donc besoin d'autant de connards ?

Hors ligne

#4 08-01-2012 18:01:58

xSonnyx
Membre
Distrib. : Wheezy
Noyau : 3.1.0-1-amd64
(G)UI : Gnome 3
Inscription : 31-10-2011

Re : Clé USB (NTFS)

Je remonte le topic car j'ai le même message d'erreur que dans le message ci dessus :

Impossible de monter Elements

Error mounting: mount exited with exit code 1: helper failed with:
Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://tuxera.com/community/ntfs-3g-faq/#unprivileged


Comment aller vérifier les droits car sous gnome 3 je ne peux pas faire de "système -> administration -> utilisateurs et groupes."?

Voici quelques infos :

# fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00040170

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048   468553727   234275840   83  Linux
/dev/sda2       468555774   488396799     9920513    5  Extended
/dev/sda5       468555776   488396799     9920512   82  Linux swap / Solaris

Disk /dev/sdb: 1000.2 GB, 1000202043392 bytes
255 heads, 63 sectors/track, 121600 cylinders, total 1953519616 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00025607

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048  1953519615   976758784    7  HPFS/NTFS/exFAT


# cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
UUID=2668890b-a139-4c76-a4ef-bd623cb36d67 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=19a675d8-53f2-49e8-9804-296fb0fac452 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
/dev/sdc1       /media/usb1     auto    rw,user,noauto  0       0

Hors ligne

#5 08-01-2012 18:05:50

xSonnyx
Membre
Distrib. : Wheezy
Noyau : 3.1.0-1-amd64
(G)UI : Gnome 3
Inscription : 31-10-2011

Re : Clé USB (NTFS)

Pour préciser je suis également sous testing Wheezy et sur mon autre pc ubuntu cela se passe sans soucis.

Hors ligne

#6 08-01-2012 19:22:26

xSonnyx
Membre
Distrib. : Wheezy
Noyau : 3.1.0-1-amd64
(G)UI : Gnome 3
Inscription : 31-10-2011

Re : Clé USB (NTFS)

Problème résolu pour ma part (usbmount n'était pas installé hmm).

Hors ligne

#7 08-01-2012 20:14:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : Clé USB (NTFS)

xSonnycx,

Sympa et merci du retour !
toutefois, on ne bernacle pas le problème des autres :
Voir ici :
http://debian-facile.org/atelier:bernacle

Tchibâââ ! lol

"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#8 09-01-2012 01:15:18

xSonnyx
Membre
Distrib. : Wheezy
Noyau : 3.1.0-1-amd64
(G)UI : Gnome 3
Inscription : 31-10-2011

Re : Clé USB (NTFS)

Oups tongue je recommencerai plus, promis smile

Hors ligne

#9 06-05-2012 14:43:00

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Clé USB (NTFS)

Merci pour le retour.

J'avais le même problème avec un Disque dur USB et l'installation de usbmount à résolu le problème. smile

Hors ligne

#10 26-05-2012 20:20:06

deuchdeb
Moderato ma non troppo
Lieu : Pays de Cocagne
Distrib. : Jessie 8 + backports
Noyau : linux-image-3.16
(G)UI : KDE4.14 - Mate
Inscription : 13-01-2010

Re : Clé USB (NTFS)

J'ai eu encore le même problème suite à une autre installation.

Je n'ai pas utilisé usbmount, j'ai supprimé les lignes suivantes qui ont été créées lors de l'installation dans le fstab.

/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0
/dev/sdc1       /media/usb1     auto    rw,user,noauto  0       0

Attention aux disques usb branchés pendant l'installation et au support d'installation avec clef usb.

Et tous mes disques usb montent automatiquement comme simple utilisateur.

Dernière modification par deuchdeb (26-05-2012 20:21:01)

Hors ligne

#11 10-01-2013 22:40:37

pili36
Membre
Lieu : Lille
Distrib. : Debian Jessie / Raspbian Jessie
Noyau : 3.16_amd64 / 3.16_armhf
(G)UI : Mate / Lxde
Inscription : 03-11-2009

Re : Clé USB (NTFS)

Voilà j'ai le même problème aussi avec ce même message d'erreur.

xSonnyx,

Cette solution fonctionne en effet même si je ne comprends pas bien pourquoi, puisque sans ce paquet usbmount, ils montent quand même les clés/disque dur externe en FAT16 ou 32?

J'ai donc regardé la solution de deuchdeb, et en effet j'avais le même type de lignes à la fin de mon fstab, :

/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
/dev/sdb1       /media/usb0     auto    rw,user,noauto  0       0



Après avoir commenté ces 2 lignes puis supprimé usbmount, le montage se fait maintenant normalement pour les périphériques en NTFS. Petit retour pour confirmer que la solution proposée par deuchdeb fonctionne.

Golgot200, je pense qu'un Résolu dans le titre serait le bienvenu, sauf si bien sur cela n'a pas fonctionné pour toi smile

Merci à tous,


Debian Jessie Amd64, Mate, Lenovo G50, Amd Q4000 4*1,3Ghz, 4Go RAM, Amd Radeon R3
Debian Jessie Amd64, (pour Steam), Mate, Amd Athlon 860K 4*3.7Ghz, 8Go RAM, AMD Radeon R7 250 2Go
Raspbian Jessie Armhf, Lxde, Raspberry Pi model B

Hors ligne

Pied de page des forums