Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 04-03-2008 14:39:46

werewolf
Membre
Inscription : 04-03-2008

[Resolu] Installation Driver nvidia pour GeForce 8400 GS

Bonjour tout le monde

Je me dirige vers vous car depuis plus d'une semaine j'essaye d'installer le driver grphique nvidia pour ma GeForce 8400 GS sur debian amx64

J'ai télécharger la dernière version de debian sur le site, je l'ai graver et installer avec succès, mais je reste en mode console, j'ai lu plusieurs articles sur le sujet mais j'ai vite été perdu dans la foule d'information et d'installation différent en fonction des version

c'est mes tout premiers pas dans le monde de linux, j'ai réinstaller debian à 5 reprise car à chaque tentative pour installer le driver je tombe sur un ecran allumer mais noir et impossible de taper des commandes, donc obliger de réinstaller

Je viens de terminer l'installation de debian, j'ai donc une version propre, et je viens à vous pour savoir si quelqu'un pourrait m'expliquer les étapes à suivre pour installer ce driver

j'ai fait plusieurs forum ou tous me redirigeait vers des topic ou il y'avait 50 pages en me disant cherche la dedans tu devrai trouver mais en vain, des lignes de codes non expliquer, des fichier modifier pour je ne sais quel raison, la réponse la plus pertinante que j'ai eu à été "C'est tout le problème des driver propriétaire" ce qui ne ma pas vraiment aider

j'ai envie d'apprendre et de connaitre le monde libre mais ce faire balader partout en te disant cherche et tu trouvera c'est pas très motivant ni instructif.

Donc si quelqu'un pouvait m'aider à installer le driver je le remercie d'avance
walter

Dernière modification par werewolf (05-03-2008 19:31:02)

Hors ligne

#2 04-03-2008 16:02:59

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

Salut et bienvenu parmi nous

Avant de penser au driver proprio de ta carte graphique, je te suggère d'installer une serveur X fonctionnel avec des drivers libres (nv dans ton cas) .

Ils ne tireront pas parti de la puissance de ta carte graphique, mais tu disposeras déjà de quelque chose d'un peu plus sexy (encore que j'aime beaucoup la ligne de commande wink  )

Une fois cette étape franchie avec succès, et un X11 fonctionnel, tu pourras envisager de passer à l'étape suivante en posant les driver proprio.

La méthode que je te propose n'est pas la plus "propre" (au sens où elle va surement installer quelques paquets dont tu n'as pas forcément besoin), mais elle a le mérite d'être simple:

apt-get install xorg


Il va sans dire que tu auras également besoin d'un x-window-manager (desktop environnement)  pour que ce soit confortable (le choix t'appartient et il est vaste: gnome, kde, xfce, openbox, fluxbox...)

EDIT --> je veins de lire ca

werewolf a écrit :

je tombe sur un ecran allumer mais noir et impossible de taper des commandes, donc obliger de réinstaller


Essai de rebasculer dans uen console pure (alt+ctl+F1 ou F2 ou F3 ou F4), tu devrais retrouver une invite de commande.

Dernière modification par freddec (04-03-2008 16:05:14)


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#3 04-03-2008 18:28:11

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

j'ai donc recommencer un nouvelle installation
j'ai taper en root

apt-get install xorg


réponse xorg is already the newest version

Hors ligne

#4 04-03-2008 20:17:45

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

Salut et bienvenue wink

As tu installé un window manager?

Hors ligne

#5 04-03-2008 20:22:04

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

comme gnome ?, il est fourni sur le DVD de debian si je ne me trompe pas big_smile

Hors ligne

#6 04-03-2008 20:52:33

palmito
Administrateur
Lieu : Dans la boite de gâteau!
Distrib. : bah....
Noyau : heu...
(G)UI : gné?
Inscription : 28-05-2007

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

Oui comme gnome par exemple. S'il est installé tente un "startx"

Hors ligne

#7 04-03-2008 21:03:28

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

# startx


me retourne la même erreur que lors du démarrage du pc

* Le démarrage du serveur X ( votre interface graphique ) à échoué. Il est probable qu'il ne soit pas configuré correctement

Hors ligne

#8 04-03-2008 22:33:27

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

le message d'erreur exacte est

(EE) No devices detected


d'apres ce que j'ai pu trouver le problème concerne bien la carte graphique non ?

Hors ligne

#9 05-03-2008 02:11:36

Melodie
Modérateur
Lieu : Pyrénées
Inscription : 28-05-2007
Site Web

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

startx pas en root  mais en user. (Ne faut-il pas un fichier .xinitrc configuré dans le /home utilisateur ?)

et que dit le log de xorg ?

cat /var/log/Xorg.0.log | grep EE


le blog d'une newbie :: Linuxvillage :: Bentovillage


À propos de l'OS dominant ::> “Il est plus facile de berner les gens que de leur faire admettre qu'ils ont été bernés” (trad d'une citation approximative de Mark Twain)

Hors ligne

#10 05-03-2008 12:08:21

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

As tu repondu lors de l'installation de xorg a des question sur ton matériel (écran, carte graphique, souris, clavier etc...)

sinon relance la configuration du serveur X, en root

#dpkg-reconfigure xserver-xorg


Sinon, regarde dans le fichier /etc/X11/xorg.conf (qui est le fichier de conf généré par la commande ci dessus)
Cherche la section "Device"
Ci dessous la mienne (mais ne t'en sers pas de base, c'est juste pour visualiser)

Section "Device"
    Identifier     "nVidia Corporation C51 [GeForce 6150 LE]"
    Driver         "nvidia"
    Option    .....


Sur la ligne Driver (là ou j'ai "nvidia") commence par mettre "vesa", c'est le pilote de base minima des cartes graphiques, théoriquement toutes les cartes fonctionnent avec ce pilote.
Relance X voir si ça marche, si ça marche pas essai de voir quelle erreur tu as (avec la commande donnée par Mélodie)

Ensuite essai avec "nv" qui est le pilote libre des cartes nvidia (ne gère pas la 3D) et relance X etc...

Dernière modification par freddec (05-03-2008 12:10:15)


Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#11 05-03-2008 15:39:38

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

bonjour tout le monde

Tout d'abord merci d'avoir prix le temps de me répondre

Alors voilà, j'ai passer ma version etch en version lenny dans mon sources.list

# apt-get update
# apt-get dist-upgrade


et hop le problème c'est résolu tout seul, j'ai l'immense plaisir de voir l'interface graphique s'afficher big_smile

Ce problème est résolu big_smile
Toutte fois j'ai un autre petit souci concernant la connexion internet

Je suis chez télé2 belgique
en mode console la connexion s'effectue puisque j'ai pu télécharger les paquets lenny, mais en mode graphique je lance le navigateur web, mais j'ai toujours le message suivant
"Impossible de trouver l'adresse www.debian.org, Vérifier que vous êtes connecter à internet et que l'adresse existe"

Comment puis-je configurer ma connexion ( qui s'effectue via la box télé2 belgique ) ?
d'avance merci de votre aide

Hors ligne

#12 05-03-2008 18:51:04

freddec
homo-informaticus du genre linuxo-debianicum
Lieu : Saint Jean d'Y (17)
Distrib. : Branche Stable (Jessie)
Noyau : Linux 3.16.0-4-amd64
(G)UI : XFCE_4.1 (+/- Mate) (+/- Cinnamon)
Inscription : 09-01-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

Re
Merci
1- De mettre Resolu dans le premier post de ce thread
2- D'ouvrir un nouveau post ou on va se perdre wink

3-Une amorce de réponse
T'aurai pas un problème de DNS ?

essai de pinger
A- Google via une IP --> ping 64.233.187.99
B- Google par son nom --> ping google.com

Si le 1 passe et pas le 2, alors tu as problème de config de ton DNS
Passe nous alors le contenu de /etc/network/interfaces

Desktop: Jessie (I5 - 16Go)
Laptop 1: Jessie (HP DV9000, 3Go)
Laptop 2: Jessie (PackardBell TS 44, Core I5, 4Go)
EeePC : Jessie (Atom N450, 2 Go)

Hors ligne

#13 05-03-2008 19:32:11

werewolf
Membre
Inscription : 04-03-2008

Re : [Resolu] Installation Driver nvidia pour GeForce 8400 GS

resolu aussi wink

me suis connecter en root et définit une IP fixe et hop tout marche big_smile
Encore merci de votre aide

Hors ligne

Pied de page des forums