Debian-facile

Bienvenue sur Debian-Facile, site d'aide pour les nouveaux utilisateurs de Debian.

Vous n'êtes pas identifié(e).

#1 03-11-2011 20:47:14

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

[Résolu] Accès à disque dur externe USB

Salut,

Ancien utilisateur d'ubuntu, j'ai passé le cap pour apprendre un peu plus et configurer à mon envie le système.
J'ai donc installé une Debian sid avec openbox + pcmanfm et jusqu'à présent tout roule correctement même si j'ai pas encore tout réglé par faute de temps.

Après cette installation j'avais réglé un problème de permission d'accès à mon disque dur externe en bidouillant un fichier.
En mettant à jour mon système récemment je me suis retrouvé à nouveau avec ce problème de ne plus pouvoir accéder à mon disque dur externe que par le biais de root. Quand j'essaie d'y accéder via mon utilisateur normal il me met :

Erreur à l'ouverture du répertoire « /media/PASTEQUE » : Permission non accordée


J'ai cherché sur les forums et le wiki qui parle tous du fichier /etc/fstab/ or je ne me souviens pas avoir modifié ce fichier la première fois que j'ai eu ce problème, mais plutôt un fichier beaucoup plus dense qui gérait les permissions selon les utilisateurs et les groupes mais je ne me souviens plus du tout de quel fichier il s'agit. Si quelqu'un a des infos pour m'éclairer  et régler mon problème merci.

Pour info, c'est un disque externe de 500Go en NTFS voici également le contenu de mon fichier fstab :

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda3 during installation
UUID=b1832a2d-06cf-43bf-9c6d-6e79c9f6c96e /               ext4    errors=remount-ro 0       1

# swap was on /dev/sda5 during installation
UUID=9197a8c0-b1c6-46e7-a126-7c482685a2a1 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0

Dernière modification par tibo (22-11-2011 21:14:20)

Hors ligne

#2 03-11-2011 20:59:49

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Accès à disque dur externe USB

Salut tibo et bienvenue sur df !

Les permissions se règlent par la ligne de commande dans un terminal root en utilisant les commandes chown pour la propriété et chmod pour les droits.

Voir le wiki df pour les tutos sur les noms en gras.

Tu peux user de la commande :

ls -l


Pour les déterminer en l'état (droits et permissions) voir ls.

Hop ! smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#3 03-11-2011 21:36:34

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Merci, du coup je viens d'essayer la commande suivante en pensant que ça me donnerait les droits pour y accéder :

chmod -R 777 /media/PASTEQUE/


sauf que non ça n'a pas voulu. Est-ce que j'ai fait faux quelque part ?

Hors ligne

#4 03-11-2011 22:00:13

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Accès à disque dur externe USB

indique le résultat de la commande :

ls -l /media/PASTEQUE


Avec le disque externe monté bien sûr smile

Pour monter manuellement un disque externe, la commande mount en root.

Yep ! smile


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#5 03-11-2011 22:06:56

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Ben je suppose que je n'ai pas besoin de le monter manuellement vu que je peux y accéder sans problème avec pcmanfm en root.

la commande ls -l sur mon disque me donne :

total 836
-rw------- 1 root root 218946 mai   21  2009 2656.jpg
-rw------- 1 root root  32805 mars  25  2009 37385717_m.jpg
-rw------- 1 root root  35846 mars  25  2009 37385822_m.jpg
-rw------- 1 root root 124711 août  27 17:57 bookmarks-2011-08-27.json
-rw------- 1 root root 240037 sept. 12 19:07 bookmarks.html
drwx------ 1 root root   4096 août  26 22:41 Candidatures
-rw------- 2 root root  36681 déc.  29  2007 can't survive without ur blaster.jpg
drwx------ 1 root root  24576 mars  24  2011 claire_sauvegardeMes documents
drwx------ 1 root root   8192 sept. 26 18:55 Documents
-rw------- 1 root root    939 déc.  21  2008 Favorites.xml
-rw------- 1 root root  18705 sept. 24  2008 frondeur-oaxaca.jpg
drwx------ 1 root root      0 juil. 23  2010 HHC
drwx------ 1 root root  20480 nov.   1 21:57 images
drwx------ 1 root root   4096 sept. 30 18:52 jeux
drwx------ 1 root root   4096 août  31  2008 music
drwx------ 1 root root      0 sept. 28 23:33 $RECYCLE.BIN
drwx------ 1 root root      0 févr.  7  2010 RECYCLER
drwx------ 1 root root   4096 août  27 17:58 Sauvegarde ordi maison
drwx------ 1 root root      0 juin  16  2010 save
drwx------ 1 root root   4096 févr.  7  2010 System Volume Information
-rw------- 1 root root   7168 déc.   9  2009 Thumbs.db
drwx------ 1 root root  36864 oct.  22 14:13 to be checked
drwx------ 1 root root  12288 sept. 28 22:37 videos

Hors ligne

#6 04-11-2011 01:36:51

martinux_qc
Administrateur
Lieu : Montréal (Québec)
Distrib. : Sid
Noyau : Linux 4.7.0-1-amd64
(G)UI : XFCE 4.12
Inscription : 12-10-2008

Re : [Résolu] Accès à disque dur externe USB

tibo a écrit :

Pour info, c'est un disque externe de 500Go en NTFS


Tu as installé le paquet ntfs-3g ?


"L'éducation vise à former des citoyens pas trop tatas et non pas à envoyer le plus de tatas possible à l'université."
Pierre Foglia (Journaliste à la retraite à La Presse)
Note : au Québec, le mot tata a un sens péjoratif qui sert à désigner une personne un peu idiote ou insignifiante. D'où les expressions familières : Espèce de grand, de gros tata! Être, avoir l'air tata.

Hors ligne

#7 07-11-2011 20:07:31

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

martin_mtl a écrit :

tibo a écrit :

Pour info, c'est un disque externe de 500Go en NTFS


Tu as installé le paquet ntfs-3g ?


Oui le paquet est bien installé.

Je viens d'essayer avec le gestionnaire de paquet Thunar et j'ai la même erreur et mon utilisateur est bien dans le groupe plugdev.

Dernière modification par tibo (07-11-2011 20:26:38)

Hors ligne

#8 07-11-2011 21:44:19

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

salut


normal, on voit bien que seul root peut accéder, lire et écrire sur ce disque

cette commande va te rendre 'propriétaire' de ton disque dur externe.

# chown -R nom_utilisateur /media/PASTEQUE

Hors ligne

#9 07-11-2011 22:40:15

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

nikau a écrit :

salut


normal, on voit bien que seul root peut accéder, lire et écrire sur ce disque

cette commande va te rendre 'propriétaire' de ton disque dur externe.

# chown -R nom_utilisateur /media/PASTEQUE


J'avais déjà essayé cette commande mais elle ne marche pas.
Donc il y a un problème au niveau des accès mais je sais plus trop où chercher et j'aimerais bien retrouvé le fichier que j'avais modifié.

Hors ligne

#10 07-11-2011 22:46:00

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

tibo a écrit :

nikau a écrit :

salut


normal, on voit bien que seul root peut accéder, lire et écrire sur ce disque

cette commande va te rendre 'propriétaire' de ton disque dur externe.

# chown -R nom_utilisateur /media/PASTEQUE


J'avais déjà essayé cette commande mais elle ne marche pas.
Donc il y a un problème au niveau des accès mais je sais plus trop où chercher et j'aimerais bien retrouvé le fichier que j'avais modifié.


comment ça elle ne marche pas ? tu peux indiquer le message d'erreur ?

Hors ligne

#11 07-11-2011 23:01:47

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Elle marche mais n'a pas d'effets.
Après avoir fait cette commande en root, j'essaye d’accéder à mon dd via mon user normal et ça me met encore le message d'erreur "permission non accordée.

Hors ligne

#12 07-11-2011 23:21:23

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

tibo a écrit :

Elle marche mais n'a pas d'effets.
Après avoir fait cette commande en root, j'essaye d’accéder à mon dd via mon user normal et ça me met encore le message d'erreur "permission non accordée.


que renvois la commande    id   ?    (en login utilisateur et non root)

Hors ligne

#13 07-11-2011 23:31:43

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Ça donne ça :

uid=1000(tibo) gid=1000(tibo) groupes=1000(tibo),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),105(bluetooth),108(netdev)

Hors ligne

#14 07-11-2011 23:55:36

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

tibo a écrit :

Ça donne ça :

uid=1000(tibo) gid=1000(tibo) groupes=1000(tibo),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),105(bluetooth),108(netdev)


rajoute ces 2 là  dialout et tape

usermod -g dialout tibo
usermod -g tape tibo

(je crois qu il faut fermer et réouvrir session pour prise en compte , vérifie)

Hors ligne

#15 08-11-2011 00:43:09

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Ça n'a rien changé même après un reboot.

Hors ligne

#16 08-11-2011 03:23:15

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Accès à disque dur externe USB

Salut tibo,

Tu as listé de nouveau le disque avec la commande :

ls -l


Méthode à jojo :
Perso, je démonterai la partition ntfs avec umount
identifier le disque avec fdisk en premier :

fdisk -l
umount /dev/partition_ntfs_identifiée


créer avec mkdir en root un répertoire de montage dans /media :

mkdir /media/disk_ntfs


donner les droits user à ce répertoire et son contenu avec chown :

chown user:user -R /media/disk_ntfs


monter la partition ntfs du disque dans le répertoire créé avec mount :

Edit : wink
Mauvais :
mount /dev/partition_ntfs
Bon :

mount -t ntfs /dev/partition_ntfs


donner les droits user sur la partition montée avec chown :

chown user:user -R /media/disk_ntfs


et tant qu'à faire y définir les droits avec chmod :

chmod 775 -R /media/partition_ntfs


un petit listage pour finir...

ls -l /media/disk_ntfs


À moins d'un truc dans la partition windows qui ne permettrai pas tout ça, je pense que cela devrait le faire.

Bref, je me passerai de pcmanfm sur ce coup.

Ce n'est qu'une suggestion, je n'utilise pas pcmanfm perso... smile

Hop !

Dernière modification par smolski (08-11-2011 11:50:30)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#17 08-11-2011 10:18:37

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

si la manip de smolki ne fonctionne pas,

essaie aussi ceci:

# umount /dev/sdb1                   (vérifie avec fdisk -l  que  la patition du disque externe est bien sur sdb1)

#  mount -t vfat -o uid=1000,gid=1000 /dev/sdb1 /media/PASTEQUE   (si formatage en fat)

OU

mount -t ntfs -o uid=1000,gid=1000 /dev/sdb1 /media/PASTEQUE        (si formatage en ntfs)


et ensuite ls -l /media/PASTEQUE   pour vérifier les droits.

si cette commande fonctionne il faudra l'automatiser dans le fstab.

Dernière modification par nikau (08-11-2011 11:05:06)

Hors ligne

#18 08-11-2011 11:48:51

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Accès à disque dur externe USB

ah oui !
Zut, j'ai oublié de mettre l'option -t ntfs pour forcer le montage..
Merci de ton intervention nikau ! smile

Voire on pourrait pas l'ajouter dans le tuto mount du wiki df ? wink

Dernière modification par smolski (08-11-2011 11:52:19)


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#19 09-11-2011 20:34:12

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Salut,

Merci pour la manip elle fonctionne mais impossible de démonter le volume sauf en root.

Si je l'automatise dans fstab est-ce que ça va marcher même si le disque n'est pas branché au démarrage ?

@smolski : Pourquoi se passer de pcmanfm puisque le problème ne vient pas de là thunar me fait la même erreur.
Thunar est bien mais il me manque vraiment la navigation par onglet.

Dernière modification par tibo (09-11-2011 20:35:36)

Hors ligne

#20 09-11-2011 23:51:27

smolski
administrateur quasi...modo
Lieu : AIN
Distrib. : 8 (jessie) 64 bits + backports
Noyau : 4.6.0-0.bpo.1-amd64
(G)UI : gnome 3.14.1
Inscription : 21-10-2008

Re : [Résolu] Accès à disque dur externe USB

Si je l'automatise dans fstab est-ce que ça va marcher même si le disque n'est pas branché au démarrage ?


S'il n'est pas branché, tu auras un message d'erreur à chaque démarrage, c'est agaçant ! big_smile

Pourquoi se passer de pcmanfm puisque le problème ne vient pas de là thunar me fait la même erreur.


Ah oui, pourquoi, tu as raison. lol


"Définition d'eric besson : S'il fallait en chier des tonnes pour devenir ministre, il aurait 2 trous du cul." - JP Douillon
"L'utopie ne signifie pas l'irréalisable, mais l'irréalisée." - T Monod (source :  La zone de Siné)
"Je peux rire de tout mais pas avec n'importe qui." - P Desproges
"saque eud dun" (patois chtimi : fonce dedans)

Hors ligne

#21 10-11-2011 00:18:49

nikau
Banni(e)
Distrib. : jessie
Noyau : 3.16.0-4-amd64
(G)UI : Xfce 4.10.1
Inscription : 19-10-2011

Re : [Résolu] Accès à disque dur externe USB

c'est quoi le modèle de ton disque dur externe ?  cela arrive ce problème.
bon le principal est que ce montage fonctionne avec les droits.
sinon pour ne pas toucher au fstab,  tu peux écrire aussi cette commande dans un script shell  que tu colles dans /usr/local/bin 
ce script si tu l'appelles mondisk par exemple, il suffira de définir le fichier sudoers pour que chaque fois tu tapes dans le terminal
sudo mondisk     le mot de passe ne soit pas demandé (pour cette commande uniquement) et idem pour une commande de démontage.
et pourquoi pas créer un lanceur dans ton bureau, un clic pour le montage, un autre pour le démontage.

Dernière modification par nikau (10-11-2011 00:33:36)

Hors ligne

#22 14-11-2011 23:08:38

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

C'est un Lacie 500Go. Je n'ai pas retrouvé l’appellation exacte du modèle.

Ce qui me tracasse c'est qu'avant que je fasse cette fameuse mise à jour qui a déclenchée le problème, ça marchait très bien et j'avais pour ça modifié un fichier qui régissait différentes permission dont celle du montage de disque externe que et si mes souvenirs sont bons j'avais changé le droit qui était accordé à "root" pour le mettre à "all".

Le fastab c'est plus pour les partitions qui sont en permanences branchées.
Je vais voir pour le script nikau.

@smolski : Je trouve pcmanfm très bien, il a ses défauts et ses avantages tout comme thunar. Mais la navigation par onglets reste l'argument déterminant.

Hors ligne

#23 14-11-2011 23:14:54

captnfab
Admin-Girafe
Lieu : /dev/random
Distrib. : Debian Stretch/Sid/Rc-Buggy
Noyau : Linux (≥ 4.3)
(G)UI : i3-wm (≥ 4.11)
Inscription : 07-07-2008
Site Web

Re : [Résolu] Accès à disque dur externe USB

Juste pour info. Pour monter et démonter un disque dur externe en tant qu'utilisateur, il suffit d'utiliser la commande pmount du paquet pmount (à installer éventuellement).
Inutile de toucher au fichier fstab.
Par contre, il faut vérifier que l'utilisateur en question appartienne au groupe "plugdev" (si besoin, en root: « adduser utilisateur plugdev », puis relancer la session)

Exemple : « pmount /dev/sdb1 »
Je pense que les droits d'accès sont bons quand on utilise cette commande.

Pour démonter : « pumount /dev/sdb1 ».

captnfab,
Association Debian-Facile, bépo.
TheDoctor: Your wish is my command… But be careful what you wish for.

Hors ligne

#24 21-11-2011 22:53:47

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Alors j'ai installer le paquet pmount et également le paquet hal.
Maintenant quand je branche ma clé usb dans pcmanfm, elle apparait dans le menu a gauche.
Si je clique dessus en tant que user, elle se monte et je peux y accéder et faire ce que je veux sauf la démonter.
Je suis obligé de passer par la commande "pumount /dev/sdb1/"
Si je fais ça, elle reste afficher dans le menu à gauche sous pcmanfm mais impossible de la remonter quand je clique dessus, j'ai à nouveau le message d'erreur "not authorized".

Pour résumer, après l'install de ces deux paquets, je peux monter mes périphériques de stockage usb graphiquement depuis user. Je ne peux pas les démonter graphiquement depuis user. Et je peux les monter et démonter en ligne de commande avec user.

Y a t'il un quelque chose à configurer sur pmount ou hal pour pouvoir monter et démonter ses périphériques usb à l'infini sans passer par la ligne de commande ?

Merci

Hors ligne

#25 22-11-2011 21:13:26

tibo
Membre
Distrib. : Wheezy/Sid
Noyau : Linux version 3.2.0-1-686-pae
(G)UI : Openbox
Inscription : 03-11-2011

Re : [Résolu] Accès à disque dur externe USB

Solution indiquée sur un autre forum et qui semble fonctionner :

tibo a écrit :

limax a écrit :

Moi je pense plutôt à un problème  policykit 
regarde google-> policykit + xfce + usb

en fait je viens de le faire regarde ce post http://lists.debian.org/debian-user/201 … 01354.html
Tu as vu la date? donc tu n'es pas le seul.
Je n'ai pas vu tout le fil et s'ils ont la solution.


! Merci
J'ai lu le post, j'ai testé ce qui est expliqué ici : http://lists.debian.org/debian-user/201 … 01232.html
C'est à dire ouvrir le fichier /etc/pam.d/common-session
Ajouter la ligne suivante :

session optional  pam_loginuid.so


(attention à bien mettre .so et non .co comme indiqué dans le post anglais).

Juste avant celle-ci :

session optional  pam_ck_connector.so nox11


Un petit reboot et ça a l'air de fonctionner.
J'ai également désinstallé hal, pmount et usbmount que j'avais installé pour tester d'autres solutions.

Dernière modification par tibo (22-11-2011 21:13:48)

Hors ligne

Pied de page des forums